[Met_help] [rt.rap.ucar.edu #70551] History for Problem compiling Met-V5

Julie Prestopnik via RT met_help at ucar.edu
Mon May 8 10:18:15 MDT 2017


----------------------------------------------------------------
  Initial Request
----------------------------------------------------------------

I have installed BUFRLIB, GSL and G2CLIB
But then how do I handle the errors below in installing MET_V5?

/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/numpbmsg.f:23: undefined
reference to `ufbtab_'
openpb.o: In function `openpb_':
/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:21: undefined
reference to `openbf_'
/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:22: undefined
reference to `datelen_'
closepb.o: In function `closepb_':
/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/closepb.f:19: undefined
reference to `closbf_'
readpb.o: In function `readpb_':
/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:82: undefined
reference to `ireadns_'
/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:90: undefined
reference to `ufbint_'
/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:94: undefined
reference to `ufbevn_'
dumppb.o: In function `readpbdump_':
/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:215: undefined
reference to `ufbint_'
/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:218: undefined
reference to `ufbevn_'
/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:224: undefined
reference to `ireadns_'
/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:203: undefined
reference to `ireadns_'
/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:228: undefined
reference to `ufbint_'
/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:259: undefined
reference to `ufbevn_'
dumppb.o: In function `dumppb_':
/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:56: undefined
reference to `openbf_'
/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:57: undefined
reference to `datelen_'
collect2: error: ld returned 1 exit status
make[4]: *** [pb2nc] Error 1
make[4]: Leaving directory `/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc'
make[3]: *** [install-recursive] Error 1
make[3]: Leaving directory `/home/zmumba/WRF/met-5.0/src/tools/other'
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory `/home/zmumba/WRF/met-5.0/src/tools'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/home/zmumba/WRF/met-5.0/src'
make: *** [install-recursive] Error 1


----------------------------------------------------------------
  Complete Ticket History
----------------------------------------------------------------

Subject: Problem compiling Met-V5
From: Julie Prestopnik
Time: Thu Jan 29 09:24:22 2015

I am sorry to hear that you are having problems installing METv5.0.  I
believe this error may have to do with how you compiled BUFRLIB.
Please
take a look at the sample commands for compiling BURFLIB on this page:
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php

I believe that the *-fno-second-underscore* (GNU compilers) or
*-Mnosecond_underscore* (PGI compilers) will fix the error you're
seeing.

I hope that helps.  If it doesn't, please send me the files
"make_met.log"
and "config.log".

Thanks,
Julie


On Thu, Jan 29, 2015 at 3:48 AM, Zilore Mumba via RT
<met_help at ucar.edu>
wrote:

>
> Thu Jan 29 03:48:08 2015: Request 70551 was acted upon.
> Transaction: Ticket created by zmumba at gmail.com
>        Queue: met_help
>      Subject: Problem compiling Met-V5
>        Owner: Nobody
>   Requestors: zmumba at gmail.com
>       Status: new
>  Ticket <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
>
>
> I have installed BUFRLIB, GSL and G2CLIB
> But then how do I handle the errors below in installing MET_V5?
>
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/numpbmsg.f:23:
undefined
> reference to `ufbtab_'
> openpb.o: In function `openpb_':
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:21:
undefined
> reference to `openbf_'
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:22:
undefined
> reference to `datelen_'
> closepb.o: In function `closepb_':
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/closepb.f:19:
undefined
> reference to `closbf_'
> readpb.o: In function `readpb_':
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:82:
undefined
> reference to `ireadns_'
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:90:
undefined
> reference to `ufbint_'
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:94:
undefined
> reference to `ufbevn_'
> dumppb.o: In function `readpbdump_':
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:215:
undefined
> reference to `ufbint_'
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:218:
undefined
> reference to `ufbevn_'
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:224:
undefined
> reference to `ireadns_'
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:203:
undefined
> reference to `ireadns_'
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:228:
undefined
> reference to `ufbint_'
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:259:
undefined
> reference to `ufbevn_'
> dumppb.o: In function `dumppb_':
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:56:
undefined
> reference to `openbf_'
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:57:
undefined
> reference to `datelen_'
> collect2: error: ld returned 1 exit status
> make[4]: *** [pb2nc] Error 1
> make[4]: Leaving directory `/home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc'
> make[3]: *** [install-recursive] Error 1
> make[3]: Leaving directory `/home/zmumba/WRF/met-
5.0/src/tools/other'
> make[2]: *** [install-recursive] Error 1
> make[2]: Leaving directory `/home/zmumba/WRF/met-5.0/src/tools'
> make[1]: *** [install-recursive] Error 1
> make[1]: Leaving directory `/home/zmumba/WRF/met-5.0/src'
> make: *** [install-recursive] Error 1
>
>


--
Julie Prestopnik
National Center for Atmospheric Research
Research Applications Laboratory
Phone: 303.497.8399
Email: jpresto at ucar.edu

------------------------------------------------
Subject: Re: [rt.rap.ucar.edu #70551] Problem compiling Met-V5
From: Zilore Mumba
Time: Sat Jan 31 17:31:45 2015

Julg
Thank you very much for your help. With the advice you gave me, I was
able to install MET using gcc and gfortran. I also had to to point
$MET_NETCDFLIB and, $MET_NETCDFINC to /usr/local/netcdf-4.1.3/lib and
include. Previously I pointed only to /usr/local/netcdf-4.1.3.
I have three executables not included though, these are modis_regrid,
plot_mode_field and pb2nc.
Thank you very much.


On 1/29/15, Julie Prestopnik via RT <met_help at ucar.edu> wrote:
> I am sorry to hear that you are having problems installing METv5.0.
I
> believe this error may have to do with how you compiled BUFRLIB.
Please
> take a look at the sample commands for compiling BURFLIB on this
page:
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
>
> I believe that the *-fno-second-underscore* (GNU compilers) or
> *-Mnosecond_underscore* (PGI compilers) will fix the error you're
seeing.
>
> I hope that helps.  If it doesn't, please send me the files
"make_met.log"
> and "config.log".
>
> Thanks,
> Julie
>
>
> On Thu, Jan 29, 2015 at 3:48 AM, Zilore Mumba via RT
<met_help at ucar.edu>
> wrote:
>
>>
>> Thu Jan 29 03:48:08 2015: Request 70551 was acted upon.
>> Transaction: Ticket created by zmumba at gmail.com
>>        Queue: met_help
>>      Subject: Problem compiling Met-V5
>>        Owner: Nobody
>>   Requestors: zmumba at gmail.com
>>       Status: new
>>  Ticket <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
>>
>>
>> I have installed BUFRLIB, GSL and G2CLIB
>> But then how do I handle the errors below in installing MET_V5?
>>
>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/numpbmsg.f:23:
undefined
>> reference to `ufbtab_'
>> openpb.o: In function `openpb_':
>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:21:
undefined
>> reference to `openbf_'
>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:22:
undefined
>> reference to `datelen_'
>> closepb.o: In function `closepb_':
>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/closepb.f:19:
undefined
>> reference to `closbf_'
>> readpb.o: In function `readpb_':
>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:82:
undefined
>> reference to `ireadns_'
>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:90:
undefined
>> reference to `ufbint_'
>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:94:
undefined
>> reference to `ufbevn_'
>> dumppb.o: In function `readpbdump_':
>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:215:
undefined
>> reference to `ufbint_'
>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:218:
undefined
>> reference to `ufbevn_'
>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:224:
undefined
>> reference to `ireadns_'
>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:203:
undefined
>> reference to `ireadns_'
>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:228:
undefined
>> reference to `ufbint_'
>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:259:
undefined
>> reference to `ufbevn_'
>> dumppb.o: In function `dumppb_':
>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:56:
undefined
>> reference to `openbf_'
>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:57:
undefined
>> reference to `datelen_'
>> collect2: error: ld returned 1 exit status
>> make[4]: *** [pb2nc] Error 1
>> make[4]: Leaving directory
>> `/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc'
>> make[3]: *** [install-recursive] Error 1
>> make[3]: Leaving directory `/home/zmumba/WRF/met-
5.0/src/tools/other'
>> make[2]: *** [install-recursive] Error 1
>> make[2]: Leaving directory `/home/zmumba/WRF/met-5.0/src/tools'
>> make[1]: *** [install-recursive] Error 1
>> make[1]: Leaving directory `/home/zmumba/WRF/met-5.0/src'
>> make: *** [install-recursive] Error 1
>>
>>
>
>
> --
> Julie Prestopnik
> National Center for Atmospheric Research
> Research Applications Laboratory
> Phone: 303.497.8399
> Email: jpresto at ucar.edu
>
>

------------------------------------------------
Subject: Re: [rt.rap.ucar.edu #70551] Problem compiling Met-V5
From: Zilore Mumba
Time: Sat Jan 31 17:31:58 2015

On 2/1/15, Zilore Mumba <zmumba at gmail.com> wrote:
> Julg
> Thank you very much for your help. With the advice you gave me, I
was
> able to install MET using gcc and gfortran. I also had to to point
> $MET_NETCDFLIB and, $MET_NETCDFINC to /usr/local/netcdf-4.1.3/lib
and
> include. Previously I pointed only to /usr/local/netcdf-4.1.3.
> I have three executables not included though, these are
modis_regrid,
> plot_mode_field and pb2nc.
> Thank you very much.
>
>
> On 1/29/15, Julie Prestopnik via RT <met_help at ucar.edu> wrote:
>> I am sorry to hear that you are having problems installing METv5.0.
I
>> believe this error may have to do with how you compiled BUFRLIB.
Please
>> take a look at the sample commands for compiling BURFLIB on this
page:
>>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
>>
>> I believe that the *-fno-second-underscore* (GNU compilers) or
>> *-Mnosecond_underscore* (PGI compilers) will fix the error you're
seeing.
>>
>> I hope that helps.  If it doesn't, please send me the files
>> "make_met.log"
>> and "config.log".
>>
>> Thanks,
>> Julie
>>
>>
>> On Thu, Jan 29, 2015 at 3:48 AM, Zilore Mumba via RT
<met_help at ucar.edu>
>> wrote:
>>
>>>
>>> Thu Jan 29 03:48:08 2015: Request 70551 was acted upon.
>>> Transaction: Ticket created by zmumba at gmail.com
>>>        Queue: met_help
>>>      Subject: Problem compiling Met-V5
>>>        Owner: Nobody
>>>   Requestors: zmumba at gmail.com
>>>       Status: new
>>>  Ticket <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
>>>
>>>
>>> I have installed BUFRLIB, GSL and G2CLIB
>>> But then how do I handle the errors below in installing MET_V5?
>>>
>>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/numpbmsg.f:23:
undefined
>>> reference to `ufbtab_'
>>> openpb.o: In function `openpb_':
>>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:21:
undefined
>>> reference to `openbf_'
>>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:22:
undefined
>>> reference to `datelen_'
>>> closepb.o: In function `closepb_':
>>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/closepb.f:19:
undefined
>>> reference to `closbf_'
>>> readpb.o: In function `readpb_':
>>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:82:
undefined
>>> reference to `ireadns_'
>>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:90:
undefined
>>> reference to `ufbint_'
>>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:94:
undefined
>>> reference to `ufbevn_'
>>> dumppb.o: In function `readpbdump_':
>>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:215:
undefined
>>> reference to `ufbint_'
>>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:218:
undefined
>>> reference to `ufbevn_'
>>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:224:
undefined
>>> reference to `ireadns_'
>>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:203:
undefined
>>> reference to `ireadns_'
>>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:228:
undefined
>>> reference to `ufbint_'
>>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:259:
undefined
>>> reference to `ufbevn_'
>>> dumppb.o: In function `dumppb_':
>>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:56:
undefined
>>> reference to `openbf_'
>>> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:57:
undefined
>>> reference to `datelen_'
>>> collect2: error: ld returned 1 exit status
>>> make[4]: *** [pb2nc] Error 1
>>> make[4]: Leaving directory
>>> `/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc'
>>> make[3]: *** [install-recursive] Error 1
>>> make[3]: Leaving directory `/home/zmumba/WRF/met-
5.0/src/tools/other'
>>> make[2]: *** [install-recursive] Error 1
>>> make[2]: Leaving directory `/home/zmumba/WRF/met-5.0/src/tools'
>>> make[1]: *** [install-recursive] Error 1
>>> make[1]: Leaving directory `/home/zmumba/WRF/met-5.0/src'
>>> make: *** [install-recursive] Error 1
>>>
>>>
>>
>>
>> --
>> Julie Prestopnik
>> National Center for Atmospheric Research
>> Research Applications Laboratory
>> Phone: 303.497.8399
>> Email: jpresto at ucar.edu
>>
>>
>

------------------------------------------------
Subject: Problem compiling Met-V5
From: Julie Prestopnik
Time: Mon Feb 02 13:46:18 2015

I'm so glad you were able to get MET installed and that you worked out
the
issue with the NetCDF environment variables.

You mentioned that three executables did not build.  I would like to
try to
help with those.  The modis_regrid tool has library dependencies - it
requires the HDF4 and HDF-EOS2 libraries.  The plot_mode_field tool
also
has library dependencies - it requires the Cairo and FreeType
libraries.

You can find information on compiling each of those library
dependencies
here:
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php

You can find information on setting the up necessary environment
variables
for those library locations here:
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php

And with pb2nc, I'm not exactly sure what is going on there.  I would
be
happy to take a look at your configure log and make install log files
to
see if I can figure out why you didn't get the executable.

I hope this helps.

Thanks,
Julie



On Sat, Jan 31, 2015 at 5:31 PM, Zilore Mumba via RT
<met_help at ucar.edu>
wrote:

>
> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
>
> Julg
> Thank you very much for your help. With the advice you gave me, I
was
> able to install MET using gcc and gfortran. I also had to to point
> $MET_NETCDFLIB and, $MET_NETCDFINC to /usr/local/netcdf-4.1.3/lib
and
> include. Previously I pointed only to /usr/local/netcdf-4.1.3.
> I have three executables not included though, these are
modis_regrid,
> plot_mode_field and pb2nc.
> Thank you very much.
>
>
> On 1/29/15, Julie Prestopnik via RT <met_help at ucar.edu> wrote:
> > I am sorry to hear that you are having problems installing
METv5.0.  I
> > believe this error may have to do with how you compiled BUFRLIB.
Please
> > take a look at the sample commands for compiling BURFLIB on this
page:
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> >
> > I believe that the *-fno-second-underscore* (GNU compilers) or
> > *-Mnosecond_underscore* (PGI compilers) will fix the error you're
seeing.
> >
> > I hope that helps.  If it doesn't, please send me the files
> "make_met.log"
> > and "config.log".
> >
> > Thanks,
> > Julie
> >
> >
> > On Thu, Jan 29, 2015 at 3:48 AM, Zilore Mumba via RT
<met_help at ucar.edu>
> > wrote:
> >
> >>
> >> Thu Jan 29 03:48:08 2015: Request 70551 was acted upon.
> >> Transaction: Ticket created by zmumba at gmail.com
> >>        Queue: met_help
> >>      Subject: Problem compiling Met-V5
> >>        Owner: Nobody
> >>   Requestors: zmumba at gmail.com
> >>       Status: new
> >>  Ticket <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> >>
> >>
> >> I have installed BUFRLIB, GSL and G2CLIB
> >> But then how do I handle the errors below in installing MET_V5?
> >>
> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/numpbmsg.f:23:
undefined
> >> reference to `ufbtab_'
> >> openpb.o: In function `openpb_':
> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:21:
undefined
> >> reference to `openbf_'
> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:22:
undefined
> >> reference to `datelen_'
> >> closepb.o: In function `closepb_':
> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/closepb.f:19:
undefined
> >> reference to `closbf_'
> >> readpb.o: In function `readpb_':
> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:82:
undefined
> >> reference to `ireadns_'
> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:90:
undefined
> >> reference to `ufbint_'
> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:94:
undefined
> >> reference to `ufbevn_'
> >> dumppb.o: In function `readpbdump_':
> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:215:
undefined
> >> reference to `ufbint_'
> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:218:
undefined
> >> reference to `ufbevn_'
> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:224:
undefined
> >> reference to `ireadns_'
> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:203:
undefined
> >> reference to `ireadns_'
> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:228:
undefined
> >> reference to `ufbint_'
> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:259:
undefined
> >> reference to `ufbevn_'
> >> dumppb.o: In function `dumppb_':
> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:56:
undefined
> >> reference to `openbf_'
> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:57:
undefined
> >> reference to `datelen_'
> >> collect2: error: ld returned 1 exit status
> >> make[4]: *** [pb2nc] Error 1
> >> make[4]: Leaving directory
> >> `/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc'
> >> make[3]: *** [install-recursive] Error 1
> >> make[3]: Leaving directory `/home/zmumba/WRF/met-
5.0/src/tools/other'
> >> make[2]: *** [install-recursive] Error 1
> >> make[2]: Leaving directory `/home/zmumba/WRF/met-5.0/src/tools'
> >> make[1]: *** [install-recursive] Error 1
> >> make[1]: Leaving directory `/home/zmumba/WRF/met-5.0/src'
> >> make: *** [install-recursive] Error 1
> >>
> >>
> >
> >
> > --
> > Julie Prestopnik
> > National Center for Atmospheric Research
> > Research Applications Laboratory
> > Phone: 303.497.8399
> > Email: jpresto at ucar.edu
> >
> >
>
>


--
Julie Prestopnik
National Center for Atmospheric Research
Research Applications Laboratory
Phone: 303.497.8399
Email: jpresto at ucar.edu

------------------------------------------------
Subject: Problem compiling Met-V5
From: Zilore Mumba
Time: Tue Feb 03 14:08:38 2015

Julie,
Thank you very much for your assistance. I failed to install Cairo and
freetype because of the dependencies. I will try again with the links
you sent me.
Please find attached my config.log and make-install.log.


On 2/2/15, Julie Prestopnik via RT <met_help at ucar.edu> wrote:
> I'm so glad you were able to get MET installed and that you worked
out the
> issue with the NetCDF environment variables.
>
> You mentioned that three executables did not build.  I would like to
try to
> help with those.  The modis_regrid tool has library dependencies -
it
> requires the HDF4 and HDF-EOS2 libraries.  The plot_mode_field tool
also
> has library dependencies - it requires the Cairo and FreeType
libraries.
>
> You can find information on compiling each of those library
dependencies
> here:
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
>
> You can find information on setting the up necessary environment
variables
> for those library locations here:
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php
>
> And with pb2nc, I'm not exactly sure what is going on there.  I
would be
> happy to take a look at your configure log and make install log
files to
> see if I can figure out why you didn't get the executable.
>
> I hope this helps.
>
> Thanks,
> Julie
>
>
>
> On Sat, Jan 31, 2015 at 5:31 PM, Zilore Mumba via RT
<met_help at ucar.edu>
> wrote:
>
>>
>> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
>>
>> Julg
>> Thank you very much for your help. With the advice you gave me, I
was
>> able to install MET using gcc and gfortran. I also had to to point
>> $MET_NETCDFLIB and, $MET_NETCDFINC to /usr/local/netcdf-4.1.3/lib
and
>> include. Previously I pointed only to /usr/local/netcdf-4.1.3.
>> I have three executables not included though, these are
modis_regrid,
>> plot_mode_field and pb2nc.
>> Thank you very much.
>>
>>
>> On 1/29/15, Julie Prestopnik via RT <met_help at ucar.edu> wrote:
>> > I am sorry to hear that you are having problems installing
METv5.0.  I
>> > believe this error may have to do with how you compiled BUFRLIB.
>> > Please
>> > take a look at the sample commands for compiling BURFLIB on this
page:
>> >
>>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
>> >
>> > I believe that the *-fno-second-underscore* (GNU compilers) or
>> > *-Mnosecond_underscore* (PGI compilers) will fix the error you're
>> > seeing.
>> >
>> > I hope that helps.  If it doesn't, please send me the files
>> "make_met.log"
>> > and "config.log".
>> >
>> > Thanks,
>> > Julie
>> >
>> >
>> > On Thu, Jan 29, 2015 at 3:48 AM, Zilore Mumba via RT
>> > <met_help at ucar.edu>
>> > wrote:
>> >
>> >>
>> >> Thu Jan 29 03:48:08 2015: Request 70551 was acted upon.
>> >> Transaction: Ticket created by zmumba at gmail.com
>> >>        Queue: met_help
>> >>      Subject: Problem compiling Met-V5
>> >>        Owner: Nobody
>> >>   Requestors: zmumba at gmail.com
>> >>       Status: new
>> >>  Ticket <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
>> >> >
>> >>
>> >>
>> >> I have installed BUFRLIB, GSL and G2CLIB
>> >> But then how do I handle the errors below in installing MET_V5?
>> >>
>> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/numpbmsg.f:23:
>> >> undefined
>> >> reference to `ufbtab_'
>> >> openpb.o: In function `openpb_':
>> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:21:
undefined
>> >> reference to `openbf_'
>> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:22:
undefined
>> >> reference to `datelen_'
>> >> closepb.o: In function `closepb_':
>> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/closepb.f:19:
undefined
>> >> reference to `closbf_'
>> >> readpb.o: In function `readpb_':
>> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:82:
undefined
>> >> reference to `ireadns_'
>> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:90:
undefined
>> >> reference to `ufbint_'
>> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:94:
undefined
>> >> reference to `ufbevn_'
>> >> dumppb.o: In function `readpbdump_':
>> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:215:
undefined
>> >> reference to `ufbint_'
>> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:218:
undefined
>> >> reference to `ufbevn_'
>> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:224:
undefined
>> >> reference to `ireadns_'
>> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:203:
undefined
>> >> reference to `ireadns_'
>> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:228:
undefined
>> >> reference to `ufbint_'
>> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:259:
undefined
>> >> reference to `ufbevn_'
>> >> dumppb.o: In function `dumppb_':
>> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:56:
undefined
>> >> reference to `openbf_'
>> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:57:
undefined
>> >> reference to `datelen_'
>> >> collect2: error: ld returned 1 exit status
>> >> make[4]: *** [pb2nc] Error 1
>> >> make[4]: Leaving directory
>> >> `/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc'
>> >> make[3]: *** [install-recursive] Error 1
>> >> make[3]: Leaving directory `/home/zmumba/WRF/met-
5.0/src/tools/other'
>> >> make[2]: *** [install-recursive] Error 1
>> >> make[2]: Leaving directory `/home/zmumba/WRF/met-5.0/src/tools'
>> >> make[1]: *** [install-recursive] Error 1
>> >> make[1]: Leaving directory `/home/zmumba/WRF/met-5.0/src'
>> >> make: *** [install-recursive] Error 1
>> >>
>> >>
>> >
>> >
>> > --
>> > Julie Prestopnik
>> > National Center for Atmospheric Research
>> > Research Applications Laboratory
>> > Phone: 303.497.8399
>> > Email: jpresto at ucar.edu
>> >
>> >
>>
>>
>
>
> --
> Julie Prestopnik
> National Center for Atmospheric Research
> Research Applications Laboratory
> Phone: 303.497.8399
> Email: jpresto at ucar.edu
>
>

------------------------------------------------
Subject: Problem compiling Met-V5
From: Julie Prestopnik
Time: Thu Feb 05 11:47:34 2015

Thank you for attaching your log files.  I did not see any errors in
your
make-install.log.  Perhaps you ran make install in the following way:

make install > make-install.log

This would catch standard out but not standard error.

Could you please try running in the following way with the &, which
will
also capture standard error?

make install >& make-install.log

And, then please send me the output of that log.  Thank you!

Julie

On Tue, Feb 3, 2015 at 2:08 PM, Zilore Mumba via RT
<met_help at ucar.edu>
wrote:

>
> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
>
> Julie,
> Thank you very much for your assistance. I failed to install Cairo
and
> freetype because of the dependencies. I will try again with the
links
> you sent me.
> Please find attached my config.log and make-install.log.
>
>
> On 2/2/15, Julie Prestopnik via RT <met_help at ucar.edu> wrote:
> > I'm so glad you were able to get MET installed and that you worked
out
> the
> > issue with the NetCDF environment variables.
> >
> > You mentioned that three executables did not build.  I would like
to try
> to
> > help with those.  The modis_regrid tool has library dependencies -
it
> > requires the HDF4 and HDF-EOS2 libraries.  The plot_mode_field
tool also
> > has library dependencies - it requires the Cairo and FreeType
libraries.
> >
> > You can find information on compiling each of those library
dependencies
> > here:
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> >
> > You can find information on setting the up necessary environment
> variables
> > for those library locations here:
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php
> >
> > And with pb2nc, I'm not exactly sure what is going on there.  I
would be
> > happy to take a look at your configure log and make install log
files to
> > see if I can figure out why you didn't get the executable.
> >
> > I hope this helps.
> >
> > Thanks,
> > Julie
> >
> >
> >
> > On Sat, Jan 31, 2015 at 5:31 PM, Zilore Mumba via RT
<met_help at ucar.edu>
> > wrote:
> >
> >>
> >> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> >>
> >> Julg
> >> Thank you very much for your help. With the advice you gave me, I
was
> >> able to install MET using gcc and gfortran. I also had to to
point
> >> $MET_NETCDFLIB and, $MET_NETCDFINC to /usr/local/netcdf-4.1.3/lib
and
> >> include. Previously I pointed only to /usr/local/netcdf-4.1.3.
> >> I have three executables not included though, these are
modis_regrid,
> >> plot_mode_field and pb2nc.
> >> Thank you very much.
> >>
> >>
> >> On 1/29/15, Julie Prestopnik via RT <met_help at ucar.edu> wrote:
> >> > I am sorry to hear that you are having problems installing
METv5.0.  I
> >> > believe this error may have to do with how you compiled
BUFRLIB.
> >> > Please
> >> > take a look at the sample commands for compiling BURFLIB on
this page:
> >> >
> >>
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> >> >
> >> > I believe that the *-fno-second-underscore* (GNU compilers) or
> >> > *-Mnosecond_underscore* (PGI compilers) will fix the error
you're
> >> > seeing.
> >> >
> >> > I hope that helps.  If it doesn't, please send me the files
> >> "make_met.log"
> >> > and "config.log".
> >> >
> >> > Thanks,
> >> > Julie
> >> >
> >> >
> >> > On Thu, Jan 29, 2015 at 3:48 AM, Zilore Mumba via RT
> >> > <met_help at ucar.edu>
> >> > wrote:
> >> >
> >> >>
> >> >> Thu Jan 29 03:48:08 2015: Request 70551 was acted upon.
> >> >> Transaction: Ticket created by zmumba at gmail.com
> >> >>        Queue: met_help
> >> >>      Subject: Problem compiling Met-V5
> >> >>        Owner: Nobody
> >> >>   Requestors: zmumba at gmail.com
> >> >>       Status: new
> >> >>  Ticket <URL:
> https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> >> >> >
> >> >>
> >> >>
> >> >> I have installed BUFRLIB, GSL and G2CLIB
> >> >> But then how do I handle the errors below in installing
MET_V5?
> >> >>
> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/numpbmsg.f:23:
> >> >> undefined
> >> >> reference to `ufbtab_'
> >> >> openpb.o: In function `openpb_':
> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:21:
undefined
> >> >> reference to `openbf_'
> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:22:
undefined
> >> >> reference to `datelen_'
> >> >> closepb.o: In function `closepb_':
> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/closepb.f:19:
> undefined
> >> >> reference to `closbf_'
> >> >> readpb.o: In function `readpb_':
> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:82:
undefined
> >> >> reference to `ireadns_'
> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:90:
undefined
> >> >> reference to `ufbint_'
> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:94:
undefined
> >> >> reference to `ufbevn_'
> >> >> dumppb.o: In function `readpbdump_':
> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:215:
> undefined
> >> >> reference to `ufbint_'
> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:218:
> undefined
> >> >> reference to `ufbevn_'
> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:224:
> undefined
> >> >> reference to `ireadns_'
> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:203:
> undefined
> >> >> reference to `ireadns_'
> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:228:
> undefined
> >> >> reference to `ufbint_'
> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:259:
> undefined
> >> >> reference to `ufbevn_'
> >> >> dumppb.o: In function `dumppb_':
> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:56:
undefined
> >> >> reference to `openbf_'
> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:57:
undefined
> >> >> reference to `datelen_'
> >> >> collect2: error: ld returned 1 exit status
> >> >> make[4]: *** [pb2nc] Error 1
> >> >> make[4]: Leaving directory
> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc'
> >> >> make[3]: *** [install-recursive] Error 1
> >> >> make[3]: Leaving directory `/home/zmumba/WRF/met-
5.0/src/tools/other'
> >> >> make[2]: *** [install-recursive] Error 1
> >> >> make[2]: Leaving directory `/home/zmumba/WRF/met-
5.0/src/tools'
> >> >> make[1]: *** [install-recursive] Error 1
> >> >> make[1]: Leaving directory `/home/zmumba/WRF/met-5.0/src'
> >> >> make: *** [install-recursive] Error 1
> >> >>
> >> >>
> >> >
> >> >
> >> > --
> >> > Julie Prestopnik
> >> > National Center for Atmospheric Research
> >> > Research Applications Laboratory
> >> > Phone: 303.497.8399
> >> > Email: jpresto at ucar.edu
> >> >
> >> >
> >>
> >>
> >
> >
> > --
> > Julie Prestopnik
> > National Center for Atmospheric Research
> > Research Applications Laboratory
> > Phone: 303.497.8399
> > Email: jpresto at ucar.edu
> >
> >
>
>


--
Julie Prestopnik
National Center for Atmospheric Research
Research Applications Laboratory
Phone: 303.497.8399
Email: jpresto at ucar.edu

------------------------------------------------
Subject: Problem compiling Met-V5
From: Zilore Mumba
Time: Sat Feb 07 21:36:58 2015

Julie,
Attached to this mail, please find the file make-install.log. It does
show 'undefined reference' to some functions. I hope this means
something to you and that you can help.
Thanks in advance
Zilore


On 2/5/15, Julie Prestopnik via RT <met_help at ucar.edu> wrote:
> Thank you for attaching your log files.  I did not see any errors in
your
> make-install.log.  Perhaps you ran make install in the following
way:
>
> make install > make-install.log
>
> This would catch standard out but not standard error.
>
> Could you please try running in the following way with the &, which
will
> also capture standard error?
>
> make install >& make-install.log
>
> And, then please send me the output of that log.  Thank you!
>
> Julie
>
> On Tue, Feb 3, 2015 at 2:08 PM, Zilore Mumba via RT
<met_help at ucar.edu>
> wrote:
>
>>
>> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
>>
>> Julie,
>> Thank you very much for your assistance. I failed to install Cairo
and
>> freetype because of the dependencies. I will try again with the
links
>> you sent me.
>> Please find attached my config.log and make-install.log.
>>
>>
>> On 2/2/15, Julie Prestopnik via RT <met_help at ucar.edu> wrote:
>> > I'm so glad you were able to get MET installed and that you
worked out
>> the
>> > issue with the NetCDF environment variables.
>> >
>> > You mentioned that three executables did not build.  I would like
to
>> > try
>> to
>> > help with those.  The modis_regrid tool has library dependencies
- it
>> > requires the HDF4 and HDF-EOS2 libraries.  The plot_mode_field
tool
>> > also
>> > has library dependencies - it requires the Cairo and FreeType
>> > libraries.
>> >
>> > You can find information on compiling each of those library
>> > dependencies
>> > here:
>> >
>>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
>> >
>> > You can find information on setting the up necessary environment
>> variables
>> > for those library locations here:
>> >
>>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php
>> >
>> > And with pb2nc, I'm not exactly sure what is going on there.  I
would
>> > be
>> > happy to take a look at your configure log and make install log
files
>> > to
>> > see if I can figure out why you didn't get the executable.
>> >
>> > I hope this helps.
>> >
>> > Thanks,
>> > Julie
>> >
>> >
>> >
>> > On Sat, Jan 31, 2015 at 5:31 PM, Zilore Mumba via RT
>> > <met_help at ucar.edu>
>> > wrote:
>> >
>> >>
>> >> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
>> >>
>> >> Julg
>> >> Thank you very much for your help. With the advice you gave me,
I was
>> >> able to install MET using gcc and gfortran. I also had to to
point
>> >> $MET_NETCDFLIB and, $MET_NETCDFINC to /usr/local/netcdf-
4.1.3/lib and
>> >> include. Previously I pointed only to /usr/local/netcdf-4.1.3.
>> >> I have three executables not included though, these are
modis_regrid,
>> >> plot_mode_field and pb2nc.
>> >> Thank you very much.
>> >>
>> >>
>> >> On 1/29/15, Julie Prestopnik via RT <met_help at ucar.edu> wrote:
>> >> > I am sorry to hear that you are having problems installing
METv5.0.
>> >> > I
>> >> > believe this error may have to do with how you compiled
BUFRLIB.
>> >> > Please
>> >> > take a look at the sample commands for compiling BURFLIB on
this
>> >> > page:
>> >> >
>> >>
>>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
>> >> >
>> >> > I believe that the *-fno-second-underscore* (GNU compilers) or
>> >> > *-Mnosecond_underscore* (PGI compilers) will fix the error
you're
>> >> > seeing.
>> >> >
>> >> > I hope that helps.  If it doesn't, please send me the files
>> >> "make_met.log"
>> >> > and "config.log".
>> >> >
>> >> > Thanks,
>> >> > Julie
>> >> >
>> >> >
>> >> > On Thu, Jan 29, 2015 at 3:48 AM, Zilore Mumba via RT
>> >> > <met_help at ucar.edu>
>> >> > wrote:
>> >> >
>> >> >>
>> >> >> Thu Jan 29 03:48:08 2015: Request 70551 was acted upon.
>> >> >> Transaction: Ticket created by zmumba at gmail.com
>> >> >>        Queue: met_help
>> >> >>      Subject: Problem compiling Met-V5
>> >> >>        Owner: Nobody
>> >> >>   Requestors: zmumba at gmail.com
>> >> >>       Status: new
>> >> >>  Ticket <URL:
>> https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
>> >> >> >
>> >> >>
>> >> >>
>> >> >> I have installed BUFRLIB, GSL and G2CLIB
>> >> >> But then how do I handle the errors below in installing
MET_V5?
>> >> >>
>> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/numpbmsg.f:23:
>> >> >> undefined
>> >> >> reference to `ufbtab_'
>> >> >> openpb.o: In function `openpb_':
>> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:21:
>> >> >> undefined
>> >> >> reference to `openbf_'
>> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:22:
>> >> >> undefined
>> >> >> reference to `datelen_'
>> >> >> closepb.o: In function `closepb_':
>> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/closepb.f:19:
>> undefined
>> >> >> reference to `closbf_'
>> >> >> readpb.o: In function `readpb_':
>> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:82:
>> >> >> undefined
>> >> >> reference to `ireadns_'
>> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:90:
>> >> >> undefined
>> >> >> reference to `ufbint_'
>> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:94:
>> >> >> undefined
>> >> >> reference to `ufbevn_'
>> >> >> dumppb.o: In function `readpbdump_':
>> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:215:
>> undefined
>> >> >> reference to `ufbint_'
>> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:218:
>> undefined
>> >> >> reference to `ufbevn_'
>> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:224:
>> undefined
>> >> >> reference to `ireadns_'
>> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:203:
>> undefined
>> >> >> reference to `ireadns_'
>> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:228:
>> undefined
>> >> >> reference to `ufbint_'
>> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:259:
>> undefined
>> >> >> reference to `ufbevn_'
>> >> >> dumppb.o: In function `dumppb_':
>> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:56:
>> >> >> undefined
>> >> >> reference to `openbf_'
>> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:57:
>> >> >> undefined
>> >> >> reference to `datelen_'
>> >> >> collect2: error: ld returned 1 exit status
>> >> >> make[4]: *** [pb2nc] Error 1
>> >> >> make[4]: Leaving directory
>> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc'
>> >> >> make[3]: *** [install-recursive] Error 1
>> >> >> make[3]: Leaving directory
>> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other'
>> >> >> make[2]: *** [install-recursive] Error 1
>> >> >> make[2]: Leaving directory `/home/zmumba/WRF/met-
5.0/src/tools'
>> >> >> make[1]: *** [install-recursive] Error 1
>> >> >> make[1]: Leaving directory `/home/zmumba/WRF/met-5.0/src'
>> >> >> make: *** [install-recursive] Error 1
>> >> >>
>> >> >>
>> >> >
>> >> >
>> >> > --
>> >> > Julie Prestopnik
>> >> > National Center for Atmospheric Research
>> >> > Research Applications Laboratory
>> >> > Phone: 303.497.8399
>> >> > Email: jpresto at ucar.edu
>> >> >
>> >> >
>> >>
>> >>
>> >
>> >
>> > --
>> > Julie Prestopnik
>> > National Center for Atmospheric Research
>> > Research Applications Laboratory
>> > Phone: 303.497.8399
>> > Email: jpresto at ucar.edu
>> >
>> >
>>
>>
>
>
> --
> Julie Prestopnik
> National Center for Atmospheric Research
> Research Applications Laboratory
> Phone: 303.497.8399
> Email: jpresto at ucar.edu
>
>

------------------------------------------------
Subject: Problem compiling Met-V5
From: Julie Prestopnik
Time: Tue Feb 10 10:12:53 2015

Thank you for rerunning and sending this log.  Perhaps MET cannot find
the
BUFR library.

On the following page are directions for setting the environment
variables
before compiling MET:
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php

The rest of the applications built, so it looks like MET was able to
find
the other needed libraries.  The directions for the BUFR environment
variable on the above page are:

"Set *$MET_BUFR* to point to the main BUFR directory, or set
*$MET_BUFRLIB*
to point to the directory with the BUFR library files. Because MET
doesn't
use any BUFR library include files, you don't need to specify
*$MET_BUFRINC*
."

Please try setting either *$MET_BUFR *or *$MET_BUFRLIB *and then
please
rerun the configure script and then rerun make install.  It is
important to
rerun configure before rerunning make install.

Please let me know how it goes.

Thanks,
Julie





On Sat, Feb 7, 2015 at 9:36 PM, Zilore Mumba via RT
<met_help at ucar.edu>
wrote:

>
> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
>
> Julie,
> Attached to this mail, please find the file make-install.log. It
does
> show 'undefined reference' to some functions. I hope this means
> something to you and that you can help.
> Thanks in advance
> Zilore
>
>
> On 2/5/15, Julie Prestopnik via RT <met_help at ucar.edu> wrote:
> > Thank you for attaching your log files.  I did not see any errors
in your
> > make-install.log.  Perhaps you ran make install in the following
way:
> >
> > make install > make-install.log
> >
> > This would catch standard out but not standard error.
> >
> > Could you please try running in the following way with the &,
which will
> > also capture standard error?
> >
> > make install >& make-install.log
> >
> > And, then please send me the output of that log.  Thank you!
> >
> > Julie
> >
> > On Tue, Feb 3, 2015 at 2:08 PM, Zilore Mumba via RT
<met_help at ucar.edu>
> > wrote:
> >
> >>
> >> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> >>
> >> Julie,
> >> Thank you very much for your assistance. I failed to install
Cairo and
> >> freetype because of the dependencies. I will try again with the
links
> >> you sent me.
> >> Please find attached my config.log and make-install.log.
> >>
> >>
> >> On 2/2/15, Julie Prestopnik via RT <met_help at ucar.edu> wrote:
> >> > I'm so glad you were able to get MET installed and that you
worked out
> >> the
> >> > issue with the NetCDF environment variables.
> >> >
> >> > You mentioned that three executables did not build.  I would
like to
> >> > try
> >> to
> >> > help with those.  The modis_regrid tool has library
dependencies - it
> >> > requires the HDF4 and HDF-EOS2 libraries.  The plot_mode_field
tool
> >> > also
> >> > has library dependencies - it requires the Cairo and FreeType
> >> > libraries.
> >> >
> >> > You can find information on compiling each of those library
> >> > dependencies
> >> > here:
> >> >
> >>
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> >> >
> >> > You can find information on setting the up necessary
environment
> >> variables
> >> > for those library locations here:
> >> >
> >>
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php
> >> >
> >> > And with pb2nc, I'm not exactly sure what is going on there.  I
would
> >> > be
> >> > happy to take a look at your configure log and make install log
files
> >> > to
> >> > see if I can figure out why you didn't get the executable.
> >> >
> >> > I hope this helps.
> >> >
> >> > Thanks,
> >> > Julie
> >> >
> >> >
> >> >
> >> > On Sat, Jan 31, 2015 at 5:31 PM, Zilore Mumba via RT
> >> > <met_help at ucar.edu>
> >> > wrote:
> >> >
> >> >>
> >> >> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
>
> >> >>
> >> >> Julg
> >> >> Thank you very much for your help. With the advice you gave
me, I was
> >> >> able to install MET using gcc and gfortran. I also had to to
point
> >> >> $MET_NETCDFLIB and, $MET_NETCDFINC to /usr/local/netcdf-
4.1.3/lib and
> >> >> include. Previously I pointed only to /usr/local/netcdf-4.1.3.
> >> >> I have three executables not included though, these are
modis_regrid,
> >> >> plot_mode_field and pb2nc.
> >> >> Thank you very much.
> >> >>
> >> >>
> >> >> On 1/29/15, Julie Prestopnik via RT <met_help at ucar.edu> wrote:
> >> >> > I am sorry to hear that you are having problems installing
METv5.0.
> >> >> > I
> >> >> > believe this error may have to do with how you compiled
BUFRLIB.
> >> >> > Please
> >> >> > take a look at the sample commands for compiling BURFLIB on
this
> >> >> > page:
> >> >> >
> >> >>
> >>
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> >> >> >
> >> >> > I believe that the *-fno-second-underscore* (GNU compilers)
or
> >> >> > *-Mnosecond_underscore* (PGI compilers) will fix the error
you're
> >> >> > seeing.
> >> >> >
> >> >> > I hope that helps.  If it doesn't, please send me the files
> >> >> "make_met.log"
> >> >> > and "config.log".
> >> >> >
> >> >> > Thanks,
> >> >> > Julie
> >> >> >
> >> >> >
> >> >> > On Thu, Jan 29, 2015 at 3:48 AM, Zilore Mumba via RT
> >> >> > <met_help at ucar.edu>
> >> >> > wrote:
> >> >> >
> >> >> >>
> >> >> >> Thu Jan 29 03:48:08 2015: Request 70551 was acted upon.
> >> >> >> Transaction: Ticket created by zmumba at gmail.com
> >> >> >>        Queue: met_help
> >> >> >>      Subject: Problem compiling Met-V5
> >> >> >>        Owner: Nobody
> >> >> >>   Requestors: zmumba at gmail.com
> >> >> >>       Status: new
> >> >> >>  Ticket <URL:
> >> https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> >> >> >> >
> >> >> >>
> >> >> >>
> >> >> >> I have installed BUFRLIB, GSL and G2CLIB
> >> >> >> But then how do I handle the errors below in installing
MET_V5?
> >> >> >>
> >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/numpbmsg.f:23:
> >> >> >> undefined
> >> >> >> reference to `ufbtab_'
> >> >> >> openpb.o: In function `openpb_':
> >> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:21:
> >> >> >> undefined
> >> >> >> reference to `openbf_'
> >> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:22:
> >> >> >> undefined
> >> >> >> reference to `datelen_'
> >> >> >> closepb.o: In function `closepb_':
> >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/closepb.f:19:
> >> undefined
> >> >> >> reference to `closbf_'
> >> >> >> readpb.o: In function `readpb_':
> >> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:82:
> >> >> >> undefined
> >> >> >> reference to `ireadns_'
> >> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:90:
> >> >> >> undefined
> >> >> >> reference to `ufbint_'
> >> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:94:
> >> >> >> undefined
> >> >> >> reference to `ufbevn_'
> >> >> >> dumppb.o: In function `readpbdump_':
> >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:215:
> >> undefined
> >> >> >> reference to `ufbint_'
> >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:218:
> >> undefined
> >> >> >> reference to `ufbevn_'
> >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:224:
> >> undefined
> >> >> >> reference to `ireadns_'
> >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:203:
> >> undefined
> >> >> >> reference to `ireadns_'
> >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:228:
> >> undefined
> >> >> >> reference to `ufbint_'
> >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:259:
> >> undefined
> >> >> >> reference to `ufbevn_'
> >> >> >> dumppb.o: In function `dumppb_':
> >> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:56:
> >> >> >> undefined
> >> >> >> reference to `openbf_'
> >> >> >> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:57:
> >> >> >> undefined
> >> >> >> reference to `datelen_'
> >> >> >> collect2: error: ld returned 1 exit status
> >> >> >> make[4]: *** [pb2nc] Error 1
> >> >> >> make[4]: Leaving directory
> >> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc'
> >> >> >> make[3]: *** [install-recursive] Error 1
> >> >> >> make[3]: Leaving directory
> >> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other'
> >> >> >> make[2]: *** [install-recursive] Error 1
> >> >> >> make[2]: Leaving directory `/home/zmumba/WRF/met-
5.0/src/tools'
> >> >> >> make[1]: *** [install-recursive] Error 1
> >> >> >> make[1]: Leaving directory `/home/zmumba/WRF/met-5.0/src'
> >> >> >> make: *** [install-recursive] Error 1
> >> >> >>
> >> >> >>
> >> >> >
> >> >> >
> >> >> > --
> >> >> > Julie Prestopnik
> >> >> > National Center for Atmospheric Research
> >> >> > Research Applications Laboratory
> >> >> > Phone: 303.497.8399
> >> >> > Email: jpresto at ucar.edu
> >> >> >
> >> >> >
> >> >>
> >> >>
> >> >
> >> >
> >> > --
> >> > Julie Prestopnik
> >> > National Center for Atmospheric Research
> >> > Research Applications Laboratory
> >> > Phone: 303.497.8399
> >> > Email: jpresto at ucar.edu
> >> >
> >> >
> >>
> >>
> >
> >
> > --
> > Julie Prestopnik
> > National Center for Atmospheric Research
> > Research Applications Laboratory
> > Phone: 303.497.8399
> > Email: jpresto at ucar.edu
> >
> >
>
>


--
Julie Prestopnik
National Center for Atmospheric Research
Research Applications Laboratory
Phone: 303.497.8399
Email: jpresto at ucar.edu

------------------------------------------------
Subject: Problem compiling Met-V5
From: Zilore Mumba
Time: Tue Mar 03 00:26:52 2015

Julie,
I did not inform you of the conclusion of my attempt to install Met-
5.1.
After making many attempts in reinstalling/reconfiguring BUFRLIB i
still
get errors relating to "undefined reference to ..." and eventually I
still
have 3 executables not installed: pb2nc, modis_regrid,
plot_mode_field.
I would like to learn how to use what I have and come back later to
pb2nc
if necessary. I will inform you if I have any other problems.


On Tue, Feb 10, 2015 at 7:12 PM, Julie Prestopnik via RT
<met_help at ucar.edu>
wrote:

> Thank you for rerunning and sending this log.  Perhaps MET cannot
find the
> BUFR library.
>
> On the following page are directions for setting the environment
variables
> before compiling MET:
>
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php
>
> The rest of the applications built, so it looks like MET was able to
find
> the other needed libraries.  The directions for the BUFR environment
> variable on the above page are:
>
> "Set *$MET_BUFR* to point to the main BUFR directory, or set
*$MET_BUFRLIB*
> to point to the directory with the BUFR library files. Because MET
doesn't
> use any BUFR library include files, you don't need to specify
> *$MET_BUFRINC*
> ."
>
> Please try setting either *$MET_BUFR *or *$MET_BUFRLIB *and then
please
> rerun the configure script and then rerun make install.  It is
important to
> rerun configure before rerunning make install.
>
> Please let me know how it goes.
>
> Thanks,
> Julie
>
>
>
>
>
> On Sat, Feb 7, 2015 at 9:36 PM, Zilore Mumba via RT
<met_help at ucar.edu>
> wrote:
>
> >
> > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> >
> > Julie,
> > Attached to this mail, please find the file make-install.log. It
does
> > show 'undefined reference' to some functions. I hope this means
> > something to you and that you can help.
> > Thanks in advance
> > Zilore
> >
> >
> > On 2/5/15, Julie Prestopnik via RT <met_help at ucar.edu> wrote:
> > > Thank you for attaching your log files.  I did not see any
errors in
> your
> > > make-install.log.  Perhaps you ran make install in the following
way:
> > >
> > > make install > make-install.log
> > >
> > > This would catch standard out but not standard error.
> > >
> > > Could you please try running in the following way with the &,
which
> will
> > > also capture standard error?
> > >
> > > make install >& make-install.log
> > >
> > > And, then please send me the output of that log.  Thank you!
> > >
> > > Julie
> > >
> > > On Tue, Feb 3, 2015 at 2:08 PM, Zilore Mumba via RT
<met_help at ucar.edu
> >
> > > wrote:
> > >
> > >>
> > >> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > >>
> > >> Julie,
> > >> Thank you very much for your assistance. I failed to install
Cairo and
> > >> freetype because of the dependencies. I will try again with the
links
> > >> you sent me.
> > >> Please find attached my config.log and make-install.log.
> > >>
> > >>
> > >> On 2/2/15, Julie Prestopnik via RT <met_help at ucar.edu> wrote:
> > >> > I'm so glad you were able to get MET installed and that you
worked
> out
> > >> the
> > >> > issue with the NetCDF environment variables.
> > >> >
> > >> > You mentioned that three executables did not build.  I would
like to
> > >> > try
> > >> to
> > >> > help with those.  The modis_regrid tool has library
dependencies -
> it
> > >> > requires the HDF4 and HDF-EOS2 libraries.  The
plot_mode_field tool
> > >> > also
> > >> > has library dependencies - it requires the Cairo and FreeType
> > >> > libraries.
> > >> >
> > >> > You can find information on compiling each of those library
> > >> > dependencies
> > >> > here:
> > >> >
> > >>
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> > >> >
> > >> > You can find information on setting the up necessary
environment
> > >> variables
> > >> > for those library locations here:
> > >> >
> > >>
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php
> > >> >
> > >> > And with pb2nc, I'm not exactly sure what is going on there.
I
> would
> > >> > be
> > >> > happy to take a look at your configure log and make install
log
> files
> > >> > to
> > >> > see if I can figure out why you didn't get the executable.
> > >> >
> > >> > I hope this helps.
> > >> >
> > >> > Thanks,
> > >> > Julie
> > >> >
> > >> >
> > >> >
> > >> > On Sat, Jan 31, 2015 at 5:31 PM, Zilore Mumba via RT
> > >> > <met_help at ucar.edu>
> > >> > wrote:
> > >> >
> > >> >>
> > >> >> <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > >> >>
> > >> >> Julg
> > >> >> Thank you very much for your help. With the advice you gave
me, I
> was
> > >> >> able to install MET using gcc and gfortran. I also had to to
point
> > >> >> $MET_NETCDFLIB and, $MET_NETCDFINC to /usr/local/netcdf-
4.1.3/lib
> and
> > >> >> include. Previously I pointed only to /usr/local/netcdf-
4.1.3.
> > >> >> I have three executables not included though, these are
> modis_regrid,
> > >> >> plot_mode_field and pb2nc.
> > >> >> Thank you very much.
> > >> >>
> > >> >>
> > >> >> On 1/29/15, Julie Prestopnik via RT <met_help at ucar.edu>
wrote:
> > >> >> > I am sorry to hear that you are having problems installing
> METv5.0.
> > >> >> > I
> > >> >> > believe this error may have to do with how you compiled
BUFRLIB.
> > >> >> > Please
> > >> >> > take a look at the sample commands for compiling BURFLIB
on this
> > >> >> > page:
> > >> >> >
> > >> >>
> > >>
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> > >> >> >
> > >> >> > I believe that the *-fno-second-underscore* (GNU
compilers) or
> > >> >> > *-Mnosecond_underscore* (PGI compilers) will fix the error
you're
> > >> >> > seeing.
> > >> >> >
> > >> >> > I hope that helps.  If it doesn't, please send me the
files
> > >> >> "make_met.log"
> > >> >> > and "config.log".
> > >> >> >
> > >> >> > Thanks,
> > >> >> > Julie
> > >> >> >
> > >> >> >
> > >> >> > On Thu, Jan 29, 2015 at 3:48 AM, Zilore Mumba via RT
> > >> >> > <met_help at ucar.edu>
> > >> >> > wrote:
> > >> >> >
> > >> >> >>
> > >> >> >> Thu Jan 29 03:48:08 2015: Request 70551 was acted upon.
> > >> >> >> Transaction: Ticket created by zmumba at gmail.com
> > >> >> >>        Queue: met_help
> > >> >> >>      Subject: Problem compiling Met-V5
> > >> >> >>        Owner: Nobody
> > >> >> >>   Requestors: zmumba at gmail.com
> > >> >> >>       Status: new
> > >> >> >>  Ticket <URL:
> > >> https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > >> >> >> >
> > >> >> >>
> > >> >> >>
> > >> >> >> I have installed BUFRLIB, GSL and G2CLIB
> > >> >> >> But then how do I handle the errors below in installing
MET_V5?
> > >> >> >>
> > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/numpbmsg.f:23:
> > >> >> >> undefined
> > >> >> >> reference to `ufbtab_'
> > >> >> >> openpb.o: In function `openpb_':
> > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/openpb.f:21:
> > >> >> >> undefined
> > >> >> >> reference to `openbf_'
> > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/openpb.f:22:
> > >> >> >> undefined
> > >> >> >> reference to `datelen_'
> > >> >> >> closepb.o: In function `closepb_':
> > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/closepb.f:19:
> > >> undefined
> > >> >> >> reference to `closbf_'
> > >> >> >> readpb.o: In function `readpb_':
> > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/readpb.f:82:
> > >> >> >> undefined
> > >> >> >> reference to `ireadns_'
> > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/readpb.f:90:
> > >> >> >> undefined
> > >> >> >> reference to `ufbint_'
> > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/readpb.f:94:
> > >> >> >> undefined
> > >> >> >> reference to `ufbevn_'
> > >> >> >> dumppb.o: In function `readpbdump_':
> > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:215:
> > >> undefined
> > >> >> >> reference to `ufbint_'
> > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:218:
> > >> undefined
> > >> >> >> reference to `ufbevn_'
> > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:224:
> > >> undefined
> > >> >> >> reference to `ireadns_'
> > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:203:
> > >> undefined
> > >> >> >> reference to `ireadns_'
> > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:228:
> > >> undefined
> > >> >> >> reference to `ufbint_'
> > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:259:
> > >> undefined
> > >> >> >> reference to `ufbevn_'
> > >> >> >> dumppb.o: In function `dumppb_':
> > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:56:
> > >> >> >> undefined
> > >> >> >> reference to `openbf_'
> > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:57:
> > >> >> >> undefined
> > >> >> >> reference to `datelen_'
> > >> >> >> collect2: error: ld returned 1 exit status
> > >> >> >> make[4]: *** [pb2nc] Error 1
> > >> >> >> make[4]: Leaving directory
> > >> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc'
> > >> >> >> make[3]: *** [install-recursive] Error 1
> > >> >> >> make[3]: Leaving directory
> > >> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other'
> > >> >> >> make[2]: *** [install-recursive] Error 1
> > >> >> >> make[2]: Leaving directory `/home/zmumba/WRF/met-
5.0/src/tools'
> > >> >> >> make[1]: *** [install-recursive] Error 1
> > >> >> >> make[1]: Leaving directory `/home/zmumba/WRF/met-5.0/src'
> > >> >> >> make: *** [install-recursive] Error 1
> > >> >> >>
> > >> >> >>
> > >> >> >
> > >> >> >
> > >> >> > --
> > >> >> > Julie Prestopnik
> > >> >> > National Center for Atmospheric Research
> > >> >> > Research Applications Laboratory
> > >> >> > Phone: 303.497.8399
> > >> >> > Email: jpresto at ucar.edu
> > >> >> >
> > >> >> >
> > >> >>
> > >> >>
> > >> >
> > >> >
> > >> > --
> > >> > Julie Prestopnik
> > >> > National Center for Atmospheric Research
> > >> > Research Applications Laboratory
> > >> > Phone: 303.497.8399
> > >> > Email: jpresto at ucar.edu
> > >> >
> > >> >
> > >>
> > >>
> > >
> > >
> > > --
> > > Julie Prestopnik
> > > National Center for Atmospheric Research
> > > Research Applications Laboratory
> > > Phone: 303.497.8399
> > > Email: jpresto at ucar.edu
> > >
> > >
> >
> >
>
>
> --
> Julie Prestopnik
> National Center for Atmospheric Research
> Research Applications Laboratory
> Phone: 303.497.8399
> Email: jpresto at ucar.edu
>
>

------------------------------------------------
Subject: Problem compiling Met-V5
From: Julie Prestopnik
Time: Tue Mar 03 10:10:25 2015

I'm sorry to hear that you are still experiencing problems installing
METv5.0.

Specifically regarding BUFRLIB, please compile it using the options
listed
on this page:

http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php

Failing to use the "-DUNDERSCORE -fno-second-underscore" (for GNU
compilers) options will result in undefined references when building
the
pb2nc tool.

If you'd like to send us the output of make please do the following:
   make clean
   make install >& make_install.log

And then send us the files "config.log" and "make_install.log".

I hope you'll find what you have been able to install useful.  Please
let
us know if you have any questions.

Thanks,
Julie

On Tue, Mar 3, 2015 at 12:26 AM, Zilore Mumba via RT
<met_help at ucar.edu>
wrote:

>
> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
>
> Julie,
> I did not inform you of the conclusion of my attempt to install Met-
5.1.
> After making many attempts in reinstalling/reconfiguring BUFRLIB i
still
> get errors relating to "undefined reference to ..." and eventually I
still
> have 3 executables not installed: pb2nc, modis_regrid,
plot_mode_field.
> I would like to learn how to use what I have and come back later to
pb2nc
> if necessary. I will inform you if I have any other problems.
>
>
> On Tue, Feb 10, 2015 at 7:12 PM, Julie Prestopnik via RT <
> met_help at ucar.edu>
> wrote:
>
> > Thank you for rerunning and sending this log.  Perhaps MET cannot
find
> the
> > BUFR library.
> >
> > On the following page are directions for setting the environment
> variables
> > before compiling MET:
> >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php
> >
> > The rest of the applications built, so it looks like MET was able
to find
> > the other needed libraries.  The directions for the BUFR
environment
> > variable on the above page are:
> >
> > "Set *$MET_BUFR* to point to the main BUFR directory, or set
> *$MET_BUFRLIB*
> > to point to the directory with the BUFR library files. Because MET
> doesn't
> > use any BUFR library include files, you don't need to specify
> > *$MET_BUFRINC*
> > ."
> >
> > Please try setting either *$MET_BUFR *or *$MET_BUFRLIB *and then
please
> > rerun the configure script and then rerun make install.  It is
important
> to
> > rerun configure before rerunning make install.
> >
> > Please let me know how it goes.
> >
> > Thanks,
> > Julie
> >
> >
> >
> >
> >
> > On Sat, Feb 7, 2015 at 9:36 PM, Zilore Mumba via RT
<met_help at ucar.edu>
> > wrote:
> >
> > >
> > > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > >
> > > Julie,
> > > Attached to this mail, please find the file make-install.log. It
does
> > > show 'undefined reference' to some functions. I hope this means
> > > something to you and that you can help.
> > > Thanks in advance
> > > Zilore
> > >
> > >
> > > On 2/5/15, Julie Prestopnik via RT <met_help at ucar.edu> wrote:
> > > > Thank you for attaching your log files.  I did not see any
errors in
> > your
> > > > make-install.log.  Perhaps you ran make install in the
following way:
> > > >
> > > > make install > make-install.log
> > > >
> > > > This would catch standard out but not standard error.
> > > >
> > > > Could you please try running in the following way with the &,
which
> > will
> > > > also capture standard error?
> > > >
> > > > make install >& make-install.log
> > > >
> > > > And, then please send me the output of that log.  Thank you!
> > > >
> > > > Julie
> > > >
> > > > On Tue, Feb 3, 2015 at 2:08 PM, Zilore Mumba via RT <
> met_help at ucar.edu
> > >
> > > > wrote:
> > > >
> > > >>
> > > >> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
>
> > > >>
> > > >> Julie,
> > > >> Thank you very much for your assistance. I failed to install
Cairo
> and
> > > >> freetype because of the dependencies. I will try again with
the
> links
> > > >> you sent me.
> > > >> Please find attached my config.log and make-install.log.
> > > >>
> > > >>
> > > >> On 2/2/15, Julie Prestopnik via RT <met_help at ucar.edu> wrote:
> > > >> > I'm so glad you were able to get MET installed and that you
worked
> > out
> > > >> the
> > > >> > issue with the NetCDF environment variables.
> > > >> >
> > > >> > You mentioned that three executables did not build.  I
would like
> to
> > > >> > try
> > > >> to
> > > >> > help with those.  The modis_regrid tool has library
dependencies -
> > it
> > > >> > requires the HDF4 and HDF-EOS2 libraries.  The
plot_mode_field
> tool
> > > >> > also
> > > >> > has library dependencies - it requires the Cairo and
FreeType
> > > >> > libraries.
> > > >> >
> > > >> > You can find information on compiling each of those library
> > > >> > dependencies
> > > >> > here:
> > > >> >
> > > >>
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> > > >> >
> > > >> > You can find information on setting the up necessary
environment
> > > >> variables
> > > >> > for those library locations here:
> > > >> >
> > > >>
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php
> > > >> >
> > > >> > And with pb2nc, I'm not exactly sure what is going on
there.  I
> > would
> > > >> > be
> > > >> > happy to take a look at your configure log and make install
log
> > files
> > > >> > to
> > > >> > see if I can figure out why you didn't get the executable.
> > > >> >
> > > >> > I hope this helps.
> > > >> >
> > > >> > Thanks,
> > > >> > Julie
> > > >> >
> > > >> >
> > > >> >
> > > >> > On Sat, Jan 31, 2015 at 5:31 PM, Zilore Mumba via RT
> > > >> > <met_help at ucar.edu>
> > > >> > wrote:
> > > >> >
> > > >> >>
> > > >> >> <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > > >> >>
> > > >> >> Julg
> > > >> >> Thank you very much for your help. With the advice you
gave me, I
> > was
> > > >> >> able to install MET using gcc and gfortran. I also had to
to
> point
> > > >> >> $MET_NETCDFLIB and, $MET_NETCDFINC to /usr/local/netcdf-
4.1.3/lib
> > and
> > > >> >> include. Previously I pointed only to /usr/local/netcdf-
4.1.3.
> > > >> >> I have three executables not included though, these are
> > modis_regrid,
> > > >> >> plot_mode_field and pb2nc.
> > > >> >> Thank you very much.
> > > >> >>
> > > >> >>
> > > >> >> On 1/29/15, Julie Prestopnik via RT <met_help at ucar.edu>
wrote:
> > > >> >> > I am sorry to hear that you are having problems
installing
> > METv5.0.
> > > >> >> > I
> > > >> >> > believe this error may have to do with how you compiled
> BUFRLIB.
> > > >> >> > Please
> > > >> >> > take a look at the sample commands for compiling BURFLIB
on
> this
> > > >> >> > page:
> > > >> >> >
> > > >> >>
> > > >>
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> > > >> >> >
> > > >> >> > I believe that the *-fno-second-underscore* (GNU
compilers) or
> > > >> >> > *-Mnosecond_underscore* (PGI compilers) will fix the
error
> you're
> > > >> >> > seeing.
> > > >> >> >
> > > >> >> > I hope that helps.  If it doesn't, please send me the
files
> > > >> >> "make_met.log"
> > > >> >> > and "config.log".
> > > >> >> >
> > > >> >> > Thanks,
> > > >> >> > Julie
> > > >> >> >
> > > >> >> >
> > > >> >> > On Thu, Jan 29, 2015 at 3:48 AM, Zilore Mumba via RT
> > > >> >> > <met_help at ucar.edu>
> > > >> >> > wrote:
> > > >> >> >
> > > >> >> >>
> > > >> >> >> Thu Jan 29 03:48:08 2015: Request 70551 was acted upon.
> > > >> >> >> Transaction: Ticket created by zmumba at gmail.com
> > > >> >> >>        Queue: met_help
> > > >> >> >>      Subject: Problem compiling Met-V5
> > > >> >> >>        Owner: Nobody
> > > >> >> >>   Requestors: zmumba at gmail.com
> > > >> >> >>       Status: new
> > > >> >> >>  Ticket <URL:
> > > >> https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > >> >> >> >
> > > >> >> >>
> > > >> >> >>
> > > >> >> >> I have installed BUFRLIB, GSL and G2CLIB
> > > >> >> >> But then how do I handle the errors below in installing
> MET_V5?
> > > >> >> >>
> > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/numpbmsg.f:23:
> > > >> >> >> undefined
> > > >> >> >> reference to `ufbtab_'
> > > >> >> >> openpb.o: In function `openpb_':
> > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/openpb.f:21:
> > > >> >> >> undefined
> > > >> >> >> reference to `openbf_'
> > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/openpb.f:22:
> > > >> >> >> undefined
> > > >> >> >> reference to `datelen_'
> > > >> >> >> closepb.o: In function `closepb_':
> > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/closepb.f:19:
> > > >> undefined
> > > >> >> >> reference to `closbf_'
> > > >> >> >> readpb.o: In function `readpb_':
> > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/readpb.f:82:
> > > >> >> >> undefined
> > > >> >> >> reference to `ireadns_'
> > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/readpb.f:90:
> > > >> >> >> undefined
> > > >> >> >> reference to `ufbint_'
> > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/readpb.f:94:
> > > >> >> >> undefined
> > > >> >> >> reference to `ufbevn_'
> > > >> >> >> dumppb.o: In function `readpbdump_':
> > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:215:
> > > >> undefined
> > > >> >> >> reference to `ufbint_'
> > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:218:
> > > >> undefined
> > > >> >> >> reference to `ufbevn_'
> > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:224:
> > > >> undefined
> > > >> >> >> reference to `ireadns_'
> > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:203:
> > > >> undefined
> > > >> >> >> reference to `ireadns_'
> > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:228:
> > > >> undefined
> > > >> >> >> reference to `ufbint_'
> > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:259:
> > > >> undefined
> > > >> >> >> reference to `ufbevn_'
> > > >> >> >> dumppb.o: In function `dumppb_':
> > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:56:
> > > >> >> >> undefined
> > > >> >> >> reference to `openbf_'
> > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:57:
> > > >> >> >> undefined
> > > >> >> >> reference to `datelen_'
> > > >> >> >> collect2: error: ld returned 1 exit status
> > > >> >> >> make[4]: *** [pb2nc] Error 1
> > > >> >> >> make[4]: Leaving directory
> > > >> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc'
> > > >> >> >> make[3]: *** [install-recursive] Error 1
> > > >> >> >> make[3]: Leaving directory
> > > >> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other'
> > > >> >> >> make[2]: *** [install-recursive] Error 1
> > > >> >> >> make[2]: Leaving directory
> `/home/zmumba/WRF/met-5.0/src/tools'
> > > >> >> >> make[1]: *** [install-recursive] Error 1
> > > >> >> >> make[1]: Leaving directory `/home/zmumba/WRF/met-
5.0/src'
> > > >> >> >> make: *** [install-recursive] Error 1
> > > >> >> >>
> > > >> >> >>
> > > >> >> >
> > > >> >> >
> > > >> >> > --
> > > >> >> > Julie Prestopnik
> > > >> >> > National Center for Atmospheric Research
> > > >> >> > Research Applications Laboratory
> > > >> >> > Phone: 303.497.8399
> > > >> >> > Email: jpresto at ucar.edu
> > > >> >> >
> > > >> >> >
> > > >> >>
> > > >> >>
> > > >> >
> > > >> >
> > > >> > --
> > > >> > Julie Prestopnik
> > > >> > National Center for Atmospheric Research
> > > >> > Research Applications Laboratory
> > > >> > Phone: 303.497.8399
> > > >> > Email: jpresto at ucar.edu
> > > >> >
> > > >> >
> > > >>
> > > >>
> > > >
> > > >
> > > > --
> > > > Julie Prestopnik
> > > > National Center for Atmospheric Research
> > > > Research Applications Laboratory
> > > > Phone: 303.497.8399
> > > > Email: jpresto at ucar.edu
> > > >
> > > >
> > >
> > >
> >
> >
> > --
> > Julie Prestopnik
> > National Center for Atmospheric Research
> > Research Applications Laboratory
> > Phone: 303.497.8399
> > Email: jpresto at ucar.edu
> >
> >
>
>


--
Julie Prestopnik
National Center for Atmospheric Research
Research Applications Laboratory
Phone: 303.497.8399
Email: jpresto at ucar.edu

------------------------------------------------
Subject: Problem compiling Met-V5
From: Zilore Mumba
Time: Wed Mar 04 05:36:38 2015

*Julie, I installed with the following commands. gcc -c -DUNDERSCORE
*.c*
   *gfortran -c -DUNDERSCORE -fno-second-underscore *.f *.F*
   *ar crv libbufr.a *.o*



*Please find attached the config.log and make_install.log *


On Tue, Mar 3, 2015 at 7:10 PM, Julie Prestopnik via RT
<met_help at ucar.edu>
wrote:

> I'm sorry to hear that you are still experiencing problems
installing
> METv5.0.
>
> Specifically regarding BUFRLIB, please compile it using the options
listed
> on this page:
>
>
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
>
> Failing to use the "-DUNDERSCORE -fno-second-underscore" (for GNU
> compilers) options will result in undefined references when building
the
> pb2nc tool.
>
> If you'd like to send us the output of make please do the following:
>    make clean
>    make install >& make_install.log
>
> And then send us the files "config.log" and "make_install.log".
>
> I hope you'll find what you have been able to install useful.
Please let
> us know if you have any questions.
>
> Thanks,
> Julie
>
> On Tue, Mar 3, 2015 at 12:26 AM, Zilore Mumba via RT
<met_help at ucar.edu>
> wrote:
>
> >
> > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> >
> > Julie,
> > I did not inform you of the conclusion of my attempt to install
Met-5.1.
> > After making many attempts in reinstalling/reconfiguring BUFRLIB i
still
> > get errors relating to "undefined reference to ..." and eventually
I
> still
> > have 3 executables not installed: pb2nc, modis_regrid,
plot_mode_field.
> > I would like to learn how to use what I have and come back later
to pb2nc
> > if necessary. I will inform you if I have any other problems.
> >
> >
> > On Tue, Feb 10, 2015 at 7:12 PM, Julie Prestopnik via RT <
> > met_help at ucar.edu>
> > wrote:
> >
> > > Thank you for rerunning and sending this log.  Perhaps MET
cannot find
> > the
> > > BUFR library.
> > >
> > > On the following page are directions for setting the environment
> > variables
> > > before compiling MET:
> > >
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php
> > >
> > > The rest of the applications built, so it looks like MET was
able to
> find
> > > the other needed libraries.  The directions for the BUFR
environment
> > > variable on the above page are:
> > >
> > > "Set *$MET_BUFR* to point to the main BUFR directory, or set
> > *$MET_BUFRLIB*
> > > to point to the directory with the BUFR library files. Because
MET
> > doesn't
> > > use any BUFR library include files, you don't need to specify
> > > *$MET_BUFRINC*
> > > ."
> > >
> > > Please try setting either *$MET_BUFR *or *$MET_BUFRLIB *and then
please
> > > rerun the configure script and then rerun make install.  It is
> important
> > to
> > > rerun configure before rerunning make install.
> > >
> > > Please let me know how it goes.
> > >
> > > Thanks,
> > > Julie
> > >
> > >
> > >
> > >
> > >
> > > On Sat, Feb 7, 2015 at 9:36 PM, Zilore Mumba via RT
<met_help at ucar.edu
> >
> > > wrote:
> > >
> > > >
> > > > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
>
> > > >
> > > > Julie,
> > > > Attached to this mail, please find the file make-install.log.
It does
> > > > show 'undefined reference' to some functions. I hope this
means
> > > > something to you and that you can help.
> > > > Thanks in advance
> > > > Zilore
> > > >
> > > >
> > > > On 2/5/15, Julie Prestopnik via RT <met_help at ucar.edu> wrote:
> > > > > Thank you for attaching your log files.  I did not see any
errors
> in
> > > your
> > > > > make-install.log.  Perhaps you ran make install in the
following
> way:
> > > > >
> > > > > make install > make-install.log
> > > > >
> > > > > This would catch standard out but not standard error.
> > > > >
> > > > > Could you please try running in the following way with the
&, which
> > > will
> > > > > also capture standard error?
> > > > >
> > > > > make install >& make-install.log
> > > > >
> > > > > And, then please send me the output of that log.  Thank you!
> > > > >
> > > > > Julie
> > > > >
> > > > > On Tue, Feb 3, 2015 at 2:08 PM, Zilore Mumba via RT <
> > met_help at ucar.edu
> > > >
> > > > > wrote:
> > > > >
> > > > >>
> > > > >> <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > > > >>
> > > > >> Julie,
> > > > >> Thank you very much for your assistance. I failed to
install Cairo
> > and
> > > > >> freetype because of the dependencies. I will try again with
the
> > links
> > > > >> you sent me.
> > > > >> Please find attached my config.log and make-install.log.
> > > > >>
> > > > >>
> > > > >> On 2/2/15, Julie Prestopnik via RT <met_help at ucar.edu>
wrote:
> > > > >> > I'm so glad you were able to get MET installed and that
you
> worked
> > > out
> > > > >> the
> > > > >> > issue with the NetCDF environment variables.
> > > > >> >
> > > > >> > You mentioned that three executables did not build.  I
would
> like
> > to
> > > > >> > try
> > > > >> to
> > > > >> > help with those.  The modis_regrid tool has library
> dependencies -
> > > it
> > > > >> > requires the HDF4 and HDF-EOS2 libraries.  The
plot_mode_field
> > tool
> > > > >> > also
> > > > >> > has library dependencies - it requires the Cairo and
FreeType
> > > > >> > libraries.
> > > > >> >
> > > > >> > You can find information on compiling each of those
library
> > > > >> > dependencies
> > > > >> > here:
> > > > >> >
> > > > >>
> > > >
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> > > > >> >
> > > > >> > You can find information on setting the up necessary
environment
> > > > >> variables
> > > > >> > for those library locations here:
> > > > >> >
> > > > >>
> > > >
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php
> > > > >> >
> > > > >> > And with pb2nc, I'm not exactly sure what is going on
there.  I
> > > would
> > > > >> > be
> > > > >> > happy to take a look at your configure log and make
install log
> > > files
> > > > >> > to
> > > > >> > see if I can figure out why you didn't get the
executable.
> > > > >> >
> > > > >> > I hope this helps.
> > > > >> >
> > > > >> > Thanks,
> > > > >> > Julie
> > > > >> >
> > > > >> >
> > > > >> >
> > > > >> > On Sat, Jan 31, 2015 at 5:31 PM, Zilore Mumba via RT
> > > > >> > <met_help at ucar.edu>
> > > > >> > wrote:
> > > > >> >
> > > > >> >>
> > > > >> >> <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> >
> > > > >> >>
> > > > >> >> Julg
> > > > >> >> Thank you very much for your help. With the advice you
gave
> me, I
> > > was
> > > > >> >> able to install MET using gcc and gfortran. I also had
to to
> > point
> > > > >> >> $MET_NETCDFLIB and, $MET_NETCDFINC to
> /usr/local/netcdf-4.1.3/lib
> > > and
> > > > >> >> include. Previously I pointed only to /usr/local/netcdf-
4.1.3.
> > > > >> >> I have three executables not included though, these are
> > > modis_regrid,
> > > > >> >> plot_mode_field and pb2nc.
> > > > >> >> Thank you very much.
> > > > >> >>
> > > > >> >>
> > > > >> >> On 1/29/15, Julie Prestopnik via RT <met_help at ucar.edu>
wrote:
> > > > >> >> > I am sorry to hear that you are having problems
installing
> > > METv5.0.
> > > > >> >> > I
> > > > >> >> > believe this error may have to do with how you
compiled
> > BUFRLIB.
> > > > >> >> > Please
> > > > >> >> > take a look at the sample commands for compiling
BURFLIB on
> > this
> > > > >> >> > page:
> > > > >> >> >
> > > > >> >>
> > > > >>
> > > >
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> > > > >> >> >
> > > > >> >> > I believe that the *-fno-second-underscore* (GNU
compilers)
> or
> > > > >> >> > *-Mnosecond_underscore* (PGI compilers) will fix the
error
> > you're
> > > > >> >> > seeing.
> > > > >> >> >
> > > > >> >> > I hope that helps.  If it doesn't, please send me the
files
> > > > >> >> "make_met.log"
> > > > >> >> > and "config.log".
> > > > >> >> >
> > > > >> >> > Thanks,
> > > > >> >> > Julie
> > > > >> >> >
> > > > >> >> >
> > > > >> >> > On Thu, Jan 29, 2015 at 3:48 AM, Zilore Mumba via RT
> > > > >> >> > <met_help at ucar.edu>
> > > > >> >> > wrote:
> > > > >> >> >
> > > > >> >> >>
> > > > >> >> >> Thu Jan 29 03:48:08 2015: Request 70551 was acted
upon.
> > > > >> >> >> Transaction: Ticket created by zmumba at gmail.com
> > > > >> >> >>        Queue: met_help
> > > > >> >> >>      Subject: Problem compiling Met-V5
> > > > >> >> >>        Owner: Nobody
> > > > >> >> >>   Requestors: zmumba at gmail.com
> > > > >> >> >>       Status: new
> > > > >> >> >>  Ticket <URL:
> > > > >> https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > > >> >> >> >
> > > > >> >> >>
> > > > >> >> >>
> > > > >> >> >> I have installed BUFRLIB, GSL and G2CLIB
> > > > >> >> >> But then how do I handle the errors below in
installing
> > MET_V5?
> > > > >> >> >>
> > > > >> >> >>
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/numpbmsg.f:23:
> > > > >> >> >> undefined
> > > > >> >> >> reference to `ufbtab_'
> > > > >> >> >> openpb.o: In function `openpb_':
> > > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/openpb.f:21:
> > > > >> >> >> undefined
> > > > >> >> >> reference to `openbf_'
> > > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/openpb.f:22:
> > > > >> >> >> undefined
> > > > >> >> >> reference to `datelen_'
> > > > >> >> >> closepb.o: In function `closepb_':
> > > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/closepb.f:19:
> > > > >> undefined
> > > > >> >> >> reference to `closbf_'
> > > > >> >> >> readpb.o: In function `readpb_':
> > > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/readpb.f:82:
> > > > >> >> >> undefined
> > > > >> >> >> reference to `ireadns_'
> > > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/readpb.f:90:
> > > > >> >> >> undefined
> > > > >> >> >> reference to `ufbint_'
> > > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/readpb.f:94:
> > > > >> >> >> undefined
> > > > >> >> >> reference to `ufbevn_'
> > > > >> >> >> dumppb.o: In function `readpbdump_':
> > > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:215:
> > > > >> undefined
> > > > >> >> >> reference to `ufbint_'
> > > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:218:
> > > > >> undefined
> > > > >> >> >> reference to `ufbevn_'
> > > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:224:
> > > > >> undefined
> > > > >> >> >> reference to `ireadns_'
> > > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:203:
> > > > >> undefined
> > > > >> >> >> reference to `ireadns_'
> > > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:228:
> > > > >> undefined
> > > > >> >> >> reference to `ufbint_'
> > > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:259:
> > > > >> undefined
> > > > >> >> >> reference to `ufbevn_'
> > > > >> >> >> dumppb.o: In function `dumppb_':
> > > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:56:
> > > > >> >> >> undefined
> > > > >> >> >> reference to `openbf_'
> > > > >> >> >> /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:57:
> > > > >> >> >> undefined
> > > > >> >> >> reference to `datelen_'
> > > > >> >> >> collect2: error: ld returned 1 exit status
> > > > >> >> >> make[4]: *** [pb2nc] Error 1
> > > > >> >> >> make[4]: Leaving directory
> > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc'
> > > > >> >> >> make[3]: *** [install-recursive] Error 1
> > > > >> >> >> make[3]: Leaving directory
> > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other'
> > > > >> >> >> make[2]: *** [install-recursive] Error 1
> > > > >> >> >> make[2]: Leaving directory
> > `/home/zmumba/WRF/met-5.0/src/tools'
> > > > >> >> >> make[1]: *** [install-recursive] Error 1
> > > > >> >> >> make[1]: Leaving directory `/home/zmumba/WRF/met-
5.0/src'
> > > > >> >> >> make: *** [install-recursive] Error 1
> > > > >> >> >>
> > > > >> >> >>
> > > > >> >> >
> > > > >> >> >
> > > > >> >> > --
> > > > >> >> > Julie Prestopnik
> > > > >> >> > National Center for Atmospheric Research
> > > > >> >> > Research Applications Laboratory
> > > > >> >> > Phone: 303.497.8399
> > > > >> >> > Email: jpresto at ucar.edu
> > > > >> >> >
> > > > >> >> >
> > > > >> >>
> > > > >> >>
> > > > >> >
> > > > >> >
> > > > >> > --
> > > > >> > Julie Prestopnik
> > > > >> > National Center for Atmospheric Research
> > > > >> > Research Applications Laboratory
> > > > >> > Phone: 303.497.8399
> > > > >> > Email: jpresto at ucar.edu
> > > > >> >
> > > > >> >
> > > > >>
> > > > >>
> > > > >
> > > > >
> > > > > --
> > > > > Julie Prestopnik
> > > > > National Center for Atmospheric Research
> > > > > Research Applications Laboratory
> > > > > Phone: 303.497.8399
> > > > > Email: jpresto at ucar.edu
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> > > --
> > > Julie Prestopnik
> > > National Center for Atmospheric Research
> > > Research Applications Laboratory
> > > Phone: 303.497.8399
> > > Email: jpresto at ucar.edu
> > >
> > >
> >
> >
>
>
> --
> Julie Prestopnik
> National Center for Atmospheric Research
> Research Applications Laboratory
> Phone: 303.497.8399
> Email: jpresto at ucar.edu
>
>

------------------------------------------------
Subject: Problem compiling Met-V5
From: Julie Prestopnik
Time: Thu Mar 05 10:59:52 2015

Hi Zilore.  Thanks for sending your commands and log files.

Looking in "config.log" for the string "BUFRLIB", it appears that you
did
not set the environment variable.

The linker error occurs on line 1057 of make_install.log.  Looking at
that
line, we're telling the linker to look in the following directories
for the
file named "libbufr.a":

-L/usr/lib/gcc/i686-linux-gnu/4.8
-L/usr/lib/gcc/i686-linux-gnu/4.8/../../../i386-linux-gnu
-L/usr/lib/gcc/i686-linux-gnu/4.8/../../../../lib
-L/lib/i386-linux-gnu
-L/lib/../lib
-L/usr/lib/i386-linux-gnu
-L/usr/lib/../lib
-L/usr/lib/gcc/i686-linux-gnu/4.8/../../..

It must be finding libbufr.a in one of those directories, otherwise we
would get an error about that.  I believe that the version of
libbufr.a it
is finding is not the version that you compiled using the "-
DUNDERSCORE"
option.

I was able to replicate your error by re-compiling a version of
BUFRLIB
*without* -DUNDERSCORE, and then by building MET linking to that bad
version.

What you'll need to do is set the MET_BUFRLIB environment variable as
indicated on this page:
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php

Then source your .cshrc or equivalent file, then run your configure
command, and then run make install and make test.

Please give that a try.  It should solve the problem you are
encountering.

Thanks,
Julie

On Wed, Mar 4, 2015 at 5:36 AM, Zilore Mumba via RT
<met_help at ucar.edu>
wrote:

>
> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
>
> *Julie, I installed with the following commands. gcc -c -DUNDERSCORE
*.c*
>    *gfortran -c -DUNDERSCORE -fno-second-underscore *.f *.F*
>    *ar crv libbufr.a *.o*
>
>
>
> *Please find attached the config.log and make_install.log *
>
>
> On Tue, Mar 3, 2015 at 7:10 PM, Julie Prestopnik via RT
<met_help at ucar.edu
> >
> wrote:
>
> > I'm sorry to hear that you are still experiencing problems
installing
> > METv5.0.
> >
> > Specifically regarding BUFRLIB, please compile it using the
options
> listed
> > on this page:
> >
> >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> >
> > Failing to use the "-DUNDERSCORE -fno-second-underscore" (for GNU
> > compilers) options will result in undefined references when
building the
> > pb2nc tool.
> >
> > If you'd like to send us the output of make please do the
following:
> >    make clean
> >    make install >& make_install.log
> >
> > And then send us the files "config.log" and "make_install.log".
> >
> > I hope you'll find what you have been able to install useful.
Please let
> > us know if you have any questions.
> >
> > Thanks,
> > Julie
> >
> > On Tue, Mar 3, 2015 at 12:26 AM, Zilore Mumba via RT
<met_help at ucar.edu>
> > wrote:
> >
> > >
> > > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > >
> > > Julie,
> > > I did not inform you of the conclusion of my attempt to install
> Met-5.1.
> > > After making many attempts in reinstalling/reconfiguring BUFRLIB
i
> still
> > > get errors relating to "undefined reference to ..." and
eventually I
> > still
> > > have 3 executables not installed: pb2nc, modis_regrid,
plot_mode_field.
> > > I would like to learn how to use what I have and come back later
to
> pb2nc
> > > if necessary. I will inform you if I have any other problems.
> > >
> > >
> > > On Tue, Feb 10, 2015 at 7:12 PM, Julie Prestopnik via RT <
> > > met_help at ucar.edu>
> > > wrote:
> > >
> > > > Thank you for rerunning and sending this log.  Perhaps MET
cannot
> find
> > > the
> > > > BUFR library.
> > > >
> > > > On the following page are directions for setting the
environment
> > > variables
> > > > before compiling MET:
> > > >
> > > >
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php
> > > >
> > > > The rest of the applications built, so it looks like MET was
able to
> > find
> > > > the other needed libraries.  The directions for the BUFR
environment
> > > > variable on the above page are:
> > > >
> > > > "Set *$MET_BUFR* to point to the main BUFR directory, or set
> > > *$MET_BUFRLIB*
> > > > to point to the directory with the BUFR library files. Because
MET
> > > doesn't
> > > > use any BUFR library include files, you don't need to specify
> > > > *$MET_BUFRINC*
> > > > ."
> > > >
> > > > Please try setting either *$MET_BUFR *or *$MET_BUFRLIB *and
then
> please
> > > > rerun the configure script and then rerun make install.  It is
> > important
> > > to
> > > > rerun configure before rerunning make install.
> > > >
> > > > Please let me know how it goes.
> > > >
> > > > Thanks,
> > > > Julie
> > > >
> > > >
> > > >
> > > >
> > > >
> > > > On Sat, Feb 7, 2015 at 9:36 PM, Zilore Mumba via RT <
> met_help at ucar.edu
> > >
> > > > wrote:
> > > >
> > > > >
> > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > > > >
> > > > > Julie,
> > > > > Attached to this mail, please find the file make-
install.log. It
> does
> > > > > show 'undefined reference' to some functions. I hope this
means
> > > > > something to you and that you can help.
> > > > > Thanks in advance
> > > > > Zilore
> > > > >
> > > > >
> > > > > On 2/5/15, Julie Prestopnik via RT <met_help at ucar.edu>
wrote:
> > > > > > Thank you for attaching your log files.  I did not see any
errors
> > in
> > > > your
> > > > > > make-install.log.  Perhaps you ran make install in the
following
> > way:
> > > > > >
> > > > > > make install > make-install.log
> > > > > >
> > > > > > This would catch standard out but not standard error.
> > > > > >
> > > > > > Could you please try running in the following way with the
&,
> which
> > > > will
> > > > > > also capture standard error?
> > > > > >
> > > > > > make install >& make-install.log
> > > > > >
> > > > > > And, then please send me the output of that log.  Thank
you!
> > > > > >
> > > > > > Julie
> > > > > >
> > > > > > On Tue, Feb 3, 2015 at 2:08 PM, Zilore Mumba via RT <
> > > met_help at ucar.edu
> > > > >
> > > > > > wrote:
> > > > > >
> > > > > >>
> > > > > >> <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > > > > >>
> > > > > >> Julie,
> > > > > >> Thank you very much for your assistance. I failed to
install
> Cairo
> > > and
> > > > > >> freetype because of the dependencies. I will try again
with the
> > > links
> > > > > >> you sent me.
> > > > > >> Please find attached my config.log and make-install.log.
> > > > > >>
> > > > > >>
> > > > > >> On 2/2/15, Julie Prestopnik via RT <met_help at ucar.edu>
wrote:
> > > > > >> > I'm so glad you were able to get MET installed and that
you
> > worked
> > > > out
> > > > > >> the
> > > > > >> > issue with the NetCDF environment variables.
> > > > > >> >
> > > > > >> > You mentioned that three executables did not build.  I
would
> > like
> > > to
> > > > > >> > try
> > > > > >> to
> > > > > >> > help with those.  The modis_regrid tool has library
> > dependencies -
> > > > it
> > > > > >> > requires the HDF4 and HDF-EOS2 libraries.  The
plot_mode_field
> > > tool
> > > > > >> > also
> > > > > >> > has library dependencies - it requires the Cairo and
FreeType
> > > > > >> > libraries.
> > > > > >> >
> > > > > >> > You can find information on compiling each of those
library
> > > > > >> > dependencies
> > > > > >> > here:
> > > > > >> >
> > > > > >>
> > > > >
> > > >
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> > > > > >> >
> > > > > >> > You can find information on setting the up necessary
> environment
> > > > > >> variables
> > > > > >> > for those library locations here:
> > > > > >> >
> > > > > >>
> > > > >
> > > >
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php
> > > > > >> >
> > > > > >> > And with pb2nc, I'm not exactly sure what is going on
there.
> I
> > > > would
> > > > > >> > be
> > > > > >> > happy to take a look at your configure log and make
install
> log
> > > > files
> > > > > >> > to
> > > > > >> > see if I can figure out why you didn't get the
executable.
> > > > > >> >
> > > > > >> > I hope this helps.
> > > > > >> >
> > > > > >> > Thanks,
> > > > > >> > Julie
> > > > > >> >
> > > > > >> >
> > > > > >> >
> > > > > >> > On Sat, Jan 31, 2015 at 5:31 PM, Zilore Mumba via RT
> > > > > >> > <met_help at ucar.edu>
> > > > > >> > wrote:
> > > > > >> >
> > > > > >> >>
> > > > > >> >> <URL:
> https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > >
> > > > > >> >>
> > > > > >> >> Julg
> > > > > >> >> Thank you very much for your help. With the advice you
gave
> > me, I
> > > > was
> > > > > >> >> able to install MET using gcc and gfortran. I also had
to to
> > > point
> > > > > >> >> $MET_NETCDFLIB and, $MET_NETCDFINC to
> > /usr/local/netcdf-4.1.3/lib
> > > > and
> > > > > >> >> include. Previously I pointed only to
> /usr/local/netcdf-4.1.3.
> > > > > >> >> I have three executables not included though, these
are
> > > > modis_regrid,
> > > > > >> >> plot_mode_field and pb2nc.
> > > > > >> >> Thank you very much.
> > > > > >> >>
> > > > > >> >>
> > > > > >> >> On 1/29/15, Julie Prestopnik via RT
<met_help at ucar.edu>
> wrote:
> > > > > >> >> > I am sorry to hear that you are having problems
installing
> > > > METv5.0.
> > > > > >> >> > I
> > > > > >> >> > believe this error may have to do with how you
compiled
> > > BUFRLIB.
> > > > > >> >> > Please
> > > > > >> >> > take a look at the sample commands for compiling
BURFLIB on
> > > this
> > > > > >> >> > page:
> > > > > >> >> >
> > > > > >> >>
> > > > > >>
> > > > >
> > > >
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> > > > > >> >> >
> > > > > >> >> > I believe that the *-fno-second-underscore* (GNU
compilers)
> > or
> > > > > >> >> > *-Mnosecond_underscore* (PGI compilers) will fix the
error
> > > you're
> > > > > >> >> > seeing.
> > > > > >> >> >
> > > > > >> >> > I hope that helps.  If it doesn't, please send me
the files
> > > > > >> >> "make_met.log"
> > > > > >> >> > and "config.log".
> > > > > >> >> >
> > > > > >> >> > Thanks,
> > > > > >> >> > Julie
> > > > > >> >> >
> > > > > >> >> >
> > > > > >> >> > On Thu, Jan 29, 2015 at 3:48 AM, Zilore Mumba via RT
> > > > > >> >> > <met_help at ucar.edu>
> > > > > >> >> > wrote:
> > > > > >> >> >
> > > > > >> >> >>
> > > > > >> >> >> Thu Jan 29 03:48:08 2015: Request 70551 was acted
upon.
> > > > > >> >> >> Transaction: Ticket created by zmumba at gmail.com
> > > > > >> >> >>        Queue: met_help
> > > > > >> >> >>      Subject: Problem compiling Met-V5
> > > > > >> >> >>        Owner: Nobody
> > > > > >> >> >>   Requestors: zmumba at gmail.com
> > > > > >> >> >>       Status: new
> > > > > >> >> >>  Ticket <URL:
> > > > > >> https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > > > >> >> >> >
> > > > > >> >> >>
> > > > > >> >> >>
> > > > > >> >> >> I have installed BUFRLIB, GSL and G2CLIB
> > > > > >> >> >> But then how do I handle the errors below in
installing
> > > MET_V5?
> > > > > >> >> >>
> > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/numpbmsg.f:23:
> > > > > >> >> >> undefined
> > > > > >> >> >> reference to `ufbtab_'
> > > > > >> >> >> openpb.o: In function `openpb_':
> > > > > >> >> >>
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:21:
> > > > > >> >> >> undefined
> > > > > >> >> >> reference to `openbf_'
> > > > > >> >> >>
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:22:
> > > > > >> >> >> undefined
> > > > > >> >> >> reference to `datelen_'
> > > > > >> >> >> closepb.o: In function `closepb_':
> > > > > >> >> >>
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/closepb.f:19:
> > > > > >> undefined
> > > > > >> >> >> reference to `closbf_'
> > > > > >> >> >> readpb.o: In function `readpb_':
> > > > > >> >> >>
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:82:
> > > > > >> >> >> undefined
> > > > > >> >> >> reference to `ireadns_'
> > > > > >> >> >>
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:90:
> > > > > >> >> >> undefined
> > > > > >> >> >> reference to `ufbint_'
> > > > > >> >> >>
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:94:
> > > > > >> >> >> undefined
> > > > > >> >> >> reference to `ufbevn_'
> > > > > >> >> >> dumppb.o: In function `readpbdump_':
> > > > > >> >> >>
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:215:
> > > > > >> undefined
> > > > > >> >> >> reference to `ufbint_'
> > > > > >> >> >>
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:218:
> > > > > >> undefined
> > > > > >> >> >> reference to `ufbevn_'
> > > > > >> >> >>
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:224:
> > > > > >> undefined
> > > > > >> >> >> reference to `ireadns_'
> > > > > >> >> >>
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:203:
> > > > > >> undefined
> > > > > >> >> >> reference to `ireadns_'
> > > > > >> >> >>
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:228:
> > > > > >> undefined
> > > > > >> >> >> reference to `ufbint_'
> > > > > >> >> >>
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:259:
> > > > > >> undefined
> > > > > >> >> >> reference to `ufbevn_'
> > > > > >> >> >> dumppb.o: In function `dumppb_':
> > > > > >> >> >>
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:56:
> > > > > >> >> >> undefined
> > > > > >> >> >> reference to `openbf_'
> > > > > >> >> >>
> /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:57:
> > > > > >> >> >> undefined
> > > > > >> >> >> reference to `datelen_'
> > > > > >> >> >> collect2: error: ld returned 1 exit status
> > > > > >> >> >> make[4]: *** [pb2nc] Error 1
> > > > > >> >> >> make[4]: Leaving directory
> > > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc'
> > > > > >> >> >> make[3]: *** [install-recursive] Error 1
> > > > > >> >> >> make[3]: Leaving directory
> > > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other'
> > > > > >> >> >> make[2]: *** [install-recursive] Error 1
> > > > > >> >> >> make[2]: Leaving directory
> > > `/home/zmumba/WRF/met-5.0/src/tools'
> > > > > >> >> >> make[1]: *** [install-recursive] Error 1
> > > > > >> >> >> make[1]: Leaving directory `/home/zmumba/WRF/met-
5.0/src'
> > > > > >> >> >> make: *** [install-recursive] Error 1
> > > > > >> >> >>
> > > > > >> >> >>
> > > > > >> >> >
> > > > > >> >> >
> > > > > >> >> > --
> > > > > >> >> > Julie Prestopnik
> > > > > >> >> > National Center for Atmospheric Research
> > > > > >> >> > Research Applications Laboratory
> > > > > >> >> > Phone: 303.497.8399
> > > > > >> >> > Email: jpresto at ucar.edu
> > > > > >> >> >
> > > > > >> >> >
> > > > > >> >>
> > > > > >> >>
> > > > > >> >
> > > > > >> >
> > > > > >> > --
> > > > > >> > Julie Prestopnik
> > > > > >> > National Center for Atmospheric Research
> > > > > >> > Research Applications Laboratory
> > > > > >> > Phone: 303.497.8399
> > > > > >> > Email: jpresto at ucar.edu
> > > > > >> >
> > > > > >> >
> > > > > >>
> > > > > >>
> > > > > >
> > > > > >
> > > > > > --
> > > > > > Julie Prestopnik
> > > > > > National Center for Atmospheric Research
> > > > > > Research Applications Laboratory
> > > > > > Phone: 303.497.8399
> > > > > > Email: jpresto at ucar.edu
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > >
> > > >
> > > > --
> > > > Julie Prestopnik
> > > > National Center for Atmospheric Research
> > > > Research Applications Laboratory
> > > > Phone: 303.497.8399
> > > > Email: jpresto at ucar.edu
> > > >
> > > >
> > >
> > >
> >
> >
> > --
> > Julie Prestopnik
> > National Center for Atmospheric Research
> > Research Applications Laboratory
> > Phone: 303.497.8399
> > Email: jpresto at ucar.edu
> >
> >
>
>


--
Julie Prestopnik
National Center for Atmospheric Research
Research Applications Laboratory
Phone: 303.497.8399
Email: jpresto at ucar.edu

------------------------------------------------
Subject: Problem compiling Met-V5
From: Zilore Mumba
Time: Thu Mar 05 15:10:42 2015

Julie,
Thank you very much. The library was in none of the paths listed. Now
i
manged to have pb2nc installed.
Now I can concentrate on learning how to use the tool.
Thank you very much

On Thu, Mar 5, 2015 at 7:59 PM, Julie Prestopnik via RT
<met_help at ucar.edu>
wrote:

> Hi Zilore.  Thanks for sending your commands and log files.
>
> Looking in "config.log" for the string "BUFRLIB", it appears that
you did
> not set the environment variable.
>
> The linker error occurs on line 1057 of make_install.log.  Looking
at that
> line, we're telling the linker to look in the following directories
for the
> file named "libbufr.a":
>
> -L/usr/lib/gcc/i686-linux-gnu/4.8
> -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../i386-linux-gnu
> -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../../lib
> -L/lib/i386-linux-gnu
> -L/lib/../lib
> -L/usr/lib/i386-linux-gnu
> -L/usr/lib/../lib
> -L/usr/lib/gcc/i686-linux-gnu/4.8/../../..
>
> It must be finding libbufr.a in one of those directories, otherwise
we
> would get an error about that.  I believe that the version of
libbufr.a it
> is finding is not the version that you compiled using the "-
DUNDERSCORE"
> option.
>
> I was able to replicate your error by re-compiling a version of
BUFRLIB
> *without* -DUNDERSCORE, and then by building MET linking to that bad
> version.
>
> What you'll need to do is set the MET_BUFRLIB environment variable
as
> indicated on this page:
>
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php
>
> Then source your .cshrc or equivalent file, then run your configure
> command, and then run make install and make test.
>
> Please give that a try.  It should solve the problem you are
encountering.
>
> Thanks,
> Julie
>
> On Wed, Mar 4, 2015 at 5:36 AM, Zilore Mumba via RT
<met_help at ucar.edu>
> wrote:
>
> >
> > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> >
> > *Julie, I installed with the following commands. gcc -c
-DUNDERSCORE *.c*
> >    *gfortran -c -DUNDERSCORE -fno-second-underscore *.f *.F*
> >    *ar crv libbufr.a *.o*
> >
> >
> >
> > *Please find attached the config.log and make_install.log *
> >
> >
> > On Tue, Mar 3, 2015 at 7:10 PM, Julie Prestopnik via RT <
> met_help at ucar.edu
> > >
> > wrote:
> >
> > > I'm sorry to hear that you are still experiencing problems
installing
> > > METv5.0.
> > >
> > > Specifically regarding BUFRLIB, please compile it using the
options
> > listed
> > > on this page:
> > >
> > >
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> > >
> > > Failing to use the "-DUNDERSCORE -fno-second-underscore" (for
GNU
> > > compilers) options will result in undefined references when
building
> the
> > > pb2nc tool.
> > >
> > > If you'd like to send us the output of make please do the
following:
> > >    make clean
> > >    make install >& make_install.log
> > >
> > > And then send us the files "config.log" and "make_install.log".
> > >
> > > I hope you'll find what you have been able to install useful.
Please
> let
> > > us know if you have any questions.
> > >
> > > Thanks,
> > > Julie
> > >
> > > On Tue, Mar 3, 2015 at 12:26 AM, Zilore Mumba via RT <
> met_help at ucar.edu>
> > > wrote:
> > >
> > > >
> > > > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
>
> > > >
> > > > Julie,
> > > > I did not inform you of the conclusion of my attempt to
install
> > Met-5.1.
> > > > After making many attempts in reinstalling/reconfiguring
BUFRLIB i
> > still
> > > > get errors relating to "undefined reference to ..." and
eventually I
> > > still
> > > > have 3 executables not installed: pb2nc, modis_regrid,
> plot_mode_field.
> > > > I would like to learn how to use what I have and come back
later to
> > pb2nc
> > > > if necessary. I will inform you if I have any other problems.
> > > >
> > > >
> > > > On Tue, Feb 10, 2015 at 7:12 PM, Julie Prestopnik via RT <
> > > > met_help at ucar.edu>
> > > > wrote:
> > > >
> > > > > Thank you for rerunning and sending this log.  Perhaps MET
cannot
> > find
> > > > the
> > > > > BUFR library.
> > > > >
> > > > > On the following page are directions for setting the
environment
> > > > variables
> > > > > before compiling MET:
> > > > >
> > > > >
> > > >
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php
> > > > >
> > > > > The rest of the applications built, so it looks like MET was
able
> to
> > > find
> > > > > the other needed libraries.  The directions for the BUFR
> environment
> > > > > variable on the above page are:
> > > > >
> > > > > "Set *$MET_BUFR* to point to the main BUFR directory, or set
> > > > *$MET_BUFRLIB*
> > > > > to point to the directory with the BUFR library files.
Because MET
> > > > doesn't
> > > > > use any BUFR library include files, you don't need to
specify
> > > > > *$MET_BUFRINC*
> > > > > ."
> > > > >
> > > > > Please try setting either *$MET_BUFR *or *$MET_BUFRLIB *and
then
> > please
> > > > > rerun the configure script and then rerun make install.  It
is
> > > important
> > > > to
> > > > > rerun configure before rerunning make install.
> > > > >
> > > > > Please let me know how it goes.
> > > > >
> > > > > Thanks,
> > > > > Julie
> > > > >
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > On Sat, Feb 7, 2015 at 9:36 PM, Zilore Mumba via RT <
> > met_help at ucar.edu
> > > >
> > > > > wrote:
> > > > >
> > > > > >
> > > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > > > > >
> > > > > > Julie,
> > > > > > Attached to this mail, please find the file make-
install.log. It
> > does
> > > > > > show 'undefined reference' to some functions. I hope this
means
> > > > > > something to you and that you can help.
> > > > > > Thanks in advance
> > > > > > Zilore
> > > > > >
> > > > > >
> > > > > > On 2/5/15, Julie Prestopnik via RT <met_help at ucar.edu>
wrote:
> > > > > > > Thank you for attaching your log files.  I did not see
any
> errors
> > > in
> > > > > your
> > > > > > > make-install.log.  Perhaps you ran make install in the
> following
> > > way:
> > > > > > >
> > > > > > > make install > make-install.log
> > > > > > >
> > > > > > > This would catch standard out but not standard error.
> > > > > > >
> > > > > > > Could you please try running in the following way with
the &,
> > which
> > > > > will
> > > > > > > also capture standard error?
> > > > > > >
> > > > > > > make install >& make-install.log
> > > > > > >
> > > > > > > And, then please send me the output of that log.  Thank
you!
> > > > > > >
> > > > > > > Julie
> > > > > > >
> > > > > > > On Tue, Feb 3, 2015 at 2:08 PM, Zilore Mumba via RT <
> > > > met_help at ucar.edu
> > > > > >
> > > > > > > wrote:
> > > > > > >
> > > > > > >>
> > > > > > >> <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> >
> > > > > > >>
> > > > > > >> Julie,
> > > > > > >> Thank you very much for your assistance. I failed to
install
> > Cairo
> > > > and
> > > > > > >> freetype because of the dependencies. I will try again
with
> the
> > > > links
> > > > > > >> you sent me.
> > > > > > >> Please find attached my config.log and make-
install.log.
> > > > > > >>
> > > > > > >>
> > > > > > >> On 2/2/15, Julie Prestopnik via RT <met_help at ucar.edu>
wrote:
> > > > > > >> > I'm so glad you were able to get MET installed and
that you
> > > worked
> > > > > out
> > > > > > >> the
> > > > > > >> > issue with the NetCDF environment variables.
> > > > > > >> >
> > > > > > >> > You mentioned that three executables did not build.
I would
> > > like
> > > > to
> > > > > > >> > try
> > > > > > >> to
> > > > > > >> > help with those.  The modis_regrid tool has library
> > > dependencies -
> > > > > it
> > > > > > >> > requires the HDF4 and HDF-EOS2 libraries.  The
> plot_mode_field
> > > > tool
> > > > > > >> > also
> > > > > > >> > has library dependencies - it requires the Cairo and
> FreeType
> > > > > > >> > libraries.
> > > > > > >> >
> > > > > > >> > You can find information on compiling each of those
library
> > > > > > >> > dependencies
> > > > > > >> > here:
> > > > > > >> >
> > > > > > >>
> > > > > >
> > > > >
> > > >
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> > > > > > >> >
> > > > > > >> > You can find information on setting the up necessary
> > environment
> > > > > > >> variables
> > > > > > >> > for those library locations here:
> > > > > > >> >
> > > > > > >>
> > > > > >
> > > > >
> > > >
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php
> > > > > > >> >
> > > > > > >> > And with pb2nc, I'm not exactly sure what is going on
there.
> > I
> > > > > would
> > > > > > >> > be
> > > > > > >> > happy to take a look at your configure log and make
install
> > log
> > > > > files
> > > > > > >> > to
> > > > > > >> > see if I can figure out why you didn't get the
executable.
> > > > > > >> >
> > > > > > >> > I hope this helps.
> > > > > > >> >
> > > > > > >> > Thanks,
> > > > > > >> > Julie
> > > > > > >> >
> > > > > > >> >
> > > > > > >> >
> > > > > > >> > On Sat, Jan 31, 2015 at 5:31 PM, Zilore Mumba via RT
> > > > > > >> > <met_help at ucar.edu>
> > > > > > >> > wrote:
> > > > > > >> >
> > > > > > >> >>
> > > > > > >> >> <URL:
> > https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > >
> > > > > > >> >>
> > > > > > >> >> Julg
> > > > > > >> >> Thank you very much for your help. With the advice
you gave
> > > me, I
> > > > > was
> > > > > > >> >> able to install MET using gcc and gfortran. I also
had to
> to
> > > > point
> > > > > > >> >> $MET_NETCDFLIB and, $MET_NETCDFINC to
> > > /usr/local/netcdf-4.1.3/lib
> > > > > and
> > > > > > >> >> include. Previously I pointed only to
> > /usr/local/netcdf-4.1.3.
> > > > > > >> >> I have three executables not included though, these
are
> > > > > modis_regrid,
> > > > > > >> >> plot_mode_field and pb2nc.
> > > > > > >> >> Thank you very much.
> > > > > > >> >>
> > > > > > >> >>
> > > > > > >> >> On 1/29/15, Julie Prestopnik via RT
<met_help at ucar.edu>
> > wrote:
> > > > > > >> >> > I am sorry to hear that you are having problems
> installing
> > > > > METv5.0.
> > > > > > >> >> > I
> > > > > > >> >> > believe this error may have to do with how you
compiled
> > > > BUFRLIB.
> > > > > > >> >> > Please
> > > > > > >> >> > take a look at the sample commands for compiling
BURFLIB
> on
> > > > this
> > > > > > >> >> > page:
> > > > > > >> >> >
> > > > > > >> >>
> > > > > > >>
> > > > > >
> > > > >
> > > >
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> > > > > > >> >> >
> > > > > > >> >> > I believe that the *-fno-second-underscore* (GNU
> compilers)
> > > or
> > > > > > >> >> > *-Mnosecond_underscore* (PGI compilers) will fix
the
> error
> > > > you're
> > > > > > >> >> > seeing.
> > > > > > >> >> >
> > > > > > >> >> > I hope that helps.  If it doesn't, please send me
the
> files
> > > > > > >> >> "make_met.log"
> > > > > > >> >> > and "config.log".
> > > > > > >> >> >
> > > > > > >> >> > Thanks,
> > > > > > >> >> > Julie
> > > > > > >> >> >
> > > > > > >> >> >
> > > > > > >> >> > On Thu, Jan 29, 2015 at 3:48 AM, Zilore Mumba via
RT
> > > > > > >> >> > <met_help at ucar.edu>
> > > > > > >> >> > wrote:
> > > > > > >> >> >
> > > > > > >> >> >>
> > > > > > >> >> >> Thu Jan 29 03:48:08 2015: Request 70551 was acted
upon.
> > > > > > >> >> >> Transaction: Ticket created by zmumba at gmail.com
> > > > > > >> >> >>        Queue: met_help
> > > > > > >> >> >>      Subject: Problem compiling Met-V5
> > > > > > >> >> >>        Owner: Nobody
> > > > > > >> >> >>   Requestors: zmumba at gmail.com
> > > > > > >> >> >>       Status: new
> > > > > > >> >> >>  Ticket <URL:
> > > > > > >> https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > > > > >> >> >> >
> > > > > > >> >> >>
> > > > > > >> >> >>
> > > > > > >> >> >> I have installed BUFRLIB, GSL and G2CLIB
> > > > > > >> >> >> But then how do I handle the errors below in
installing
> > > > MET_V5?
> > > > > > >> >> >>
> > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/numpbmsg.f:23:
> > > > > > >> >> >> undefined
> > > > > > >> >> >> reference to `ufbtab_'
> > > > > > >> >> >> openpb.o: In function `openpb_':
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:21:
> > > > > > >> >> >> undefined
> > > > > > >> >> >> reference to `openbf_'
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:22:
> > > > > > >> >> >> undefined
> > > > > > >> >> >> reference to `datelen_'
> > > > > > >> >> >> closepb.o: In function `closepb_':
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/closepb.f:19:
> > > > > > >> undefined
> > > > > > >> >> >> reference to `closbf_'
> > > > > > >> >> >> readpb.o: In function `readpb_':
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:82:
> > > > > > >> >> >> undefined
> > > > > > >> >> >> reference to `ireadns_'
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:90:
> > > > > > >> >> >> undefined
> > > > > > >> >> >> reference to `ufbint_'
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:94:
> > > > > > >> >> >> undefined
> > > > > > >> >> >> reference to `ufbevn_'
> > > > > > >> >> >> dumppb.o: In function `readpbdump_':
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:215:
> > > > > > >> undefined
> > > > > > >> >> >> reference to `ufbint_'
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:218:
> > > > > > >> undefined
> > > > > > >> >> >> reference to `ufbevn_'
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:224:
> > > > > > >> undefined
> > > > > > >> >> >> reference to `ireadns_'
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:203:
> > > > > > >> undefined
> > > > > > >> >> >> reference to `ireadns_'
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:228:
> > > > > > >> undefined
> > > > > > >> >> >> reference to `ufbint_'
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:259:
> > > > > > >> undefined
> > > > > > >> >> >> reference to `ufbevn_'
> > > > > > >> >> >> dumppb.o: In function `dumppb_':
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:56:
> > > > > > >> >> >> undefined
> > > > > > >> >> >> reference to `openbf_'
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:57:
> > > > > > >> >> >> undefined
> > > > > > >> >> >> reference to `datelen_'
> > > > > > >> >> >> collect2: error: ld returned 1 exit status
> > > > > > >> >> >> make[4]: *** [pb2nc] Error 1
> > > > > > >> >> >> make[4]: Leaving directory
> > > > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc'
> > > > > > >> >> >> make[3]: *** [install-recursive] Error 1
> > > > > > >> >> >> make[3]: Leaving directory
> > > > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other'
> > > > > > >> >> >> make[2]: *** [install-recursive] Error 1
> > > > > > >> >> >> make[2]: Leaving directory
> > > > `/home/zmumba/WRF/met-5.0/src/tools'
> > > > > > >> >> >> make[1]: *** [install-recursive] Error 1
> > > > > > >> >> >> make[1]: Leaving directory
> `/home/zmumba/WRF/met-5.0/src'
> > > > > > >> >> >> make: *** [install-recursive] Error 1
> > > > > > >> >> >>
> > > > > > >> >> >>
> > > > > > >> >> >
> > > > > > >> >> >
> > > > > > >> >> > --
> > > > > > >> >> > Julie Prestopnik
> > > > > > >> >> > National Center for Atmospheric Research
> > > > > > >> >> > Research Applications Laboratory
> > > > > > >> >> > Phone: 303.497.8399
> > > > > > >> >> > Email: jpresto at ucar.edu
> > > > > > >> >> >
> > > > > > >> >> >
> > > > > > >> >>
> > > > > > >> >>
> > > > > > >> >
> > > > > > >> >
> > > > > > >> > --
> > > > > > >> > Julie Prestopnik
> > > > > > >> > National Center for Atmospheric Research
> > > > > > >> > Research Applications Laboratory
> > > > > > >> > Phone: 303.497.8399
> > > > > > >> > Email: jpresto at ucar.edu
> > > > > > >> >
> > > > > > >> >
> > > > > > >>
> > > > > > >>
> > > > > > >
> > > > > > >
> > > > > > > --
> > > > > > > Julie Prestopnik
> > > > > > > National Center for Atmospheric Research
> > > > > > > Research Applications Laboratory
> > > > > > > Phone: 303.497.8399
> > > > > > > Email: jpresto at ucar.edu
> > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Julie Prestopnik
> > > > > National Center for Atmospheric Research
> > > > > Research Applications Laboratory
> > > > > Phone: 303.497.8399
> > > > > Email: jpresto at ucar.edu
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> > > --
> > > Julie Prestopnik
> > > National Center for Atmospheric Research
> > > Research Applications Laboratory
> > > Phone: 303.497.8399
> > > Email: jpresto at ucar.edu
> > >
> > >
> >
> >
>
>
> --
> Julie Prestopnik
> National Center for Atmospheric Research
> Research Applications Laboratory
> Phone: 303.497.8399
> Email: jpresto at ucar.edu
>
>

------------------------------------------------
Subject: Problem compiling Met-V5
From: Julie Prestopnik
Time: Thu Mar 05 15:12:03 2015

I'm so glad to hear you got pb2nc installed.  Please let us know if
you
have any other questions as you learn to use the tools.

Julie

On Thu, Mar 5, 2015 at 3:10 PM, Zilore Mumba via RT
<met_help at ucar.edu>
wrote:

>
> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
>
> Julie,
> Thank you very much. The library was in none of the paths listed.
Now i
> manged to have pb2nc installed.
> Now I can concentrate on learning how to use the tool.
> Thank you very much
>
> On Thu, Mar 5, 2015 at 7:59 PM, Julie Prestopnik via RT
<met_help at ucar.edu
> >
> wrote:
>
> > Hi Zilore.  Thanks for sending your commands and log files.
> >
> > Looking in "config.log" for the string "BUFRLIB", it appears that
you did
> > not set the environment variable.
> >
> > The linker error occurs on line 1057 of make_install.log.  Looking
at
> that
> > line, we're telling the linker to look in the following
directories for
> the
> > file named "libbufr.a":
> >
> > -L/usr/lib/gcc/i686-linux-gnu/4.8
> > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../i386-linux-gnu
> > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../../lib
> > -L/lib/i386-linux-gnu
> > -L/lib/../lib
> > -L/usr/lib/i386-linux-gnu
> > -L/usr/lib/../lib
> > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../..
> >
> > It must be finding libbufr.a in one of those directories,
otherwise we
> > would get an error about that.  I believe that the version of
libbufr.a
> it
> > is finding is not the version that you compiled using the "-
DUNDERSCORE"
> > option.
> >
> > I was able to replicate your error by re-compiling a version of
BUFRLIB
> > *without* -DUNDERSCORE, and then by building MET linking to that
bad
> > version.
> >
> > What you'll need to do is set the MET_BUFRLIB environment variable
as
> > indicated on this page:
> >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php
> >
> > Then source your .cshrc or equivalent file, then run your
configure
> > command, and then run make install and make test.
> >
> > Please give that a try.  It should solve the problem you are
> encountering.
> >
> > Thanks,
> > Julie
> >
> > On Wed, Mar 4, 2015 at 5:36 AM, Zilore Mumba via RT
<met_help at ucar.edu>
> > wrote:
> >
> > >
> > > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > >
> > > *Julie, I installed with the following commands. gcc -c
-DUNDERSCORE
> *.c*
> > >    *gfortran -c -DUNDERSCORE -fno-second-underscore *.f *.F*
> > >    *ar crv libbufr.a *.o*
> > >
> > >
> > >
> > > *Please find attached the config.log and make_install.log *
> > >
> > >
> > > On Tue, Mar 3, 2015 at 7:10 PM, Julie Prestopnik via RT <
> > met_help at ucar.edu
> > > >
> > > wrote:
> > >
> > > > I'm sorry to hear that you are still experiencing problems
installing
> > > > METv5.0.
> > > >
> > > > Specifically regarding BUFRLIB, please compile it using the
options
> > > listed
> > > > on this page:
> > > >
> > > >
> > > >
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> > > >
> > > > Failing to use the "-DUNDERSCORE -fno-second-underscore" (for
GNU
> > > > compilers) options will result in undefined references when
building
> > the
> > > > pb2nc tool.
> > > >
> > > > If you'd like to send us the output of make please do the
following:
> > > >    make clean
> > > >    make install >& make_install.log
> > > >
> > > > And then send us the files "config.log" and
"make_install.log".
> > > >
> > > > I hope you'll find what you have been able to install useful.
Please
> > let
> > > > us know if you have any questions.
> > > >
> > > > Thanks,
> > > > Julie
> > > >
> > > > On Tue, Mar 3, 2015 at 12:26 AM, Zilore Mumba via RT <
> > met_help at ucar.edu>
> > > > wrote:
> > > >
> > > > >
> > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > > > >
> > > > > Julie,
> > > > > I did not inform you of the conclusion of my attempt to
install
> > > Met-5.1.
> > > > > After making many attempts in reinstalling/reconfiguring
BUFRLIB i
> > > still
> > > > > get errors relating to "undefined reference to ..." and
eventually
> I
> > > > still
> > > > > have 3 executables not installed: pb2nc, modis_regrid,
> > plot_mode_field.
> > > > > I would like to learn how to use what I have and come back
later to
> > > pb2nc
> > > > > if necessary. I will inform you if I have any other
problems.
> > > > >
> > > > >
> > > > > On Tue, Feb 10, 2015 at 7:12 PM, Julie Prestopnik via RT <
> > > > > met_help at ucar.edu>
> > > > > wrote:
> > > > >
> > > > > > Thank you for rerunning and sending this log.  Perhaps MET
cannot
> > > find
> > > > > the
> > > > > > BUFR library.
> > > > > >
> > > > > > On the following page are directions for setting the
environment
> > > > > variables
> > > > > > before compiling MET:
> > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php
> > > > > >
> > > > > > The rest of the applications built, so it looks like MET
was able
> > to
> > > > find
> > > > > > the other needed libraries.  The directions for the BUFR
> > environment
> > > > > > variable on the above page are:
> > > > > >
> > > > > > "Set *$MET_BUFR* to point to the main BUFR directory, or
set
> > > > > *$MET_BUFRLIB*
> > > > > > to point to the directory with the BUFR library files.
Because
> MET
> > > > > doesn't
> > > > > > use any BUFR library include files, you don't need to
specify
> > > > > > *$MET_BUFRINC*
> > > > > > ."
> > > > > >
> > > > > > Please try setting either *$MET_BUFR *or *$MET_BUFRLIB
*and then
> > > please
> > > > > > rerun the configure script and then rerun make install.
It is
> > > > important
> > > > > to
> > > > > > rerun configure before rerunning make install.
> > > > > >
> > > > > > Please let me know how it goes.
> > > > > >
> > > > > > Thanks,
> > > > > > Julie
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > > On Sat, Feb 7, 2015 at 9:36 PM, Zilore Mumba via RT <
> > > met_help at ucar.edu
> > > > >
> > > > > > wrote:
> > > > > >
> > > > > > >
> > > > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> >
> > > > > > >
> > > > > > > Julie,
> > > > > > > Attached to this mail, please find the file make-
install.log.
> It
> > > does
> > > > > > > show 'undefined reference' to some functions. I hope
this means
> > > > > > > something to you and that you can help.
> > > > > > > Thanks in advance
> > > > > > > Zilore
> > > > > > >
> > > > > > >
> > > > > > > On 2/5/15, Julie Prestopnik via RT <met_help at ucar.edu>
wrote:
> > > > > > > > Thank you for attaching your log files.  I did not see
any
> > errors
> > > > in
> > > > > > your
> > > > > > > > make-install.log.  Perhaps you ran make install in the
> > following
> > > > way:
> > > > > > > >
> > > > > > > > make install > make-install.log
> > > > > > > >
> > > > > > > > This would catch standard out but not standard error.
> > > > > > > >
> > > > > > > > Could you please try running in the following way with
the &,
> > > which
> > > > > > will
> > > > > > > > also capture standard error?
> > > > > > > >
> > > > > > > > make install >& make-install.log
> > > > > > > >
> > > > > > > > And, then please send me the output of that log.
Thank you!
> > > > > > > >
> > > > > > > > Julie
> > > > > > > >
> > > > > > > > On Tue, Feb 3, 2015 at 2:08 PM, Zilore Mumba via RT <
> > > > > met_help at ucar.edu
> > > > > > >
> > > > > > > > wrote:
> > > > > > > >
> > > > > > > >>
> > > > > > > >> <URL:
> https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > >
> > > > > > > >>
> > > > > > > >> Julie,
> > > > > > > >> Thank you very much for your assistance. I failed to
install
> > > Cairo
> > > > > and
> > > > > > > >> freetype because of the dependencies. I will try
again with
> > the
> > > > > links
> > > > > > > >> you sent me.
> > > > > > > >> Please find attached my config.log and make-
install.log.
> > > > > > > >>
> > > > > > > >>
> > > > > > > >> On 2/2/15, Julie Prestopnik via RT
<met_help at ucar.edu>
> wrote:
> > > > > > > >> > I'm so glad you were able to get MET installed and
that
> you
> > > > worked
> > > > > > out
> > > > > > > >> the
> > > > > > > >> > issue with the NetCDF environment variables.
> > > > > > > >> >
> > > > > > > >> > You mentioned that three executables did not build.
I
> would
> > > > like
> > > > > to
> > > > > > > >> > try
> > > > > > > >> to
> > > > > > > >> > help with those.  The modis_regrid tool has library
> > > > dependencies -
> > > > > > it
> > > > > > > >> > requires the HDF4 and HDF-EOS2 libraries.  The
> > plot_mode_field
> > > > > tool
> > > > > > > >> > also
> > > > > > > >> > has library dependencies - it requires the Cairo
and
> > FreeType
> > > > > > > >> > libraries.
> > > > > > > >> >
> > > > > > > >> > You can find information on compiling each of those
> library
> > > > > > > >> > dependencies
> > > > > > > >> > here:
> > > > > > > >> >
> > > > > > > >>
> > > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> > > > > > > >> >
> > > > > > > >> > You can find information on setting the up
necessary
> > > environment
> > > > > > > >> variables
> > > > > > > >> > for those library locations here:
> > > > > > > >> >
> > > > > > > >>
> > > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/configure.php
> > > > > > > >> >
> > > > > > > >> > And with pb2nc, I'm not exactly sure what is going
on
> there.
> > > I
> > > > > > would
> > > > > > > >> > be
> > > > > > > >> > happy to take a look at your configure log and make
> install
> > > log
> > > > > > files
> > > > > > > >> > to
> > > > > > > >> > see if I can figure out why you didn't get the
executable.
> > > > > > > >> >
> > > > > > > >> > I hope this helps.
> > > > > > > >> >
> > > > > > > >> > Thanks,
> > > > > > > >> > Julie
> > > > > > > >> >
> > > > > > > >> >
> > > > > > > >> >
> > > > > > > >> > On Sat, Jan 31, 2015 at 5:31 PM, Zilore Mumba via
RT
> > > > > > > >> > <met_help at ucar.edu>
> > > > > > > >> > wrote:
> > > > > > > >> >
> > > > > > > >> >>
> > > > > > > >> >> <URL:
> > > https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > > >
> > > > > > > >> >>
> > > > > > > >> >> Julg
> > > > > > > >> >> Thank you very much for your help. With the advice
you
> gave
> > > > me, I
> > > > > > was
> > > > > > > >> >> able to install MET using gcc and gfortran. I also
had to
> > to
> > > > > point
> > > > > > > >> >> $MET_NETCDFLIB and, $MET_NETCDFINC to
> > > > /usr/local/netcdf-4.1.3/lib
> > > > > > and
> > > > > > > >> >> include. Previously I pointed only to
> > > /usr/local/netcdf-4.1.3.
> > > > > > > >> >> I have three executables not included though,
these are
> > > > > > modis_regrid,
> > > > > > > >> >> plot_mode_field and pb2nc.
> > > > > > > >> >> Thank you very much.
> > > > > > > >> >>
> > > > > > > >> >>
> > > > > > > >> >> On 1/29/15, Julie Prestopnik via RT
<met_help at ucar.edu>
> > > wrote:
> > > > > > > >> >> > I am sorry to hear that you are having problems
> > installing
> > > > > > METv5.0.
> > > > > > > >> >> > I
> > > > > > > >> >> > believe this error may have to do with how you
compiled
> > > > > BUFRLIB.
> > > > > > > >> >> > Please
> > > > > > > >> >> > take a look at the sample commands for compiling
> BURFLIB
> > on
> > > > > this
> > > > > > > >> >> > page:
> > > > > > > >> >> >
> > > > > > > >> >>
> > > > > > > >>
> > > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
>
http://www.dtcenter.org/met/users/support/online_tutorial/METv5.0/compilation/req_libs.php
> > > > > > > >> >> >
> > > > > > > >> >> > I believe that the *-fno-second-underscore* (GNU
> > compilers)
> > > > or
> > > > > > > >> >> > *-Mnosecond_underscore* (PGI compilers) will fix
the
> > error
> > > > > you're
> > > > > > > >> >> > seeing.
> > > > > > > >> >> >
> > > > > > > >> >> > I hope that helps.  If it doesn't, please send
me the
> > files
> > > > > > > >> >> "make_met.log"
> > > > > > > >> >> > and "config.log".
> > > > > > > >> >> >
> > > > > > > >> >> > Thanks,
> > > > > > > >> >> > Julie
> > > > > > > >> >> >
> > > > > > > >> >> >
> > > > > > > >> >> > On Thu, Jan 29, 2015 at 3:48 AM, Zilore Mumba
via RT
> > > > > > > >> >> > <met_help at ucar.edu>
> > > > > > > >> >> > wrote:
> > > > > > > >> >> >
> > > > > > > >> >> >>
> > > > > > > >> >> >> Thu Jan 29 03:48:08 2015: Request 70551 was
acted
> upon.
> > > > > > > >> >> >> Transaction: Ticket created by zmumba at gmail.com
> > > > > > > >> >> >>        Queue: met_help
> > > > > > > >> >> >>      Subject: Problem compiling Met-V5
> > > > > > > >> >> >>        Owner: Nobody
> > > > > > > >> >> >>   Requestors: zmumba at gmail.com
> > > > > > > >> >> >>       Status: new
> > > > > > > >> >> >>  Ticket <URL:
> > > > > > > >>
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > > > > > >> >> >> >
> > > > > > > >> >> >>
> > > > > > > >> >> >>
> > > > > > > >> >> >> I have installed BUFRLIB, GSL and G2CLIB
> > > > > > > >> >> >> But then how do I handle the errors below in
> installing
> > > > > MET_V5?
> > > > > > > >> >> >>
> > > > > > > >> >> >>
> > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/numpbmsg.f:23:
> > > > > > > >> >> >> undefined
> > > > > > > >> >> >> reference to `ufbtab_'
> > > > > > > >> >> >> openpb.o: In function `openpb_':
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:21:
> > > > > > > >> >> >> undefined
> > > > > > > >> >> >> reference to `openbf_'
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:22:
> > > > > > > >> >> >> undefined
> > > > > > > >> >> >> reference to `datelen_'
> > > > > > > >> >> >> closepb.o: In function `closepb_':
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/closepb.f:19:
> > > > > > > >> undefined
> > > > > > > >> >> >> reference to `closbf_'
> > > > > > > >> >> >> readpb.o: In function `readpb_':
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:82:
> > > > > > > >> >> >> undefined
> > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:90:
> > > > > > > >> >> >> undefined
> > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:94:
> > > > > > > >> >> >> undefined
> > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > >> >> >> dumppb.o: In function `readpbdump_':
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:215:
> > > > > > > >> undefined
> > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:218:
> > > > > > > >> undefined
> > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:224:
> > > > > > > >> undefined
> > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:203:
> > > > > > > >> undefined
> > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:228:
> > > > > > > >> undefined
> > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:259:
> > > > > > > >> undefined
> > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > >> >> >> dumppb.o: In function `dumppb_':
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:56:
> > > > > > > >> >> >> undefined
> > > > > > > >> >> >> reference to `openbf_'
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:57:
> > > > > > > >> >> >> undefined
> > > > > > > >> >> >> reference to `datelen_'
> > > > > > > >> >> >> collect2: error: ld returned 1 exit status
> > > > > > > >> >> >> make[4]: *** [pb2nc] Error 1
> > > > > > > >> >> >> make[4]: Leaving directory
> > > > > > > >> >> >> `/home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc'
> > > > > > > >> >> >> make[3]: *** [install-recursive] Error 1
> > > > > > > >> >> >> make[3]: Leaving directory
> > > > > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other'
> > > > > > > >> >> >> make[2]: *** [install-recursive] Error 1
> > > > > > > >> >> >> make[2]: Leaving directory
> > > > > `/home/zmumba/WRF/met-5.0/src/tools'
> > > > > > > >> >> >> make[1]: *** [install-recursive] Error 1
> > > > > > > >> >> >> make[1]: Leaving directory
> > `/home/zmumba/WRF/met-5.0/src'
> > > > > > > >> >> >> make: *** [install-recursive] Error 1
> > > > > > > >> >> >>
> > > > > > > >> >> >>
> > > > > > > >> >> >
> > > > > > > >> >> >
> > > > > > > >> >> > --
> > > > > > > >> >> > Julie Prestopnik
> > > > > > > >> >> > National Center for Atmospheric Research
> > > > > > > >> >> > Research Applications Laboratory
> > > > > > > >> >> > Phone: 303.497.8399
> > > > > > > >> >> > Email: jpresto at ucar.edu
> > > > > > > >> >> >
> > > > > > > >> >> >
> > > > > > > >> >>
> > > > > > > >> >>
> > > > > > > >> >
> > > > > > > >> >
> > > > > > > >> > --
> > > > > > > >> > Julie Prestopnik
> > > > > > > >> > National Center for Atmospheric Research
> > > > > > > >> > Research Applications Laboratory
> > > > > > > >> > Phone: 303.497.8399
> > > > > > > >> > Email: jpresto at ucar.edu
> > > > > > > >> >
> > > > > > > >> >
> > > > > > > >>
> > > > > > > >>
> > > > > > > >
> > > > > > > >
> > > > > > > > --
> > > > > > > > Julie Prestopnik
> > > > > > > > National Center for Atmospheric Research
> > > > > > > > Research Applications Laboratory
> > > > > > > > Phone: 303.497.8399
> > > > > > > > Email: jpresto at ucar.edu
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > > > --
> > > > > > Julie Prestopnik
> > > > > > National Center for Atmospheric Research
> > > > > > Research Applications Laboratory
> > > > > > Phone: 303.497.8399
> > > > > > Email: jpresto at ucar.edu
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > >
> > > >
> > > > --
> > > > Julie Prestopnik
> > > > National Center for Atmospheric Research
> > > > Research Applications Laboratory
> > > > Phone: 303.497.8399
> > > > Email: jpresto at ucar.edu
> > > >
> > > >
> > >
> > >
> >
> >
> > --
> > Julie Prestopnik
> > National Center for Atmospheric Research
> > Research Applications Laboratory
> > Phone: 303.497.8399
> > Email: jpresto at ucar.edu
> >
> >
>
>


--
Julie Prestopnik
National Center for Atmospheric Research
Research Applications Laboratory
Phone: 303.497.8399
Email: jpresto at ucar.edu

------------------------------------------------
Subject: Problem compiling Met-V5
From: Zilore Mumba
Time: Sat Apr 08 15:53:41 2017

Julie, I hope you are fine, and that I can still reach you. In March
2015
you helped me installing met_v5.0. I have now downloaded v6.0 and I am
having a compilation error I do not seem to figure out.
I believe I have installed all the libraries (and set the environment
variables correctly: BUFRLIB-v10-2-3, netcdf-4.4.1.1, gsl-2.3,
g2clib-1.6.0, freetype-2.7.1 andcairo-1.14.8.
I also have zlib, jasper and libpng.
My configure exits with exit code 0 which I understand to be ok.
However my
make install gives an error of not finding netcdf (as you can see from
make-install.log). I do not understand which netcdf it cannot find.
I hope you can assist.
Zilore

On Thu, Mar 5, 2015 at 7:59 PM, Julie Prestopnik via RT
<met_help at ucar.edu>
wrote:

> Hi Zilore.  Thanks for sending your commands and log files.
>
> Looking in "config.log" for the string "BUFRLIB", it appears that
you did
> not set the environment variable.
>
> The linker error occurs on line 1057 of make_install.log.  Looking
at that
> line, we're telling the linker to look in the following directories
for the
> file named "libbufr.a":
>
> -L/usr/lib/gcc/i686-linux-gnu/4.8
> -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../i386-linux-gnu
> -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../../lib
> -L/lib/i386-linux-gnu
> -L/lib/../lib
> -L/usr/lib/i386-linux-gnu
> -L/usr/lib/../lib
> -L/usr/lib/gcc/i686-linux-gnu/4.8/../../..
>
> It must be finding libbufr.a in one of those directories, otherwise
we
> would get an error about that.  I believe that the version of
libbufr.a it
> is finding is not the version that you compiled using the "-
DUNDERSCORE"
> option.
>
> I was able to replicate your error by re-compiling a version of
BUFRLIB
> *without* -DUNDERSCORE, and then by building MET linking to that bad
> version.
>
> What you'll need to do is set the MET_BUFRLIB environment variable
as
> indicated on this page:
> http://www.dtcenter.org/met/users/support/online_tutorial/
> METv5.0/compilation/configure.php
>
> Then source your .cshrc or equivalent file, then run your configure
> command, and then run make install and make test.
>
> Please give that a try.  It should solve the problem you are
encountering.
>
> Thanks,
> Julie
>
> On Wed, Mar 4, 2015 at 5:36 AM, Zilore Mumba via RT
<met_help at ucar.edu>
> wrote:
>
> >
> > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> >
> > *Julie, I installed with the following commands. gcc -c
-DUNDERSCORE *.c*
> >    *gfortran -c -DUNDERSCORE -fno-second-underscore *.f *.F*
> >    *ar crv libbufr.a *.o*
> >
> >
> >
> > *Please find attached the config.log and make_install.log *
> >
> >
> > On Tue, Mar 3, 2015 at 7:10 PM, Julie Prestopnik via RT <
> met_help at ucar.edu
> > >
> > wrote:
> >
> > > I'm sorry to hear that you are still experiencing problems
installing
> > > METv5.0.
> > >
> > > Specifically regarding BUFRLIB, please compile it using the
options
> > listed
> > > on this page:
> > >
> > >
> > >
> > http://www.dtcenter.org/met/users/support/online_tutorial/
> METv5.0/compilation/req_libs.php
> > >
> > > Failing to use the "-DUNDERSCORE -fno-second-underscore" (for
GNU
> > > compilers) options will result in undefined references when
building
> the
> > > pb2nc tool.
> > >
> > > If you'd like to send us the output of make please do the
following:
> > >    make clean
> > >    make install >& make_install.log
> > >
> > > And then send us the files "config.log" and "make_install.log".
> > >
> > > I hope you'll find what you have been able to install useful.
Please
> let
> > > us know if you have any questions.
> > >
> > > Thanks,
> > > Julie
> > >
> > > On Tue, Mar 3, 2015 at 12:26 AM, Zilore Mumba via RT <
> met_help at ucar.edu>
> > > wrote:
> > >
> > > >
> > > > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
>
> > > >
> > > > Julie,
> > > > I did not inform you of the conclusion of my attempt to
install
> > Met-5.1.
> > > > After making many attempts in reinstalling/reconfiguring
BUFRLIB i
> > still
> > > > get errors relating to "undefined reference to ..." and
eventually I
> > > still
> > > > have 3 executables not installed: pb2nc, modis_regrid,
> plot_mode_field.
> > > > I would like to learn how to use what I have and come back
later to
> > pb2nc
> > > > if necessary. I will inform you if I have any other problems.
> > > >
> > > >
> > > > On Tue, Feb 10, 2015 at 7:12 PM, Julie Prestopnik via RT <
> > > > met_help at ucar.edu>
> > > > wrote:
> > > >
> > > > > Thank you for rerunning and sending this log.  Perhaps MET
cannot
> > find
> > > > the
> > > > > BUFR library.
> > > > >
> > > > > On the following page are directions for setting the
environment
> > > > variables
> > > > > before compiling MET:
> > > > >
> > > > >
> > > >
> > >
> > http://www.dtcenter.org/met/users/support/online_tutorial/
> METv5.0/compilation/configure.php
> > > > >
> > > > > The rest of the applications built, so it looks like MET was
able
> to
> > > find
> > > > > the other needed libraries.  The directions for the BUFR
> environment
> > > > > variable on the above page are:
> > > > >
> > > > > "Set *$MET_BUFR* to point to the main BUFR directory, or set
> > > > *$MET_BUFRLIB*
> > > > > to point to the directory with the BUFR library files.
Because MET
> > > > doesn't
> > > > > use any BUFR library include files, you don't need to
specify
> > > > > *$MET_BUFRINC*
> > > > > ."
> > > > >
> > > > > Please try setting either *$MET_BUFR *or *$MET_BUFRLIB *and
then
> > please
> > > > > rerun the configure script and then rerun make install.  It
is
> > > important
> > > > to
> > > > > rerun configure before rerunning make install.
> > > > >
> > > > > Please let me know how it goes.
> > > > >
> > > > > Thanks,
> > > > > Julie
> > > > >
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > On Sat, Feb 7, 2015 at 9:36 PM, Zilore Mumba via RT <
> > met_help at ucar.edu
> > > >
> > > > > wrote:
> > > > >
> > > > > >
> > > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > > > > >
> > > > > > Julie,
> > > > > > Attached to this mail, please find the file make-
install.log. It
> > does
> > > > > > show 'undefined reference' to some functions. I hope this
means
> > > > > > something to you and that you can help.
> > > > > > Thanks in advance
> > > > > > Zilore
> > > > > >
> > > > > >
> > > > > > On 2/5/15, Julie Prestopnik via RT <met_help at ucar.edu>
wrote:
> > > > > > > Thank you for attaching your log files.  I did not see
any
> errors
> > > in
> > > > > your
> > > > > > > make-install.log.  Perhaps you ran make install in the
> following
> > > way:
> > > > > > >
> > > > > > > make install > make-install.log
> > > > > > >
> > > > > > > This would catch standard out but not standard error.
> > > > > > >
> > > > > > > Could you please try running in the following way with
the &,
> > which
> > > > > will
> > > > > > > also capture standard error?
> > > > > > >
> > > > > > > make install >& make-install.log
> > > > > > >
> > > > > > > And, then please send me the output of that log.  Thank
you!
> > > > > > >
> > > > > > > Julie
> > > > > > >
> > > > > > > On Tue, Feb 3, 2015 at 2:08 PM, Zilore Mumba via RT <
> > > > met_help at ucar.edu
> > > > > >
> > > > > > > wrote:
> > > > > > >
> > > > > > >>
> > > > > > >> <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> >
> > > > > > >>
> > > > > > >> Julie,
> > > > > > >> Thank you very much for your assistance. I failed to
install
> > Cairo
> > > > and
> > > > > > >> freetype because of the dependencies. I will try again
with
> the
> > > > links
> > > > > > >> you sent me.
> > > > > > >> Please find attached my config.log and make-
install.log.
> > > > > > >>
> > > > > > >>
> > > > > > >> On 2/2/15, Julie Prestopnik via RT <met_help at ucar.edu>
wrote:
> > > > > > >> > I'm so glad you were able to get MET installed and
that you
> > > worked
> > > > > out
> > > > > > >> the
> > > > > > >> > issue with the NetCDF environment variables.
> > > > > > >> >
> > > > > > >> > You mentioned that three executables did not build.
I would
> > > like
> > > > to
> > > > > > >> > try
> > > > > > >> to
> > > > > > >> > help with those.  The modis_regrid tool has library
> > > dependencies -
> > > > > it
> > > > > > >> > requires the HDF4 and HDF-EOS2 libraries.  The
> plot_mode_field
> > > > tool
> > > > > > >> > also
> > > > > > >> > has library dependencies - it requires the Cairo and
> FreeType
> > > > > > >> > libraries.
> > > > > > >> >
> > > > > > >> > You can find information on compiling each of those
library
> > > > > > >> > dependencies
> > > > > > >> > here:
> > > > > > >> >
> > > > > > >>
> > > > > >
> > > > >
> > > >
> > >
> > http://www.dtcenter.org/met/users/support/online_tutorial/
> METv5.0/compilation/req_libs.php
> > > > > > >> >
> > > > > > >> > You can find information on setting the up necessary
> > environment
> > > > > > >> variables
> > > > > > >> > for those library locations here:
> > > > > > >> >
> > > > > > >>
> > > > > >
> > > > >
> > > >
> > >
> > http://www.dtcenter.org/met/users/support/online_tutorial/
> METv5.0/compilation/configure.php
> > > > > > >> >
> > > > > > >> > And with pb2nc, I'm not exactly sure what is going on
there.
> > I
> > > > > would
> > > > > > >> > be
> > > > > > >> > happy to take a look at your configure log and make
install
> > log
> > > > > files
> > > > > > >> > to
> > > > > > >> > see if I can figure out why you didn't get the
executable.
> > > > > > >> >
> > > > > > >> > I hope this helps.
> > > > > > >> >
> > > > > > >> > Thanks,
> > > > > > >> > Julie
> > > > > > >> >
> > > > > > >> >
> > > > > > >> >
> > > > > > >> > On Sat, Jan 31, 2015 at 5:31 PM, Zilore Mumba via RT
> > > > > > >> > <met_help at ucar.edu>
> > > > > > >> > wrote:
> > > > > > >> >
> > > > > > >> >>
> > > > > > >> >> <URL:
> > https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > >
> > > > > > >> >>
> > > > > > >> >> Julg
> > > > > > >> >> Thank you very much for your help. With the advice
you gave
> > > me, I
> > > > > was
> > > > > > >> >> able to install MET using gcc and gfortran. I also
had to
> to
> > > > point
> > > > > > >> >> $MET_NETCDFLIB and, $MET_NETCDFINC to
> > > /usr/local/netcdf-4.1.3/lib
> > > > > and
> > > > > > >> >> include. Previously I pointed only to
> > /usr/local/netcdf-4.1.3.
> > > > > > >> >> I have three executables not included though, these
are
> > > > > modis_regrid,
> > > > > > >> >> plot_mode_field and pb2nc.
> > > > > > >> >> Thank you very much.
> > > > > > >> >>
> > > > > > >> >>
> > > > > > >> >> On 1/29/15, Julie Prestopnik via RT
<met_help at ucar.edu>
> > wrote:
> > > > > > >> >> > I am sorry to hear that you are having problems
> installing
> > > > > METv5.0.
> > > > > > >> >> > I
> > > > > > >> >> > believe this error may have to do with how you
compiled
> > > > BUFRLIB.
> > > > > > >> >> > Please
> > > > > > >> >> > take a look at the sample commands for compiling
BURFLIB
> on
> > > > this
> > > > > > >> >> > page:
> > > > > > >> >> >
> > > > > > >> >>
> > > > > > >>
> > > > > >
> > > > >
> > > >
> > >
> > http://www.dtcenter.org/met/users/support/online_tutorial/
> METv5.0/compilation/req_libs.php
> > > > > > >> >> >
> > > > > > >> >> > I believe that the *-fno-second-underscore* (GNU
> compilers)
> > > or
> > > > > > >> >> > *-Mnosecond_underscore* (PGI compilers) will fix
the
> error
> > > > you're
> > > > > > >> >> > seeing.
> > > > > > >> >> >
> > > > > > >> >> > I hope that helps.  If it doesn't, please send me
the
> files
> > > > > > >> >> "make_met.log"
> > > > > > >> >> > and "config.log".
> > > > > > >> >> >
> > > > > > >> >> > Thanks,
> > > > > > >> >> > Julie
> > > > > > >> >> >
> > > > > > >> >> >
> > > > > > >> >> > On Thu, Jan 29, 2015 at 3:48 AM, Zilore Mumba via
RT
> > > > > > >> >> > <met_help at ucar.edu>
> > > > > > >> >> > wrote:
> > > > > > >> >> >
> > > > > > >> >> >>
> > > > > > >> >> >> Thu Jan 29 03:48:08 2015: Request 70551 was acted
upon.
> > > > > > >> >> >> Transaction: Ticket created by zmumba at gmail.com
> > > > > > >> >> >>        Queue: met_help
> > > > > > >> >> >>      Subject: Problem compiling Met-V5
> > > > > > >> >> >>        Owner: Nobody
> > > > > > >> >> >>   Requestors: zmumba at gmail.com
> > > > > > >> >> >>       Status: new
> > > > > > >> >> >>  Ticket <URL:
> > > > > > >> https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > > > > >> >> >> >
> > > > > > >> >> >>
> > > > > > >> >> >>
> > > > > > >> >> >> I have installed BUFRLIB, GSL and G2CLIB
> > > > > > >> >> >> But then how do I handle the errors below in
installing
> > > > MET_V5?
> > > > > > >> >> >>
> > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/numpbmsg.f:23:
> > > > > > >> >> >> undefined
> > > > > > >> >> >> reference to `ufbtab_'
> > > > > > >> >> >> openpb.o: In function `openpb_':
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:21:
> > > > > > >> >> >> undefined
> > > > > > >> >> >> reference to `openbf_'
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:22:
> > > > > > >> >> >> undefined
> > > > > > >> >> >> reference to `datelen_'
> > > > > > >> >> >> closepb.o: In function `closepb_':
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/closepb.f:19:
> > > > > > >> undefined
> > > > > > >> >> >> reference to `closbf_'
> > > > > > >> >> >> readpb.o: In function `readpb_':
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:82:
> > > > > > >> >> >> undefined
> > > > > > >> >> >> reference to `ireadns_'
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:90:
> > > > > > >> >> >> undefined
> > > > > > >> >> >> reference to `ufbint_'
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:94:
> > > > > > >> >> >> undefined
> > > > > > >> >> >> reference to `ufbevn_'
> > > > > > >> >> >> dumppb.o: In function `readpbdump_':
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:215:
> > > > > > >> undefined
> > > > > > >> >> >> reference to `ufbint_'
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:218:
> > > > > > >> undefined
> > > > > > >> >> >> reference to `ufbevn_'
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:224:
> > > > > > >> undefined
> > > > > > >> >> >> reference to `ireadns_'
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:203:
> > > > > > >> undefined
> > > > > > >> >> >> reference to `ireadns_'
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:228:
> > > > > > >> undefined
> > > > > > >> >> >> reference to `ufbint_'
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:259:
> > > > > > >> undefined
> > > > > > >> >> >> reference to `ufbevn_'
> > > > > > >> >> >> dumppb.o: In function `dumppb_':
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:56:
> > > > > > >> >> >> undefined
> > > > > > >> >> >> reference to `openbf_'
> > > > > > >> >> >>
> > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:57:
> > > > > > >> >> >> undefined
> > > > > > >> >> >> reference to `datelen_'
> > > > > > >> >> >> collect2: error: ld returned 1 exit status
> > > > > > >> >> >> make[4]: *** [pb2nc] Error 1
> > > > > > >> >> >> make[4]: Leaving directory
> > > > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other/pb2nc'
> > > > > > >> >> >> make[3]: *** [install-recursive] Error 1
> > > > > > >> >> >> make[3]: Leaving directory
> > > > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other'
> > > > > > >> >> >> make[2]: *** [install-recursive] Error 1
> > > > > > >> >> >> make[2]: Leaving directory
> > > > `/home/zmumba/WRF/met-5.0/src/tools'
> > > > > > >> >> >> make[1]: *** [install-recursive] Error 1
> > > > > > >> >> >> make[1]: Leaving directory
> `/home/zmumba/WRF/met-5.0/src'
> > > > > > >> >> >> make: *** [install-recursive] Error 1
> > > > > > >> >> >>
> > > > > > >> >> >>
> > > > > > >> >> >
> > > > > > >> >> >
> > > > > > >> >> > --
> > > > > > >> >> > Julie Prestopnik
> > > > > > >> >> > National Center for Atmospheric Research
> > > > > > >> >> > Research Applications Laboratory
> > > > > > >> >> > Phone: 303.497.8399
> > > > > > >> >> > Email: jpresto at ucar.edu
> > > > > > >> >> >
> > > > > > >> >> >
> > > > > > >> >>
> > > > > > >> >>
> > > > > > >> >
> > > > > > >> >
> > > > > > >> > --
> > > > > > >> > Julie Prestopnik
> > > > > > >> > National Center for Atmospheric Research
> > > > > > >> > Research Applications Laboratory
> > > > > > >> > Phone: 303.497.8399
> > > > > > >> > Email: jpresto at ucar.edu
> > > > > > >> >
> > > > > > >> >
> > > > > > >>
> > > > > > >>
> > > > > > >
> > > > > > >
> > > > > > > --
> > > > > > > Julie Prestopnik
> > > > > > > National Center for Atmospheric Research
> > > > > > > Research Applications Laboratory
> > > > > > > Phone: 303.497.8399
> > > > > > > Email: jpresto at ucar.edu
> > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Julie Prestopnik
> > > > > National Center for Atmospheric Research
> > > > > Research Applications Laboratory
> > > > > Phone: 303.497.8399
> > > > > Email: jpresto at ucar.edu
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> > > --
> > > Julie Prestopnik
> > > National Center for Atmospheric Research
> > > Research Applications Laboratory
> > > Phone: 303.497.8399
> > > Email: jpresto at ucar.edu
> > >
> > >
> >
> >
>
>
> --
> Julie Prestopnik
> National Center for Atmospheric Research
> Research Applications Laboratory
> Phone: 303.497.8399
> Email: jpresto at ucar.edu
>
>

------------------------------------------------
Subject: Problem compiling Met-V5
From: Julie Prestopnik
Time: Mon Apr 10 09:40:56 2017

Hi Zilore.  In 6.0 we've made a large change from using NetCDF 3 to 4.
You'll need to have both NetCDF 4 and HDF5, upon which NetCDF 4 is
built,
installed.

Please feel free to take a look at the MET User's Guide and the online
tutorial:
http://www.dtcenter.org/met/users/docs/users_guide/MET_Users_Guide_v6.0.pdf
http://www.dtcenter.org/met/users/support/online_tutorial/METv6.0/tutorial.php?name=compilation&category=req_libs

There is an additional environment variable that will need to be set,
with
the addition of HDF5:
Set *$MET_HDF5* to point to the main HDF5 directory.

Also, both the NetCDF-C package (netcdf-c-4.4.1.1) and the NetCDF-CXX
package (netcdf-cxx4-4.3.0) are necessary.

Here are the commands we've been using to compile these packages from
source.  The following assumes that you're using the GNU compilers and
that
you've defined MET_LIB_DIR to point to your desired installation
directory:

# Compilers

setenv CC `which gcc`

setenv CXX `which g++`

setenv FC `which gfortran`
setenv F77 `which gfortran`

# HDF5

wget
https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.10/
hdf5-1.10.0-patch1/src/hdf5-1.10.0-patch1.tar

tar -xvzf hdf5-1.10.0-patch1.tar

cd hdf5-1.10.0-patch1

./configure --prefix=${MET_LIB_DIR}

make install

# NetCDF-C

wget https://github.com/Unidata/netcdf-c/archive/v4.4.1.1.zip

unzip v4.4.1.1.zip

cd netcdf-c-4.4.1.1

./configure --prefix=${MET_LIB_DIR} LDFLAGS=-L${MET_LIB_DIR}/lib
CPPFLAGS=-I${MET_LIB_DIR}/include

make install


# NetCDF-CXX

wget https://github.com/Unidata/netcdf-cxx4/archive/v4.3.0.tar.gz

tar -xvzf v4.3.0.tar.gz

cd netcdf-cxx4-4.3.0

./configure --prefix=${MET_LIB_DIR} LDFLAGS=-L${MET_LIB_DIR}/lib
CPPFLAGS=-I${MET_LIB_DIR}/include
make install


I hope this helps!  Please let us know if you need further assistance.

Thanks,
Julie

On Sat, Apr 8, 2017 at 3:53 PM, Zilore Mumba via RT
<met_help at ucar.edu>
wrote:

>
> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
>
> Julie, I hope you are fine, and that I can still reach you. In March
2015
> you helped me installing met_v5.0. I have now downloaded v6.0 and I
am
> having a compilation error I do not seem to figure out.
> I believe I have installed all the libraries (and set the
environment
> variables correctly: BUFRLIB-v10-2-3, netcdf-4.4.1.1, gsl-2.3,
> g2clib-1.6.0, freetype-2.7.1 andcairo-1.14.8.
> I also have zlib, jasper and libpng.
> My configure exits with exit code 0 which I understand to be ok.
However my
> make install gives an error of not finding netcdf (as you can see
from
> make-install.log). I do not understand which netcdf it cannot find.
> I hope you can assist.
> Zilore
>
> On Thu, Mar 5, 2015 at 7:59 PM, Julie Prestopnik via RT
<met_help at ucar.edu
> >
> wrote:
>
> > Hi Zilore.  Thanks for sending your commands and log files.
> >
> > Looking in "config.log" for the string "BUFRLIB", it appears that
you did
> > not set the environment variable.
> >
> > The linker error occurs on line 1057 of make_install.log.  Looking
at
> that
> > line, we're telling the linker to look in the following
directories for
> the
> > file named "libbufr.a":
> >
> > -L/usr/lib/gcc/i686-linux-gnu/4.8
> > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../i386-linux-gnu
> > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../../lib
> > -L/lib/i386-linux-gnu
> > -L/lib/../lib
> > -L/usr/lib/i386-linux-gnu
> > -L/usr/lib/../lib
> > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../..
> >
> > It must be finding libbufr.a in one of those directories,
otherwise we
> > would get an error about that.  I believe that the version of
libbufr.a
> it
> > is finding is not the version that you compiled using the "-
DUNDERSCORE"
> > option.
> >
> > I was able to replicate your error by re-compiling a version of
BUFRLIB
> > *without* -DUNDERSCORE, and then by building MET linking to that
bad
> > version.
> >
> > What you'll need to do is set the MET_BUFRLIB environment variable
as
> > indicated on this page:
> > http://www.dtcenter.org/met/users/support/online_tutorial/
> > METv5.0/compilation/configure.php
> >
> > Then source your .cshrc or equivalent file, then run your
configure
> > command, and then run make install and make test.
> >
> > Please give that a try.  It should solve the problem you are
> encountering.
> >
> > Thanks,
> > Julie
> >
> > On Wed, Mar 4, 2015 at 5:36 AM, Zilore Mumba via RT
<met_help at ucar.edu>
> > wrote:
> >
> > >
> > > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > >
> > > *Julie, I installed with the following commands. gcc -c
-DUNDERSCORE
> *.c*
> > >    *gfortran -c -DUNDERSCORE -fno-second-underscore *.f *.F*
> > >    *ar crv libbufr.a *.o*
> > >
> > >
> > >
> > > *Please find attached the config.log and make_install.log *
> > >
> > >
> > > On Tue, Mar 3, 2015 at 7:10 PM, Julie Prestopnik via RT <
> > met_help at ucar.edu
> > > >
> > > wrote:
> > >
> > > > I'm sorry to hear that you are still experiencing problems
installing
> > > > METv5.0.
> > > >
> > > > Specifically regarding BUFRLIB, please compile it using the
options
> > > listed
> > > > on this page:
> > > >
> > > >
> > > >
> > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > METv5.0/compilation/req_libs.php
> > > >
> > > > Failing to use the "-DUNDERSCORE -fno-second-underscore" (for
GNU
> > > > compilers) options will result in undefined references when
building
> > the
> > > > pb2nc tool.
> > > >
> > > > If you'd like to send us the output of make please do the
following:
> > > >    make clean
> > > >    make install >& make_install.log
> > > >
> > > > And then send us the files "config.log" and
"make_install.log".
> > > >
> > > > I hope you'll find what you have been able to install useful.
Please
> > let
> > > > us know if you have any questions.
> > > >
> > > > Thanks,
> > > > Julie
> > > >
> > > > On Tue, Mar 3, 2015 at 12:26 AM, Zilore Mumba via RT <
> > met_help at ucar.edu>
> > > > wrote:
> > > >
> > > > >
> > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > > > >
> > > > > Julie,
> > > > > I did not inform you of the conclusion of my attempt to
install
> > > Met-5.1.
> > > > > After making many attempts in reinstalling/reconfiguring
BUFRLIB i
> > > still
> > > > > get errors relating to "undefined reference to ..." and
eventually
> I
> > > > still
> > > > > have 3 executables not installed: pb2nc, modis_regrid,
> > plot_mode_field.
> > > > > I would like to learn how to use what I have and come back
later to
> > > pb2nc
> > > > > if necessary. I will inform you if I have any other
problems.
> > > > >
> > > > >
> > > > > On Tue, Feb 10, 2015 at 7:12 PM, Julie Prestopnik via RT <
> > > > > met_help at ucar.edu>
> > > > > wrote:
> > > > >
> > > > > > Thank you for rerunning and sending this log.  Perhaps MET
cannot
> > > find
> > > > > the
> > > > > > BUFR library.
> > > > > >
> > > > > > On the following page are directions for setting the
environment
> > > > > variables
> > > > > > before compiling MET:
> > > > > >
> > > > > >
> > > > >
> > > >
> > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > METv5.0/compilation/configure.php
> > > > > >
> > > > > > The rest of the applications built, so it looks like MET
was able
> > to
> > > > find
> > > > > > the other needed libraries.  The directions for the BUFR
> > environment
> > > > > > variable on the above page are:
> > > > > >
> > > > > > "Set *$MET_BUFR* to point to the main BUFR directory, or
set
> > > > > *$MET_BUFRLIB*
> > > > > > to point to the directory with the BUFR library files.
Because
> MET
> > > > > doesn't
> > > > > > use any BUFR library include files, you don't need to
specify
> > > > > > *$MET_BUFRINC*
> > > > > > ."
> > > > > >
> > > > > > Please try setting either *$MET_BUFR *or *$MET_BUFRLIB
*and then
> > > please
> > > > > > rerun the configure script and then rerun make install.
It is
> > > > important
> > > > > to
> > > > > > rerun configure before rerunning make install.
> > > > > >
> > > > > > Please let me know how it goes.
> > > > > >
> > > > > > Thanks,
> > > > > > Julie
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > > On Sat, Feb 7, 2015 at 9:36 PM, Zilore Mumba via RT <
> > > met_help at ucar.edu
> > > > >
> > > > > > wrote:
> > > > > >
> > > > > > >
> > > > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> >
> > > > > > >
> > > > > > > Julie,
> > > > > > > Attached to this mail, please find the file make-
install.log.
> It
> > > does
> > > > > > > show 'undefined reference' to some functions. I hope
this means
> > > > > > > something to you and that you can help.
> > > > > > > Thanks in advance
> > > > > > > Zilore
> > > > > > >
> > > > > > >
> > > > > > > On 2/5/15, Julie Prestopnik via RT <met_help at ucar.edu>
wrote:
> > > > > > > > Thank you for attaching your log files.  I did not see
any
> > errors
> > > > in
> > > > > > your
> > > > > > > > make-install.log.  Perhaps you ran make install in the
> > following
> > > > way:
> > > > > > > >
> > > > > > > > make install > make-install.log
> > > > > > > >
> > > > > > > > This would catch standard out but not standard error.
> > > > > > > >
> > > > > > > > Could you please try running in the following way with
the &,
> > > which
> > > > > > will
> > > > > > > > also capture standard error?
> > > > > > > >
> > > > > > > > make install >& make-install.log
> > > > > > > >
> > > > > > > > And, then please send me the output of that log.
Thank you!
> > > > > > > >
> > > > > > > > Julie
> > > > > > > >
> > > > > > > > On Tue, Feb 3, 2015 at 2:08 PM, Zilore Mumba via RT <
> > > > > met_help at ucar.edu
> > > > > > >
> > > > > > > > wrote:
> > > > > > > >
> > > > > > > >>
> > > > > > > >> <URL: https://rt.rap.ucar.edu/rt/Tic
> ket/Display.html?id=70551
> > >
> > > > > > > >>
> > > > > > > >> Julie,
> > > > > > > >> Thank you very much for your assistance. I failed to
install
> > > Cairo
> > > > > and
> > > > > > > >> freetype because of the dependencies. I will try
again with
> > the
> > > > > links
> > > > > > > >> you sent me.
> > > > > > > >> Please find attached my config.log and make-
install.log.
> > > > > > > >>
> > > > > > > >>
> > > > > > > >> On 2/2/15, Julie Prestopnik via RT
<met_help at ucar.edu>
> wrote:
> > > > > > > >> > I'm so glad you were able to get MET installed and
that
> you
> > > > worked
> > > > > > out
> > > > > > > >> the
> > > > > > > >> > issue with the NetCDF environment variables.
> > > > > > > >> >
> > > > > > > >> > You mentioned that three executables did not build.
I
> would
> > > > like
> > > > > to
> > > > > > > >> > try
> > > > > > > >> to
> > > > > > > >> > help with those.  The modis_regrid tool has library
> > > > dependencies -
> > > > > > it
> > > > > > > >> > requires the HDF4 and HDF-EOS2 libraries.  The
> > plot_mode_field
> > > > > tool
> > > > > > > >> > also
> > > > > > > >> > has library dependencies - it requires the Cairo
and
> > FreeType
> > > > > > > >> > libraries.
> > > > > > > >> >
> > > > > > > >> > You can find information on compiling each of those
> library
> > > > > > > >> > dependencies
> > > > > > > >> > here:
> > > > > > > >> >
> > > > > > > >>
> > > > > > >
> > > > > >
> > > > >
> > > >
> > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > METv5.0/compilation/req_libs.php
> > > > > > > >> >
> > > > > > > >> > You can find information on setting the up
necessary
> > > environment
> > > > > > > >> variables
> > > > > > > >> > for those library locations here:
> > > > > > > >> >
> > > > > > > >>
> > > > > > >
> > > > > >
> > > > >
> > > >
> > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > METv5.0/compilation/configure.php
> > > > > > > >> >
> > > > > > > >> > And with pb2nc, I'm not exactly sure what is going
on
> there.
> > > I
> > > > > > would
> > > > > > > >> > be
> > > > > > > >> > happy to take a look at your configure log and make
> install
> > > log
> > > > > > files
> > > > > > > >> > to
> > > > > > > >> > see if I can figure out why you didn't get the
executable.
> > > > > > > >> >
> > > > > > > >> > I hope this helps.
> > > > > > > >> >
> > > > > > > >> > Thanks,
> > > > > > > >> > Julie
> > > > > > > >> >
> > > > > > > >> >
> > > > > > > >> >
> > > > > > > >> > On Sat, Jan 31, 2015 at 5:31 PM, Zilore Mumba via
RT
> > > > > > > >> > <met_help at ucar.edu>
> > > > > > > >> > wrote:
> > > > > > > >> >
> > > > > > > >> >>
> > > > > > > >> >> <URL:
> > > https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > > >
> > > > > > > >> >>
> > > > > > > >> >> Julg
> > > > > > > >> >> Thank you very much for your help. With the advice
you
> gave
> > > > me, I
> > > > > > was
> > > > > > > >> >> able to install MET using gcc and gfortran. I also
had to
> > to
> > > > > point
> > > > > > > >> >> $MET_NETCDFLIB and, $MET_NETCDFINC to
> > > > /usr/local/netcdf-4.1.3/lib
> > > > > > and
> > > > > > > >> >> include. Previously I pointed only to
> > > /usr/local/netcdf-4.1.3.
> > > > > > > >> >> I have three executables not included though,
these are
> > > > > > modis_regrid,
> > > > > > > >> >> plot_mode_field and pb2nc.
> > > > > > > >> >> Thank you very much.
> > > > > > > >> >>
> > > > > > > >> >>
> > > > > > > >> >> On 1/29/15, Julie Prestopnik via RT
<met_help at ucar.edu>
> > > wrote:
> > > > > > > >> >> > I am sorry to hear that you are having problems
> > installing
> > > > > > METv5.0.
> > > > > > > >> >> > I
> > > > > > > >> >> > believe this error may have to do with how you
compiled
> > > > > BUFRLIB.
> > > > > > > >> >> > Please
> > > > > > > >> >> > take a look at the sample commands for compiling
> BURFLIB
> > on
> > > > > this
> > > > > > > >> >> > page:
> > > > > > > >> >> >
> > > > > > > >> >>
> > > > > > > >>
> > > > > > >
> > > > > >
> > > > >
> > > >
> > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > METv5.0/compilation/req_libs.php
> > > > > > > >> >> >
> > > > > > > >> >> > I believe that the *-fno-second-underscore* (GNU
> > compilers)
> > > > or
> > > > > > > >> >> > *-Mnosecond_underscore* (PGI compilers) will fix
the
> > error
> > > > > you're
> > > > > > > >> >> > seeing.
> > > > > > > >> >> >
> > > > > > > >> >> > I hope that helps.  If it doesn't, please send
me the
> > files
> > > > > > > >> >> "make_met.log"
> > > > > > > >> >> > and "config.log".
> > > > > > > >> >> >
> > > > > > > >> >> > Thanks,
> > > > > > > >> >> > Julie
> > > > > > > >> >> >
> > > > > > > >> >> >
> > > > > > > >> >> > On Thu, Jan 29, 2015 at 3:48 AM, Zilore Mumba
via RT
> > > > > > > >> >> > <met_help at ucar.edu>
> > > > > > > >> >> > wrote:
> > > > > > > >> >> >
> > > > > > > >> >> >>
> > > > > > > >> >> >> Thu Jan 29 03:48:08 2015: Request 70551 was
acted
> upon.
> > > > > > > >> >> >> Transaction: Ticket created by zmumba at gmail.com
> > > > > > > >> >> >>        Queue: met_help
> > > > > > > >> >> >>      Subject: Problem compiling Met-V5
> > > > > > > >> >> >>        Owner: Nobody
> > > > > > > >> >> >>   Requestors: zmumba at gmail.com
> > > > > > > >> >> >>       Status: new
> > > > > > > >> >> >>  Ticket <URL:
> > > > > > > >>
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > > > > > >> >> >> >
> > > > > > > >> >> >>
> > > > > > > >> >> >>
> > > > > > > >> >> >> I have installed BUFRLIB, GSL and G2CLIB
> > > > > > > >> >> >> But then how do I handle the errors below in
> installing
> > > > > MET_V5?
> > > > > > > >> >> >>
> > > > > > > >> >> >>
> > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/numpbmsg.f:23:
> > > > > > > >> >> >> undefined
> > > > > > > >> >> >> reference to `ufbtab_'
> > > > > > > >> >> >> openpb.o: In function `openpb_':
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:21:
> > > > > > > >> >> >> undefined
> > > > > > > >> >> >> reference to `openbf_'
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:22:
> > > > > > > >> >> >> undefined
> > > > > > > >> >> >> reference to `datelen_'
> > > > > > > >> >> >> closepb.o: In function `closepb_':
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/closepb.f:19:
> > > > > > > >> undefined
> > > > > > > >> >> >> reference to `closbf_'
> > > > > > > >> >> >> readpb.o: In function `readpb_':
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:82:
> > > > > > > >> >> >> undefined
> > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:90:
> > > > > > > >> >> >> undefined
> > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:94:
> > > > > > > >> >> >> undefined
> > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > >> >> >> dumppb.o: In function `readpbdump_':
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:215:
> > > > > > > >> undefined
> > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:218:
> > > > > > > >> undefined
> > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:224:
> > > > > > > >> undefined
> > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:203:
> > > > > > > >> undefined
> > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:228:
> > > > > > > >> undefined
> > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:259:
> > > > > > > >> undefined
> > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > >> >> >> dumppb.o: In function `dumppb_':
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:56:
> > > > > > > >> >> >> undefined
> > > > > > > >> >> >> reference to `openbf_'
> > > > > > > >> >> >>
> > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:57:
> > > > > > > >> >> >> undefined
> > > > > > > >> >> >> reference to `datelen_'
> > > > > > > >> >> >> collect2: error: ld returned 1 exit status
> > > > > > > >> >> >> make[4]: *** [pb2nc] Error 1
> > > > > > > >> >> >> make[4]: Leaving directory
> > > > > > > >> >> >> `/home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc'
> > > > > > > >> >> >> make[3]: *** [install-recursive] Error 1
> > > > > > > >> >> >> make[3]: Leaving directory
> > > > > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other'
> > > > > > > >> >> >> make[2]: *** [install-recursive] Error 1
> > > > > > > >> >> >> make[2]: Leaving directory
> > > > > `/home/zmumba/WRF/met-5.0/src/tools'
> > > > > > > >> >> >> make[1]: *** [install-recursive] Error 1
> > > > > > > >> >> >> make[1]: Leaving directory
> > `/home/zmumba/WRF/met-5.0/src'
> > > > > > > >> >> >> make: *** [install-recursive] Error 1
> > > > > > > >> >> >>
> > > > > > > >> >> >>
> > > > > > > >> >> >
> > > > > > > >> >> >
> > > > > > > >> >> > --
> > > > > > > >> >> > Julie Prestopnik
> > > > > > > >> >> > National Center for Atmospheric Research
> > > > > > > >> >> > Research Applications Laboratory
> > > > > > > >> >> > Phone: 303.497.8399 <%28303%29%20497-8399>
> > > > > > > >> >> > Email: jpresto at ucar.edu
> > > > > > > >> >> >
> > > > > > > >> >> >
> > > > > > > >> >>
> > > > > > > >> >>
> > > > > > > >> >
> > > > > > > >> >
> > > > > > > >> > --
> > > > > > > >> > Julie Prestopnik
> > > > > > > >> > National Center for Atmospheric Research
> > > > > > > >> > Research Applications Laboratory
> > > > > > > >> > Phone: 303.497.8399
> > > > > > > >> > Email: jpresto at ucar.edu
> > > > > > > >> >
> > > > > > > >> >
> > > > > > > >>
> > > > > > > >>
> > > > > > > >
> > > > > > > >
> > > > > > > > --
> > > > > > > > Julie Prestopnik
> > > > > > > > National Center for Atmospheric Research
> > > > > > > > Research Applications Laboratory
> > > > > > > > Phone: 303.497.8399
> > > > > > > > Email: jpresto at ucar.edu
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > > > --
> > > > > > Julie Prestopnik
> > > > > > National Center for Atmospheric Research
> > > > > > Research Applications Laboratory
> > > > > > Phone: 303.497.8399
> > > > > > Email: jpresto at ucar.edu
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > >
> > > >
> > > > --
> > > > Julie Prestopnik
> > > > National Center for Atmospheric Research
> > > > Research Applications Laboratory
> > > > Phone: 303.497.8399
> > > > Email: jpresto at ucar.edu
> > > >
> > > >
> > >
> > >
> >
> >
> > --
> > Julie Prestopnik
> > National Center for Atmospheric Research
> > Research Applications Laboratory
> > Phone: 303.497.8399
> > Email: jpresto at ucar.edu
> >
> >
>
>

------------------------------------------------
Subject: Problem compiling Met-V5
From: Zilore Mumba
Time: Tue Apr 11 08:13:01 2017

Julie,
Thanks very much for all the details you provided.
However, am still getting the same error, i.e.
The file "nc_var_info.cc" (i.e. #include on line 24) calls
"nc_utils.h".
Now the latter file has "#include netcdf" on line 22. It is this
netcdf it
is saying no such file.

I believe my setup is ok.
Using the lines you gave me on installing the hdf5 and netcdf
libraries, if
I use prefix=${MET_LIB_DIR}, I am not able to find where the libraries
are
installed, though there are no errors indicated. I tried to set
"export
MET_LIB_DIR=/usr/local/met6" and alternatively "export
MET_LIB_DIR=~/met6"
after creating the met6 directory in each case.
But putting prefix=/usr/local/met6, I get both netcdf-c and netcdf-cxx
libraries in /usr/local/met6/lib, include files in
/usr/local/met6/include,
and some executables in /usr/local/met6/bin as well as an hdf5
directory.
So am wondering if the include file nc_utils.h has the correct entry
on
line 22.
Thanks for your time and effort
Zilore

On Mon, Apr 10, 2017 at 5:40 PM, Julie Prestopnik via RT
<met_help at ucar.edu>
wrote:

> Hi Zilore.  In 6.0 we've made a large change from using NetCDF 3 to
4.
> You'll need to have both NetCDF 4 and HDF5, upon which NetCDF 4 is
built,
> installed.
>
> Please feel free to take a look at the MET User's Guide and the
online
> tutorial:
> http://www.dtcenter.org/met/users/docs/users_guide/MET_
> Users_Guide_v6.0.pdf
> http://www.dtcenter.org/met/users/support/online_tutorial/
> METv6.0/tutorial.php?name=compilation&category=req_libs
>
> There is an additional environment variable that will need to be
set, with
> the addition of HDF5:
> Set *$MET_HDF5* to point to the main HDF5 directory.
>
> Also, both the NetCDF-C package (netcdf-c-4.4.1.1) and the NetCDF-
CXX
> package (netcdf-cxx4-4.3.0) are necessary.
>
> Here are the commands we've been using to compile these packages
from
> source.  The following assumes that you're using the GNU compilers
and that
> you've defined MET_LIB_DIR to point to your desired installation
directory:
>
> # Compilers
>
> setenv CC `which gcc`
>
> setenv CXX `which g++`
>
> setenv FC `which gfortran`
> setenv F77 `which gfortran`
>
> # HDF5
>
> wget
> https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.10/
> hdf5-1.10.0-patch1/src/hdf5-1.10.0-patch1.tar
>
> tar -xvzf hdf5-1.10.0-patch1.tar
>
> cd hdf5-1.10.0-patch1
>
> ./configure --prefix=${MET_LIB_DIR}
>
> make install
>
> # NetCDF-C
>
> wget https://github.com/Unidata/netcdf-c/archive/v4.4.1.1.zip
>
> unzip v4.4.1.1.zip
>
> cd netcdf-c-4.4.1.1
>
> ./configure --prefix=${MET_LIB_DIR} LDFLAGS=-L${MET_LIB_DIR}/lib
> CPPFLAGS=-I${MET_LIB_DIR}/include
>
> make install
>
>
> # NetCDF-CXX
>
> wget https://github.com/Unidata/netcdf-cxx4/archive/v4.3.0.tar.gz
>
> tar -xvzf v4.3.0.tar.gz
>
> cd netcdf-cxx4-4.3.0
>
> ./configure --prefix=${MET_LIB_DIR} LDFLAGS=-L${MET_LIB_DIR}/lib
> CPPFLAGS=-I${MET_LIB_DIR}/include
> make install
>
>
> I hope this helps!  Please let us know if you need further
assistance.
>
> Thanks,
> Julie
>
> On Sat, Apr 8, 2017 at 3:53 PM, Zilore Mumba via RT
<met_help at ucar.edu>
> wrote:
>
> >
> > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> >
> > Julie, I hope you are fine, and that I can still reach you. In
March 2015
> > you helped me installing met_v5.0. I have now downloaded v6.0 and
I am
> > having a compilation error I do not seem to figure out.
> > I believe I have installed all the libraries (and set the
environment
> > variables correctly: BUFRLIB-v10-2-3, netcdf-4.4.1.1, gsl-2.3,
> > g2clib-1.6.0, freetype-2.7.1 andcairo-1.14.8.
> > I also have zlib, jasper and libpng.
> > My configure exits with exit code 0 which I understand to be ok.
However
> my
> > make install gives an error of not finding netcdf (as you can see
from
> > make-install.log). I do not understand which netcdf it cannot
find.
> > I hope you can assist.
> > Zilore
> >
> > On Thu, Mar 5, 2015 at 7:59 PM, Julie Prestopnik via RT <
> met_help at ucar.edu
> > >
> > wrote:
> >
> > > Hi Zilore.  Thanks for sending your commands and log files.
> > >
> > > Looking in "config.log" for the string "BUFRLIB", it appears
that you
> did
> > > not set the environment variable.
> > >
> > > The linker error occurs on line 1057 of make_install.log.
Looking at
> > that
> > > line, we're telling the linker to look in the following
directories for
> > the
> > > file named "libbufr.a":
> > >
> > > -L/usr/lib/gcc/i686-linux-gnu/4.8
> > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../i386-linux-gnu
> > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../../lib
> > > -L/lib/i386-linux-gnu
> > > -L/lib/../lib
> > > -L/usr/lib/i386-linux-gnu
> > > -L/usr/lib/../lib
> > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../..
> > >
> > > It must be finding libbufr.a in one of those directories,
otherwise we
> > > would get an error about that.  I believe that the version of
libbufr.a
> > it
> > > is finding is not the version that you compiled using the
> "-DUNDERSCORE"
> > > option.
> > >
> > > I was able to replicate your error by re-compiling a version of
BUFRLIB
> > > *without* -DUNDERSCORE, and then by building MET linking to that
bad
> > > version.
> > >
> > > What you'll need to do is set the MET_BUFRLIB environment
variable as
> > > indicated on this page:
> > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > METv5.0/compilation/configure.php
> > >
> > > Then source your .cshrc or equivalent file, then run your
configure
> > > command, and then run make install and make test.
> > >
> > > Please give that a try.  It should solve the problem you are
> > encountering.
> > >
> > > Thanks,
> > > Julie
> > >
> > > On Wed, Mar 4, 2015 at 5:36 AM, Zilore Mumba via RT
<met_help at ucar.edu
> >
> > > wrote:
> > >
> > > >
> > > > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
>
> > > >
> > > > *Julie, I installed with the following commands. gcc -c
-DUNDERSCORE
> > *.c*
> > > >    *gfortran -c -DUNDERSCORE -fno-second-underscore *.f *.F*
> > > >    *ar crv libbufr.a *.o*
> > > >
> > > >
> > > >
> > > > *Please find attached the config.log and make_install.log *
> > > >
> > > >
> > > > On Tue, Mar 3, 2015 at 7:10 PM, Julie Prestopnik via RT <
> > > met_help at ucar.edu
> > > > >
> > > > wrote:
> > > >
> > > > > I'm sorry to hear that you are still experiencing problems
> installing
> > > > > METv5.0.
> > > > >
> > > > > Specifically regarding BUFRLIB, please compile it using the
options
> > > > listed
> > > > > on this page:
> > > > >
> > > > >
> > > > >
> > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > METv5.0/compilation/req_libs.php
> > > > >
> > > > > Failing to use the "-DUNDERSCORE -fno-second-underscore"
(for GNU
> > > > > compilers) options will result in undefined references when
> building
> > > the
> > > > > pb2nc tool.
> > > > >
> > > > > If you'd like to send us the output of make please do the
> following:
> > > > >    make clean
> > > > >    make install >& make_install.log
> > > > >
> > > > > And then send us the files "config.log" and
"make_install.log".
> > > > >
> > > > > I hope you'll find what you have been able to install
useful.
> Please
> > > let
> > > > > us know if you have any questions.
> > > > >
> > > > > Thanks,
> > > > > Julie
> > > > >
> > > > > On Tue, Mar 3, 2015 at 12:26 AM, Zilore Mumba via RT <
> > > met_help at ucar.edu>
> > > > > wrote:
> > > > >
> > > > > >
> > > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > > > > >
> > > > > > Julie,
> > > > > > I did not inform you of the conclusion of my attempt to
install
> > > > Met-5.1.
> > > > > > After making many attempts in reinstalling/reconfiguring
BUFRLIB
> i
> > > > still
> > > > > > get errors relating to "undefined reference to ..." and
> eventually
> > I
> > > > > still
> > > > > > have 3 executables not installed: pb2nc, modis_regrid,
> > > plot_mode_field.
> > > > > > I would like to learn how to use what I have and come back
later
> to
> > > > pb2nc
> > > > > > if necessary. I will inform you if I have any other
problems.
> > > > > >
> > > > > >
> > > > > > On Tue, Feb 10, 2015 at 7:12 PM, Julie Prestopnik via RT <
> > > > > > met_help at ucar.edu>
> > > > > > wrote:
> > > > > >
> > > > > > > Thank you for rerunning and sending this log.  Perhaps
MET
> cannot
> > > > find
> > > > > > the
> > > > > > > BUFR library.
> > > > > > >
> > > > > > > On the following page are directions for setting the
> environment
> > > > > > variables
> > > > > > > before compiling MET:
> > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > METv5.0/compilation/configure.php
> > > > > > >
> > > > > > > The rest of the applications built, so it looks like MET
was
> able
> > > to
> > > > > find
> > > > > > > the other needed libraries.  The directions for the BUFR
> > > environment
> > > > > > > variable on the above page are:
> > > > > > >
> > > > > > > "Set *$MET_BUFR* to point to the main BUFR directory, or
set
> > > > > > *$MET_BUFRLIB*
> > > > > > > to point to the directory with the BUFR library files.
Because
> > MET
> > > > > > doesn't
> > > > > > > use any BUFR library include files, you don't need to
specify
> > > > > > > *$MET_BUFRINC*
> > > > > > > ."
> > > > > > >
> > > > > > > Please try setting either *$MET_BUFR *or *$MET_BUFRLIB
*and
> then
> > > > please
> > > > > > > rerun the configure script and then rerun make install.
It is
> > > > > important
> > > > > > to
> > > > > > > rerun configure before rerunning make install.
> > > > > > >
> > > > > > > Please let me know how it goes.
> > > > > > >
> > > > > > > Thanks,
> > > > > > > Julie
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > On Sat, Feb 7, 2015 at 9:36 PM, Zilore Mumba via RT <
> > > > met_help at ucar.edu
> > > > > >
> > > > > > > wrote:
> > > > > > >
> > > > > > > >
> > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> Ticket/Display.html?id=70551
> > >
> > > > > > > >
> > > > > > > > Julie,
> > > > > > > > Attached to this mail, please find the file make-
install.log.
> > It
> > > > does
> > > > > > > > show 'undefined reference' to some functions. I hope
this
> means
> > > > > > > > something to you and that you can help.
> > > > > > > > Thanks in advance
> > > > > > > > Zilore
> > > > > > > >
> > > > > > > >
> > > > > > > > On 2/5/15, Julie Prestopnik via RT <met_help at ucar.edu>
> wrote:
> > > > > > > > > Thank you for attaching your log files.  I did not
see any
> > > errors
> > > > > in
> > > > > > > your
> > > > > > > > > make-install.log.  Perhaps you ran make install in
the
> > > following
> > > > > way:
> > > > > > > > >
> > > > > > > > > make install > make-install.log
> > > > > > > > >
> > > > > > > > > This would catch standard out but not standard
error.
> > > > > > > > >
> > > > > > > > > Could you please try running in the following way
with the
> &,
> > > > which
> > > > > > > will
> > > > > > > > > also capture standard error?
> > > > > > > > >
> > > > > > > > > make install >& make-install.log
> > > > > > > > >
> > > > > > > > > And, then please send me the output of that log.
Thank
> you!
> > > > > > > > >
> > > > > > > > > Julie
> > > > > > > > >
> > > > > > > > > On Tue, Feb 3, 2015 at 2:08 PM, Zilore Mumba via RT
<
> > > > > > met_help at ucar.edu
> > > > > > > >
> > > > > > > > > wrote:
> > > > > > > > >
> > > > > > > > >>
> > > > > > > > >> <URL: https://rt.rap.ucar.edu/rt/Tic
> > ket/Display.html?id=70551
> > > >
> > > > > > > > >>
> > > > > > > > >> Julie,
> > > > > > > > >> Thank you very much for your assistance. I failed
to
> install
> > > > Cairo
> > > > > > and
> > > > > > > > >> freetype because of the dependencies. I will try
again
> with
> > > the
> > > > > > links
> > > > > > > > >> you sent me.
> > > > > > > > >> Please find attached my config.log and make-
install.log.
> > > > > > > > >>
> > > > > > > > >>
> > > > > > > > >> On 2/2/15, Julie Prestopnik via RT
<met_help at ucar.edu>
> > wrote:
> > > > > > > > >> > I'm so glad you were able to get MET installed
and that
> > you
> > > > > worked
> > > > > > > out
> > > > > > > > >> the
> > > > > > > > >> > issue with the NetCDF environment variables.
> > > > > > > > >> >
> > > > > > > > >> > You mentioned that three executables did not
build.  I
> > would
> > > > > like
> > > > > > to
> > > > > > > > >> > try
> > > > > > > > >> to
> > > > > > > > >> > help with those.  The modis_regrid tool has
library
> > > > > dependencies -
> > > > > > > it
> > > > > > > > >> > requires the HDF4 and HDF-EOS2 libraries.  The
> > > plot_mode_field
> > > > > > tool
> > > > > > > > >> > also
> > > > > > > > >> > has library dependencies - it requires the Cairo
and
> > > FreeType
> > > > > > > > >> > libraries.
> > > > > > > > >> >
> > > > > > > > >> > You can find information on compiling each of
those
> > library
> > > > > > > > >> > dependencies
> > > > > > > > >> > here:
> > > > > > > > >> >
> > > > > > > > >>
> > > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > METv5.0/compilation/req_libs.php
> > > > > > > > >> >
> > > > > > > > >> > You can find information on setting the up
necessary
> > > > environment
> > > > > > > > >> variables
> > > > > > > > >> > for those library locations here:
> > > > > > > > >> >
> > > > > > > > >>
> > > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > METv5.0/compilation/configure.php
> > > > > > > > >> >
> > > > > > > > >> > And with pb2nc, I'm not exactly sure what is
going on
> > there.
> > > > I
> > > > > > > would
> > > > > > > > >> > be
> > > > > > > > >> > happy to take a look at your configure log and
make
> > install
> > > > log
> > > > > > > files
> > > > > > > > >> > to
> > > > > > > > >> > see if I can figure out why you didn't get the
> executable.
> > > > > > > > >> >
> > > > > > > > >> > I hope this helps.
> > > > > > > > >> >
> > > > > > > > >> > Thanks,
> > > > > > > > >> > Julie
> > > > > > > > >> >
> > > > > > > > >> >
> > > > > > > > >> >
> > > > > > > > >> > On Sat, Jan 31, 2015 at 5:31 PM, Zilore Mumba via
RT
> > > > > > > > >> > <met_help at ucar.edu>
> > > > > > > > >> > wrote:
> > > > > > > > >> >
> > > > > > > > >> >>
> > > > > > > > >> >> <URL:
> > > > https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > > > >
> > > > > > > > >> >>
> > > > > > > > >> >> Julg
> > > > > > > > >> >> Thank you very much for your help. With the
advice you
> > gave
> > > > > me, I
> > > > > > > was
> > > > > > > > >> >> able to install MET using gcc and gfortran. I
also had
> to
> > > to
> > > > > > point
> > > > > > > > >> >> $MET_NETCDFLIB and, $MET_NETCDFINC to
> > > > > /usr/local/netcdf-4.1.3/lib
> > > > > > > and
> > > > > > > > >> >> include. Previously I pointed only to
> > > > /usr/local/netcdf-4.1.3.
> > > > > > > > >> >> I have three executables not included though,
these are
> > > > > > > modis_regrid,
> > > > > > > > >> >> plot_mode_field and pb2nc.
> > > > > > > > >> >> Thank you very much.
> > > > > > > > >> >>
> > > > > > > > >> >>
> > > > > > > > >> >> On 1/29/15, Julie Prestopnik via RT
<met_help at ucar.edu
> >
> > > > wrote:
> > > > > > > > >> >> > I am sorry to hear that you are having
problems
> > > installing
> > > > > > > METv5.0.
> > > > > > > > >> >> > I
> > > > > > > > >> >> > believe this error may have to do with how you
> compiled
> > > > > > BUFRLIB.
> > > > > > > > >> >> > Please
> > > > > > > > >> >> > take a look at the sample commands for
compiling
> > BURFLIB
> > > on
> > > > > > this
> > > > > > > > >> >> > page:
> > > > > > > > >> >> >
> > > > > > > > >> >>
> > > > > > > > >>
> > > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > METv5.0/compilation/req_libs.php
> > > > > > > > >> >> >
> > > > > > > > >> >> > I believe that the *-fno-second-underscore*
(GNU
> > > compilers)
> > > > > or
> > > > > > > > >> >> > *-Mnosecond_underscore* (PGI compilers) will
fix the
> > > error
> > > > > > you're
> > > > > > > > >> >> > seeing.
> > > > > > > > >> >> >
> > > > > > > > >> >> > I hope that helps.  If it doesn't, please send
me the
> > > files
> > > > > > > > >> >> "make_met.log"
> > > > > > > > >> >> > and "config.log".
> > > > > > > > >> >> >
> > > > > > > > >> >> > Thanks,
> > > > > > > > >> >> > Julie
> > > > > > > > >> >> >
> > > > > > > > >> >> >
> > > > > > > > >> >> > On Thu, Jan 29, 2015 at 3:48 AM, Zilore Mumba
via RT
> > > > > > > > >> >> > <met_help at ucar.edu>
> > > > > > > > >> >> > wrote:
> > > > > > > > >> >> >
> > > > > > > > >> >> >>
> > > > > > > > >> >> >> Thu Jan 29 03:48:08 2015: Request 70551 was
acted
> > upon.
> > > > > > > > >> >> >> Transaction: Ticket created by
zmumba at gmail.com
> > > > > > > > >> >> >>        Queue: met_help
> > > > > > > > >> >> >>      Subject: Problem compiling Met-V5
> > > > > > > > >> >> >>        Owner: Nobody
> > > > > > > > >> >> >>   Requestors: zmumba at gmail.com
> > > > > > > > >> >> >>       Status: new
> > > > > > > > >> >> >>  Ticket <URL:
> > > > > > > > >>
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > > > > > > >> >> >> >
> > > > > > > > >> >> >>
> > > > > > > > >> >> >>
> > > > > > > > >> >> >> I have installed BUFRLIB, GSL and G2CLIB
> > > > > > > > >> >> >> But then how do I handle the errors below in
> > installing
> > > > > > MET_V5?
> > > > > > > > >> >> >>
> > > > > > > > >> >> >>
> > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/numpbmsg.f:23:
> > > > > > > > >> >> >> undefined
> > > > > > > > >> >> >> reference to `ufbtab_'
> > > > > > > > >> >> >> openpb.o: In function `openpb_':
> > > > > > > > >> >> >>
> > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:21:
> > > > > > > > >> >> >> undefined
> > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > >> >> >>
> > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:22:
> > > > > > > > >> >> >> undefined
> > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > >> >> >> closepb.o: In function `closepb_':
> > > > > > > > >> >> >>
> > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/closepb.f:19:
> > > > > > > > >> undefined
> > > > > > > > >> >> >> reference to `closbf_'
> > > > > > > > >> >> >> readpb.o: In function `readpb_':
> > > > > > > > >> >> >>
> > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:82:
> > > > > > > > >> >> >> undefined
> > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > >> >> >>
> > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:90:
> > > > > > > > >> >> >> undefined
> > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > >> >> >>
> > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:94:
> > > > > > > > >> >> >> undefined
> > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > >> >> >> dumppb.o: In function `readpbdump_':
> > > > > > > > >> >> >>
> > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:215:
> > > > > > > > >> undefined
> > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > >> >> >>
> > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:218:
> > > > > > > > >> undefined
> > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > >> >> >>
> > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:224:
> > > > > > > > >> undefined
> > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > >> >> >>
> > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:203:
> > > > > > > > >> undefined
> > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > >> >> >>
> > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:228:
> > > > > > > > >> undefined
> > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > >> >> >>
> > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:259:
> > > > > > > > >> undefined
> > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > >> >> >> dumppb.o: In function `dumppb_':
> > > > > > > > >> >> >>
> > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:56:
> > > > > > > > >> >> >> undefined
> > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > >> >> >>
> > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:57:
> > > > > > > > >> >> >> undefined
> > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > >> >> >> collect2: error: ld returned 1 exit status
> > > > > > > > >> >> >> make[4]: *** [pb2nc] Error 1
> > > > > > > > >> >> >> make[4]: Leaving directory
> > > > > > > > >> >> >> `/home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc'
> > > > > > > > >> >> >> make[3]: *** [install-recursive] Error 1
> > > > > > > > >> >> >> make[3]: Leaving directory
> > > > > > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other'
> > > > > > > > >> >> >> make[2]: *** [install-recursive] Error 1
> > > > > > > > >> >> >> make[2]: Leaving directory
> > > > > > `/home/zmumba/WRF/met-5.0/src/tools'
> > > > > > > > >> >> >> make[1]: *** [install-recursive] Error 1
> > > > > > > > >> >> >> make[1]: Leaving directory
> > > `/home/zmumba/WRF/met-5.0/src'
> > > > > > > > >> >> >> make: *** [install-recursive] Error 1
> > > > > > > > >> >> >>
> > > > > > > > >> >> >>
> > > > > > > > >> >> >
> > > > > > > > >> >> >
> > > > > > > > >> >> > --
> > > > > > > > >> >> > Julie Prestopnik
> > > > > > > > >> >> > National Center for Atmospheric Research
> > > > > > > > >> >> > Research Applications Laboratory
> > > > > > > > >> >> > Phone: 303.497.8399 <%28303%29%20497-8399>
> > > > > > > > >> >> > Email: jpresto at ucar.edu
> > > > > > > > >> >> >
> > > > > > > > >> >> >
> > > > > > > > >> >>
> > > > > > > > >> >>
> > > > > > > > >> >
> > > > > > > > >> >
> > > > > > > > >> > --
> > > > > > > > >> > Julie Prestopnik
> > > > > > > > >> > National Center for Atmospheric Research
> > > > > > > > >> > Research Applications Laboratory
> > > > > > > > >> > Phone: 303.497.8399
> > > > > > > > >> > Email: jpresto at ucar.edu
> > > > > > > > >> >
> > > > > > > > >> >
> > > > > > > > >>
> > > > > > > > >>
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > --
> > > > > > > > > Julie Prestopnik
> > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > Research Applications Laboratory
> > > > > > > > > Phone: 303.497.8399
> > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > --
> > > > > > > Julie Prestopnik
> > > > > > > National Center for Atmospheric Research
> > > > > > > Research Applications Laboratory
> > > > > > > Phone: 303.497.8399
> > > > > > > Email: jpresto at ucar.edu
> > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Julie Prestopnik
> > > > > National Center for Atmospheric Research
> > > > > Research Applications Laboratory
> > > > > Phone: 303.497.8399
> > > > > Email: jpresto at ucar.edu
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> > > --
> > > Julie Prestopnik
> > > National Center for Atmospheric Research
> > > Research Applications Laboratory
> > > Phone: 303.497.8399
> > > Email: jpresto at ucar.edu
> > >
> > >
> >
> >
>
>

------------------------------------------------
Subject: Problem compiling Met-V5
From: Julie Prestopnik
Time: Tue Apr 11 08:29:41 2017

Hi Zilore.  I'm sorry to hear that you are still experiencing
problems.
Could you please send your most recent configure.log and
make_install.log
files?

Thanks!

Julie

On Tue, Apr 11, 2017 at 8:13 AM, Zilore Mumba via RT
<met_help at ucar.edu>
wrote:

>
> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
>
> Julie,
> Thanks very much for all the details you provided.
> However, am still getting the same error, i.e.
> The file "nc_var_info.cc" (i.e. #include on line 24) calls
"nc_utils.h".
> Now the latter file has "#include netcdf" on line 22. It is this
netcdf it
> is saying no such file.
>
> I believe my setup is ok.
> Using the lines you gave me on installing the hdf5 and netcdf
libraries, if
> I use prefix=${MET_LIB_DIR}, I am not able to find where the
libraries are
> installed, though there are no errors indicated. I tried to set
"export
> MET_LIB_DIR=/usr/local/met6" and alternatively "export
MET_LIB_DIR=~/met6"
> after creating the met6 directory in each case.
> But putting prefix=/usr/local/met6, I get both netcdf-c and netcdf-
cxx
> libraries in /usr/local/met6/lib, include files in
/usr/local/met6/include,
> and some executables in /usr/local/met6/bin as well as an hdf5
directory.
> So am wondering if the include file nc_utils.h has the correct entry
on
> line 22.
> Thanks for your time and effort
> Zilore
>
> On Mon, Apr 10, 2017 at 5:40 PM, Julie Prestopnik via RT <
> met_help at ucar.edu>
> wrote:
>
> > Hi Zilore.  In 6.0 we've made a large change from using NetCDF 3
to 4.
> > You'll need to have both NetCDF 4 and HDF5, upon which NetCDF 4 is
built,
> > installed.
> >
> > Please feel free to take a look at the MET User's Guide and the
online
> > tutorial:
> > http://www.dtcenter.org/met/users/docs/users_guide/MET_
> > Users_Guide_v6.0.pdf
> > http://www.dtcenter.org/met/users/support/online_tutorial/
> > METv6.0/tutorial.php?name=compilation&category=req_libs
> >
> > There is an additional environment variable that will need to be
set,
> with
> > the addition of HDF5:
> > Set *$MET_HDF5* to point to the main HDF5 directory.
> >
> > Also, both the NetCDF-C package (netcdf-c-4.4.1.1) and the NetCDF-
CXX
> > package (netcdf-cxx4-4.3.0) are necessary.
> >
> > Here are the commands we've been using to compile these packages
from
> > source.  The following assumes that you're using the GNU compilers
and
> that
> > you've defined MET_LIB_DIR to point to your desired installation
> directory:
> >
> > # Compilers
> >
> > setenv CC `which gcc`
> >
> > setenv CXX `which g++`
> >
> > setenv FC `which gfortran`
> > setenv F77 `which gfortran`
> >
> > # HDF5
> >
> > wget
> > https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.10/
> > hdf5-1.10.0-patch1/src/hdf5-1.10.0-patch1.tar
> >
> > tar -xvzf hdf5-1.10.0-patch1.tar
> >
> > cd hdf5-1.10.0-patch1
> >
> > ./configure --prefix=${MET_LIB_DIR}
> >
> > make install
> >
> > # NetCDF-C
> >
> > wget https://github.com/Unidata/netcdf-c/archive/v4.4.1.1.zip
> >
> > unzip v4.4.1.1.zip
> >
> > cd netcdf-c-4.4.1.1
> >
> > ./configure --prefix=${MET_LIB_DIR} LDFLAGS=-L${MET_LIB_DIR}/lib
> > CPPFLAGS=-I${MET_LIB_DIR}/include
> >
> > make install
> >
> >
> > # NetCDF-CXX
> >
> > wget https://github.com/Unidata/netcdf-cxx4/archive/v4.3.0.tar.gz
> >
> > tar -xvzf v4.3.0.tar.gz
> >
> > cd netcdf-cxx4-4.3.0
> >
> > ./configure --prefix=${MET_LIB_DIR} LDFLAGS=-L${MET_LIB_DIR}/lib
> > CPPFLAGS=-I${MET_LIB_DIR}/include
> > make install
> >
> >
> > I hope this helps!  Please let us know if you need further
assistance.
> >
> > Thanks,
> > Julie
> >
> > On Sat, Apr 8, 2017 at 3:53 PM, Zilore Mumba via RT
<met_help at ucar.edu>
> > wrote:
> >
> > >
> > > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > >
> > > Julie, I hope you are fine, and that I can still reach you. In
March
> 2015
> > > you helped me installing met_v5.0. I have now downloaded v6.0
and I am
> > > having a compilation error I do not seem to figure out.
> > > I believe I have installed all the libraries (and set the
environment
> > > variables correctly: BUFRLIB-v10-2-3, netcdf-4.4.1.1, gsl-2.3,
> > > g2clib-1.6.0, freetype-2.7.1 andcairo-1.14.8.
> > > I also have zlib, jasper and libpng.
> > > My configure exits with exit code 0 which I understand to be ok.
> However
> > my
> > > make install gives an error of not finding netcdf (as you can
see from
> > > make-install.log). I do not understand which netcdf it cannot
find.
> > > I hope you can assist.
> > > Zilore
> > >
> > > On Thu, Mar 5, 2015 at 7:59 PM, Julie Prestopnik via RT <
> > met_help at ucar.edu
> > > >
> > > wrote:
> > >
> > > > Hi Zilore.  Thanks for sending your commands and log files.
> > > >
> > > > Looking in "config.log" for the string "BUFRLIB", it appears
that you
> > did
> > > > not set the environment variable.
> > > >
> > > > The linker error occurs on line 1057 of make_install.log.
Looking at
> > > that
> > > > line, we're telling the linker to look in the following
directories
> for
> > > the
> > > > file named "libbufr.a":
> > > >
> > > > -L/usr/lib/gcc/i686-linux-gnu/4.8
> > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../i386-linux-gnu
> > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../../lib
> > > > -L/lib/i386-linux-gnu
> > > > -L/lib/../lib
> > > > -L/usr/lib/i386-linux-gnu
> > > > -L/usr/lib/../lib
> > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../..
> > > >
> > > > It must be finding libbufr.a in one of those directories,
otherwise
> we
> > > > would get an error about that.  I believe that the version of
> libbufr.a
> > > it
> > > > is finding is not the version that you compiled using the
> > "-DUNDERSCORE"
> > > > option.
> > > >
> > > > I was able to replicate your error by re-compiling a version
of
> BUFRLIB
> > > > *without* -DUNDERSCORE, and then by building MET linking to
that bad
> > > > version.
> > > >
> > > > What you'll need to do is set the MET_BUFRLIB environment
variable as
> > > > indicated on this page:
> > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > METv5.0/compilation/configure.php
> > > >
> > > > Then source your .cshrc or equivalent file, then run your
configure
> > > > command, and then run make install and make test.
> > > >
> > > > Please give that a try.  It should solve the problem you are
> > > encountering.
> > > >
> > > > Thanks,
> > > > Julie
> > > >
> > > > On Wed, Mar 4, 2015 at 5:36 AM, Zilore Mumba via RT <
> met_help at ucar.edu
> > >
> > > > wrote:
> > > >
> > > > >
> > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > > > >
> > > > > *Julie, I installed with the following commands. gcc -c
> -DUNDERSCORE
> > > *.c*
> > > > >    *gfortran -c -DUNDERSCORE -fno-second-underscore *.f *.F*
> > > > >    *ar crv libbufr.a *.o*
> > > > >
> > > > >
> > > > >
> > > > > *Please find attached the config.log and make_install.log *
> > > > >
> > > > >
> > > > > On Tue, Mar 3, 2015 at 7:10 PM, Julie Prestopnik via RT <
> > > > met_help at ucar.edu
> > > > > >
> > > > > wrote:
> > > > >
> > > > > > I'm sorry to hear that you are still experiencing problems
> > installing
> > > > > > METv5.0.
> > > > > >
> > > > > > Specifically regarding BUFRLIB, please compile it using
the
> options
> > > > > listed
> > > > > > on this page:
> > > > > >
> > > > > >
> > > > > >
> > > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > METv5.0/compilation/req_libs.php
> > > > > >
> > > > > > Failing to use the "-DUNDERSCORE -fno-second-underscore"
(for GNU
> > > > > > compilers) options will result in undefined references
when
> > building
> > > > the
> > > > > > pb2nc tool.
> > > > > >
> > > > > > If you'd like to send us the output of make please do the
> > following:
> > > > > >    make clean
> > > > > >    make install >& make_install.log
> > > > > >
> > > > > > And then send us the files "config.log" and
"make_install.log".
> > > > > >
> > > > > > I hope you'll find what you have been able to install
useful.
> > Please
> > > > let
> > > > > > us know if you have any questions.
> > > > > >
> > > > > > Thanks,
> > > > > > Julie
> > > > > >
> > > > > > On Tue, Mar 3, 2015 at 12:26 AM, Zilore Mumba via RT <
> > > > met_help at ucar.edu>
> > > > > > wrote:
> > > > > >
> > > > > > >
> > > > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> >
> > > > > > >
> > > > > > > Julie,
> > > > > > > I did not inform you of the conclusion of my attempt to
install
> > > > > Met-5.1.
> > > > > > > After making many attempts in reinstalling/reconfiguring
> BUFRLIB
> > i
> > > > > still
> > > > > > > get errors relating to "undefined reference to ..." and
> > eventually
> > > I
> > > > > > still
> > > > > > > have 3 executables not installed: pb2nc, modis_regrid,
> > > > plot_mode_field.
> > > > > > > I would like to learn how to use what I have and come
back
> later
> > to
> > > > > pb2nc
> > > > > > > if necessary. I will inform you if I have any other
problems.
> > > > > > >
> > > > > > >
> > > > > > > On Tue, Feb 10, 2015 at 7:12 PM, Julie Prestopnik via RT
<
> > > > > > > met_help at ucar.edu>
> > > > > > > wrote:
> > > > > > >
> > > > > > > > Thank you for rerunning and sending this log.  Perhaps
MET
> > cannot
> > > > > find
> > > > > > > the
> > > > > > > > BUFR library.
> > > > > > > >
> > > > > > > > On the following page are directions for setting the
> > environment
> > > > > > > variables
> > > > > > > > before compiling MET:
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > >
> > > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > METv5.0/compilation/configure.php
> > > > > > > >
> > > > > > > > The rest of the applications built, so it looks like
MET was
> > able
> > > > to
> > > > > > find
> > > > > > > > the other needed libraries.  The directions for the
BUFR
> > > > environment
> > > > > > > > variable on the above page are:
> > > > > > > >
> > > > > > > > "Set *$MET_BUFR* to point to the main BUFR directory,
or set
> > > > > > > *$MET_BUFRLIB*
> > > > > > > > to point to the directory with the BUFR library files.
> Because
> > > MET
> > > > > > > doesn't
> > > > > > > > use any BUFR library include files, you don't need to
specify
> > > > > > > > *$MET_BUFRINC*
> > > > > > > > ."
> > > > > > > >
> > > > > > > > Please try setting either *$MET_BUFR *or *$MET_BUFRLIB
*and
> > then
> > > > > please
> > > > > > > > rerun the configure script and then rerun make
install.  It
> is
> > > > > > important
> > > > > > > to
> > > > > > > > rerun configure before rerunning make install.
> > > > > > > >
> > > > > > > > Please let me know how it goes.
> > > > > > > >
> > > > > > > > Thanks,
> > > > > > > > Julie
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > On Sat, Feb 7, 2015 at 9:36 PM, Zilore Mumba via RT <
> > > > > met_help at ucar.edu
> > > > > > >
> > > > > > > > wrote:
> > > > > > > >
> > > > > > > > >
> > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > Ticket/Display.html?id=70551
> > > >
> > > > > > > > >
> > > > > > > > > Julie,
> > > > > > > > > Attached to this mail, please find the file
> make-install.log.
> > > It
> > > > > does
> > > > > > > > > show 'undefined reference' to some functions. I hope
this
> > means
> > > > > > > > > something to you and that you can help.
> > > > > > > > > Thanks in advance
> > > > > > > > > Zilore
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > On 2/5/15, Julie Prestopnik via RT
<met_help at ucar.edu>
> > wrote:
> > > > > > > > > > Thank you for attaching your log files.  I did not
see
> any
> > > > errors
> > > > > > in
> > > > > > > > your
> > > > > > > > > > make-install.log.  Perhaps you ran make install in
the
> > > > following
> > > > > > way:
> > > > > > > > > >
> > > > > > > > > > make install > make-install.log
> > > > > > > > > >
> > > > > > > > > > This would catch standard out but not standard
error.
> > > > > > > > > >
> > > > > > > > > > Could you please try running in the following way
with
> the
> > &,
> > > > > which
> > > > > > > > will
> > > > > > > > > > also capture standard error?
> > > > > > > > > >
> > > > > > > > > > make install >& make-install.log
> > > > > > > > > >
> > > > > > > > > > And, then please send me the output of that log.
Thank
> > you!
> > > > > > > > > >
> > > > > > > > > > Julie
> > > > > > > > > >
> > > > > > > > > > On Tue, Feb 3, 2015 at 2:08 PM, Zilore Mumba via
RT <
> > > > > > > met_help at ucar.edu
> > > > > > > > >
> > > > > > > > > > wrote:
> > > > > > > > > >
> > > > > > > > > >>
> > > > > > > > > >> <URL: https://rt.rap.ucar.edu/rt/Tic
> > > ket/Display.html?id=70551
> > > > >
> > > > > > > > > >>
> > > > > > > > > >> Julie,
> > > > > > > > > >> Thank you very much for your assistance. I failed
to
> > install
> > > > > Cairo
> > > > > > > and
> > > > > > > > > >> freetype because of the dependencies. I will try
again
> > with
> > > > the
> > > > > > > links
> > > > > > > > > >> you sent me.
> > > > > > > > > >> Please find attached my config.log and make-
install.log.
> > > > > > > > > >>
> > > > > > > > > >>
> > > > > > > > > >> On 2/2/15, Julie Prestopnik via RT
<met_help at ucar.edu>
> > > wrote:
> > > > > > > > > >> > I'm so glad you were able to get MET installed
and
> that
> > > you
> > > > > > worked
> > > > > > > > out
> > > > > > > > > >> the
> > > > > > > > > >> > issue with the NetCDF environment variables.
> > > > > > > > > >> >
> > > > > > > > > >> > You mentioned that three executables did not
build.  I
> > > would
> > > > > > like
> > > > > > > to
> > > > > > > > > >> > try
> > > > > > > > > >> to
> > > > > > > > > >> > help with those.  The modis_regrid tool has
library
> > > > > > dependencies -
> > > > > > > > it
> > > > > > > > > >> > requires the HDF4 and HDF-EOS2 libraries.  The
> > > > plot_mode_field
> > > > > > > tool
> > > > > > > > > >> > also
> > > > > > > > > >> > has library dependencies - it requires the
Cairo and
> > > > FreeType
> > > > > > > > > >> > libraries.
> > > > > > > > > >> >
> > > > > > > > > >> > You can find information on compiling each of
those
> > > library
> > > > > > > > > >> > dependencies
> > > > > > > > > >> > here:
> > > > > > > > > >> >
> > > > > > > > > >>
> > > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > >
> > > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > METv5.0/compilation/req_libs.php
> > > > > > > > > >> >
> > > > > > > > > >> > You can find information on setting the up
necessary
> > > > > environment
> > > > > > > > > >> variables
> > > > > > > > > >> > for those library locations here:
> > > > > > > > > >> >
> > > > > > > > > >>
> > > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > >
> > > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > METv5.0/compilation/configure.php
> > > > > > > > > >> >
> > > > > > > > > >> > And with pb2nc, I'm not exactly sure what is
going on
> > > there.
> > > > > I
> > > > > > > > would
> > > > > > > > > >> > be
> > > > > > > > > >> > happy to take a look at your configure log and
make
> > > install
> > > > > log
> > > > > > > > files
> > > > > > > > > >> > to
> > > > > > > > > >> > see if I can figure out why you didn't get the
> > executable.
> > > > > > > > > >> >
> > > > > > > > > >> > I hope this helps.
> > > > > > > > > >> >
> > > > > > > > > >> > Thanks,
> > > > > > > > > >> > Julie
> > > > > > > > > >> >
> > > > > > > > > >> >
> > > > > > > > > >> >
> > > > > > > > > >> > On Sat, Jan 31, 2015 at 5:31 PM, Zilore Mumba
via RT
> > > > > > > > > >> > <met_help at ucar.edu>
> > > > > > > > > >> > wrote:
> > > > > > > > > >> >
> > > > > > > > > >> >>
> > > > > > > > > >> >> <URL:
> > > > > https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > > > > >
> > > > > > > > > >> >>
> > > > > > > > > >> >> Julg
> > > > > > > > > >> >> Thank you very much for your help. With the
advice
> you
> > > gave
> > > > > > me, I
> > > > > > > > was
> > > > > > > > > >> >> able to install MET using gcc and gfortran. I
also
> had
> > to
> > > > to
> > > > > > > point
> > > > > > > > > >> >> $MET_NETCDFLIB and, $MET_NETCDFINC to
> > > > > > /usr/local/netcdf-4.1.3/lib
> > > > > > > > and
> > > > > > > > > >> >> include. Previously I pointed only to
> > > > > /usr/local/netcdf-4.1.3.
> > > > > > > > > >> >> I have three executables not included though,
these
> are
> > > > > > > > modis_regrid,
> > > > > > > > > >> >> plot_mode_field and pb2nc.
> > > > > > > > > >> >> Thank you very much.
> > > > > > > > > >> >>
> > > > > > > > > >> >>
> > > > > > > > > >> >> On 1/29/15, Julie Prestopnik via RT <
> met_help at ucar.edu
> > >
> > > > > wrote:
> > > > > > > > > >> >> > I am sorry to hear that you are having
problems
> > > > installing
> > > > > > > > METv5.0.
> > > > > > > > > >> >> > I
> > > > > > > > > >> >> > believe this error may have to do with how
you
> > compiled
> > > > > > > BUFRLIB.
> > > > > > > > > >> >> > Please
> > > > > > > > > >> >> > take a look at the sample commands for
compiling
> > > BURFLIB
> > > > on
> > > > > > > this
> > > > > > > > > >> >> > page:
> > > > > > > > > >> >> >
> > > > > > > > > >> >>
> > > > > > > > > >>
> > > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > >
> > > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > METv5.0/compilation/req_libs.php
> > > > > > > > > >> >> >
> > > > > > > > > >> >> > I believe that the *-fno-second-underscore*
(GNU
> > > > compilers)
> > > > > > or
> > > > > > > > > >> >> > *-Mnosecond_underscore* (PGI compilers) will
fix
> the
> > > > error
> > > > > > > you're
> > > > > > > > > >> >> > seeing.
> > > > > > > > > >> >> >
> > > > > > > > > >> >> > I hope that helps.  If it doesn't, please
send me
> the
> > > > files
> > > > > > > > > >> >> "make_met.log"
> > > > > > > > > >> >> > and "config.log".
> > > > > > > > > >> >> >
> > > > > > > > > >> >> > Thanks,
> > > > > > > > > >> >> > Julie
> > > > > > > > > >> >> >
> > > > > > > > > >> >> >
> > > > > > > > > >> >> > On Thu, Jan 29, 2015 at 3:48 AM, Zilore
Mumba via
> RT
> > > > > > > > > >> >> > <met_help at ucar.edu>
> > > > > > > > > >> >> > wrote:
> > > > > > > > > >> >> >
> > > > > > > > > >> >> >>
> > > > > > > > > >> >> >> Thu Jan 29 03:48:08 2015: Request 70551 was
acted
> > > upon.
> > > > > > > > > >> >> >> Transaction: Ticket created by
zmumba at gmail.com
> > > > > > > > > >> >> >>        Queue: met_help
> > > > > > > > > >> >> >>      Subject: Problem compiling Met-V5
> > > > > > > > > >> >> >>        Owner: Nobody
> > > > > > > > > >> >> >>   Requestors: zmumba at gmail.com
> > > > > > > > > >> >> >>       Status: new
> > > > > > > > > >> >> >>  Ticket <URL:
> > > > > > > > > >>
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > > > > > > > >> >> >> >
> > > > > > > > > >> >> >>
> > > > > > > > > >> >> >>
> > > > > > > > > >> >> >> I have installed BUFRLIB, GSL and G2CLIB
> > > > > > > > > >> >> >> But then how do I handle the errors below
in
> > > installing
> > > > > > > MET_V5?
> > > > > > > > > >> >> >>
> > > > > > > > > >> >> >>
> > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/numpbmsg.f:23:
> > > > > > > > > >> >> >> undefined
> > > > > > > > > >> >> >> reference to `ufbtab_'
> > > > > > > > > >> >> >> openpb.o: In function `openpb_':
> > > > > > > > > >> >> >>
> > > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:21:
> > > > > > > > > >> >> >> undefined
> > > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > > >> >> >>
> > > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/openpb.f:22:
> > > > > > > > > >> >> >> undefined
> > > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > > >> >> >> closepb.o: In function `closepb_':
> > > > > > > > > >> >> >>
> > > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/closepb.f:19:
> > > > > > > > > >> undefined
> > > > > > > > > >> >> >> reference to `closbf_'
> > > > > > > > > >> >> >> readpb.o: In function `readpb_':
> > > > > > > > > >> >> >>
> > > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:82:
> > > > > > > > > >> >> >> undefined
> > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > >> >> >>
> > > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:90:
> > > > > > > > > >> >> >> undefined
> > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > >> >> >>
> > > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/readpb.f:94:
> > > > > > > > > >> >> >> undefined
> > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > >> >> >> dumppb.o: In function `readpbdump_':
> > > > > > > > > >> >> >>
> > > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:215:
> > > > > > > > > >> undefined
> > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > >> >> >>
> > > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:218:
> > > > > > > > > >> undefined
> > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > >> >> >>
> > > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:224:
> > > > > > > > > >> undefined
> > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > >> >> >>
> > > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:203:
> > > > > > > > > >> undefined
> > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > >> >> >>
> > > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:228:
> > > > > > > > > >> undefined
> > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > >> >> >>
> > > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:259:
> > > > > > > > > >> undefined
> > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > >> >> >> dumppb.o: In function `dumppb_':
> > > > > > > > > >> >> >>
> > > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:56:
> > > > > > > > > >> >> >> undefined
> > > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > > >> >> >>
> > > > > /home/zmumba/WRF/met-5.0/src/tools/other/pb2nc/dumppb.f:57:
> > > > > > > > > >> >> >> undefined
> > > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > > >> >> >> collect2: error: ld returned 1 exit status
> > > > > > > > > >> >> >> make[4]: *** [pb2nc] Error 1
> > > > > > > > > >> >> >> make[4]: Leaving directory
> > > > > > > > > >> >> >> `/home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc'
> > > > > > > > > >> >> >> make[3]: *** [install-recursive] Error 1
> > > > > > > > > >> >> >> make[3]: Leaving directory
> > > > > > > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/tools/other'
> > > > > > > > > >> >> >> make[2]: *** [install-recursive] Error 1
> > > > > > > > > >> >> >> make[2]: Leaving directory
> > > > > > > `/home/zmumba/WRF/met-5.0/src/tools'
> > > > > > > > > >> >> >> make[1]: *** [install-recursive] Error 1
> > > > > > > > > >> >> >> make[1]: Leaving directory
> > > > `/home/zmumba/WRF/met-5.0/src'
> > > > > > > > > >> >> >> make: *** [install-recursive] Error 1
> > > > > > > > > >> >> >>
> > > > > > > > > >> >> >>
> > > > > > > > > >> >> >
> > > > > > > > > >> >> >
> > > > > > > > > >> >> > --
> > > > > > > > > >> >> > Julie Prestopnik
> > > > > > > > > >> >> > National Center for Atmospheric Research
> > > > > > > > > >> >> > Research Applications Laboratory
> > > > > > > > > >> >> > Phone: 303.497.8399 <%28303%29%20497-8399>
> > > > > > > > > >> >> > Email: jpresto at ucar.edu
> > > > > > > > > >> >> >
> > > > > > > > > >> >> >
> > > > > > > > > >> >>
> > > > > > > > > >> >>
> > > > > > > > > >> >
> > > > > > > > > >> >
> > > > > > > > > >> > --
> > > > > > > > > >> > Julie Prestopnik
> > > > > > > > > >> > National Center for Atmospheric Research
> > > > > > > > > >> > Research Applications Laboratory
> > > > > > > > > >> > Phone: 303.497.8399
> > > > > > > > > >> > Email: jpresto at ucar.edu
> > > > > > > > > >> >
> > > > > > > > > >> >
> > > > > > > > > >>
> > > > > > > > > >>
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > --
> > > > > > > > > > Julie Prestopnik
> > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > --
> > > > > > > > Julie Prestopnik
> > > > > > > > National Center for Atmospheric Research
> > > > > > > > Research Applications Laboratory
> > > > > > > > Phone: 303.497.8399
> > > > > > > > Email: jpresto at ucar.edu
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > > > --
> > > > > > Julie Prestopnik
> > > > > > National Center for Atmospheric Research
> > > > > > Research Applications Laboratory
> > > > > > Phone: 303.497.8399
> > > > > > Email: jpresto at ucar.edu
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > >
> > > >
> > > > --
> > > > Julie Prestopnik
> > > > National Center for Atmospheric Research
> > > > Research Applications Laboratory
> > > > Phone: 303.497.8399
> > > > Email: jpresto at ucar.edu
> > > >
> > > >
> > >
> > >
> >
> >
>
>

------------------------------------------------
Subject: Problem compiling Met-V5
From: Zilore Mumba
Time: Tue Apr 11 13:22:34 2017

Julie,
Please find attached to this mail, my config.log and make-install.log.

On Tue, Apr 11, 2017 at 4:29 PM, Julie Prestopnik via RT
<met_help at ucar.edu>
wrote:

> Hi Zilore.  I'm sorry to hear that you are still experiencing
problems.
> Could you please send your most recent configure.log and
make_install.log
> files?
>
> Thanks!
>
> Julie
>
> On Tue, Apr 11, 2017 at 8:13 AM, Zilore Mumba via RT
<met_help at ucar.edu>
> wrote:
>
> >
> > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> >
> > Julie,
> > Thanks very much for all the details you provided.
> > However, am still getting the same error, i.e.
> > The file "nc_var_info.cc" (i.e. #include on line 24) calls
"nc_utils.h".
> > Now the latter file has "#include netcdf" on line 22. It is this
netcdf
> it
> > is saying no such file.
> >
> > I believe my setup is ok.
> > Using the lines you gave me on installing the hdf5 and netcdf
libraries,
> if
> > I use prefix=${MET_LIB_DIR}, I am not able to find where the
libraries
> are
> > installed, though there are no errors indicated. I tried to set
"export
> > MET_LIB_DIR=/usr/local/met6" and alternatively "export
> MET_LIB_DIR=~/met6"
> > after creating the met6 directory in each case.
> > But putting prefix=/usr/local/met6, I get both netcdf-c and
netcdf-cxx
> > libraries in /usr/local/met6/lib, include files in
> /usr/local/met6/include,
> > and some executables in /usr/local/met6/bin as well as an hdf5
directory.
> > So am wondering if the include file nc_utils.h has the correct
entry on
> > line 22.
> > Thanks for your time and effort
> > Zilore
> >
> > On Mon, Apr 10, 2017 at 5:40 PM, Julie Prestopnik via RT <
> > met_help at ucar.edu>
> > wrote:
> >
> > > Hi Zilore.  In 6.0 we've made a large change from using NetCDF 3
to 4.
> > > You'll need to have both NetCDF 4 and HDF5, upon which NetCDF 4
is
> built,
> > > installed.
> > >
> > > Please feel free to take a look at the MET User's Guide and the
online
> > > tutorial:
> > > http://www.dtcenter.org/met/users/docs/users_guide/MET_
> > > Users_Guide_v6.0.pdf
> > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > METv6.0/tutorial.php?name=compilation&category=req_libs
> > >
> > > There is an additional environment variable that will need to be
set,
> > with
> > > the addition of HDF5:
> > > Set *$MET_HDF5* to point to the main HDF5 directory.
> > >
> > > Also, both the NetCDF-C package (netcdf-c-4.4.1.1) and the
NetCDF-CXX
> > > package (netcdf-cxx4-4.3.0) are necessary.
> > >
> > > Here are the commands we've been using to compile these packages
from
> > > source.  The following assumes that you're using the GNU
compilers and
> > that
> > > you've defined MET_LIB_DIR to point to your desired installation
> > directory:
> > >
> > > # Compilers
> > >
> > > setenv CC `which gcc`
> > >
> > > setenv CXX `which g++`
> > >
> > > setenv FC `which gfortran`
> > > setenv F77 `which gfortran`
> > >
> > > # HDF5
> > >
> > > wget
> > > https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.10/
> > > hdf5-1.10.0-patch1/src/hdf5-1.10.0-patch1.tar
> > >
> > > tar -xvzf hdf5-1.10.0-patch1.tar
> > >
> > > cd hdf5-1.10.0-patch1
> > >
> > > ./configure --prefix=${MET_LIB_DIR}
> > >
> > > make install
> > >
> > > # NetCDF-C
> > >
> > > wget https://github.com/Unidata/netcdf-c/archive/v4.4.1.1.zip
> > >
> > > unzip v4.4.1.1.zip
> > >
> > > cd netcdf-c-4.4.1.1
> > >
> > > ./configure --prefix=${MET_LIB_DIR} LDFLAGS=-L${MET_LIB_DIR}/lib
> > > CPPFLAGS=-I${MET_LIB_DIR}/include
> > >
> > > make install
> > >
> > >
> > > # NetCDF-CXX
> > >
> > > wget https://github.com/Unidata/netcdf-
cxx4/archive/v4.3.0.tar.gz
> > >
> > > tar -xvzf v4.3.0.tar.gz
> > >
> > > cd netcdf-cxx4-4.3.0
> > >
> > > ./configure --prefix=${MET_LIB_DIR} LDFLAGS=-L${MET_LIB_DIR}/lib
> > > CPPFLAGS=-I${MET_LIB_DIR}/include
> > > make install
> > >
> > >
> > > I hope this helps!  Please let us know if you need further
assistance.
> > >
> > > Thanks,
> > > Julie
> > >
> > > On Sat, Apr 8, 2017 at 3:53 PM, Zilore Mumba via RT
<met_help at ucar.edu
> >
> > > wrote:
> > >
> > > >
> > > > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
>
> > > >
> > > > Julie, I hope you are fine, and that I can still reach you. In
March
> > 2015
> > > > you helped me installing met_v5.0. I have now downloaded v6.0
and I
> am
> > > > having a compilation error I do not seem to figure out.
> > > > I believe I have installed all the libraries (and set the
environment
> > > > variables correctly: BUFRLIB-v10-2-3, netcdf-4.4.1.1, gsl-2.3,
> > > > g2clib-1.6.0, freetype-2.7.1 andcairo-1.14.8.
> > > > I also have zlib, jasper and libpng.
> > > > My configure exits with exit code 0 which I understand to be
ok.
> > However
> > > my
> > > > make install gives an error of not finding netcdf (as you can
see
> from
> > > > make-install.log). I do not understand which netcdf it cannot
find.
> > > > I hope you can assist.
> > > > Zilore
> > > >
> > > > On Thu, Mar 5, 2015 at 7:59 PM, Julie Prestopnik via RT <
> > > met_help at ucar.edu
> > > > >
> > > > wrote:
> > > >
> > > > > Hi Zilore.  Thanks for sending your commands and log files.
> > > > >
> > > > > Looking in "config.log" for the string "BUFRLIB", it appears
that
> you
> > > did
> > > > > not set the environment variable.
> > > > >
> > > > > The linker error occurs on line 1057 of make_install.log.
Looking
> at
> > > > that
> > > > > line, we're telling the linker to look in the following
directories
> > for
> > > > the
> > > > > file named "libbufr.a":
> > > > >
> > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8
> > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../i386-linux-gnu
> > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../../lib
> > > > > -L/lib/i386-linux-gnu
> > > > > -L/lib/../lib
> > > > > -L/usr/lib/i386-linux-gnu
> > > > > -L/usr/lib/../lib
> > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../..
> > > > >
> > > > > It must be finding libbufr.a in one of those directories,
otherwise
> > we
> > > > > would get an error about that.  I believe that the version
of
> > libbufr.a
> > > > it
> > > > > is finding is not the version that you compiled using the
> > > "-DUNDERSCORE"
> > > > > option.
> > > > >
> > > > > I was able to replicate your error by re-compiling a version
of
> > BUFRLIB
> > > > > *without* -DUNDERSCORE, and then by building MET linking to
that
> bad
> > > > > version.
> > > > >
> > > > > What you'll need to do is set the MET_BUFRLIB environment
variable
> as
> > > > > indicated on this page:
> > > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > METv5.0/compilation/configure.php
> > > > >
> > > > > Then source your .cshrc or equivalent file, then run your
configure
> > > > > command, and then run make install and make test.
> > > > >
> > > > > Please give that a try.  It should solve the problem you are
> > > > encountering.
> > > > >
> > > > > Thanks,
> > > > > Julie
> > > > >
> > > > > On Wed, Mar 4, 2015 at 5:36 AM, Zilore Mumba via RT <
> > met_help at ucar.edu
> > > >
> > > > > wrote:
> > > > >
> > > > > >
> > > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > > > > >
> > > > > > *Julie, I installed with the following commands. gcc -c
> > -DUNDERSCORE
> > > > *.c*
> > > > > >    *gfortran -c -DUNDERSCORE -fno-second-underscore *.f
*.F*
> > > > > >    *ar crv libbufr.a *.o*
> > > > > >
> > > > > >
> > > > > >
> > > > > > *Please find attached the config.log and make_install.log
*
> > > > > >
> > > > > >
> > > > > > On Tue, Mar 3, 2015 at 7:10 PM, Julie Prestopnik via RT <
> > > > > met_help at ucar.edu
> > > > > > >
> > > > > > wrote:
> > > > > >
> > > > > > > I'm sorry to hear that you are still experiencing
problems
> > > installing
> > > > > > > METv5.0.
> > > > > > >
> > > > > > > Specifically regarding BUFRLIB, please compile it using
the
> > options
> > > > > > listed
> > > > > > > on this page:
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > METv5.0/compilation/req_libs.php
> > > > > > >
> > > > > > > Failing to use the "-DUNDERSCORE -fno-second-underscore"
(for
> GNU
> > > > > > > compilers) options will result in undefined references
when
> > > building
> > > > > the
> > > > > > > pb2nc tool.
> > > > > > >
> > > > > > > If you'd like to send us the output of make please do
the
> > > following:
> > > > > > >    make clean
> > > > > > >    make install >& make_install.log
> > > > > > >
> > > > > > > And then send us the files "config.log" and
"make_install.log".
> > > > > > >
> > > > > > > I hope you'll find what you have been able to install
useful.
> > > Please
> > > > > let
> > > > > > > us know if you have any questions.
> > > > > > >
> > > > > > > Thanks,
> > > > > > > Julie
> > > > > > >
> > > > > > > On Tue, Mar 3, 2015 at 12:26 AM, Zilore Mumba via RT <
> > > > > met_help at ucar.edu>
> > > > > > > wrote:
> > > > > > >
> > > > > > > >
> > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> Ticket/Display.html?id=70551
> > >
> > > > > > > >
> > > > > > > > Julie,
> > > > > > > > I did not inform you of the conclusion of my attempt
to
> install
> > > > > > Met-5.1.
> > > > > > > > After making many attempts in
reinstalling/reconfiguring
> > BUFRLIB
> > > i
> > > > > > still
> > > > > > > > get errors relating to "undefined reference to ..."
and
> > > eventually
> > > > I
> > > > > > > still
> > > > > > > > have 3 executables not installed: pb2nc, modis_regrid,
> > > > > plot_mode_field.
> > > > > > > > I would like to learn how to use what I have and come
back
> > later
> > > to
> > > > > > pb2nc
> > > > > > > > if necessary. I will inform you if I have any other
problems.
> > > > > > > >
> > > > > > > >
> > > > > > > > On Tue, Feb 10, 2015 at 7:12 PM, Julie Prestopnik via
RT <
> > > > > > > > met_help at ucar.edu>
> > > > > > > > wrote:
> > > > > > > >
> > > > > > > > > Thank you for rerunning and sending this log.
Perhaps MET
> > > cannot
> > > > > > find
> > > > > > > > the
> > > > > > > > > BUFR library.
> > > > > > > > >
> > > > > > > > > On the following page are directions for setting the
> > > environment
> > > > > > > > variables
> > > > > > > > > before compiling MET:
> > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > METv5.0/compilation/configure.php
> > > > > > > > >
> > > > > > > > > The rest of the applications built, so it looks like
MET
> was
> > > able
> > > > > to
> > > > > > > find
> > > > > > > > > the other needed libraries.  The directions for the
BUFR
> > > > > environment
> > > > > > > > > variable on the above page are:
> > > > > > > > >
> > > > > > > > > "Set *$MET_BUFR* to point to the main BUFR
directory, or
> set
> > > > > > > > *$MET_BUFRLIB*
> > > > > > > > > to point to the directory with the BUFR library
files.
> > Because
> > > > MET
> > > > > > > > doesn't
> > > > > > > > > use any BUFR library include files, you don't need
to
> specify
> > > > > > > > > *$MET_BUFRINC*
> > > > > > > > > ."
> > > > > > > > >
> > > > > > > > > Please try setting either *$MET_BUFR *or
*$MET_BUFRLIB *and
> > > then
> > > > > > please
> > > > > > > > > rerun the configure script and then rerun make
install.  It
> > is
> > > > > > > important
> > > > > > > > to
> > > > > > > > > rerun configure before rerunning make install.
> > > > > > > > >
> > > > > > > > > Please let me know how it goes.
> > > > > > > > >
> > > > > > > > > Thanks,
> > > > > > > > > Julie
> > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > On Sat, Feb 7, 2015 at 9:36 PM, Zilore Mumba via RT
<
> > > > > > met_help at ucar.edu
> > > > > > > >
> > > > > > > > > wrote:
> > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > Ticket/Display.html?id=70551
> > > > >
> > > > > > > > > >
> > > > > > > > > > Julie,
> > > > > > > > > > Attached to this mail, please find the file
> > make-install.log.
> > > > It
> > > > > > does
> > > > > > > > > > show 'undefined reference' to some functions. I
hope this
> > > means
> > > > > > > > > > something to you and that you can help.
> > > > > > > > > > Thanks in advance
> > > > > > > > > > Zilore
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > On 2/5/15, Julie Prestopnik via RT
<met_help at ucar.edu>
> > > wrote:
> > > > > > > > > > > Thank you for attaching your log files.  I did
not see
> > any
> > > > > errors
> > > > > > > in
> > > > > > > > > your
> > > > > > > > > > > make-install.log.  Perhaps you ran make install
in the
> > > > > following
> > > > > > > way:
> > > > > > > > > > >
> > > > > > > > > > > make install > make-install.log
> > > > > > > > > > >
> > > > > > > > > > > This would catch standard out but not standard
error.
> > > > > > > > > > >
> > > > > > > > > > > Could you please try running in the following
way with
> > the
> > > &,
> > > > > > which
> > > > > > > > > will
> > > > > > > > > > > also capture standard error?
> > > > > > > > > > >
> > > > > > > > > > > make install >& make-install.log
> > > > > > > > > > >
> > > > > > > > > > > And, then please send me the output of that log.
Thank
> > > you!
> > > > > > > > > > >
> > > > > > > > > > > Julie
> > > > > > > > > > >
> > > > > > > > > > > On Tue, Feb 3, 2015 at 2:08 PM, Zilore Mumba via
RT <
> > > > > > > > met_help at ucar.edu
> > > > > > > > > >
> > > > > > > > > > > wrote:
> > > > > > > > > > >
> > > > > > > > > > >>
> > > > > > > > > > >> <URL: https://rt.rap.ucar.edu/rt/Tic
> > > > ket/Display.html?id=70551
> > > > > >
> > > > > > > > > > >>
> > > > > > > > > > >> Julie,
> > > > > > > > > > >> Thank you very much for your assistance. I
failed to
> > > install
> > > > > > Cairo
> > > > > > > > and
> > > > > > > > > > >> freetype because of the dependencies. I will
try again
> > > with
> > > > > the
> > > > > > > > links
> > > > > > > > > > >> you sent me.
> > > > > > > > > > >> Please find attached my config.log and
> make-install.log.
> > > > > > > > > > >>
> > > > > > > > > > >>
> > > > > > > > > > >> On 2/2/15, Julie Prestopnik via RT
<met_help at ucar.edu
> >
> > > > wrote:
> > > > > > > > > > >> > I'm so glad you were able to get MET
installed and
> > that
> > > > you
> > > > > > > worked
> > > > > > > > > out
> > > > > > > > > > >> the
> > > > > > > > > > >> > issue with the NetCDF environment variables.
> > > > > > > > > > >> >
> > > > > > > > > > >> > You mentioned that three executables did not
> build.  I
> > > > would
> > > > > > > like
> > > > > > > > to
> > > > > > > > > > >> > try
> > > > > > > > > > >> to
> > > > > > > > > > >> > help with those.  The modis_regrid tool has
library
> > > > > > > dependencies -
> > > > > > > > > it
> > > > > > > > > > >> > requires the HDF4 and HDF-EOS2 libraries.
The
> > > > > plot_mode_field
> > > > > > > > tool
> > > > > > > > > > >> > also
> > > > > > > > > > >> > has library dependencies - it requires the
Cairo and
> > > > > FreeType
> > > > > > > > > > >> > libraries.
> > > > > > > > > > >> >
> > > > > > > > > > >> > You can find information on compiling each of
those
> > > > library
> > > > > > > > > > >> > dependencies
> > > > > > > > > > >> > here:
> > > > > > > > > > >> >
> > > > > > > > > > >>
> > > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > >> >
> > > > > > > > > > >> > You can find information on setting the up
necessary
> > > > > > environment
> > > > > > > > > > >> variables
> > > > > > > > > > >> > for those library locations here:
> > > > > > > > > > >> >
> > > > > > > > > > >>
> > > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > METv5.0/compilation/configure.php
> > > > > > > > > > >> >
> > > > > > > > > > >> > And with pb2nc, I'm not exactly sure what is
going
> on
> > > > there.
> > > > > > I
> > > > > > > > > would
> > > > > > > > > > >> > be
> > > > > > > > > > >> > happy to take a look at your configure log
and make
> > > > install
> > > > > > log
> > > > > > > > > files
> > > > > > > > > > >> > to
> > > > > > > > > > >> > see if I can figure out why you didn't get
the
> > > executable.
> > > > > > > > > > >> >
> > > > > > > > > > >> > I hope this helps.
> > > > > > > > > > >> >
> > > > > > > > > > >> > Thanks,
> > > > > > > > > > >> > Julie
> > > > > > > > > > >> >
> > > > > > > > > > >> >
> > > > > > > > > > >> >
> > > > > > > > > > >> > On Sat, Jan 31, 2015 at 5:31 PM, Zilore Mumba
via RT
> > > > > > > > > > >> > <met_help at ucar.edu>
> > > > > > > > > > >> > wrote:
> > > > > > > > > > >> >
> > > > > > > > > > >> >>
> > > > > > > > > > >> >> <URL:
> > > > > > https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > > > > > >
> > > > > > > > > > >> >>
> > > > > > > > > > >> >> Julg
> > > > > > > > > > >> >> Thank you very much for your help. With the
advice
> > you
> > > > gave
> > > > > > > me, I
> > > > > > > > > was
> > > > > > > > > > >> >> able to install MET using gcc and gfortran.
I also
> > had
> > > to
> > > > > to
> > > > > > > > point
> > > > > > > > > > >> >> $MET_NETCDFLIB and, $MET_NETCDFINC to
> > > > > > > /usr/local/netcdf-4.1.3/lib
> > > > > > > > > and
> > > > > > > > > > >> >> include. Previously I pointed only to
> > > > > > /usr/local/netcdf-4.1.3.
> > > > > > > > > > >> >> I have three executables not included
though, these
> > are
> > > > > > > > > modis_regrid,
> > > > > > > > > > >> >> plot_mode_field and pb2nc.
> > > > > > > > > > >> >> Thank you very much.
> > > > > > > > > > >> >>
> > > > > > > > > > >> >>
> > > > > > > > > > >> >> On 1/29/15, Julie Prestopnik via RT <
> > met_help at ucar.edu
> > > >
> > > > > > wrote:
> > > > > > > > > > >> >> > I am sorry to hear that you are having
problems
> > > > > installing
> > > > > > > > > METv5.0.
> > > > > > > > > > >> >> > I
> > > > > > > > > > >> >> > believe this error may have to do with how
you
> > > compiled
> > > > > > > > BUFRLIB.
> > > > > > > > > > >> >> > Please
> > > > > > > > > > >> >> > take a look at the sample commands for
compiling
> > > > BURFLIB
> > > > > on
> > > > > > > > this
> > > > > > > > > > >> >> > page:
> > > > > > > > > > >> >> >
> > > > > > > > > > >> >>
> > > > > > > > > > >>
> > > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > >> >> >
> > > > > > > > > > >> >> > I believe that the *-fno-second-
underscore* (GNU
> > > > > compilers)
> > > > > > > or
> > > > > > > > > > >> >> > *-Mnosecond_underscore* (PGI compilers)
will fix
> > the
> > > > > error
> > > > > > > > you're
> > > > > > > > > > >> >> > seeing.
> > > > > > > > > > >> >> >
> > > > > > > > > > >> >> > I hope that helps.  If it doesn't, please
send me
> > the
> > > > > files
> > > > > > > > > > >> >> "make_met.log"
> > > > > > > > > > >> >> > and "config.log".
> > > > > > > > > > >> >> >
> > > > > > > > > > >> >> > Thanks,
> > > > > > > > > > >> >> > Julie
> > > > > > > > > > >> >> >
> > > > > > > > > > >> >> >
> > > > > > > > > > >> >> > On Thu, Jan 29, 2015 at 3:48 AM, Zilore
Mumba via
> > RT
> > > > > > > > > > >> >> > <met_help at ucar.edu>
> > > > > > > > > > >> >> > wrote:
> > > > > > > > > > >> >> >
> > > > > > > > > > >> >> >>
> > > > > > > > > > >> >> >> Thu Jan 29 03:48:08 2015: Request 70551
was
> acted
> > > > upon.
> > > > > > > > > > >> >> >> Transaction: Ticket created by
zmumba at gmail.com
> > > > > > > > > > >> >> >>        Queue: met_help
> > > > > > > > > > >> >> >>      Subject: Problem compiling Met-V5
> > > > > > > > > > >> >> >>        Owner: Nobody
> > > > > > > > > > >> >> >>   Requestors: zmumba at gmail.com
> > > > > > > > > > >> >> >>       Status: new
> > > > > > > > > > >> >> >>  Ticket <URL:
> > > > > > > > > > >> https://rt.rap.ucar.edu/rt/
> Ticket/Display.html?id=70551
> > > > > > > > > > >> >> >> >
> > > > > > > > > > >> >> >>
> > > > > > > > > > >> >> >>
> > > > > > > > > > >> >> >> I have installed BUFRLIB, GSL and G2CLIB
> > > > > > > > > > >> >> >> But then how do I handle the errors below
in
> > > > installing
> > > > > > > > MET_V5?
> > > > > > > > > > >> >> >>
> > > > > > > > > > >> >> >>
> > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/numpbmsg.f:23:
> > > > > > > > > > >> >> >> undefined
> > > > > > > > > > >> >> >> reference to `ufbtab_'
> > > > > > > > > > >> >> >> openpb.o: In function `openpb_':
> > > > > > > > > > >> >> >>
> > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/openpb.f:21:
> > > > > > > > > > >> >> >> undefined
> > > > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > > > >> >> >>
> > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/openpb.f:22:
> > > > > > > > > > >> >> >> undefined
> > > > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > > > >> >> >> closepb.o: In function `closepb_':
> > > > > > > > > > >> >> >>
> > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/closepb.f:19:
> > > > > > > > > > >> undefined
> > > > > > > > > > >> >> >> reference to `closbf_'
> > > > > > > > > > >> >> >> readpb.o: In function `readpb_':
> > > > > > > > > > >> >> >>
> > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/readpb.f:82:
> > > > > > > > > > >> >> >> undefined
> > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > >> >> >>
> > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/readpb.f:90:
> > > > > > > > > > >> >> >> undefined
> > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > >> >> >>
> > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/readpb.f:94:
> > > > > > > > > > >> >> >> undefined
> > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > >> >> >> dumppb.o: In function `readpbdump_':
> > > > > > > > > > >> >> >>
> > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:215:
> > > > > > > > > > >> undefined
> > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > >> >> >>
> > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:218:
> > > > > > > > > > >> undefined
> > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > >> >> >>
> > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:224:
> > > > > > > > > > >> undefined
> > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > >> >> >>
> > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:203:
> > > > > > > > > > >> undefined
> > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > >> >> >>
> > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:228:
> > > > > > > > > > >> undefined
> > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > >> >> >>
> > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:259:
> > > > > > > > > > >> undefined
> > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > >> >> >> dumppb.o: In function `dumppb_':
> > > > > > > > > > >> >> >>
> > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:56:
> > > > > > > > > > >> >> >> undefined
> > > > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > > > >> >> >>
> > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:57:
> > > > > > > > > > >> >> >> undefined
> > > > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > > > >> >> >> collect2: error: ld returned 1 exit
status
> > > > > > > > > > >> >> >> make[4]: *** [pb2nc] Error 1
> > > > > > > > > > >> >> >> make[4]: Leaving directory
> > > > > > > > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/
> tools/other/pb2nc'
> > > > > > > > > > >> >> >> make[3]: *** [install-recursive] Error 1
> > > > > > > > > > >> >> >> make[3]: Leaving directory
> > > > > > > > > > >> >> >> `/home/zmumba/WRF/met-
5.0/src/tools/other'
> > > > > > > > > > >> >> >> make[2]: *** [install-recursive] Error 1
> > > > > > > > > > >> >> >> make[2]: Leaving directory
> > > > > > > > `/home/zmumba/WRF/met-5.0/src/tools'
> > > > > > > > > > >> >> >> make[1]: *** [install-recursive] Error 1
> > > > > > > > > > >> >> >> make[1]: Leaving directory
> > > > > `/home/zmumba/WRF/met-5.0/src'
> > > > > > > > > > >> >> >> make: *** [install-recursive] Error 1
> > > > > > > > > > >> >> >>
> > > > > > > > > > >> >> >>
> > > > > > > > > > >> >> >
> > > > > > > > > > >> >> >
> > > > > > > > > > >> >> > --
> > > > > > > > > > >> >> > Julie Prestopnik
> > > > > > > > > > >> >> > National Center for Atmospheric Research
> > > > > > > > > > >> >> > Research Applications Laboratory
> > > > > > > > > > >> >> > Phone: 303.497.8399 <%28303%29%20497-8399>
> > > > > > > > > > >> >> > Email: jpresto at ucar.edu
> > > > > > > > > > >> >> >
> > > > > > > > > > >> >> >
> > > > > > > > > > >> >>
> > > > > > > > > > >> >>
> > > > > > > > > > >> >
> > > > > > > > > > >> >
> > > > > > > > > > >> > --
> > > > > > > > > > >> > Julie Prestopnik
> > > > > > > > > > >> > National Center for Atmospheric Research
> > > > > > > > > > >> > Research Applications Laboratory
> > > > > > > > > > >> > Phone: 303.497.8399
> > > > > > > > > > >> > Email: jpresto at ucar.edu
> > > > > > > > > > >> >
> > > > > > > > > > >> >
> > > > > > > > > > >>
> > > > > > > > > > >>
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > --
> > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > --
> > > > > > > > > Julie Prestopnik
> > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > Research Applications Laboratory
> > > > > > > > > Phone: 303.497.8399
> > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > --
> > > > > > > Julie Prestopnik
> > > > > > > National Center for Atmospheric Research
> > > > > > > Research Applications Laboratory
> > > > > > > Phone: 303.497.8399
> > > > > > > Email: jpresto at ucar.edu
> > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Julie Prestopnik
> > > > > National Center for Atmospheric Research
> > > > > Research Applications Laboratory
> > > > > Phone: 303.497.8399
> > > > > Email: jpresto at ucar.edu
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> >
> >
>
>

------------------------------------------------
Subject: Problem compiling Met-V5
From: Julie Prestopnik
Time: Tue Apr 11 13:52:51 2017

Hi Zilore.

In your config.log file, it appears that you do not have your MET
environment variables set up.  The MET build process uses environment
variables to specify the locations of the needed external libraries.

The following page describes the MET environment variables that you
will
need to set up in your .cshrc or equivalent file:

http://www.dtcenter.org/met/users/support/online_tutorial/METv6.0/tutorial.php?name=compilation&category=configure

The error you are getting:

In file included from nc_var_info.cc:24:0:
nc_utils.h:22:18: fatal error: netcdf: No such file or directory

seems to imply that MET doesn't know where to find the file "netcdf",
which
is included in the NetCDF-CXX installation.  It could be that NetCDF-
CXX is
installed and that file does exist, but MET just doesn't know where to
find
it.  Setting those environment variables will help MET know where
those
required libraries and include files are.

Here is a quick reference checklist for NetCDF4C++ installation that
you
can use to see if you have the necessary files:

Files for NetCDF4 C:

   - $MET_NETCDF/include/netcdf.h
   - $MET_NETCDF/lib/libnetcdf.a
   - $MET_NETCDF/lib/libnetcdf.so

Files for NetCDF4 C++:

   - $MET_NETCDF/include/netcdf
   - $MET_NETCDF/lib/libnetcdf_c++4.a
   - $MET_NETCDF/lib/libnetcdf_c++4.so

Files for NetCDF3 C++ (not required, if --disabled-netcdf4 is
activated):

   - $MET_NETCDF/include/netcdf.hh
   - $MET_NETCDF/lib/libnetcdf_c++.a
   - $MET_NETCDF/lib/libnetcdf_c++.so

Please follow the instructions on the webpage above to set up the
necessary
environment variables, then please reconfigure and recompile MET and
let us
know if you encounter further difficulty.

I hope this helps!

Thanks!

Julie

On Tue, Apr 11, 2017 at 1:22 PM, Zilore Mumba via RT
<met_help at ucar.edu>
wrote:

>
> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
>
> Julie,
> Please find attached to this mail, my config.log and make-
install.log.
>
> On Tue, Apr 11, 2017 at 4:29 PM, Julie Prestopnik via RT <
> met_help at ucar.edu>
> wrote:
>
> > Hi Zilore.  I'm sorry to hear that you are still experiencing
problems.
> > Could you please send your most recent configure.log and
make_install.log
> > files?
> >
> > Thanks!
> >
> > Julie
> >
> > On Tue, Apr 11, 2017 at 8:13 AM, Zilore Mumba via RT
<met_help at ucar.edu>
> > wrote:
> >
> > >
> > > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > >
> > > Julie,
> > > Thanks very much for all the details you provided.
> > > However, am still getting the same error, i.e.
> > > The file "nc_var_info.cc" (i.e. #include on line 24) calls
> "nc_utils.h".
> > > Now the latter file has "#include netcdf" on line 22. It is this
netcdf
> > it
> > > is saying no such file.
> > >
> > > I believe my setup is ok.
> > > Using the lines you gave me on installing the hdf5 and netcdf
> libraries,
> > if
> > > I use prefix=${MET_LIB_DIR}, I am not able to find where the
libraries
> > are
> > > installed, though there are no errors indicated. I tried to set
"export
> > > MET_LIB_DIR=/usr/local/met6" and alternatively "export
> > MET_LIB_DIR=~/met6"
> > > after creating the met6 directory in each case.
> > > But putting prefix=/usr/local/met6, I get both netcdf-c and
netcdf-cxx
> > > libraries in /usr/local/met6/lib, include files in
> > /usr/local/met6/include,
> > > and some executables in /usr/local/met6/bin as well as an hdf5
> directory.
> > > So am wondering if the include file nc_utils.h has the correct
entry on
> > > line 22.
> > > Thanks for your time and effort
> > > Zilore
> > >
> > > On Mon, Apr 10, 2017 at 5:40 PM, Julie Prestopnik via RT <
> > > met_help at ucar.edu>
> > > wrote:
> > >
> > > > Hi Zilore.  In 6.0 we've made a large change from using NetCDF
3 to
> 4.
> > > > You'll need to have both NetCDF 4 and HDF5, upon which NetCDF
4 is
> > built,
> > > > installed.
> > > >
> > > > Please feel free to take a look at the MET User's Guide and
the
> online
> > > > tutorial:
> > > > http://www.dtcenter.org/met/users/docs/users_guide/MET_
> > > > Users_Guide_v6.0.pdf
> > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > METv6.0/tutorial.php?name=compilation&category=req_libs
> > > >
> > > > There is an additional environment variable that will need to
be set,
> > > with
> > > > the addition of HDF5:
> > > > Set *$MET_HDF5* to point to the main HDF5 directory.
> > > >
> > > > Also, both the NetCDF-C package (netcdf-c-4.4.1.1) and the
NetCDF-CXX
> > > > package (netcdf-cxx4-4.3.0) are necessary.
> > > >
> > > > Here are the commands we've been using to compile these
packages from
> > > > source.  The following assumes that you're using the GNU
compilers
> and
> > > that
> > > > you've defined MET_LIB_DIR to point to your desired
installation
> > > directory:
> > > >
> > > > # Compilers
> > > >
> > > > setenv CC `which gcc`
> > > >
> > > > setenv CXX `which g++`
> > > >
> > > > setenv FC `which gfortran`
> > > > setenv F77 `which gfortran`
> > > >
> > > > # HDF5
> > > >
> > > > wget
> > > > https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.10/
> > > > hdf5-1.10.0-patch1/src/hdf5-1.10.0-patch1.tar
> > > >
> > > > tar -xvzf hdf5-1.10.0-patch1.tar
> > > >
> > > > cd hdf5-1.10.0-patch1
> > > >
> > > > ./configure --prefix=${MET_LIB_DIR}
> > > >
> > > > make install
> > > >
> > > > # NetCDF-C
> > > >
> > > > wget https://github.com/Unidata/netcdf-c/archive/v4.4.1.1.zip
> > > >
> > > > unzip v4.4.1.1.zip
> > > >
> > > > cd netcdf-c-4.4.1.1
> > > >
> > > > ./configure --prefix=${MET_LIB_DIR} LDFLAGS=-
L${MET_LIB_DIR}/lib
> > > > CPPFLAGS=-I${MET_LIB_DIR}/include
> > > >
> > > > make install
> > > >
> > > >
> > > > # NetCDF-CXX
> > > >
> > > > wget https://github.com/Unidata/netcdf-
cxx4/archive/v4.3.0.tar.gz
> > > >
> > > > tar -xvzf v4.3.0.tar.gz
> > > >
> > > > cd netcdf-cxx4-4.3.0
> > > >
> > > > ./configure --prefix=${MET_LIB_DIR} LDFLAGS=-
L${MET_LIB_DIR}/lib
> > > > CPPFLAGS=-I${MET_LIB_DIR}/include
> > > > make install
> > > >
> > > >
> > > > I hope this helps!  Please let us know if you need further
> assistance.
> > > >
> > > > Thanks,
> > > > Julie
> > > >
> > > > On Sat, Apr 8, 2017 at 3:53 PM, Zilore Mumba via RT <
> met_help at ucar.edu
> > >
> > > > wrote:
> > > >
> > > > >
> > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > > > >
> > > > > Julie, I hope you are fine, and that I can still reach you.
In
> March
> > > 2015
> > > > > you helped me installing met_v5.0. I have now downloaded
v6.0 and I
> > am
> > > > > having a compilation error I do not seem to figure out.
> > > > > I believe I have installed all the libraries (and set the
> environment
> > > > > variables correctly: BUFRLIB-v10-2-3, netcdf-4.4.1.1, gsl-
2.3,
> > > > > g2clib-1.6.0, freetype-2.7.1 andcairo-1.14.8.
> > > > > I also have zlib, jasper and libpng.
> > > > > My configure exits with exit code 0 which I understand to be
ok.
> > > However
> > > > my
> > > > > make install gives an error of not finding netcdf (as you
can see
> > from
> > > > > make-install.log). I do not understand which netcdf it
cannot find.
> > > > > I hope you can assist.
> > > > > Zilore
> > > > >
> > > > > On Thu, Mar 5, 2015 at 7:59 PM, Julie Prestopnik via RT <
> > > > met_help at ucar.edu
> > > > > >
> > > > > wrote:
> > > > >
> > > > > > Hi Zilore.  Thanks for sending your commands and log
files.
> > > > > >
> > > > > > Looking in "config.log" for the string "BUFRLIB", it
appears that
> > you
> > > > did
> > > > > > not set the environment variable.
> > > > > >
> > > > > > The linker error occurs on line 1057 of make_install.log.
> Looking
> > at
> > > > > that
> > > > > > line, we're telling the linker to look in the following
> directories
> > > for
> > > > > the
> > > > > > file named "libbufr.a":
> > > > > >
> > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8
> > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../i386-linux-gnu
> > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../../lib
> > > > > > -L/lib/i386-linux-gnu
> > > > > > -L/lib/../lib
> > > > > > -L/usr/lib/i386-linux-gnu
> > > > > > -L/usr/lib/../lib
> > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../..
> > > > > >
> > > > > > It must be finding libbufr.a in one of those directories,
> otherwise
> > > we
> > > > > > would get an error about that.  I believe that the version
of
> > > libbufr.a
> > > > > it
> > > > > > is finding is not the version that you compiled using the
> > > > "-DUNDERSCORE"
> > > > > > option.
> > > > > >
> > > > > > I was able to replicate your error by re-compiling a
version of
> > > BUFRLIB
> > > > > > *without* -DUNDERSCORE, and then by building MET linking
to that
> > bad
> > > > > > version.
> > > > > >
> > > > > > What you'll need to do is set the MET_BUFRLIB environment
> variable
> > as
> > > > > > indicated on this page:
> > > > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > METv5.0/compilation/configure.php
> > > > > >
> > > > > > Then source your .cshrc or equivalent file, then run your
> configure
> > > > > > command, and then run make install and make test.
> > > > > >
> > > > > > Please give that a try.  It should solve the problem you
are
> > > > > encountering.
> > > > > >
> > > > > > Thanks,
> > > > > > Julie
> > > > > >
> > > > > > On Wed, Mar 4, 2015 at 5:36 AM, Zilore Mumba via RT <
> > > met_help at ucar.edu
> > > > >
> > > > > > wrote:
> > > > > >
> > > > > > >
> > > > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> >
> > > > > > >
> > > > > > > *Julie, I installed with the following commands. gcc -c
> > > -DUNDERSCORE
> > > > > *.c*
> > > > > > >    *gfortran -c -DUNDERSCORE -fno-second-underscore *.f
*.F*
> > > > > > >    *ar crv libbufr.a *.o*
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > *Please find attached the config.log and
make_install.log *
> > > > > > >
> > > > > > >
> > > > > > > On Tue, Mar 3, 2015 at 7:10 PM, Julie Prestopnik via RT
<
> > > > > > met_help at ucar.edu
> > > > > > > >
> > > > > > > wrote:
> > > > > > >
> > > > > > > > I'm sorry to hear that you are still experiencing
problems
> > > > installing
> > > > > > > > METv5.0.
> > > > > > > >
> > > > > > > > Specifically regarding BUFRLIB, please compile it
using the
> > > options
> > > > > > > listed
> > > > > > > > on this page:
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > METv5.0/compilation/req_libs.php
> > > > > > > >
> > > > > > > > Failing to use the "-DUNDERSCORE -fno-second-
underscore" (for
> > GNU
> > > > > > > > compilers) options will result in undefined references
when
> > > > building
> > > > > > the
> > > > > > > > pb2nc tool.
> > > > > > > >
> > > > > > > > If you'd like to send us the output of make please do
the
> > > > following:
> > > > > > > >    make clean
> > > > > > > >    make install >& make_install.log
> > > > > > > >
> > > > > > > > And then send us the files "config.log" and
> "make_install.log".
> > > > > > > >
> > > > > > > > I hope you'll find what you have been able to install
useful.
> > > > Please
> > > > > > let
> > > > > > > > us know if you have any questions.
> > > > > > > >
> > > > > > > > Thanks,
> > > > > > > > Julie
> > > > > > > >
> > > > > > > > On Tue, Mar 3, 2015 at 12:26 AM, Zilore Mumba via RT <
> > > > > > met_help at ucar.edu>
> > > > > > > > wrote:
> > > > > > > >
> > > > > > > > >
> > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > Ticket/Display.html?id=70551
> > > >
> > > > > > > > >
> > > > > > > > > Julie,
> > > > > > > > > I did not inform you of the conclusion of my attempt
to
> > install
> > > > > > > Met-5.1.
> > > > > > > > > After making many attempts in
reinstalling/reconfiguring
> > > BUFRLIB
> > > > i
> > > > > > > still
> > > > > > > > > get errors relating to "undefined reference to ..."
and
> > > > eventually
> > > > > I
> > > > > > > > still
> > > > > > > > > have 3 executables not installed: pb2nc,
modis_regrid,
> > > > > > plot_mode_field.
> > > > > > > > > I would like to learn how to use what I have and
come back
> > > later
> > > > to
> > > > > > > pb2nc
> > > > > > > > > if necessary. I will inform you if I have any other
> problems.
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > On Tue, Feb 10, 2015 at 7:12 PM, Julie Prestopnik
via RT <
> > > > > > > > > met_help at ucar.edu>
> > > > > > > > > wrote:
> > > > > > > > >
> > > > > > > > > > Thank you for rerunning and sending this log.
Perhaps
> MET
> > > > cannot
> > > > > > > find
> > > > > > > > > the
> > > > > > > > > > BUFR library.
> > > > > > > > > >
> > > > > > > > > > On the following page are directions for setting
the
> > > > environment
> > > > > > > > > variables
> > > > > > > > > > before compiling MET:
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > METv5.0/compilation/configure.php
> > > > > > > > > >
> > > > > > > > > > The rest of the applications built, so it looks
like MET
> > was
> > > > able
> > > > > > to
> > > > > > > > find
> > > > > > > > > > the other needed libraries.  The directions for
the BUFR
> > > > > > environment
> > > > > > > > > > variable on the above page are:
> > > > > > > > > >
> > > > > > > > > > "Set *$MET_BUFR* to point to the main BUFR
directory, or
> > set
> > > > > > > > > *$MET_BUFRLIB*
> > > > > > > > > > to point to the directory with the BUFR library
files.
> > > Because
> > > > > MET
> > > > > > > > > doesn't
> > > > > > > > > > use any BUFR library include files, you don't need
to
> > specify
> > > > > > > > > > *$MET_BUFRINC*
> > > > > > > > > > ."
> > > > > > > > > >
> > > > > > > > > > Please try setting either *$MET_BUFR *or
*$MET_BUFRLIB
> *and
> > > > then
> > > > > > > please
> > > > > > > > > > rerun the configure script and then rerun make
install.
> It
> > > is
> > > > > > > > important
> > > > > > > > > to
> > > > > > > > > > rerun configure before rerunning make install.
> > > > > > > > > >
> > > > > > > > > > Please let me know how it goes.
> > > > > > > > > >
> > > > > > > > > > Thanks,
> > > > > > > > > > Julie
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > On Sat, Feb 7, 2015 at 9:36 PM, Zilore Mumba via
RT <
> > > > > > > met_help at ucar.edu
> > > > > > > > >
> > > > > > > > > > wrote:
> > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > > Ticket/Display.html?id=70551
> > > > > >
> > > > > > > > > > >
> > > > > > > > > > > Julie,
> > > > > > > > > > > Attached to this mail, please find the file
> > > make-install.log.
> > > > > It
> > > > > > > does
> > > > > > > > > > > show 'undefined reference' to some functions. I
hope
> this
> > > > means
> > > > > > > > > > > something to you and that you can help.
> > > > > > > > > > > Thanks in advance
> > > > > > > > > > > Zilore
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > On 2/5/15, Julie Prestopnik via RT
<met_help at ucar.edu>
> > > > wrote:
> > > > > > > > > > > > Thank you for attaching your log files.  I did
not
> see
> > > any
> > > > > > errors
> > > > > > > > in
> > > > > > > > > > your
> > > > > > > > > > > > make-install.log.  Perhaps you ran make
install in
> the
> > > > > > following
> > > > > > > > way:
> > > > > > > > > > > >
> > > > > > > > > > > > make install > make-install.log
> > > > > > > > > > > >
> > > > > > > > > > > > This would catch standard out but not standard
error.
> > > > > > > > > > > >
> > > > > > > > > > > > Could you please try running in the following
way
> with
> > > the
> > > > &,
> > > > > > > which
> > > > > > > > > > will
> > > > > > > > > > > > also capture standard error?
> > > > > > > > > > > >
> > > > > > > > > > > > make install >& make-install.log
> > > > > > > > > > > >
> > > > > > > > > > > > And, then please send me the output of that
log.
> Thank
> > > > you!
> > > > > > > > > > > >
> > > > > > > > > > > > Julie
> > > > > > > > > > > >
> > > > > > > > > > > > On Tue, Feb 3, 2015 at 2:08 PM, Zilore Mumba
via RT <
> > > > > > > > > met_help at ucar.edu
> > > > > > > > > > >
> > > > > > > > > > > > wrote:
> > > > > > > > > > > >
> > > > > > > > > > > >>
> > > > > > > > > > > >> <URL: https://rt.rap.ucar.edu/rt/Tic
> > > > > ket/Display.html?id=70551
> > > > > > >
> > > > > > > > > > > >>
> > > > > > > > > > > >> Julie,
> > > > > > > > > > > >> Thank you very much for your assistance. I
failed to
> > > > install
> > > > > > > Cairo
> > > > > > > > > and
> > > > > > > > > > > >> freetype because of the dependencies. I will
try
> again
> > > > with
> > > > > > the
> > > > > > > > > links
> > > > > > > > > > > >> you sent me.
> > > > > > > > > > > >> Please find attached my config.log and
> > make-install.log.
> > > > > > > > > > > >>
> > > > > > > > > > > >>
> > > > > > > > > > > >> On 2/2/15, Julie Prestopnik via RT <
> met_help at ucar.edu
> > >
> > > > > wrote:
> > > > > > > > > > > >> > I'm so glad you were able to get MET
installed and
> > > that
> > > > > you
> > > > > > > > worked
> > > > > > > > > > out
> > > > > > > > > > > >> the
> > > > > > > > > > > >> > issue with the NetCDF environment
variables.
> > > > > > > > > > > >> >
> > > > > > > > > > > >> > You mentioned that three executables did
not
> > build.  I
> > > > > would
> > > > > > > > like
> > > > > > > > > to
> > > > > > > > > > > >> > try
> > > > > > > > > > > >> to
> > > > > > > > > > > >> > help with those.  The modis_regrid tool has
> library
> > > > > > > > dependencies -
> > > > > > > > > > it
> > > > > > > > > > > >> > requires the HDF4 and HDF-EOS2 libraries.
The
> > > > > > plot_mode_field
> > > > > > > > > tool
> > > > > > > > > > > >> > also
> > > > > > > > > > > >> > has library dependencies - it requires the
Cairo
> and
> > > > > > FreeType
> > > > > > > > > > > >> > libraries.
> > > > > > > > > > > >> >
> > > > > > > > > > > >> > You can find information on compiling each
of
> those
> > > > > library
> > > > > > > > > > > >> > dependencies
> > > > > > > > > > > >> > here:
> > > > > > > > > > > >> >
> > > > > > > > > > > >>
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > > >> >
> > > > > > > > > > > >> > You can find information on setting the up
> necessary
> > > > > > > environment
> > > > > > > > > > > >> variables
> > > > > > > > > > > >> > for those library locations here:
> > > > > > > > > > > >> >
> > > > > > > > > > > >>
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > METv5.0/compilation/configure.php
> > > > > > > > > > > >> >
> > > > > > > > > > > >> > And with pb2nc, I'm not exactly sure what
is going
> > on
> > > > > there.
> > > > > > > I
> > > > > > > > > > would
> > > > > > > > > > > >> > be
> > > > > > > > > > > >> > happy to take a look at your configure log
and
> make
> > > > > install
> > > > > > > log
> > > > > > > > > > files
> > > > > > > > > > > >> > to
> > > > > > > > > > > >> > see if I can figure out why you didn't get
the
> > > > executable.
> > > > > > > > > > > >> >
> > > > > > > > > > > >> > I hope this helps.
> > > > > > > > > > > >> >
> > > > > > > > > > > >> > Thanks,
> > > > > > > > > > > >> > Julie
> > > > > > > > > > > >> >
> > > > > > > > > > > >> >
> > > > > > > > > > > >> >
> > > > > > > > > > > >> > On Sat, Jan 31, 2015 at 5:31 PM, Zilore
Mumba via
> RT
> > > > > > > > > > > >> > <met_help at ucar.edu>
> > > > > > > > > > > >> > wrote:
> > > > > > > > > > > >> >
> > > > > > > > > > > >> >>
> > > > > > > > > > > >> >> <URL:
> > > > > > > https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > > > > > > >
> > > > > > > > > > > >> >>
> > > > > > > > > > > >> >> Julg
> > > > > > > > > > > >> >> Thank you very much for your help. With
the
> advice
> > > you
> > > > > gave
> > > > > > > > me, I
> > > > > > > > > > was
> > > > > > > > > > > >> >> able to install MET using gcc and
gfortran. I
> also
> > > had
> > > > to
> > > > > > to
> > > > > > > > > point
> > > > > > > > > > > >> >> $MET_NETCDFLIB and, $MET_NETCDFINC to
> > > > > > > > /usr/local/netcdf-4.1.3/lib
> > > > > > > > > > and
> > > > > > > > > > > >> >> include. Previously I pointed only to
> > > > > > > /usr/local/netcdf-4.1.3.
> > > > > > > > > > > >> >> I have three executables not included
though,
> these
> > > are
> > > > > > > > > > modis_regrid,
> > > > > > > > > > > >> >> plot_mode_field and pb2nc.
> > > > > > > > > > > >> >> Thank you very much.
> > > > > > > > > > > >> >>
> > > > > > > > > > > >> >>
> > > > > > > > > > > >> >> On 1/29/15, Julie Prestopnik via RT <
> > > met_help at ucar.edu
> > > > >
> > > > > > > wrote:
> > > > > > > > > > > >> >> > I am sorry to hear that you are having
problems
> > > > > > installing
> > > > > > > > > > METv5.0.
> > > > > > > > > > > >> >> > I
> > > > > > > > > > > >> >> > believe this error may have to do with
how you
> > > > compiled
> > > > > > > > > BUFRLIB.
> > > > > > > > > > > >> >> > Please
> > > > > > > > > > > >> >> > take a look at the sample commands for
> compiling
> > > > > BURFLIB
> > > > > > on
> > > > > > > > > this
> > > > > > > > > > > >> >> > page:
> > > > > > > > > > > >> >> >
> > > > > > > > > > > >> >>
> > > > > > > > > > > >>
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > > >> >> >
> > > > > > > > > > > >> >> > I believe that the *-fno-second-
underscore*
> (GNU
> > > > > > compilers)
> > > > > > > > or
> > > > > > > > > > > >> >> > *-Mnosecond_underscore* (PGI compilers)
will
> fix
> > > the
> > > > > > error
> > > > > > > > > you're
> > > > > > > > > > > >> >> > seeing.
> > > > > > > > > > > >> >> >
> > > > > > > > > > > >> >> > I hope that helps.  If it doesn't,
please send
> me
> > > the
> > > > > > files
> > > > > > > > > > > >> >> "make_met.log"
> > > > > > > > > > > >> >> > and "config.log".
> > > > > > > > > > > >> >> >
> > > > > > > > > > > >> >> > Thanks,
> > > > > > > > > > > >> >> > Julie
> > > > > > > > > > > >> >> >
> > > > > > > > > > > >> >> >
> > > > > > > > > > > >> >> > On Thu, Jan 29, 2015 at 3:48 AM, Zilore
Mumba
> via
> > > RT
> > > > > > > > > > > >> >> > <met_help at ucar.edu>
> > > > > > > > > > > >> >> > wrote:
> > > > > > > > > > > >> >> >
> > > > > > > > > > > >> >> >>
> > > > > > > > > > > >> >> >> Thu Jan 29 03:48:08 2015: Request 70551
was
> > acted
> > > > > upon.
> > > > > > > > > > > >> >> >> Transaction: Ticket created by
> zmumba at gmail.com
> > > > > > > > > > > >> >> >>        Queue: met_help
> > > > > > > > > > > >> >> >>      Subject: Problem compiling Met-V5
> > > > > > > > > > > >> >> >>        Owner: Nobody
> > > > > > > > > > > >> >> >>   Requestors: zmumba at gmail.com
> > > > > > > > > > > >> >> >>       Status: new
> > > > > > > > > > > >> >> >>  Ticket <URL:
> > > > > > > > > > > >> https://rt.rap.ucar.edu/rt/
> > Ticket/Display.html?id=70551
> > > > > > > > > > > >> >> >> >
> > > > > > > > > > > >> >> >>
> > > > > > > > > > > >> >> >>
> > > > > > > > > > > >> >> >> I have installed BUFRLIB, GSL and
G2CLIB
> > > > > > > > > > > >> >> >> But then how do I handle the errors
below in
> > > > > installing
> > > > > > > > > MET_V5?
> > > > > > > > > > > >> >> >>
> > > > > > > > > > > >> >> >>
> > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/numpbmsg.f:
> 23:
> > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > >> >> >> reference to `ufbtab_'
> > > > > > > > > > > >> >> >> openpb.o: In function `openpb_':
> > > > > > > > > > > >> >> >>
> > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/openpb.f:21:
> > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > > > > >> >> >>
> > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/openpb.f:22:
> > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > > > > >> >> >> closepb.o: In function `closepb_':
> > > > > > > > > > > >> >> >>
> > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/closepb.f:19:
> > > > > > > > > > > >> undefined
> > > > > > > > > > > >> >> >> reference to `closbf_'
> > > > > > > > > > > >> >> >> readpb.o: In function `readpb_':
> > > > > > > > > > > >> >> >>
> > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/readpb.f:82:
> > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > >> >> >>
> > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/readpb.f:90:
> > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > >> >> >>
> > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/readpb.f:94:
> > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > >> >> >> dumppb.o: In function `readpbdump_':
> > > > > > > > > > > >> >> >>
> > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:215:
> > > > > > > > > > > >> undefined
> > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > >> >> >>
> > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:218:
> > > > > > > > > > > >> undefined
> > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > >> >> >>
> > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:224:
> > > > > > > > > > > >> undefined
> > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > >> >> >>
> > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:203:
> > > > > > > > > > > >> undefined
> > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > >> >> >>
> > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:228:
> > > > > > > > > > > >> undefined
> > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > >> >> >>
> > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:259:
> > > > > > > > > > > >> undefined
> > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > >> >> >> dumppb.o: In function `dumppb_':
> > > > > > > > > > > >> >> >>
> > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:56:
> > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > > > > >> >> >>
> > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:57:
> > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > > > > >> >> >> collect2: error: ld returned 1 exit
status
> > > > > > > > > > > >> >> >> make[4]: *** [pb2nc] Error 1
> > > > > > > > > > > >> >> >> make[4]: Leaving directory
> > > > > > > > > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/
> > tools/other/pb2nc'
> > > > > > > > > > > >> >> >> make[3]: *** [install-recursive] Error
1
> > > > > > > > > > > >> >> >> make[3]: Leaving directory
> > > > > > > > > > > >> >> >> `/home/zmumba/WRF/met-
5.0/src/tools/other'
> > > > > > > > > > > >> >> >> make[2]: *** [install-recursive] Error
1
> > > > > > > > > > > >> >> >> make[2]: Leaving directory
> > > > > > > > > `/home/zmumba/WRF/met-5.0/src/tools'
> > > > > > > > > > > >> >> >> make[1]: *** [install-recursive] Error
1
> > > > > > > > > > > >> >> >> make[1]: Leaving directory
> > > > > > `/home/zmumba/WRF/met-5.0/src'
> > > > > > > > > > > >> >> >> make: *** [install-recursive] Error 1
> > > > > > > > > > > >> >> >>
> > > > > > > > > > > >> >> >>
> > > > > > > > > > > >> >> >
> > > > > > > > > > > >> >> >
> > > > > > > > > > > >> >> > --
> > > > > > > > > > > >> >> > Julie Prestopnik
> > > > > > > > > > > >> >> > National Center for Atmospheric Research
> > > > > > > > > > > >> >> > Research Applications Laboratory
> > > > > > > > > > > >> >> > Phone: 303.497.8399 <%28303%29%20497-
8399>
> > > > > > > > > > > >> >> > Email: jpresto at ucar.edu
> > > > > > > > > > > >> >> >
> > > > > > > > > > > >> >> >
> > > > > > > > > > > >> >>
> > > > > > > > > > > >> >>
> > > > > > > > > > > >> >
> > > > > > > > > > > >> >
> > > > > > > > > > > >> > --
> > > > > > > > > > > >> > Julie Prestopnik
> > > > > > > > > > > >> > National Center for Atmospheric Research
> > > > > > > > > > > >> > Research Applications Laboratory
> > > > > > > > > > > >> > Phone: 303.497.8399
> > > > > > > > > > > >> > Email: jpresto at ucar.edu
> > > > > > > > > > > >> >
> > > > > > > > > > > >> >
> > > > > > > > > > > >>
> > > > > > > > > > > >>
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > --
> > > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > --
> > > > > > > > > > Julie Prestopnik
> > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > --
> > > > > > > > Julie Prestopnik
> > > > > > > > National Center for Atmospheric Research
> > > > > > > > Research Applications Laboratory
> > > > > > > > Phone: 303.497.8399
> > > > > > > > Email: jpresto at ucar.edu
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > > > --
> > > > > > Julie Prestopnik
> > > > > > National Center for Atmospheric Research
> > > > > > Research Applications Laboratory
> > > > > > Phone: 303.497.8399
> > > > > > Email: jpresto at ucar.edu
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> >
> >
>
>

------------------------------------------------
Subject: Problem compiling Met-V5
From: Zilore Mumba
Time: Tue Apr 11 16:12:06 2017

Julie,
Thanks once again for your time. My apologies, because in the
environmental
variable I put "/usr/local/MET6" while as the directory I created was
"/usr/local/met6", i.e. met capitalized. When I do "ll $MET_NETCDFINC"
I
can see the include files, including "netcdf".
But am getting the same error. Let me work over it. I will get back to
you
if I fail or succeed.
Best regards
Zilore

On Tue, Apr 11, 2017 at 9:52 PM, Julie Prestopnik via RT
<met_help at ucar.edu>
wrote:

> Hi Zilore.
>
> In your config.log file, it appears that you do not have your MET
> environment variables set up.  The MET build process uses
environment
> variables to specify the locations of the needed external libraries.
>
> The following page describes the MET environment variables that you
will
> need to set up in your .cshrc or equivalent file:
>
> http://www.dtcenter.org/met/users/support/online_tutorial/
> METv6.0/tutorial.php?name=compilation&category=configure
>
> The error you are getting:
>
> In file included from nc_var_info.cc:24:0:
> nc_utils.h:22:18: fatal error: netcdf: No such file or directory
>
> seems to imply that MET doesn't know where to find the file
"netcdf", which
> is included in the NetCDF-CXX installation.  It could be that
NetCDF-CXX is
> installed and that file does exist, but MET just doesn't know where
to find
> it.  Setting those environment variables will help MET know where
those
> required libraries and include files are.
>
> Here is a quick reference checklist for NetCDF4C++ installation that
you
> can use to see if you have the necessary files:
>
> Files for NetCDF4 C:
>
>    - $MET_NETCDF/include/netcdf.h
>    - $MET_NETCDF/lib/libnetcdf.a
>    - $MET_NETCDF/lib/libnetcdf.so
>
> Files for NetCDF4 C++:
>
>    - $MET_NETCDF/include/netcdf
>    - $MET_NETCDF/lib/libnetcdf_c++4.a
>    - $MET_NETCDF/lib/libnetcdf_c++4.so
>
> Files for NetCDF3 C++ (not required, if --disabled-netcdf4 is
activated):
>
>    - $MET_NETCDF/include/netcdf.hh
>    - $MET_NETCDF/lib/libnetcdf_c++.a
>    - $MET_NETCDF/lib/libnetcdf_c++.so
>
> Please follow the instructions on the webpage above to set up the
necessary
> environment variables, then please reconfigure and recompile MET and
let us
> know if you encounter further difficulty.
>
> I hope this helps!
>
> Thanks!
>
> Julie
>
> On Tue, Apr 11, 2017 at 1:22 PM, Zilore Mumba via RT
<met_help at ucar.edu>
> wrote:
>
> >
> > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> >
> > Julie,
> > Please find attached to this mail, my config.log and make-
install.log.
> >
> > On Tue, Apr 11, 2017 at 4:29 PM, Julie Prestopnik via RT <
> > met_help at ucar.edu>
> > wrote:
> >
> > > Hi Zilore.  I'm sorry to hear that you are still experiencing
problems.
> > > Could you please send your most recent configure.log and
> make_install.log
> > > files?
> > >
> > > Thanks!
> > >
> > > Julie
> > >
> > > On Tue, Apr 11, 2017 at 8:13 AM, Zilore Mumba via RT <
> met_help at ucar.edu>
> > > wrote:
> > >
> > > >
> > > > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
>
> > > >
> > > > Julie,
> > > > Thanks very much for all the details you provided.
> > > > However, am still getting the same error, i.e.
> > > > The file "nc_var_info.cc" (i.e. #include on line 24) calls
> > "nc_utils.h".
> > > > Now the latter file has "#include netcdf" on line 22. It is
this
> netcdf
> > > it
> > > > is saying no such file.
> > > >
> > > > I believe my setup is ok.
> > > > Using the lines you gave me on installing the hdf5 and netcdf
> > libraries,
> > > if
> > > > I use prefix=${MET_LIB_DIR}, I am not able to find where the
> libraries
> > > are
> > > > installed, though there are no errors indicated. I tried to
set
> "export
> > > > MET_LIB_DIR=/usr/local/met6" and alternatively "export
> > > MET_LIB_DIR=~/met6"
> > > > after creating the met6 directory in each case.
> > > > But putting prefix=/usr/local/met6, I get both netcdf-c and
> netcdf-cxx
> > > > libraries in /usr/local/met6/lib, include files in
> > > /usr/local/met6/include,
> > > > and some executables in /usr/local/met6/bin as well as an hdf5
> > directory.
> > > > So am wondering if the include file nc_utils.h has the correct
entry
> on
> > > > line 22.
> > > > Thanks for your time and effort
> > > > Zilore
> > > >
> > > > On Mon, Apr 10, 2017 at 5:40 PM, Julie Prestopnik via RT <
> > > > met_help at ucar.edu>
> > > > wrote:
> > > >
> > > > > Hi Zilore.  In 6.0 we've made a large change from using
NetCDF 3 to
> > 4.
> > > > > You'll need to have both NetCDF 4 and HDF5, upon which
NetCDF 4 is
> > > built,
> > > > > installed.
> > > > >
> > > > > Please feel free to take a look at the MET User's Guide and
the
> > online
> > > > > tutorial:
> > > > > http://www.dtcenter.org/met/users/docs/users_guide/MET_
> > > > > Users_Guide_v6.0.pdf
> > > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > METv6.0/tutorial.php?name=compilation&category=req_libs
> > > > >
> > > > > There is an additional environment variable that will need
to be
> set,
> > > > with
> > > > > the addition of HDF5:
> > > > > Set *$MET_HDF5* to point to the main HDF5 directory.
> > > > >
> > > > > Also, both the NetCDF-C package (netcdf-c-4.4.1.1) and the
> NetCDF-CXX
> > > > > package (netcdf-cxx4-4.3.0) are necessary.
> > > > >
> > > > > Here are the commands we've been using to compile these
packages
> from
> > > > > source.  The following assumes that you're using the GNU
compilers
> > and
> > > > that
> > > > > you've defined MET_LIB_DIR to point to your desired
installation
> > > > directory:
> > > > >
> > > > > # Compilers
> > > > >
> > > > > setenv CC `which gcc`
> > > > >
> > > > > setenv CXX `which g++`
> > > > >
> > > > > setenv FC `which gfortran`
> > > > > setenv F77 `which gfortran`
> > > > >
> > > > > # HDF5
> > > > >
> > > > > wget
> > > > > https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.10/
> > > > > hdf5-1.10.0-patch1/src/hdf5-1.10.0-patch1.tar
> > > > >
> > > > > tar -xvzf hdf5-1.10.0-patch1.tar
> > > > >
> > > > > cd hdf5-1.10.0-patch1
> > > > >
> > > > > ./configure --prefix=${MET_LIB_DIR}
> > > > >
> > > > > make install
> > > > >
> > > > > # NetCDF-C
> > > > >
> > > > > wget https://github.com/Unidata/netcdf-
c/archive/v4.4.1.1.zip
> > > > >
> > > > > unzip v4.4.1.1.zip
> > > > >
> > > > > cd netcdf-c-4.4.1.1
> > > > >
> > > > > ./configure --prefix=${MET_LIB_DIR} LDFLAGS=-
L${MET_LIB_DIR}/lib
> > > > > CPPFLAGS=-I${MET_LIB_DIR}/include
> > > > >
> > > > > make install
> > > > >
> > > > >
> > > > > # NetCDF-CXX
> > > > >
> > > > > wget https://github.com/Unidata/netcdf-
cxx4/archive/v4.3.0.tar.gz
> > > > >
> > > > > tar -xvzf v4.3.0.tar.gz
> > > > >
> > > > > cd netcdf-cxx4-4.3.0
> > > > >
> > > > > ./configure --prefix=${MET_LIB_DIR} LDFLAGS=-
L${MET_LIB_DIR}/lib
> > > > > CPPFLAGS=-I${MET_LIB_DIR}/include
> > > > > make install
> > > > >
> > > > >
> > > > > I hope this helps!  Please let us know if you need further
> > assistance.
> > > > >
> > > > > Thanks,
> > > > > Julie
> > > > >
> > > > > On Sat, Apr 8, 2017 at 3:53 PM, Zilore Mumba via RT <
> > met_help at ucar.edu
> > > >
> > > > > wrote:
> > > > >
> > > > > >
> > > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > > > > >
> > > > > > Julie, I hope you are fine, and that I can still reach
you. In
> > March
> > > > 2015
> > > > > > you helped me installing met_v5.0. I have now downloaded
v6.0
> and I
> > > am
> > > > > > having a compilation error I do not seem to figure out.
> > > > > > I believe I have installed all the libraries (and set the
> > environment
> > > > > > variables correctly: BUFRLIB-v10-2-3, netcdf-4.4.1.1, gsl-
2.3,
> > > > > > g2clib-1.6.0, freetype-2.7.1 andcairo-1.14.8.
> > > > > > I also have zlib, jasper and libpng.
> > > > > > My configure exits with exit code 0 which I understand to
be ok.
> > > > However
> > > > > my
> > > > > > make install gives an error of not finding netcdf (as you
can see
> > > from
> > > > > > make-install.log). I do not understand which netcdf it
cannot
> find.
> > > > > > I hope you can assist.
> > > > > > Zilore
> > > > > >
> > > > > > On Thu, Mar 5, 2015 at 7:59 PM, Julie Prestopnik via RT <
> > > > > met_help at ucar.edu
> > > > > > >
> > > > > > wrote:
> > > > > >
> > > > > > > Hi Zilore.  Thanks for sending your commands and log
files.
> > > > > > >
> > > > > > > Looking in "config.log" for the string "BUFRLIB", it
appears
> that
> > > you
> > > > > did
> > > > > > > not set the environment variable.
> > > > > > >
> > > > > > > The linker error occurs on line 1057 of
make_install.log.
> > Looking
> > > at
> > > > > > that
> > > > > > > line, we're telling the linker to look in the following
> > directories
> > > > for
> > > > > > the
> > > > > > > file named "libbufr.a":
> > > > > > >
> > > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8
> > > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../i386-linux-
gnu
> > > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../../lib
> > > > > > > -L/lib/i386-linux-gnu
> > > > > > > -L/lib/../lib
> > > > > > > -L/usr/lib/i386-linux-gnu
> > > > > > > -L/usr/lib/../lib
> > > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../..
> > > > > > >
> > > > > > > It must be finding libbufr.a in one of those
directories,
> > otherwise
> > > > we
> > > > > > > would get an error about that.  I believe that the
version of
> > > > libbufr.a
> > > > > > it
> > > > > > > is finding is not the version that you compiled using
the
> > > > > "-DUNDERSCORE"
> > > > > > > option.
> > > > > > >
> > > > > > > I was able to replicate your error by re-compiling a
version of
> > > > BUFRLIB
> > > > > > > *without* -DUNDERSCORE, and then by building MET linking
to
> that
> > > bad
> > > > > > > version.
> > > > > > >
> > > > > > > What you'll need to do is set the MET_BUFRLIB
environment
> > variable
> > > as
> > > > > > > indicated on this page:
> > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > > METv5.0/compilation/configure.php
> > > > > > >
> > > > > > > Then source your .cshrc or equivalent file, then run
your
> > configure
> > > > > > > command, and then run make install and make test.
> > > > > > >
> > > > > > > Please give that a try.  It should solve the problem you
are
> > > > > > encountering.
> > > > > > >
> > > > > > > Thanks,
> > > > > > > Julie
> > > > > > >
> > > > > > > On Wed, Mar 4, 2015 at 5:36 AM, Zilore Mumba via RT <
> > > > met_help at ucar.edu
> > > > > >
> > > > > > > wrote:
> > > > > > >
> > > > > > > >
> > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> Ticket/Display.html?id=70551
> > >
> > > > > > > >
> > > > > > > > *Julie, I installed with the following commands. gcc
-c
> > > > -DUNDERSCORE
> > > > > > *.c*
> > > > > > > >    *gfortran -c -DUNDERSCORE -fno-second-underscore
*.f *.F*
> > > > > > > >    *ar crv libbufr.a *.o*
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > *Please find attached the config.log and
make_install.log *
> > > > > > > >
> > > > > > > >
> > > > > > > > On Tue, Mar 3, 2015 at 7:10 PM, Julie Prestopnik via
RT <
> > > > > > > met_help at ucar.edu
> > > > > > > > >
> > > > > > > > wrote:
> > > > > > > >
> > > > > > > > > I'm sorry to hear that you are still experiencing
problems
> > > > > installing
> > > > > > > > > METv5.0.
> > > > > > > > >
> > > > > > > > > Specifically regarding BUFRLIB, please compile it
using the
> > > > options
> > > > > > > > listed
> > > > > > > > > on this page:
> > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > >
> > > > > > > > > Failing to use the "-DUNDERSCORE -fno-second-
underscore"
> (for
> > > GNU
> > > > > > > > > compilers) options will result in undefined
references when
> > > > > building
> > > > > > > the
> > > > > > > > > pb2nc tool.
> > > > > > > > >
> > > > > > > > > If you'd like to send us the output of make please
do the
> > > > > following:
> > > > > > > > >    make clean
> > > > > > > > >    make install >& make_install.log
> > > > > > > > >
> > > > > > > > > And then send us the files "config.log" and
> > "make_install.log".
> > > > > > > > >
> > > > > > > > > I hope you'll find what you have been able to
install
> useful.
> > > > > Please
> > > > > > > let
> > > > > > > > > us know if you have any questions.
> > > > > > > > >
> > > > > > > > > Thanks,
> > > > > > > > > Julie
> > > > > > > > >
> > > > > > > > > On Tue, Mar 3, 2015 at 12:26 AM, Zilore Mumba via RT
<
> > > > > > > met_help at ucar.edu>
> > > > > > > > > wrote:
> > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > Ticket/Display.html?id=70551
> > > > >
> > > > > > > > > >
> > > > > > > > > > Julie,
> > > > > > > > > > I did not inform you of the conclusion of my
attempt to
> > > install
> > > > > > > > Met-5.1.
> > > > > > > > > > After making many attempts in
reinstalling/reconfiguring
> > > > BUFRLIB
> > > > > i
> > > > > > > > still
> > > > > > > > > > get errors relating to "undefined reference to
..." and
> > > > > eventually
> > > > > > I
> > > > > > > > > still
> > > > > > > > > > have 3 executables not installed: pb2nc,
modis_regrid,
> > > > > > > plot_mode_field.
> > > > > > > > > > I would like to learn how to use what I have and
come
> back
> > > > later
> > > > > to
> > > > > > > > pb2nc
> > > > > > > > > > if necessary. I will inform you if I have any
other
> > problems.
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > On Tue, Feb 10, 2015 at 7:12 PM, Julie Prestopnik
via RT
> <
> > > > > > > > > > met_help at ucar.edu>
> > > > > > > > > > wrote:
> > > > > > > > > >
> > > > > > > > > > > Thank you for rerunning and sending this log.
Perhaps
> > MET
> > > > > cannot
> > > > > > > > find
> > > > > > > > > > the
> > > > > > > > > > > BUFR library.
> > > > > > > > > > >
> > > > > > > > > > > On the following page are directions for setting
the
> > > > > environment
> > > > > > > > > > variables
> > > > > > > > > > > before compiling MET:
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > > METv5.0/compilation/configure.php
> > > > > > > > > > >
> > > > > > > > > > > The rest of the applications built, so it looks
like
> MET
> > > was
> > > > > able
> > > > > > > to
> > > > > > > > > find
> > > > > > > > > > > the other needed libraries.  The directions for
the
> BUFR
> > > > > > > environment
> > > > > > > > > > > variable on the above page are:
> > > > > > > > > > >
> > > > > > > > > > > "Set *$MET_BUFR* to point to the main BUFR
directory,
> or
> > > set
> > > > > > > > > > *$MET_BUFRLIB*
> > > > > > > > > > > to point to the directory with the BUFR library
files.
> > > > Because
> > > > > > MET
> > > > > > > > > > doesn't
> > > > > > > > > > > use any BUFR library include files, you don't
need to
> > > specify
> > > > > > > > > > > *$MET_BUFRINC*
> > > > > > > > > > > ."
> > > > > > > > > > >
> > > > > > > > > > > Please try setting either *$MET_BUFR *or
*$MET_BUFRLIB
> > *and
> > > > > then
> > > > > > > > please
> > > > > > > > > > > rerun the configure script and then rerun make
install.
> > It
> > > > is
> > > > > > > > > important
> > > > > > > > > > to
> > > > > > > > > > > rerun configure before rerunning make install.
> > > > > > > > > > >
> > > > > > > > > > > Please let me know how it goes.
> > > > > > > > > > >
> > > > > > > > > > > Thanks,
> > > > > > > > > > > Julie
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > On Sat, Feb 7, 2015 at 9:36 PM, Zilore Mumba via
RT <
> > > > > > > > met_help at ucar.edu
> > > > > > > > > >
> > > > > > > > > > > wrote:
> > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > > > Ticket/Display.html?id=70551
> > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > Julie,
> > > > > > > > > > > > Attached to this mail, please find the file
> > > > make-install.log.
> > > > > > It
> > > > > > > > does
> > > > > > > > > > > > show 'undefined reference' to some functions.
I hope
> > this
> > > > > means
> > > > > > > > > > > > something to you and that you can help.
> > > > > > > > > > > > Thanks in advance
> > > > > > > > > > > > Zilore
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > On 2/5/15, Julie Prestopnik via RT <
> met_help at ucar.edu>
> > > > > wrote:
> > > > > > > > > > > > > Thank you for attaching your log files.  I
did not
> > see
> > > > any
> > > > > > > errors
> > > > > > > > > in
> > > > > > > > > > > your
> > > > > > > > > > > > > make-install.log.  Perhaps you ran make
install in
> > the
> > > > > > > following
> > > > > > > > > way:
> > > > > > > > > > > > >
> > > > > > > > > > > > > make install > make-install.log
> > > > > > > > > > > > >
> > > > > > > > > > > > > This would catch standard out but not
standard
> error.
> > > > > > > > > > > > >
> > > > > > > > > > > > > Could you please try running in the
following way
> > with
> > > > the
> > > > > &,
> > > > > > > > which
> > > > > > > > > > > will
> > > > > > > > > > > > > also capture standard error?
> > > > > > > > > > > > >
> > > > > > > > > > > > > make install >& make-install.log
> > > > > > > > > > > > >
> > > > > > > > > > > > > And, then please send me the output of that
log.
> > Thank
> > > > > you!
> > > > > > > > > > > > >
> > > > > > > > > > > > > Julie
> > > > > > > > > > > > >
> > > > > > > > > > > > > On Tue, Feb 3, 2015 at 2:08 PM, Zilore Mumba
via
> RT <
> > > > > > > > > > met_help at ucar.edu
> > > > > > > > > > > >
> > > > > > > > > > > > > wrote:
> > > > > > > > > > > > >
> > > > > > > > > > > > >>
> > > > > > > > > > > > >> <URL: https://rt.rap.ucar.edu/rt/Tic
> > > > > > ket/Display.html?id=70551
> > > > > > > >
> > > > > > > > > > > > >>
> > > > > > > > > > > > >> Julie,
> > > > > > > > > > > > >> Thank you very much for your assistance. I
failed
> to
> > > > > install
> > > > > > > > Cairo
> > > > > > > > > > and
> > > > > > > > > > > > >> freetype because of the dependencies. I
will try
> > again
> > > > > with
> > > > > > > the
> > > > > > > > > > links
> > > > > > > > > > > > >> you sent me.
> > > > > > > > > > > > >> Please find attached my config.log and
> > > make-install.log.
> > > > > > > > > > > > >>
> > > > > > > > > > > > >>
> > > > > > > > > > > > >> On 2/2/15, Julie Prestopnik via RT <
> > met_help at ucar.edu
> > > >
> > > > > > wrote:
> > > > > > > > > > > > >> > I'm so glad you were able to get MET
installed
> and
> > > > that
> > > > > > you
> > > > > > > > > worked
> > > > > > > > > > > out
> > > > > > > > > > > > >> the
> > > > > > > > > > > > >> > issue with the NetCDF environment
variables.
> > > > > > > > > > > > >> >
> > > > > > > > > > > > >> > You mentioned that three executables did
not
> > > build.  I
> > > > > > would
> > > > > > > > > like
> > > > > > > > > > to
> > > > > > > > > > > > >> > try
> > > > > > > > > > > > >> to
> > > > > > > > > > > > >> > help with those.  The modis_regrid tool
has
> > library
> > > > > > > > > dependencies -
> > > > > > > > > > > it
> > > > > > > > > > > > >> > requires the HDF4 and HDF-EOS2 libraries.
The
> > > > > > > plot_mode_field
> > > > > > > > > > tool
> > > > > > > > > > > > >> > also
> > > > > > > > > > > > >> > has library dependencies - it requires
the Cairo
> > and
> > > > > > > FreeType
> > > > > > > > > > > > >> > libraries.
> > > > > > > > > > > > >> >
> > > > > > > > > > > > >> > You can find information on compiling
each of
> > those
> > > > > > library
> > > > > > > > > > > > >> > dependencies
> > > > > > > > > > > > >> > here:
> > > > > > > > > > > > >> >
> > > > > > > > > > > > >>
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > > > >> >
> > > > > > > > > > > > >> > You can find information on setting the
up
> > necessary
> > > > > > > > environment
> > > > > > > > > > > > >> variables
> > > > > > > > > > > > >> > for those library locations here:
> > > > > > > > > > > > >> >
> > > > > > > > > > > > >>
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > > METv5.0/compilation/configure.php
> > > > > > > > > > > > >> >
> > > > > > > > > > > > >> > And with pb2nc, I'm not exactly sure what
is
> going
> > > on
> > > > > > there.
> > > > > > > > I
> > > > > > > > > > > would
> > > > > > > > > > > > >> > be
> > > > > > > > > > > > >> > happy to take a look at your configure
log and
> > make
> > > > > > install
> > > > > > > > log
> > > > > > > > > > > files
> > > > > > > > > > > > >> > to
> > > > > > > > > > > > >> > see if I can figure out why you didn't
get the
> > > > > executable.
> > > > > > > > > > > > >> >
> > > > > > > > > > > > >> > I hope this helps.
> > > > > > > > > > > > >> >
> > > > > > > > > > > > >> > Thanks,
> > > > > > > > > > > > >> > Julie
> > > > > > > > > > > > >> >
> > > > > > > > > > > > >> >
> > > > > > > > > > > > >> >
> > > > > > > > > > > > >> > On Sat, Jan 31, 2015 at 5:31 PM, Zilore
Mumba
> via
> > RT
> > > > > > > > > > > > >> > <met_help at ucar.edu>
> > > > > > > > > > > > >> > wrote:
> > > > > > > > > > > > >> >
> > > > > > > > > > > > >> >>
> > > > > > > > > > > > >> >> <URL:
> > > > > > > >
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > > > > > > > >
> > > > > > > > > > > > >> >>
> > > > > > > > > > > > >> >> Julg
> > > > > > > > > > > > >> >> Thank you very much for your help. With
the
> > advice
> > > > you
> > > > > > gave
> > > > > > > > > me, I
> > > > > > > > > > > was
> > > > > > > > > > > > >> >> able to install MET using gcc and
gfortran. I
> > also
> > > > had
> > > > > to
> > > > > > > to
> > > > > > > > > > point
> > > > > > > > > > > > >> >> $MET_NETCDFLIB and, $MET_NETCDFINC to
> > > > > > > > > /usr/local/netcdf-4.1.3/lib
> > > > > > > > > > > and
> > > > > > > > > > > > >> >> include. Previously I pointed only to
> > > > > > > > /usr/local/netcdf-4.1.3.
> > > > > > > > > > > > >> >> I have three executables not included
though,
> > these
> > > > are
> > > > > > > > > > > modis_regrid,
> > > > > > > > > > > > >> >> plot_mode_field and pb2nc.
> > > > > > > > > > > > >> >> Thank you very much.
> > > > > > > > > > > > >> >>
> > > > > > > > > > > > >> >>
> > > > > > > > > > > > >> >> On 1/29/15, Julie Prestopnik via RT <
> > > > met_help at ucar.edu
> > > > > >
> > > > > > > > wrote:
> > > > > > > > > > > > >> >> > I am sorry to hear that you are having
> problems
> > > > > > > installing
> > > > > > > > > > > METv5.0.
> > > > > > > > > > > > >> >> > I
> > > > > > > > > > > > >> >> > believe this error may have to do with
how
> you
> > > > > compiled
> > > > > > > > > > BUFRLIB.
> > > > > > > > > > > > >> >> > Please
> > > > > > > > > > > > >> >> > take a look at the sample commands for
> > compiling
> > > > > > BURFLIB
> > > > > > > on
> > > > > > > > > > this
> > > > > > > > > > > > >> >> > page:
> > > > > > > > > > > > >> >> >
> > > > > > > > > > > > >> >>
> > > > > > > > > > > > >>
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > > > >> >> >
> > > > > > > > > > > > >> >> > I believe that the *-fno-second-
underscore*
> > (GNU
> > > > > > > compilers)
> > > > > > > > > or
> > > > > > > > > > > > >> >> > *-Mnosecond_underscore* (PGI
compilers) will
> > fix
> > > > the
> > > > > > > error
> > > > > > > > > > you're
> > > > > > > > > > > > >> >> > seeing.
> > > > > > > > > > > > >> >> >
> > > > > > > > > > > > >> >> > I hope that helps.  If it doesn't,
please
> send
> > me
> > > > the
> > > > > > > files
> > > > > > > > > > > > >> >> "make_met.log"
> > > > > > > > > > > > >> >> > and "config.log".
> > > > > > > > > > > > >> >> >
> > > > > > > > > > > > >> >> > Thanks,
> > > > > > > > > > > > >> >> > Julie
> > > > > > > > > > > > >> >> >
> > > > > > > > > > > > >> >> >
> > > > > > > > > > > > >> >> > On Thu, Jan 29, 2015 at 3:48 AM,
Zilore Mumba
> > via
> > > > RT
> > > > > > > > > > > > >> >> > <met_help at ucar.edu>
> > > > > > > > > > > > >> >> > wrote:
> > > > > > > > > > > > >> >> >
> > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > >> >> >> Thu Jan 29 03:48:08 2015: Request
70551 was
> > > acted
> > > > > > upon.
> > > > > > > > > > > > >> >> >> Transaction: Ticket created by
> > zmumba at gmail.com
> > > > > > > > > > > > >> >> >>        Queue: met_help
> > > > > > > > > > > > >> >> >>      Subject: Problem compiling Met-
V5
> > > > > > > > > > > > >> >> >>        Owner: Nobody
> > > > > > > > > > > > >> >> >>   Requestors: zmumba at gmail.com
> > > > > > > > > > > > >> >> >>       Status: new
> > > > > > > > > > > > >> >> >>  Ticket <URL:
> > > > > > > > > > > > >> https://rt.rap.ucar.edu/rt/
> > > Ticket/Display.html?id=70551
> > > > > > > > > > > > >> >> >> >
> > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > >> >> >> I have installed BUFRLIB, GSL and
G2CLIB
> > > > > > > > > > > > >> >> >> But then how do I handle the errors
below in
> > > > > > installing
> > > > > > > > > > MET_V5?
> > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > >> >> >>
> > > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/numpbmsg.f:
> > 23:
> > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > >> >> >> reference to `ufbtab_'
> > > > > > > > > > > > >> >> >> openpb.o: In function `openpb_':
> > > > > > > > > > > > >> >> >>
> > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/openpb.f:21:
> > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > > > > > >> >> >>
> > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/openpb.f:22:
> > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > > > > > >> >> >> closepb.o: In function `closepb_':
> > > > > > > > > > > > >> >> >>
> > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/closepb.f:19:
> > > > > > > > > > > > >> undefined
> > > > > > > > > > > > >> >> >> reference to `closbf_'
> > > > > > > > > > > > >> >> >> readpb.o: In function `readpb_':
> > > > > > > > > > > > >> >> >>
> > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/readpb.f:82:
> > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > > >> >> >>
> > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/readpb.f:90:
> > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > > >> >> >>
> > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/readpb.f:94:
> > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > > >> >> >> dumppb.o: In function `readpbdump_':
> > > > > > > > > > > > >> >> >>
> > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:215:
> > > > > > > > > > > > >> undefined
> > > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > > >> >> >>
> > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:218:
> > > > > > > > > > > > >> undefined
> > > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > > >> >> >>
> > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:224:
> > > > > > > > > > > > >> undefined
> > > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > > >> >> >>
> > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:203:
> > > > > > > > > > > > >> undefined
> > > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > > >> >> >>
> > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:228:
> > > > > > > > > > > > >> undefined
> > > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > > >> >> >>
> > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:259:
> > > > > > > > > > > > >> undefined
> > > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > > >> >> >> dumppb.o: In function `dumppb_':
> > > > > > > > > > > > >> >> >>
> > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:56:
> > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > > > > > >> >> >>
> > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:57:
> > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > > > > > >> >> >> collect2: error: ld returned 1 exit
status
> > > > > > > > > > > > >> >> >> make[4]: *** [pb2nc] Error 1
> > > > > > > > > > > > >> >> >> make[4]: Leaving directory
> > > > > > > > > > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/
> > > tools/other/pb2nc'
> > > > > > > > > > > > >> >> >> make[3]: *** [install-recursive]
Error 1
> > > > > > > > > > > > >> >> >> make[3]: Leaving directory
> > > > > > > > > > > > >> >> >> `/home/zmumba/WRF/met-
5.0/src/tools/other'
> > > > > > > > > > > > >> >> >> make[2]: *** [install-recursive]
Error 1
> > > > > > > > > > > > >> >> >> make[2]: Leaving directory
> > > > > > > > > > `/home/zmumba/WRF/met-5.0/src/tools'
> > > > > > > > > > > > >> >> >> make[1]: *** [install-recursive]
Error 1
> > > > > > > > > > > > >> >> >> make[1]: Leaving directory
> > > > > > > `/home/zmumba/WRF/met-5.0/src'
> > > > > > > > > > > > >> >> >> make: *** [install-recursive] Error 1
> > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > >> >> >
> > > > > > > > > > > > >> >> >
> > > > > > > > > > > > >> >> > --
> > > > > > > > > > > > >> >> > Julie Prestopnik
> > > > > > > > > > > > >> >> > National Center for Atmospheric
Research
> > > > > > > > > > > > >> >> > Research Applications Laboratory
> > > > > > > > > > > > >> >> > Phone: 303.497.8399 <%28303%29%20497-
8399>
> > > > > > > > > > > > >> >> > Email: jpresto at ucar.edu
> > > > > > > > > > > > >> >> >
> > > > > > > > > > > > >> >> >
> > > > > > > > > > > > >> >>
> > > > > > > > > > > > >> >>
> > > > > > > > > > > > >> >
> > > > > > > > > > > > >> >
> > > > > > > > > > > > >> > --
> > > > > > > > > > > > >> > Julie Prestopnik
> > > > > > > > > > > > >> > National Center for Atmospheric Research
> > > > > > > > > > > > >> > Research Applications Laboratory
> > > > > > > > > > > > >> > Phone: 303.497.8399
> > > > > > > > > > > > >> > Email: jpresto at ucar.edu
> > > > > > > > > > > > >> >
> > > > > > > > > > > > >> >
> > > > > > > > > > > > >>
> > > > > > > > > > > > >>
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > > --
> > > > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > --
> > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > --
> > > > > > > > > Julie Prestopnik
> > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > Research Applications Laboratory
> > > > > > > > > Phone: 303.497.8399
> > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > --
> > > > > > > Julie Prestopnik
> > > > > > > National Center for Atmospheric Research
> > > > > > > Research Applications Laboratory
> > > > > > > Phone: 303.497.8399
> > > > > > > Email: jpresto at ucar.edu
> > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> >
> >
>
>

------------------------------------------------
Subject: Problem compiling Met-V5
From: Julie Prestopnik
Time: Thu Apr 27 13:09:37 2017

Hi Zilore.

I just wanted to touch base and see if you were able to resolve the
problem.  Please let us know if you need further assistance.

Thanks,
Julie

On Tue, Apr 11, 2017 at 4:12 PM, Zilore Mumba via RT
<met_help at ucar.edu>
wrote:

>
> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
>
> Julie,
> Thanks once again for your time. My apologies, because in the
environmental
> variable I put "/usr/local/MET6" while as the directory I created
was
> "/usr/local/met6", i.e. met capitalized. When I do "ll
$MET_NETCDFINC" I
> can see the include files, including "netcdf".
> But am getting the same error. Let me work over it. I will get back
to you
> if I fail or succeed.
> Best regards
> Zilore
>
> On Tue, Apr 11, 2017 at 9:52 PM, Julie Prestopnik via RT <
> met_help at ucar.edu>
> wrote:
>
> > Hi Zilore.
> >
> > In your config.log file, it appears that you do not have your MET
> > environment variables set up.  The MET build process uses
environment
> > variables to specify the locations of the needed external
libraries.
> >
> > The following page describes the MET environment variables that
you will
> > need to set up in your .cshrc or equivalent file:
> >
> > http://www.dtcenter.org/met/users/support/online_tutorial/
> > METv6.0/tutorial.php?name=compilation&category=configure
> >
> > The error you are getting:
> >
> > In file included from nc_var_info.cc:24:0:
> > nc_utils.h:22:18: fatal error: netcdf: No such file or directory
> >
> > seems to imply that MET doesn't know where to find the file
"netcdf",
> which
> > is included in the NetCDF-CXX installation.  It could be that
NetCDF-CXX
> is
> > installed and that file does exist, but MET just doesn't know
where to
> find
> > it.  Setting those environment variables will help MET know where
those
> > required libraries and include files are.
> >
> > Here is a quick reference checklist for NetCDF4C++ installation
that you
> > can use to see if you have the necessary files:
> >
> > Files for NetCDF4 C:
> >
> >    - $MET_NETCDF/include/netcdf.h
> >    - $MET_NETCDF/lib/libnetcdf.a
> >    - $MET_NETCDF/lib/libnetcdf.so
> >
> > Files for NetCDF4 C++:
> >
> >    - $MET_NETCDF/include/netcdf
> >    - $MET_NETCDF/lib/libnetcdf_c++4.a
> >    - $MET_NETCDF/lib/libnetcdf_c++4.so
> >
> > Files for NetCDF3 C++ (not required, if --disabled-netcdf4 is
activated):
> >
> >    - $MET_NETCDF/include/netcdf.hh
> >    - $MET_NETCDF/lib/libnetcdf_c++.a
> >    - $MET_NETCDF/lib/libnetcdf_c++.so
> >
> > Please follow the instructions on the webpage above to set up the
> necessary
> > environment variables, then please reconfigure and recompile MET
and let
> us
> > know if you encounter further difficulty.
> >
> > I hope this helps!
> >
> > Thanks!
> >
> > Julie
> >
> > On Tue, Apr 11, 2017 at 1:22 PM, Zilore Mumba via RT
<met_help at ucar.edu>
> > wrote:
> >
> > >
> > > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > >
> > > Julie,
> > > Please find attached to this mail, my config.log and make-
install.log.
> > >
> > > On Tue, Apr 11, 2017 at 4:29 PM, Julie Prestopnik via RT <
> > > met_help at ucar.edu>
> > > wrote:
> > >
> > > > Hi Zilore.  I'm sorry to hear that you are still experiencing
> problems.
> > > > Could you please send your most recent configure.log and
> > make_install.log
> > > > files?
> > > >
> > > > Thanks!
> > > >
> > > > Julie
> > > >
> > > > On Tue, Apr 11, 2017 at 8:13 AM, Zilore Mumba via RT <
> > met_help at ucar.edu>
> > > > wrote:
> > > >
> > > > >
> > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > > > >
> > > > > Julie,
> > > > > Thanks very much for all the details you provided.
> > > > > However, am still getting the same error, i.e.
> > > > > The file "nc_var_info.cc" (i.e. #include on line 24) calls
> > > "nc_utils.h".
> > > > > Now the latter file has "#include netcdf" on line 22. It is
this
> > netcdf
> > > > it
> > > > > is saying no such file.
> > > > >
> > > > > I believe my setup is ok.
> > > > > Using the lines you gave me on installing the hdf5 and
netcdf
> > > libraries,
> > > > if
> > > > > I use prefix=${MET_LIB_DIR}, I am not able to find where the
> > libraries
> > > > are
> > > > > installed, though there are no errors indicated. I tried to
set
> > "export
> > > > > MET_LIB_DIR=/usr/local/met6" and alternatively "export
> > > > MET_LIB_DIR=~/met6"
> > > > > after creating the met6 directory in each case.
> > > > > But putting prefix=/usr/local/met6, I get both netcdf-c and
> > netcdf-cxx
> > > > > libraries in /usr/local/met6/lib, include files in
> > > > /usr/local/met6/include,
> > > > > and some executables in /usr/local/met6/bin as well as an
hdf5
> > > directory.
> > > > > So am wondering if the include file nc_utils.h has the
correct
> entry
> > on
> > > > > line 22.
> > > > > Thanks for your time and effort
> > > > > Zilore
> > > > >
> > > > > On Mon, Apr 10, 2017 at 5:40 PM, Julie Prestopnik via RT <
> > > > > met_help at ucar.edu>
> > > > > wrote:
> > > > >
> > > > > > Hi Zilore.  In 6.0 we've made a large change from using
NetCDF 3
> to
> > > 4.
> > > > > > You'll need to have both NetCDF 4 and HDF5, upon which
NetCDF 4
> is
> > > > built,
> > > > > > installed.
> > > > > >
> > > > > > Please feel free to take a look at the MET User's Guide
and the
> > > online
> > > > > > tutorial:
> > > > > > http://www.dtcenter.org/met/users/docs/users_guide/MET_
> > > > > > Users_Guide_v6.0.pdf
> > > > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > METv6.0/tutorial.php?name=compilation&category=req_libs
> > > > > >
> > > > > > There is an additional environment variable that will need
to be
> > set,
> > > > > with
> > > > > > the addition of HDF5:
> > > > > > Set *$MET_HDF5* to point to the main HDF5 directory.
> > > > > >
> > > > > > Also, both the NetCDF-C package (netcdf-c-4.4.1.1) and the
> > NetCDF-CXX
> > > > > > package (netcdf-cxx4-4.3.0) are necessary.
> > > > > >
> > > > > > Here are the commands we've been using to compile these
packages
> > from
> > > > > > source.  The following assumes that you're using the GNU
> compilers
> > > and
> > > > > that
> > > > > > you've defined MET_LIB_DIR to point to your desired
installation
> > > > > directory:
> > > > > >
> > > > > > # Compilers
> > > > > >
> > > > > > setenv CC `which gcc`
> > > > > >
> > > > > > setenv CXX `which g++`
> > > > > >
> > > > > > setenv FC `which gfortran`
> > > > > > setenv F77 `which gfortran`
> > > > > >
> > > > > > # HDF5
> > > > > >
> > > > > > wget
> > > > > > https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.10/
> > > > > > hdf5-1.10.0-patch1/src/hdf5-1.10.0-patch1.tar
> > > > > >
> > > > > > tar -xvzf hdf5-1.10.0-patch1.tar
> > > > > >
> > > > > > cd hdf5-1.10.0-patch1
> > > > > >
> > > > > > ./configure --prefix=${MET_LIB_DIR}
> > > > > >
> > > > > > make install
> > > > > >
> > > > > > # NetCDF-C
> > > > > >
> > > > > > wget https://github.com/Unidata/netcdf-
c/archive/v4.4.1.1.zip
> > > > > >
> > > > > > unzip v4.4.1.1.zip
> > > > > >
> > > > > > cd netcdf-c-4.4.1.1
> > > > > >
> > > > > > ./configure --prefix=${MET_LIB_DIR} LDFLAGS=-
L${MET_LIB_DIR}/lib
> > > > > > CPPFLAGS=-I${MET_LIB_DIR}/include
> > > > > >
> > > > > > make install
> > > > > >
> > > > > >
> > > > > > # NetCDF-CXX
> > > > > >
> > > > > > wget https://github.com/Unidata/netcdf-
cxx4/archive/v4.3.0.
> tar.gz
> > > > > >
> > > > > > tar -xvzf v4.3.0.tar.gz
> > > > > >
> > > > > > cd netcdf-cxx4-4.3.0
> > > > > >
> > > > > > ./configure --prefix=${MET_LIB_DIR} LDFLAGS=-
L${MET_LIB_DIR}/lib
> > > > > > CPPFLAGS=-I${MET_LIB_DIR}/include
> > > > > > make install
> > > > > >
> > > > > >
> > > > > > I hope this helps!  Please let us know if you need further
> > > assistance.
> > > > > >
> > > > > > Thanks,
> > > > > > Julie
> > > > > >
> > > > > > On Sat, Apr 8, 2017 at 3:53 PM, Zilore Mumba via RT <
> > > met_help at ucar.edu
> > > > >
> > > > > > wrote:
> > > > > >
> > > > > > >
> > > > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> >
> > > > > > >
> > > > > > > Julie, I hope you are fine, and that I can still reach
you. In
> > > March
> > > > > 2015
> > > > > > > you helped me installing met_v5.0. I have now downloaded
v6.0
> > and I
> > > > am
> > > > > > > having a compilation error I do not seem to figure out.
> > > > > > > I believe I have installed all the libraries (and set
the
> > > environment
> > > > > > > variables correctly: BUFRLIB-v10-2-3, netcdf-4.4.1.1,
gsl-2.3,
> > > > > > > g2clib-1.6.0, freetype-2.7.1 andcairo-1.14.8.
> > > > > > > I also have zlib, jasper and libpng.
> > > > > > > My configure exits with exit code 0 which I understand
to be
> ok.
> > > > > However
> > > > > > my
> > > > > > > make install gives an error of not finding netcdf (as
you can
> see
> > > > from
> > > > > > > make-install.log). I do not understand which netcdf it
cannot
> > find.
> > > > > > > I hope you can assist.
> > > > > > > Zilore
> > > > > > >
> > > > > > > On Thu, Mar 5, 2015 at 7:59 PM, Julie Prestopnik via RT
<
> > > > > > met_help at ucar.edu
> > > > > > > >
> > > > > > > wrote:
> > > > > > >
> > > > > > > > Hi Zilore.  Thanks for sending your commands and log
files.
> > > > > > > >
> > > > > > > > Looking in "config.log" for the string "BUFRLIB", it
appears
> > that
> > > > you
> > > > > > did
> > > > > > > > not set the environment variable.
> > > > > > > >
> > > > > > > > The linker error occurs on line 1057 of
make_install.log.
> > > Looking
> > > > at
> > > > > > > that
> > > > > > > > line, we're telling the linker to look in the
following
> > > directories
> > > > > for
> > > > > > > the
> > > > > > > > file named "libbufr.a":
> > > > > > > >
> > > > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8
> > > > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../i386-linux-
gnu
> > > > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../../lib
> > > > > > > > -L/lib/i386-linux-gnu
> > > > > > > > -L/lib/../lib
> > > > > > > > -L/usr/lib/i386-linux-gnu
> > > > > > > > -L/usr/lib/../lib
> > > > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../..
> > > > > > > >
> > > > > > > > It must be finding libbufr.a in one of those
directories,
> > > otherwise
> > > > > we
> > > > > > > > would get an error about that.  I believe that the
version of
> > > > > libbufr.a
> > > > > > > it
> > > > > > > > is finding is not the version that you compiled using
the
> > > > > > "-DUNDERSCORE"
> > > > > > > > option.
> > > > > > > >
> > > > > > > > I was able to replicate your error by re-compiling a
version
> of
> > > > > BUFRLIB
> > > > > > > > *without* -DUNDERSCORE, and then by building MET
linking to
> > that
> > > > bad
> > > > > > > > version.
> > > > > > > >
> > > > > > > > What you'll need to do is set the MET_BUFRLIB
environment
> > > variable
> > > > as
> > > > > > > > indicated on this page:
> > > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > > > METv5.0/compilation/configure.php
> > > > > > > >
> > > > > > > > Then source your .cshrc or equivalent file, then run
your
> > > configure
> > > > > > > > command, and then run make install and make test.
> > > > > > > >
> > > > > > > > Please give that a try.  It should solve the problem
you are
> > > > > > > encountering.
> > > > > > > >
> > > > > > > > Thanks,
> > > > > > > > Julie
> > > > > > > >
> > > > > > > > On Wed, Mar 4, 2015 at 5:36 AM, Zilore Mumba via RT <
> > > > > met_help at ucar.edu
> > > > > > >
> > > > > > > > wrote:
> > > > > > > >
> > > > > > > > >
> > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > Ticket/Display.html?id=70551
> > > >
> > > > > > > > >
> > > > > > > > > *Julie, I installed with the following commands. gcc
-c
> > > > > -DUNDERSCORE
> > > > > > > *.c*
> > > > > > > > >    *gfortran -c -DUNDERSCORE -fno-second-underscore
*.f
> *.F*
> > > > > > > > >    *ar crv libbufr.a *.o*
> > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > *Please find attached the config.log and
make_install.log *
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > On Tue, Mar 3, 2015 at 7:10 PM, Julie Prestopnik via
RT <
> > > > > > > > met_help at ucar.edu
> > > > > > > > > >
> > > > > > > > > wrote:
> > > > > > > > >
> > > > > > > > > > I'm sorry to hear that you are still experiencing
> problems
> > > > > > installing
> > > > > > > > > > METv5.0.
> > > > > > > > > >
> > > > > > > > > > Specifically regarding BUFRLIB, please compile it
using
> the
> > > > > options
> > > > > > > > > listed
> > > > > > > > > > on this page:
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > >
> > > > > > > > > > Failing to use the "-DUNDERSCORE -fno-second-
underscore"
> > (for
> > > > GNU
> > > > > > > > > > compilers) options will result in undefined
references
> when
> > > > > > building
> > > > > > > > the
> > > > > > > > > > pb2nc tool.
> > > > > > > > > >
> > > > > > > > > > If you'd like to send us the output of make please
do the
> > > > > > following:
> > > > > > > > > >    make clean
> > > > > > > > > >    make install >& make_install.log
> > > > > > > > > >
> > > > > > > > > > And then send us the files "config.log" and
> > > "make_install.log".
> > > > > > > > > >
> > > > > > > > > > I hope you'll find what you have been able to
install
> > useful.
> > > > > > Please
> > > > > > > > let
> > > > > > > > > > us know if you have any questions.
> > > > > > > > > >
> > > > > > > > > > Thanks,
> > > > > > > > > > Julie
> > > > > > > > > >
> > > > > > > > > > On Tue, Mar 3, 2015 at 12:26 AM, Zilore Mumba via
RT <
> > > > > > > > met_help at ucar.edu>
> > > > > > > > > > wrote:
> > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > > Ticket/Display.html?id=70551
> > > > > >
> > > > > > > > > > >
> > > > > > > > > > > Julie,
> > > > > > > > > > > I did not inform you of the conclusion of my
attempt to
> > > > install
> > > > > > > > > Met-5.1.
> > > > > > > > > > > After making many attempts in
> reinstalling/reconfiguring
> > > > > BUFRLIB
> > > > > > i
> > > > > > > > > still
> > > > > > > > > > > get errors relating to "undefined reference to
..." and
> > > > > > eventually
> > > > > > > I
> > > > > > > > > > still
> > > > > > > > > > > have 3 executables not installed: pb2nc,
modis_regrid,
> > > > > > > > plot_mode_field.
> > > > > > > > > > > I would like to learn how to use what I have and
come
> > back
> > > > > later
> > > > > > to
> > > > > > > > > pb2nc
> > > > > > > > > > > if necessary. I will inform you if I have any
other
> > > problems.
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > On Tue, Feb 10, 2015 at 7:12 PM, Julie
Prestopnik via
> RT
> > <
> > > > > > > > > > > met_help at ucar.edu>
> > > > > > > > > > > wrote:
> > > > > > > > > > >
> > > > > > > > > > > > Thank you for rerunning and sending this log.
> Perhaps
> > > MET
> > > > > > cannot
> > > > > > > > > find
> > > > > > > > > > > the
> > > > > > > > > > > > BUFR library.
> > > > > > > > > > > >
> > > > > > > > > > > > On the following page are directions for
setting the
> > > > > > environment
> > > > > > > > > > > variables
> > > > > > > > > > > > before compiling MET:
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > > > METv5.0/compilation/configure.php
> > > > > > > > > > > >
> > > > > > > > > > > > The rest of the applications built, so it
looks like
> > MET
> > > > was
> > > > > > able
> > > > > > > > to
> > > > > > > > > > find
> > > > > > > > > > > > the other needed libraries.  The directions
for the
> > BUFR
> > > > > > > > environment
> > > > > > > > > > > > variable on the above page are:
> > > > > > > > > > > >
> > > > > > > > > > > > "Set *$MET_BUFR* to point to the main BUFR
directory,
> > or
> > > > set
> > > > > > > > > > > *$MET_BUFRLIB*
> > > > > > > > > > > > to point to the directory with the BUFR
library
> files.
> > > > > Because
> > > > > > > MET
> > > > > > > > > > > doesn't
> > > > > > > > > > > > use any BUFR library include files, you don't
need to
> > > > specify
> > > > > > > > > > > > *$MET_BUFRINC*
> > > > > > > > > > > > ."
> > > > > > > > > > > >
> > > > > > > > > > > > Please try setting either *$MET_BUFR *or
> *$MET_BUFRLIB
> > > *and
> > > > > > then
> > > > > > > > > please
> > > > > > > > > > > > rerun the configure script and then rerun make
> install.
> > > It
> > > > > is
> > > > > > > > > > important
> > > > > > > > > > > to
> > > > > > > > > > > > rerun configure before rerunning make install.
> > > > > > > > > > > >
> > > > > > > > > > > > Please let me know how it goes.
> > > > > > > > > > > >
> > > > > > > > > > > > Thanks,
> > > > > > > > > > > > Julie
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > On Sat, Feb 7, 2015 at 9:36 PM, Zilore Mumba
via RT <
> > > > > > > > > met_help at ucar.edu
> > > > > > > > > > >
> > > > > > > > > > > > wrote:
> > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > > > > Ticket/Display.html?id=70551
> > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > > Julie,
> > > > > > > > > > > > > Attached to this mail, please find the file
> > > > > make-install.log.
> > > > > > > It
> > > > > > > > > does
> > > > > > > > > > > > > show 'undefined reference' to some
functions. I
> hope
> > > this
> > > > > > means
> > > > > > > > > > > > > something to you and that you can help.
> > > > > > > > > > > > > Thanks in advance
> > > > > > > > > > > > > Zilore
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > > On 2/5/15, Julie Prestopnik via RT <
> > met_help at ucar.edu>
> > > > > > wrote:
> > > > > > > > > > > > > > Thank you for attaching your log files.  I
did
> not
> > > see
> > > > > any
> > > > > > > > errors
> > > > > > > > > > in
> > > > > > > > > > > > your
> > > > > > > > > > > > > > make-install.log.  Perhaps you ran make
install
> in
> > > the
> > > > > > > > following
> > > > > > > > > > way:
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > make install > make-install.log
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > This would catch standard out but not
standard
> > error.
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > Could you please try running in the
following way
> > > with
> > > > > the
> > > > > > &,
> > > > > > > > > which
> > > > > > > > > > > > will
> > > > > > > > > > > > > > also capture standard error?
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > make install >& make-install.log
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > And, then please send me the output of
that log.
> > > Thank
> > > > > > you!
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > Julie
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > On Tue, Feb 3, 2015 at 2:08 PM, Zilore
Mumba via
> > RT <
> > > > > > > > > > > met_help at ucar.edu
> > > > > > > > > > > > >
> > > > > > > > > > > > > > wrote:
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >>
> > > > > > > > > > > > > >> <URL: https://rt.rap.ucar.edu/rt/Tic
> > > > > > > ket/Display.html?id=70551
> > > > > > > > >
> > > > > > > > > > > > > >>
> > > > > > > > > > > > > >> Julie,
> > > > > > > > > > > > > >> Thank you very much for your assistance.
I
> failed
> > to
> > > > > > install
> > > > > > > > > Cairo
> > > > > > > > > > > and
> > > > > > > > > > > > > >> freetype because of the dependencies. I
will try
> > > again
> > > > > > with
> > > > > > > > the
> > > > > > > > > > > links
> > > > > > > > > > > > > >> you sent me.
> > > > > > > > > > > > > >> Please find attached my config.log and
> > > > make-install.log.
> > > > > > > > > > > > > >>
> > > > > > > > > > > > > >>
> > > > > > > > > > > > > >> On 2/2/15, Julie Prestopnik via RT <
> > > met_help at ucar.edu
> > > > >
> > > > > > > wrote:
> > > > > > > > > > > > > >> > I'm so glad you were able to get MET
installed
> > and
> > > > > that
> > > > > > > you
> > > > > > > > > > worked
> > > > > > > > > > > > out
> > > > > > > > > > > > > >> the
> > > > > > > > > > > > > >> > issue with the NetCDF environment
variables.
> > > > > > > > > > > > > >> >
> > > > > > > > > > > > > >> > You mentioned that three executables
did not
> > > > build.  I
> > > > > > > would
> > > > > > > > > > like
> > > > > > > > > > > to
> > > > > > > > > > > > > >> > try
> > > > > > > > > > > > > >> to
> > > > > > > > > > > > > >> > help with those.  The modis_regrid tool
has
> > > library
> > > > > > > > > > dependencies -
> > > > > > > > > > > > it
> > > > > > > > > > > > > >> > requires the HDF4 and HDF-EOS2
libraries.  The
> > > > > > > > plot_mode_field
> > > > > > > > > > > tool
> > > > > > > > > > > > > >> > also
> > > > > > > > > > > > > >> > has library dependencies - it requires
the
> Cairo
> > > and
> > > > > > > > FreeType
> > > > > > > > > > > > > >> > libraries.
> > > > > > > > > > > > > >> >
> > > > > > > > > > > > > >> > You can find information on compiling
each of
> > > those
> > > > > > > library
> > > > > > > > > > > > > >> > dependencies
> > > > > > > > > > > > > >> > here:
> > > > > > > > > > > > > >> >
> > > > > > > > > > > > > >>
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > > > > >> >
> > > > > > > > > > > > > >> > You can find information on setting the
up
> > > necessary
> > > > > > > > > environment
> > > > > > > > > > > > > >> variables
> > > > > > > > > > > > > >> > for those library locations here:
> > > > > > > > > > > > > >> >
> > > > > > > > > > > > > >>
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > > > METv5.0/compilation/configure.php
> > > > > > > > > > > > > >> >
> > > > > > > > > > > > > >> > And with pb2nc, I'm not exactly sure
what is
> > going
> > > > on
> > > > > > > there.
> > > > > > > > > I
> > > > > > > > > > > > would
> > > > > > > > > > > > > >> > be
> > > > > > > > > > > > > >> > happy to take a look at your configure
log and
> > > make
> > > > > > > install
> > > > > > > > > log
> > > > > > > > > > > > files
> > > > > > > > > > > > > >> > to
> > > > > > > > > > > > > >> > see if I can figure out why you didn't
get the
> > > > > > executable.
> > > > > > > > > > > > > >> >
> > > > > > > > > > > > > >> > I hope this helps.
> > > > > > > > > > > > > >> >
> > > > > > > > > > > > > >> > Thanks,
> > > > > > > > > > > > > >> > Julie
> > > > > > > > > > > > > >> >
> > > > > > > > > > > > > >> >
> > > > > > > > > > > > > >> >
> > > > > > > > > > > > > >> > On Sat, Jan 31, 2015 at 5:31 PM, Zilore
Mumba
> > via
> > > RT
> > > > > > > > > > > > > >> > <met_help at ucar.edu>
> > > > > > > > > > > > > >> > wrote:
> > > > > > > > > > > > > >> >
> > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > >> >> <URL:
> > > > > > > > >
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > > > > > > > > >
> > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > >> >> Julg
> > > > > > > > > > > > > >> >> Thank you very much for your help.
With the
> > > advice
> > > > > you
> > > > > > > gave
> > > > > > > > > > me, I
> > > > > > > > > > > > was
> > > > > > > > > > > > > >> >> able to install MET using gcc and
gfortran. I
> > > also
> > > > > had
> > > > > > to
> > > > > > > > to
> > > > > > > > > > > point
> > > > > > > > > > > > > >> >> $MET_NETCDFLIB and, $MET_NETCDFINC to
> > > > > > > > > > /usr/local/netcdf-4.1.3/lib
> > > > > > > > > > > > and
> > > > > > > > > > > > > >> >> include. Previously I pointed only to
> > > > > > > > > /usr/local/netcdf-4.1.3.
> > > > > > > > > > > > > >> >> I have three executables not included
though,
> > > these
> > > > > are
> > > > > > > > > > > > modis_regrid,
> > > > > > > > > > > > > >> >> plot_mode_field and pb2nc.
> > > > > > > > > > > > > >> >> Thank you very much.
> > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > >> >> On 1/29/15, Julie Prestopnik via RT <
> > > > > met_help at ucar.edu
> > > > > > >
> > > > > > > > > wrote:
> > > > > > > > > > > > > >> >> > I am sorry to hear that you are
having
> > problems
> > > > > > > > installing
> > > > > > > > > > > > METv5.0.
> > > > > > > > > > > > > >> >> > I
> > > > > > > > > > > > > >> >> > believe this error may have to do
with how
> > you
> > > > > > compiled
> > > > > > > > > > > BUFRLIB.
> > > > > > > > > > > > > >> >> > Please
> > > > > > > > > > > > > >> >> > take a look at the sample commands
for
> > > compiling
> > > > > > > BURFLIB
> > > > > > > > on
> > > > > > > > > > > this
> > > > > > > > > > > > > >> >> > page:
> > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > >>
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > >> >> > I believe that the *-fno-second-
underscore*
> > > (GNU
> > > > > > > > compilers)
> > > > > > > > > > or
> > > > > > > > > > > > > >> >> > *-Mnosecond_underscore* (PGI
compilers)
> will
> > > fix
> > > > > the
> > > > > > > > error
> > > > > > > > > > > you're
> > > > > > > > > > > > > >> >> > seeing.
> > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > >> >> > I hope that helps.  If it doesn't,
please
> > send
> > > me
> > > > > the
> > > > > > > > files
> > > > > > > > > > > > > >> >> "make_met.log"
> > > > > > > > > > > > > >> >> > and "config.log".
> > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > >> >> > Thanks,
> > > > > > > > > > > > > >> >> > Julie
> > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > >> >> > On Thu, Jan 29, 2015 at 3:48 AM,
Zilore
> Mumba
> > > via
> > > > > RT
> > > > > > > > > > > > > >> >> > <met_help at ucar.edu>
> > > > > > > > > > > > > >> >> > wrote:
> > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > >> >> >> Thu Jan 29 03:48:08 2015: Request
70551
> was
> > > > acted
> > > > > > > upon.
> > > > > > > > > > > > > >> >> >> Transaction: Ticket created by
> > > zmumba at gmail.com
> > > > > > > > > > > > > >> >> >>        Queue: met_help
> > > > > > > > > > > > > >> >> >>      Subject: Problem compiling
Met-V5
> > > > > > > > > > > > > >> >> >>        Owner: Nobody
> > > > > > > > > > > > > >> >> >>   Requestors: zmumba at gmail.com
> > > > > > > > > > > > > >> >> >>       Status: new
> > > > > > > > > > > > > >> >> >>  Ticket <URL:
> > > > > > > > > > > > > >> https://rt.rap.ucar.edu/rt/
> > > > Ticket/Display.html?id=70551
> > > > > > > > > > > > > >> >> >> >
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > >> >> >> I have installed BUFRLIB, GSL and
G2CLIB
> > > > > > > > > > > > > >> >> >> But then how do I handle the errors
below
> in
> > > > > > > installing
> > > > > > > > > > > MET_V5?
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> tools/other/pb2nc/numpbmsg.f:
> > > 23:
> > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > >> >> >> reference to `ufbtab_'
> > > > > > > > > > > > > >> >> >> openpb.o: In function `openpb_':
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> tools/other/pb2nc/openpb.f:21:
> > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> tools/other/pb2nc/openpb.f:22:
> > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > > > > > > >> >> >> closepb.o: In function `closepb_':
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/closepb.f:
> 19:
> > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > >> >> >> reference to `closbf_'
> > > > > > > > > > > > > >> >> >> readpb.o: In function `readpb_':
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> tools/other/pb2nc/readpb.f:82:
> > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> tools/other/pb2nc/readpb.f:90:
> > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> tools/other/pb2nc/readpb.f:94:
> > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > > > >> >> >> dumppb.o: In function
`readpbdump_':
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:
> 215:
> > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:
> 218:
> > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:
> 224:
> > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:
> 203:
> > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:
> 228:
> > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:
> 259:
> > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > > > >> >> >> dumppb.o: In function `dumppb_':
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> tools/other/pb2nc/dumppb.f:56:
> > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> tools/other/pb2nc/dumppb.f:57:
> > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > > > > > > >> >> >> collect2: error: ld returned 1 exit
status
> > > > > > > > > > > > > >> >> >> make[4]: *** [pb2nc] Error 1
> > > > > > > > > > > > > >> >> >> make[4]: Leaving directory
> > > > > > > > > > > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/
> > > > tools/other/pb2nc'
> > > > > > > > > > > > > >> >> >> make[3]: *** [install-recursive]
Error 1
> > > > > > > > > > > > > >> >> >> make[3]: Leaving directory
> > > > > > > > > > > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/
> tools/other'
> > > > > > > > > > > > > >> >> >> make[2]: *** [install-recursive]
Error 1
> > > > > > > > > > > > > >> >> >> make[2]: Leaving directory
> > > > > > > > > > > `/home/zmumba/WRF/met-5.0/src/tools'
> > > > > > > > > > > > > >> >> >> make[1]: *** [install-recursive]
Error 1
> > > > > > > > > > > > > >> >> >> make[1]: Leaving directory
> > > > > > > > `/home/zmumba/WRF/met-5.0/src'
> > > > > > > > > > > > > >> >> >> make: *** [install-recursive] Error
1
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > >> >> > --
> > > > > > > > > > > > > >> >> > Julie Prestopnik
> > > > > > > > > > > > > >> >> > National Center for Atmospheric
Research
> > > > > > > > > > > > > >> >> > Research Applications Laboratory
> > > > > > > > > > > > > >> >> > Phone: 303.497.8399
<%28303%29%20497-8399>
> > > > > > > > > > > > > >> >> > Email: jpresto at ucar.edu
> > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > >> >
> > > > > > > > > > > > > >> >
> > > > > > > > > > > > > >> > --
> > > > > > > > > > > > > >> > Julie Prestopnik
> > > > > > > > > > > > > >> > National Center for Atmospheric
Research
> > > > > > > > > > > > > >> > Research Applications Laboratory
> > > > > > > > > > > > > >> > Phone: 303.497.8399
> > > > > > > > > > > > > >> > Email: jpresto at ucar.edu
> > > > > > > > > > > > > >> >
> > > > > > > > > > > > > >> >
> > > > > > > > > > > > > >>
> > > > > > > > > > > > > >>
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > --
> > > > > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > --
> > > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > --
> > > > > > > > > > Julie Prestopnik
> > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > --
> > > > > > > > Julie Prestopnik
> > > > > > > > National Center for Atmospheric Research
> > > > > > > > Research Applications Laboratory
> > > > > > > > Phone: 303.497.8399
> > > > > > > > Email: jpresto at ucar.edu
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> >
> >
>
>

------------------------------------------------
Subject: Problem compiling Met-V5
From: Zilore Mumba
Time: Tue May 02 02:27:32 2017

Julie,
My apologies, since you sent me mail I had no access to Internet until
today.
I have not been able to install met-6.0. My problem seems to have got
worse.
I was trying to reorganize my installation by trying to install
everything
in /usr/local so that I do not have any complications of some
libraries not
being found.

I managed to install *gsl-2.3. T*he libraries are installed, though
make
check gives one failed test, *Makefile:750: recipe for target
'test-suite.log' failed* (and says See linalg/test-suite.log)

*I installed cairo-1.14.8* and *freetype-2.7.1* in their own
directories in
*/usr/loca*l, i.e. */usr/loca*l/cairo and */usr/loca*l/freetype.
Howver
trtying to reinstall these in */usr/loca*l I am now getting a lot of
c++
style comment problems. I have to work this out.

Then I copied BUFRLIB_v10-2-3.tar to /usr/local, untarred it in that
directory.
Running:
*preproc.sh*,
*gcc -c -DUNDERSCORE *.c,*
*gfortran -c -DUNDERSCORE -fno-second-underscore *.f *.F*
*/usr/loca*l
*gives the errors in the files attached*

*.*
*I am not sure if I should just copy **g2clib** into** /usr/local.
**There
are no instructions on how to install, but it has *

*libg2c.a*

*So currently am still looking at all these issues. Perhaps you can
assist
me on BUFRLIB. What am I doing wrong? Previously I have not had any
problem.*

*Best Regards*
*Zilore*

On Thu, Apr 27, 2017 at 9:09 PM, Julie Prestopnik via RT
<met_help at ucar.edu>
wrote:

> Hi Zilore.
>
> I just wanted to touch base and see if you were able to resolve the
> problem.  Please let us know if you need further assistance.
>
> Thanks,
> Julie
>
> On Tue, Apr 11, 2017 at 4:12 PM, Zilore Mumba via RT
<met_help at ucar.edu>
> wrote:
>
> >
> > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> >
> > Julie,
> > Thanks once again for your time. My apologies, because in the
> environmental
> > variable I put "/usr/local/MET6" while as the directory I created
was
> > "/usr/local/met6", i.e. met capitalized. When I do "ll
$MET_NETCDFINC" I
> > can see the include files, including "netcdf".
> > But am getting the same error. Let me work over it. I will get
back to
> you
> > if I fail or succeed.
> > Best regards
> > Zilore
> >
> > On Tue, Apr 11, 2017 at 9:52 PM, Julie Prestopnik via RT <
> > met_help at ucar.edu>
> > wrote:
> >
> > > Hi Zilore.
> > >
> > > In your config.log file, it appears that you do not have your
MET
> > > environment variables set up.  The MET build process uses
environment
> > > variables to specify the locations of the needed external
libraries.
> > >
> > > The following page describes the MET environment variables that
you
> will
> > > need to set up in your .cshrc or equivalent file:
> > >
> > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > METv6.0/tutorial.php?name=compilation&category=configure
> > >
> > > The error you are getting:
> > >
> > > In file included from nc_var_info.cc:24:0:
> > > nc_utils.h:22:18: fatal error: netcdf: No such file or directory
> > >
> > > seems to imply that MET doesn't know where to find the file
"netcdf",
> > which
> > > is included in the NetCDF-CXX installation.  It could be that
> NetCDF-CXX
> > is
> > > installed and that file does exist, but MET just doesn't know
where to
> > find
> > > it.  Setting those environment variables will help MET know
where those
> > > required libraries and include files are.
> > >
> > > Here is a quick reference checklist for NetCDF4C++ installation
that
> you
> > > can use to see if you have the necessary files:
> > >
> > > Files for NetCDF4 C:
> > >
> > >    - $MET_NETCDF/include/netcdf.h
> > >    - $MET_NETCDF/lib/libnetcdf.a
> > >    - $MET_NETCDF/lib/libnetcdf.so
> > >
> > > Files for NetCDF4 C++:
> > >
> > >    - $MET_NETCDF/include/netcdf
> > >    - $MET_NETCDF/lib/libnetcdf_c++4.a
> > >    - $MET_NETCDF/lib/libnetcdf_c++4.so
> > >
> > > Files for NetCDF3 C++ (not required, if --disabled-netcdf4 is
> activated):
> > >
> > >    - $MET_NETCDF/include/netcdf.hh
> > >    - $MET_NETCDF/lib/libnetcdf_c++.a
> > >    - $MET_NETCDF/lib/libnetcdf_c++.so
> > >
> > > Please follow the instructions on the webpage above to set up
the
> > necessary
> > > environment variables, then please reconfigure and recompile MET
and
> let
> > us
> > > know if you encounter further difficulty.
> > >
> > > I hope this helps!
> > >
> > > Thanks!
> > >
> > > Julie
> > >
> > > On Tue, Apr 11, 2017 at 1:22 PM, Zilore Mumba via RT <
> met_help at ucar.edu>
> > > wrote:
> > >
> > > >
> > > > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
>
> > > >
> > > > Julie,
> > > > Please find attached to this mail, my config.log and
> make-install.log.
> > > >
> > > > On Tue, Apr 11, 2017 at 4:29 PM, Julie Prestopnik via RT <
> > > > met_help at ucar.edu>
> > > > wrote:
> > > >
> > > > > Hi Zilore.  I'm sorry to hear that you are still
experiencing
> > problems.
> > > > > Could you please send your most recent configure.log and
> > > make_install.log
> > > > > files?
> > > > >
> > > > > Thanks!
> > > > >
> > > > > Julie
> > > > >
> > > > > On Tue, Apr 11, 2017 at 8:13 AM, Zilore Mumba via RT <
> > > met_help at ucar.edu>
> > > > > wrote:
> > > > >
> > > > > >
> > > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > > > > >
> > > > > > Julie,
> > > > > > Thanks very much for all the details you provided.
> > > > > > However, am still getting the same error, i.e.
> > > > > > The file "nc_var_info.cc" (i.e. #include on line 24) calls
> > > > "nc_utils.h".
> > > > > > Now the latter file has "#include netcdf" on line 22. It
is this
> > > netcdf
> > > > > it
> > > > > > is saying no such file.
> > > > > >
> > > > > > I believe my setup is ok.
> > > > > > Using the lines you gave me on installing the hdf5 and
netcdf
> > > > libraries,
> > > > > if
> > > > > > I use prefix=${MET_LIB_DIR}, I am not able to find where
the
> > > libraries
> > > > > are
> > > > > > installed, though there are no errors indicated. I tried
to set
> > > "export
> > > > > > MET_LIB_DIR=/usr/local/met6" and alternatively "export
> > > > > MET_LIB_DIR=~/met6"
> > > > > > after creating the met6 directory in each case.
> > > > > > But putting prefix=/usr/local/met6, I get both netcdf-c
and
> > > netcdf-cxx
> > > > > > libraries in /usr/local/met6/lib, include files in
> > > > > /usr/local/met6/include,
> > > > > > and some executables in /usr/local/met6/bin as well as an
hdf5
> > > > directory.
> > > > > > So am wondering if the include file nc_utils.h has the
correct
> > entry
> > > on
> > > > > > line 22.
> > > > > > Thanks for your time and effort
> > > > > > Zilore
> > > > > >
> > > > > > On Mon, Apr 10, 2017 at 5:40 PM, Julie Prestopnik via RT <
> > > > > > met_help at ucar.edu>
> > > > > > wrote:
> > > > > >
> > > > > > > Hi Zilore.  In 6.0 we've made a large change from using
NetCDF
> 3
> > to
> > > > 4.
> > > > > > > You'll need to have both NetCDF 4 and HDF5, upon which
NetCDF 4
> > is
> > > > > built,
> > > > > > > installed.
> > > > > > >
> > > > > > > Please feel free to take a look at the MET User's Guide
and the
> > > > online
> > > > > > > tutorial:
> > > > > > > http://www.dtcenter.org/met/users/docs/users_guide/MET_
> > > > > > > Users_Guide_v6.0.pdf
> > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > > METv6.0/tutorial.php?name=compilation&category=req_libs
> > > > > > >
> > > > > > > There is an additional environment variable that will
need to
> be
> > > set,
> > > > > > with
> > > > > > > the addition of HDF5:
> > > > > > > Set *$MET_HDF5* to point to the main HDF5 directory.
> > > > > > >
> > > > > > > Also, both the NetCDF-C package (netcdf-c-4.4.1.1) and
the
> > > NetCDF-CXX
> > > > > > > package (netcdf-cxx4-4.3.0) are necessary.
> > > > > > >
> > > > > > > Here are the commands we've been using to compile these
> packages
> > > from
> > > > > > > source.  The following assumes that you're using the GNU
> > compilers
> > > > and
> > > > > > that
> > > > > > > you've defined MET_LIB_DIR to point to your desired
> installation
> > > > > > directory:
> > > > > > >
> > > > > > > # Compilers
> > > > > > >
> > > > > > > setenv CC `which gcc`
> > > > > > >
> > > > > > > setenv CXX `which g++`
> > > > > > >
> > > > > > > setenv FC `which gfortran`
> > > > > > > setenv F77 `which gfortran`
> > > > > > >
> > > > > > > # HDF5
> > > > > > >
> > > > > > > wget
> > > > > > > https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-
1.10/
> > > > > > > hdf5-1.10.0-patch1/src/hdf5-1.10.0-patch1.tar
> > > > > > >
> > > > > > > tar -xvzf hdf5-1.10.0-patch1.tar
> > > > > > >
> > > > > > > cd hdf5-1.10.0-patch1
> > > > > > >
> > > > > > > ./configure --prefix=${MET_LIB_DIR}
> > > > > > >
> > > > > > > make install
> > > > > > >
> > > > > > > # NetCDF-C
> > > > > > >
> > > > > > > wget https://github.com/Unidata/netcdf-
c/archive/v4.4.1.1.zip
> > > > > > >
> > > > > > > unzip v4.4.1.1.zip
> > > > > > >
> > > > > > > cd netcdf-c-4.4.1.1
> > > > > > >
> > > > > > > ./configure --prefix=${MET_LIB_DIR}
> LDFLAGS=-L${MET_LIB_DIR}/lib
> > > > > > > CPPFLAGS=-I${MET_LIB_DIR}/include
> > > > > > >
> > > > > > > make install
> > > > > > >
> > > > > > >
> > > > > > > # NetCDF-CXX
> > > > > > >
> > > > > > > wget https://github.com/Unidata/netcdf-
cxx4/archive/v4.3.0.
> > tar.gz
> > > > > > >
> > > > > > > tar -xvzf v4.3.0.tar.gz
> > > > > > >
> > > > > > > cd netcdf-cxx4-4.3.0
> > > > > > >
> > > > > > > ./configure --prefix=${MET_LIB_DIR}
> LDFLAGS=-L${MET_LIB_DIR}/lib
> > > > > > > CPPFLAGS=-I${MET_LIB_DIR}/include
> > > > > > > make install
> > > > > > >
> > > > > > >
> > > > > > > I hope this helps!  Please let us know if you need
further
> > > > assistance.
> > > > > > >
> > > > > > > Thanks,
> > > > > > > Julie
> > > > > > >
> > > > > > > On Sat, Apr 8, 2017 at 3:53 PM, Zilore Mumba via RT <
> > > > met_help at ucar.edu
> > > > > >
> > > > > > > wrote:
> > > > > > >
> > > > > > > >
> > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> Ticket/Display.html?id=70551
> > >
> > > > > > > >
> > > > > > > > Julie, I hope you are fine, and that I can still reach
you.
> In
> > > > March
> > > > > > 2015
> > > > > > > > you helped me installing met_v5.0. I have now
downloaded v6.0
> > > and I
> > > > > am
> > > > > > > > having a compilation error I do not seem to figure
out.
> > > > > > > > I believe I have installed all the libraries (and set
the
> > > > environment
> > > > > > > > variables correctly: BUFRLIB-v10-2-3, netcdf-4.4.1.1,
> gsl-2.3,
> > > > > > > > g2clib-1.6.0, freetype-2.7.1 andcairo-1.14.8.
> > > > > > > > I also have zlib, jasper and libpng.
> > > > > > > > My configure exits with exit code 0 which I understand
to be
> > ok.
> > > > > > However
> > > > > > > my
> > > > > > > > make install gives an error of not finding netcdf (as
you can
> > see
> > > > > from
> > > > > > > > make-install.log). I do not understand which netcdf it
cannot
> > > find.
> > > > > > > > I hope you can assist.
> > > > > > > > Zilore
> > > > > > > >
> > > > > > > > On Thu, Mar 5, 2015 at 7:59 PM, Julie Prestopnik via
RT <
> > > > > > > met_help at ucar.edu
> > > > > > > > >
> > > > > > > > wrote:
> > > > > > > >
> > > > > > > > > Hi Zilore.  Thanks for sending your commands and log
files.
> > > > > > > > >
> > > > > > > > > Looking in "config.log" for the string "BUFRLIB", it
> appears
> > > that
> > > > > you
> > > > > > > did
> > > > > > > > > not set the environment variable.
> > > > > > > > >
> > > > > > > > > The linker error occurs on line 1057 of
make_install.log.
> > > > Looking
> > > > > at
> > > > > > > > that
> > > > > > > > > line, we're telling the linker to look in the
following
> > > > directories
> > > > > > for
> > > > > > > > the
> > > > > > > > > file named "libbufr.a":
> > > > > > > > >
> > > > > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8
> > > > > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../i386-
linux-gnu
> > > > > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../../lib
> > > > > > > > > -L/lib/i386-linux-gnu
> > > > > > > > > -L/lib/../lib
> > > > > > > > > -L/usr/lib/i386-linux-gnu
> > > > > > > > > -L/usr/lib/../lib
> > > > > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../..
> > > > > > > > >
> > > > > > > > > It must be finding libbufr.a in one of those
directories,
> > > > otherwise
> > > > > > we
> > > > > > > > > would get an error about that.  I believe that the
version
> of
> > > > > > libbufr.a
> > > > > > > > it
> > > > > > > > > is finding is not the version that you compiled
using the
> > > > > > > "-DUNDERSCORE"
> > > > > > > > > option.
> > > > > > > > >
> > > > > > > > > I was able to replicate your error by re-compiling a
> version
> > of
> > > > > > BUFRLIB
> > > > > > > > > *without* -DUNDERSCORE, and then by building MET
linking to
> > > that
> > > > > bad
> > > > > > > > > version.
> > > > > > > > >
> > > > > > > > > What you'll need to do is set the MET_BUFRLIB
environment
> > > > variable
> > > > > as
> > > > > > > > > indicated on this page:
> > > > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > > > > METv5.0/compilation/configure.php
> > > > > > > > >
> > > > > > > > > Then source your .cshrc or equivalent file, then run
your
> > > > configure
> > > > > > > > > command, and then run make install and make test.
> > > > > > > > >
> > > > > > > > > Please give that a try.  It should solve the problem
you
> are
> > > > > > > > encountering.
> > > > > > > > >
> > > > > > > > > Thanks,
> > > > > > > > > Julie
> > > > > > > > >
> > > > > > > > > On Wed, Mar 4, 2015 at 5:36 AM, Zilore Mumba via RT
<
> > > > > > met_help at ucar.edu
> > > > > > > >
> > > > > > > > > wrote:
> > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > Ticket/Display.html?id=70551
> > > > >
> > > > > > > > > >
> > > > > > > > > > *Julie, I installed with the following commands.
gcc -c
> > > > > > -DUNDERSCORE
> > > > > > > > *.c*
> > > > > > > > > >    *gfortran -c -DUNDERSCORE -fno-second-
underscore *.f
> > *.F*
> > > > > > > > > >    *ar crv libbufr.a *.o*
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > *Please find attached the config.log and
> make_install.log *
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > On Tue, Mar 3, 2015 at 7:10 PM, Julie Prestopnik
via RT <
> > > > > > > > > met_help at ucar.edu
> > > > > > > > > > >
> > > > > > > > > > wrote:
> > > > > > > > > >
> > > > > > > > > > > I'm sorry to hear that you are still
experiencing
> > problems
> > > > > > > installing
> > > > > > > > > > > METv5.0.
> > > > > > > > > > >
> > > > > > > > > > > Specifically regarding BUFRLIB, please compile
it using
> > the
> > > > > > options
> > > > > > > > > > listed
> > > > > > > > > > > on this page:
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > http://www.dtcenter.org/met/
> users/support/online_tutorial/
> > > > > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > >
> > > > > > > > > > > Failing to use the "-DUNDERSCORE
> -fno-second-underscore"
> > > (for
> > > > > GNU
> > > > > > > > > > > compilers) options will result in undefined
references
> > when
> > > > > > > building
> > > > > > > > > the
> > > > > > > > > > > pb2nc tool.
> > > > > > > > > > >
> > > > > > > > > > > If you'd like to send us the output of make
please do
> the
> > > > > > > following:
> > > > > > > > > > >    make clean
> > > > > > > > > > >    make install >& make_install.log
> > > > > > > > > > >
> > > > > > > > > > > And then send us the files "config.log" and
> > > > "make_install.log".
> > > > > > > > > > >
> > > > > > > > > > > I hope you'll find what you have been able to
install
> > > useful.
> > > > > > > Please
> > > > > > > > > let
> > > > > > > > > > > us know if you have any questions.
> > > > > > > > > > >
> > > > > > > > > > > Thanks,
> > > > > > > > > > > Julie
> > > > > > > > > > >
> > > > > > > > > > > On Tue, Mar 3, 2015 at 12:26 AM, Zilore Mumba
via RT <
> > > > > > > > > met_help at ucar.edu>
> > > > > > > > > > > wrote:
> > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > > > Ticket/Display.html?id=70551
> > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > Julie,
> > > > > > > > > > > > I did not inform you of the conclusion of my
attempt
> to
> > > > > install
> > > > > > > > > > Met-5.1.
> > > > > > > > > > > > After making many attempts in
> > reinstalling/reconfiguring
> > > > > > BUFRLIB
> > > > > > > i
> > > > > > > > > > still
> > > > > > > > > > > > get errors relating to "undefined reference to
..."
> and
> > > > > > > eventually
> > > > > > > > I
> > > > > > > > > > > still
> > > > > > > > > > > > have 3 executables not installed: pb2nc,
> modis_regrid,
> > > > > > > > > plot_mode_field.
> > > > > > > > > > > > I would like to learn how to use what I have
and come
> > > back
> > > > > > later
> > > > > > > to
> > > > > > > > > > pb2nc
> > > > > > > > > > > > if necessary. I will inform you if I have any
other
> > > > problems.
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > On Tue, Feb 10, 2015 at 7:12 PM, Julie
Prestopnik via
> > RT
> > > <
> > > > > > > > > > > > met_help at ucar.edu>
> > > > > > > > > > > > wrote:
> > > > > > > > > > > >
> > > > > > > > > > > > > Thank you for rerunning and sending this
log.
> > Perhaps
> > > > MET
> > > > > > > cannot
> > > > > > > > > > find
> > > > > > > > > > > > the
> > > > > > > > > > > > > BUFR library.
> > > > > > > > > > > > >
> > > > > > > > > > > > > On the following page are directions for
setting
> the
> > > > > > > environment
> > > > > > > > > > > > variables
> > > > > > > > > > > > > before compiling MET:
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > http://www.dtcenter.org/met/
> users/support/online_tutorial/
> > > > > > > > > METv5.0/compilation/configure.php
> > > > > > > > > > > > >
> > > > > > > > > > > > > The rest of the applications built, so it
looks
> like
> > > MET
> > > > > was
> > > > > > > able
> > > > > > > > > to
> > > > > > > > > > > find
> > > > > > > > > > > > > the other needed libraries.  The directions
for the
> > > BUFR
> > > > > > > > > environment
> > > > > > > > > > > > > variable on the above page are:
> > > > > > > > > > > > >
> > > > > > > > > > > > > "Set *$MET_BUFR* to point to the main BUFR
> directory,
> > > or
> > > > > set
> > > > > > > > > > > > *$MET_BUFRLIB*
> > > > > > > > > > > > > to point to the directory with the BUFR
library
> > files.
> > > > > > Because
> > > > > > > > MET
> > > > > > > > > > > > doesn't
> > > > > > > > > > > > > use any BUFR library include files, you
don't need
> to
> > > > > specify
> > > > > > > > > > > > > *$MET_BUFRINC*
> > > > > > > > > > > > > ."
> > > > > > > > > > > > >
> > > > > > > > > > > > > Please try setting either *$MET_BUFR *or
> > *$MET_BUFRLIB
> > > > *and
> > > > > > > then
> > > > > > > > > > please
> > > > > > > > > > > > > rerun the configure script and then rerun
make
> > install.
> > > > It
> > > > > > is
> > > > > > > > > > > important
> > > > > > > > > > > > to
> > > > > > > > > > > > > rerun configure before rerunning make
install.
> > > > > > > > > > > > >
> > > > > > > > > > > > > Please let me know how it goes.
> > > > > > > > > > > > >
> > > > > > > > > > > > > Thanks,
> > > > > > > > > > > > > Julie
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > > On Sat, Feb 7, 2015 at 9:36 PM, Zilore Mumba
via
> RT <
> > > > > > > > > > met_help at ucar.edu
> > > > > > > > > > > >
> > > > > > > > > > > > > wrote:
> > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > > > > > Ticket/Display.html?id=70551
> > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > Julie,
> > > > > > > > > > > > > > Attached to this mail, please find the
file
> > > > > > make-install.log.
> > > > > > > > It
> > > > > > > > > > does
> > > > > > > > > > > > > > show 'undefined reference' to some
functions. I
> > hope
> > > > this
> > > > > > > means
> > > > > > > > > > > > > > something to you and that you can help.
> > > > > > > > > > > > > > Thanks in advance
> > > > > > > > > > > > > > Zilore
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > On 2/5/15, Julie Prestopnik via RT <
> > > met_help at ucar.edu>
> > > > > > > wrote:
> > > > > > > > > > > > > > > Thank you for attaching your log files.
I did
> > not
> > > > see
> > > > > > any
> > > > > > > > > errors
> > > > > > > > > > > in
> > > > > > > > > > > > > your
> > > > > > > > > > > > > > > make-install.log.  Perhaps you ran make
install
> > in
> > > > the
> > > > > > > > > following
> > > > > > > > > > > way:
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > make install > make-install.log
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > This would catch standard out but not
standard
> > > error.
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > Could you please try running in the
following
> way
> > > > with
> > > > > > the
> > > > > > > &,
> > > > > > > > > > which
> > > > > > > > > > > > > will
> > > > > > > > > > > > > > > also capture standard error?
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > make install >& make-install.log
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > And, then please send me the output of
that
> log.
> > > > Thank
> > > > > > > you!
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > Julie
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > On Tue, Feb 3, 2015 at 2:08 PM, Zilore
Mumba
> via
> > > RT <
> > > > > > > > > > > > met_help at ucar.edu
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > > wrote:
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > >> <URL: https://rt.rap.ucar.edu/rt/Tic
> > > > > > > > ket/Display.html?id=70551
> > > > > > > > > >
> > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > >> Julie,
> > > > > > > > > > > > > > >> Thank you very much for your
assistance. I
> > failed
> > > to
> > > > > > > install
> > > > > > > > > > Cairo
> > > > > > > > > > > > and
> > > > > > > > > > > > > > >> freetype because of the dependencies. I
will
> try
> > > > again
> > > > > > > with
> > > > > > > > > the
> > > > > > > > > > > > links
> > > > > > > > > > > > > > >> you sent me.
> > > > > > > > > > > > > > >> Please find attached my config.log and
> > > > > make-install.log.
> > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > >> On 2/2/15, Julie Prestopnik via RT <
> > > > met_help at ucar.edu
> > > > > >
> > > > > > > > wrote:
> > > > > > > > > > > > > > >> > I'm so glad you were able to get MET
> installed
> > > and
> > > > > > that
> > > > > > > > you
> > > > > > > > > > > worked
> > > > > > > > > > > > > out
> > > > > > > > > > > > > > >> the
> > > > > > > > > > > > > > >> > issue with the NetCDF environment
variables.
> > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > >> > You mentioned that three executables
did not
> > > > > build.  I
> > > > > > > > would
> > > > > > > > > > > like
> > > > > > > > > > > > to
> > > > > > > > > > > > > > >> > try
> > > > > > > > > > > > > > >> to
> > > > > > > > > > > > > > >> > help with those.  The modis_regrid
tool has
> > > > library
> > > > > > > > > > > dependencies -
> > > > > > > > > > > > > it
> > > > > > > > > > > > > > >> > requires the HDF4 and HDF-EOS2
libraries.
> The
> > > > > > > > > plot_mode_field
> > > > > > > > > > > > tool
> > > > > > > > > > > > > > >> > also
> > > > > > > > > > > > > > >> > has library dependencies - it
requires the
> > Cairo
> > > > and
> > > > > > > > > FreeType
> > > > > > > > > > > > > > >> > libraries.
> > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > >> > You can find information on compiling
each
> of
> > > > those
> > > > > > > > library
> > > > > > > > > > > > > > >> > dependencies
> > > > > > > > > > > > > > >> > here:
> > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > >>
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > http://www.dtcenter.org/met/
> users/support/online_tutorial/
> > > > > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > >> > You can find information on setting
the up
> > > > necessary
> > > > > > > > > > environment
> > > > > > > > > > > > > > >> variables
> > > > > > > > > > > > > > >> > for those library locations here:
> > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > >>
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > http://www.dtcenter.org/met/
> users/support/online_tutorial/
> > > > > > > > > METv5.0/compilation/configure.php
> > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > >> > And with pb2nc, I'm not exactly sure
what is
> > > going
> > > > > on
> > > > > > > > there.
> > > > > > > > > > I
> > > > > > > > > > > > > would
> > > > > > > > > > > > > > >> > be
> > > > > > > > > > > > > > >> > happy to take a look at your
configure log
> and
> > > > make
> > > > > > > > install
> > > > > > > > > > log
> > > > > > > > > > > > > files
> > > > > > > > > > > > > > >> > to
> > > > > > > > > > > > > > >> > see if I can figure out why you
didn't get
> the
> > > > > > > executable.
> > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > >> > I hope this helps.
> > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > >> > Thanks,
> > > > > > > > > > > > > > >> > Julie
> > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > >> > On Sat, Jan 31, 2015 at 5:31 PM,
Zilore
> Mumba
> > > via
> > > > RT
> > > > > > > > > > > > > > >> > <met_help at ucar.edu>
> > > > > > > > > > > > > > >> > wrote:
> > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > >> >> <URL:
> > > > > > > > > >
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> > > > > > > > > > > >
> > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > >> >> Julg
> > > > > > > > > > > > > > >> >> Thank you very much for your help.
With the
> > > > advice
> > > > > > you
> > > > > > > > gave
> > > > > > > > > > > me, I
> > > > > > > > > > > > > was
> > > > > > > > > > > > > > >> >> able to install MET using gcc and
> gfortran. I
> > > > also
> > > > > > had
> > > > > > > to
> > > > > > > > > to
> > > > > > > > > > > > point
> > > > > > > > > > > > > > >> >> $MET_NETCDFLIB and, $MET_NETCDFINC
to
> > > > > > > > > > > /usr/local/netcdf-4.1.3/lib
> > > > > > > > > > > > > and
> > > > > > > > > > > > > > >> >> include. Previously I pointed only
to
> > > > > > > > > > /usr/local/netcdf-4.1.3.
> > > > > > > > > > > > > > >> >> I have three executables not
included
> though,
> > > > these
> > > > > > are
> > > > > > > > > > > > > modis_regrid,
> > > > > > > > > > > > > > >> >> plot_mode_field and pb2nc.
> > > > > > > > > > > > > > >> >> Thank you very much.
> > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > >> >> On 1/29/15, Julie Prestopnik via RT
<
> > > > > > met_help at ucar.edu
> > > > > > > >
> > > > > > > > > > wrote:
> > > > > > > > > > > > > > >> >> > I am sorry to hear that you are
having
> > > problems
> > > > > > > > > installing
> > > > > > > > > > > > > METv5.0.
> > > > > > > > > > > > > > >> >> > I
> > > > > > > > > > > > > > >> >> > believe this error may have to do
with
> how
> > > you
> > > > > > > compiled
> > > > > > > > > > > > BUFRLIB.
> > > > > > > > > > > > > > >> >> > Please
> > > > > > > > > > > > > > >> >> > take a look at the sample commands
for
> > > > compiling
> > > > > > > > BURFLIB
> > > > > > > > > on
> > > > > > > > > > > > this
> > > > > > > > > > > > > > >> >> > page:
> > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > >>
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > http://www.dtcenter.org/met/
> users/support/online_tutorial/
> > > > > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > >> >> > I believe that the
> *-fno-second-underscore*
> > > > (GNU
> > > > > > > > > compilers)
> > > > > > > > > > > or
> > > > > > > > > > > > > > >> >> > *-Mnosecond_underscore* (PGI
compilers)
> > will
> > > > fix
> > > > > > the
> > > > > > > > > error
> > > > > > > > > > > > you're
> > > > > > > > > > > > > > >> >> > seeing.
> > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > >> >> > I hope that helps.  If it doesn't,
please
> > > send
> > > > me
> > > > > > the
> > > > > > > > > files
> > > > > > > > > > > > > > >> >> "make_met.log"
> > > > > > > > > > > > > > >> >> > and "config.log".
> > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > >> >> > Thanks,
> > > > > > > > > > > > > > >> >> > Julie
> > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > >> >> > On Thu, Jan 29, 2015 at 3:48 AM,
Zilore
> > Mumba
> > > > via
> > > > > > RT
> > > > > > > > > > > > > > >> >> > <met_help at ucar.edu>
> > > > > > > > > > > > > > >> >> > wrote:
> > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > >> >> >> Thu Jan 29 03:48:08 2015: Request
70551
> > was
> > > > > acted
> > > > > > > > upon.
> > > > > > > > > > > > > > >> >> >> Transaction: Ticket created by
> > > > zmumba at gmail.com
> > > > > > > > > > > > > > >> >> >>        Queue: met_help
> > > > > > > > > > > > > > >> >> >>      Subject: Problem compiling
Met-V5
> > > > > > > > > > > > > > >> >> >>        Owner: Nobody
> > > > > > > > > > > > > > >> >> >>   Requestors: zmumba at gmail.com
> > > > > > > > > > > > > > >> >> >>       Status: new
> > > > > > > > > > > > > > >> >> >>  Ticket <URL:
> > > > > > > > > > > > > > >> https://rt.rap.ucar.edu/rt/
> > > > > Ticket/Display.html?id=70551
> > > > > > > > > > > > > > >> >> >> >
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > >> >> >> I have installed BUFRLIB, GSL and
G2CLIB
> > > > > > > > > > > > > > >> >> >> But then how do I handle the
errors
> below
> > in
> > > > > > > > installing
> > > > > > > > > > > > MET_V5?
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > tools/other/pb2nc/numpbmsg.f:
> > > > 23:
> > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > >> >> >> reference to `ufbtab_'
> > > > > > > > > > > > > > >> >> >> openpb.o: In function `openpb_':
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > tools/other/pb2nc/openpb.f:21:
> > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > tools/other/pb2nc/openpb.f:22:
> > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > > > > > > > >> >> >> closepb.o: In function
`closepb_':
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> tools/other/pb2nc/closepb.f:
> > 19:
> > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > >> >> >> reference to `closbf_'
> > > > > > > > > > > > > > >> >> >> readpb.o: In function `readpb_':
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > tools/other/pb2nc/readpb.f:82:
> > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > tools/other/pb2nc/readpb.f:90:
> > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > tools/other/pb2nc/readpb.f:94:
> > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > > > > >> >> >> dumppb.o: In function
`readpbdump_':
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:
> > 215:
> > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:
> > 218:
> > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:
> > 224:
> > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:
> > 203:
> > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:
> > 228:
> > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > /home/zmumba/WRF/met-
5.0/src/tools/other/pb2nc/dumppb.f:
> > 259:
> > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > > > > >> >> >> dumppb.o: In function `dumppb_':
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > tools/other/pb2nc/dumppb.f:56:
> > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > tools/other/pb2nc/dumppb.f:57:
> > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > > > > > > > >> >> >> collect2: error: ld returned 1
exit
> status
> > > > > > > > > > > > > > >> >> >> make[4]: *** [pb2nc] Error 1
> > > > > > > > > > > > > > >> >> >> make[4]: Leaving directory
> > > > > > > > > > > > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/
> > > > > tools/other/pb2nc'
> > > > > > > > > > > > > > >> >> >> make[3]: *** [install-recursive]
Error 1
> > > > > > > > > > > > > > >> >> >> make[3]: Leaving directory
> > > > > > > > > > > > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/
> > tools/other'
> > > > > > > > > > > > > > >> >> >> make[2]: *** [install-recursive]
Error 1
> > > > > > > > > > > > > > >> >> >> make[2]: Leaving directory
> > > > > > > > > > > > `/home/zmumba/WRF/met-5.0/src/tools'
> > > > > > > > > > > > > > >> >> >> make[1]: *** [install-recursive]
Error 1
> > > > > > > > > > > > > > >> >> >> make[1]: Leaving directory
> > > > > > > > > `/home/zmumba/WRF/met-5.0/src'
> > > > > > > > > > > > > > >> >> >> make: *** [install-recursive]
Error 1
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > >> >> > --
> > > > > > > > > > > > > > >> >> > Julie Prestopnik
> > > > > > > > > > > > > > >> >> > National Center for Atmospheric
Research
> > > > > > > > > > > > > > >> >> > Research Applications Laboratory
> > > > > > > > > > > > > > >> >> > Phone: 303.497.8399
> <%28303%29%20497-8399>
> > > > > > > > > > > > > > >> >> > Email: jpresto at ucar.edu
> > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > >> > --
> > > > > > > > > > > > > > >> > Julie Prestopnik
> > > > > > > > > > > > > > >> > National Center for Atmospheric
Research
> > > > > > > > > > > > > > >> > Research Applications Laboratory
> > > > > > > > > > > > > > >> > Phone: 303.497.8399
> > > > > > > > > > > > > > >> > Email: jpresto at ucar.edu
> > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > --
> > > > > > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > > --
> > > > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > --
> > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > --
> > > > > > > > > Julie Prestopnik
> > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > Research Applications Laboratory
> > > > > > > > > Phone: 303.497.8399
> > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> >
> >
>
>

------------------------------------------------
Subject: Problem compiling Met-V5
From: Julie Prestopnik
Time: Tue May 02 09:25:10 2017

Hi Zilore.  No need to apologize.  I just wanted to check in, in case
you
still needed any help getting MET installed.

You should not need to reorganize your installation to put anything in
/usr/local/.  We should be able to tell MET where to find anything it
needs.

Do you already have successful installations of gsl, cairo, freetype,
and
bufrlib elsewhere?  If so, I would suggest we go ahead and use those
installations, telling MET where to find them.  I can help take you
through
that process.

Please let me know, and we can go from there.

Kind regards,
Julie

On Tue, May 2, 2017 at 2:27 AM, Zilore Mumba via RT
<met_help at ucar.edu>
wrote:

>
> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
>
> Julie,
> My apologies, since you sent me mail I had no access to Internet
until
> today.
> I have not been able to install met-6.0. My problem seems to have
got
> worse.
> I was trying to reorganize my installation by trying to install
everything
> in /usr/local so that I do not have any complications of some
libraries not
> being found.
>
> I managed to install *gsl-2.3. T*he libraries are installed, though
make
> check gives one failed test, *Makefile:750: recipe for target
> 'test-suite.log' failed* (and says See linalg/test-suite.log)
>
> *I installed cairo-1.14.8* and *freetype-2.7.1* in their own
directories in
> */usr/loca*l, i.e. */usr/loca*l/cairo and */usr/loca*l/freetype.
Howver
> trtying to reinstall these in */usr/loca*l I am now getting a lot of
c++
> style comment problems. I have to work this out.
>
> Then I copied BUFRLIB_v10-2-3.tar to /usr/local, untarred it in that
> directory.
> Running:
> *preproc.sh*,
> *gcc -c -DUNDERSCORE *.c,*
> *gfortran -c -DUNDERSCORE -fno-second-underscore *.f *.F*
> */usr/loca*l
> *gives the errors in the files attached*
>
> *.*
> *I am not sure if I should just copy **g2clib** into** /usr/local.
**There
> are no instructions on how to install, but it has *
>
> *libg2c.a*
>
> *So currently am still looking at all these issues. Perhaps you can
assist
> me on BUFRLIB. What am I doing wrong? Previously I have not had any
> problem.*
>
> *Best Regards*
> *Zilore*
>
> On Thu, Apr 27, 2017 at 9:09 PM, Julie Prestopnik via RT <
> met_help at ucar.edu>
> wrote:
>
> > Hi Zilore.
> >
> > I just wanted to touch base and see if you were able to resolve
the
> > problem.  Please let us know if you need further assistance.
> >
> > Thanks,
> > Julie
> >
> > On Tue, Apr 11, 2017 at 4:12 PM, Zilore Mumba via RT
<met_help at ucar.edu>
> > wrote:
> >
> > >
> > > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > >
> > > Julie,
> > > Thanks once again for your time. My apologies, because in the
> > environmental
> > > variable I put "/usr/local/MET6" while as the directory I
created was
> > > "/usr/local/met6", i.e. met capitalized. When I do "ll
$MET_NETCDFINC"
> I
> > > can see the include files, including "netcdf".
> > > But am getting the same error. Let me work over it. I will get
back to
> > you
> > > if I fail or succeed.
> > > Best regards
> > > Zilore
> > >
> > > On Tue, Apr 11, 2017 at 9:52 PM, Julie Prestopnik via RT <
> > > met_help at ucar.edu>
> > > wrote:
> > >
> > > > Hi Zilore.
> > > >
> > > > In your config.log file, it appears that you do not have your
MET
> > > > environment variables set up.  The MET build process uses
environment
> > > > variables to specify the locations of the needed external
libraries.
> > > >
> > > > The following page describes the MET environment variables
that you
> > will
> > > > need to set up in your .cshrc or equivalent file:
> > > >
> > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > METv6.0/tutorial.php?name=compilation&category=configure
> > > >
> > > > The error you are getting:
> > > >
> > > > In file included from nc_var_info.cc:24:0:
> > > > nc_utils.h:22:18: fatal error: netcdf: No such file or
directory
> > > >
> > > > seems to imply that MET doesn't know where to find the file
"netcdf",
> > > which
> > > > is included in the NetCDF-CXX installation.  It could be that
> > NetCDF-CXX
> > > is
> > > > installed and that file does exist, but MET just doesn't know
where
> to
> > > find
> > > > it.  Setting those environment variables will help MET know
where
> those
> > > > required libraries and include files are.
> > > >
> > > > Here is a quick reference checklist for NetCDF4C++
installation that
> > you
> > > > can use to see if you have the necessary files:
> > > >
> > > > Files for NetCDF4 C:
> > > >
> > > >    - $MET_NETCDF/include/netcdf.h
> > > >    - $MET_NETCDF/lib/libnetcdf.a
> > > >    - $MET_NETCDF/lib/libnetcdf.so
> > > >
> > > > Files for NetCDF4 C++:
> > > >
> > > >    - $MET_NETCDF/include/netcdf
> > > >    - $MET_NETCDF/lib/libnetcdf_c++4.a
> > > >    - $MET_NETCDF/lib/libnetcdf_c++4.so
> > > >
> > > > Files for NetCDF3 C++ (not required, if --disabled-netcdf4 is
> > activated):
> > > >
> > > >    - $MET_NETCDF/include/netcdf.hh
> > > >    - $MET_NETCDF/lib/libnetcdf_c++.a
> > > >    - $MET_NETCDF/lib/libnetcdf_c++.so
> > > >
> > > > Please follow the instructions on the webpage above to set up
the
> > > necessary
> > > > environment variables, then please reconfigure and recompile
MET and
> > let
> > > us
> > > > know if you encounter further difficulty.
> > > >
> > > > I hope this helps!
> > > >
> > > > Thanks!
> > > >
> > > > Julie
> > > >
> > > > On Tue, Apr 11, 2017 at 1:22 PM, Zilore Mumba via RT <
> > met_help at ucar.edu>
> > > > wrote:
> > > >
> > > > >
> > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > > > >
> > > > > Julie,
> > > > > Please find attached to this mail, my config.log and
> > make-install.log.
> > > > >
> > > > > On Tue, Apr 11, 2017 at 4:29 PM, Julie Prestopnik via RT <
> > > > > met_help at ucar.edu>
> > > > > wrote:
> > > > >
> > > > > > Hi Zilore.  I'm sorry to hear that you are still
experiencing
> > > problems.
> > > > > > Could you please send your most recent configure.log and
> > > > make_install.log
> > > > > > files?
> > > > > >
> > > > > > Thanks!
> > > > > >
> > > > > > Julie
> > > > > >
> > > > > > On Tue, Apr 11, 2017 at 8:13 AM, Zilore Mumba via RT <
> > > > met_help at ucar.edu>
> > > > > > wrote:
> > > > > >
> > > > > > >
> > > > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> >
> > > > > > >
> > > > > > > Julie,
> > > > > > > Thanks very much for all the details you provided.
> > > > > > > However, am still getting the same error, i.e.
> > > > > > > The file "nc_var_info.cc" (i.e. #include on line 24)
calls
> > > > > "nc_utils.h".
> > > > > > > Now the latter file has "#include netcdf" on line 22. It
is
> this
> > > > netcdf
> > > > > > it
> > > > > > > is saying no such file.
> > > > > > >
> > > > > > > I believe my setup is ok.
> > > > > > > Using the lines you gave me on installing the hdf5 and
netcdf
> > > > > libraries,
> > > > > > if
> > > > > > > I use prefix=${MET_LIB_DIR}, I am not able to find where
the
> > > > libraries
> > > > > > are
> > > > > > > installed, though there are no errors indicated. I tried
to set
> > > > "export
> > > > > > > MET_LIB_DIR=/usr/local/met6" and alternatively "export
> > > > > > MET_LIB_DIR=~/met6"
> > > > > > > after creating the met6 directory in each case.
> > > > > > > But putting prefix=/usr/local/met6, I get both netcdf-c
and
> > > > netcdf-cxx
> > > > > > > libraries in /usr/local/met6/lib, include files in
> > > > > > /usr/local/met6/include,
> > > > > > > and some executables in /usr/local/met6/bin as well as
an hdf5
> > > > > directory.
> > > > > > > So am wondering if the include file nc_utils.h has the
correct
> > > entry
> > > > on
> > > > > > > line 22.
> > > > > > > Thanks for your time and effort
> > > > > > > Zilore
> > > > > > >
> > > > > > > On Mon, Apr 10, 2017 at 5:40 PM, Julie Prestopnik via RT
<
> > > > > > > met_help at ucar.edu>
> > > > > > > wrote:
> > > > > > >
> > > > > > > > Hi Zilore.  In 6.0 we've made a large change from
using
> NetCDF
> > 3
> > > to
> > > > > 4.
> > > > > > > > You'll need to have both NetCDF 4 and HDF5, upon which
> NetCDF 4
> > > is
> > > > > > built,
> > > > > > > > installed.
> > > > > > > >
> > > > > > > > Please feel free to take a look at the MET User's
Guide and
> the
> > > > > online
> > > > > > > > tutorial:
> > > > > > > >
http://www.dtcenter.org/met/users/docs/users_guide/MET_
> > > > > > > > Users_Guide_v6.0.pdf
> > > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > > >
METv6.0/tutorial.php?name=compilation&category=req_libs
> > > > > > > >
> > > > > > > > There is an additional environment variable that will
need to
> > be
> > > > set,
> > > > > > > with
> > > > > > > > the addition of HDF5:
> > > > > > > > Set *$MET_HDF5* to point to the main HDF5 directory.
> > > > > > > >
> > > > > > > > Also, both the NetCDF-C package (netcdf-c-4.4.1.1) and
the
> > > > NetCDF-CXX
> > > > > > > > package (netcdf-cxx4-4.3.0) are necessary.
> > > > > > > >
> > > > > > > > Here are the commands we've been using to compile
these
> > packages
> > > > from
> > > > > > > > source.  The following assumes that you're using the
GNU
> > > compilers
> > > > > and
> > > > > > > that
> > > > > > > > you've defined MET_LIB_DIR to point to your desired
> > installation
> > > > > > > directory:
> > > > > > > >
> > > > > > > > # Compilers
> > > > > > > >
> > > > > > > > setenv CC `which gcc`
> > > > > > > >
> > > > > > > > setenv CXX `which g++`
> > > > > > > >
> > > > > > > > setenv FC `which gfortran`
> > > > > > > > setenv F77 `which gfortran`
> > > > > > > >
> > > > > > > > # HDF5
> > > > > > > >
> > > > > > > > wget
> > > > > > > > https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-
1.10/
> > > > > > > > hdf5-1.10.0-patch1/src/hdf5-1.10.0-patch1.tar
> > > > > > > >
> > > > > > > > tar -xvzf hdf5-1.10.0-patch1.tar
> > > > > > > >
> > > > > > > > cd hdf5-1.10.0-patch1
> > > > > > > >
> > > > > > > > ./configure --prefix=${MET_LIB_DIR}
> > > > > > > >
> > > > > > > > make install
> > > > > > > >
> > > > > > > > # NetCDF-C
> > > > > > > >
> > > > > > > > wget https://github.com/Unidata/
> netcdf-c/archive/v4.4.1.1.zip
> > > > > > > >
> > > > > > > > unzip v4.4.1.1.zip
> > > > > > > >
> > > > > > > > cd netcdf-c-4.4.1.1
> > > > > > > >
> > > > > > > > ./configure --prefix=${MET_LIB_DIR}
> > LDFLAGS=-L${MET_LIB_DIR}/lib
> > > > > > > > CPPFLAGS=-I${MET_LIB_DIR}/include
> > > > > > > >
> > > > > > > > make install
> > > > > > > >
> > > > > > > >
> > > > > > > > # NetCDF-CXX
> > > > > > > >
> > > > > > > > wget https://github.com/Unidata/netcdf-
cxx4/archive/v4.3.0.
> > > tar.gz
> > > > > > > >
> > > > > > > > tar -xvzf v4.3.0.tar.gz
> > > > > > > >
> > > > > > > > cd netcdf-cxx4-4.3.0
> > > > > > > >
> > > > > > > > ./configure --prefix=${MET_LIB_DIR}
> > LDFLAGS=-L${MET_LIB_DIR}/lib
> > > > > > > > CPPFLAGS=-I${MET_LIB_DIR}/include
> > > > > > > > make install
> > > > > > > >
> > > > > > > >
> > > > > > > > I hope this helps!  Please let us know if you need
further
> > > > > assistance.
> > > > > > > >
> > > > > > > > Thanks,
> > > > > > > > Julie
> > > > > > > >
> > > > > > > > On Sat, Apr 8, 2017 at 3:53 PM, Zilore Mumba via RT <
> > > > > met_help at ucar.edu
> > > > > > >
> > > > > > > > wrote:
> > > > > > > >
> > > > > > > > >
> > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > Ticket/Display.html?id=70551
> > > >
> > > > > > > > >
> > > > > > > > > Julie, I hope you are fine, and that I can still
reach you.
> > In
> > > > > March
> > > > > > > 2015
> > > > > > > > > you helped me installing met_v5.0. I have now
downloaded
> v6.0
> > > > and I
> > > > > > am
> > > > > > > > > having a compilation error I do not seem to figure
out.
> > > > > > > > > I believe I have installed all the libraries (and
set the
> > > > > environment
> > > > > > > > > variables correctly: BUFRLIB-v10-2-3, netcdf-
4.4.1.1,
> > gsl-2.3,
> > > > > > > > > g2clib-1.6.0, freetype-2.7.1 andcairo-1.14.8.
> > > > > > > > > I also have zlib, jasper and libpng.
> > > > > > > > > My configure exits with exit code 0 which I
understand to
> be
> > > ok.
> > > > > > > However
> > > > > > > > my
> > > > > > > > > make install gives an error of not finding netcdf
(as you
> can
> > > see
> > > > > > from
> > > > > > > > > make-install.log). I do not understand which netcdf
it
> cannot
> > > > find.
> > > > > > > > > I hope you can assist.
> > > > > > > > > Zilore
> > > > > > > > >
> > > > > > > > > On Thu, Mar 5, 2015 at 7:59 PM, Julie Prestopnik via
RT <
> > > > > > > > met_help at ucar.edu
> > > > > > > > > >
> > > > > > > > > wrote:
> > > > > > > > >
> > > > > > > > > > Hi Zilore.  Thanks for sending your commands and
log
> files.
> > > > > > > > > >
> > > > > > > > > > Looking in "config.log" for the string "BUFRLIB",
it
> > appears
> > > > that
> > > > > > you
> > > > > > > > did
> > > > > > > > > > not set the environment variable.
> > > > > > > > > >
> > > > > > > > > > The linker error occurs on line 1057 of
make_install.log.
> > > > > Looking
> > > > > > at
> > > > > > > > > that
> > > > > > > > > > line, we're telling the linker to look in the
following
> > > > > directories
> > > > > > > for
> > > > > > > > > the
> > > > > > > > > > file named "libbufr.a":
> > > > > > > > > >
> > > > > > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8
> > > > > > > > > > -L/usr/lib/gcc/i686-linux-gnu/
> 4.8/../../../i386-linux-gnu
> > > > > > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../../../lib
> > > > > > > > > > -L/lib/i386-linux-gnu
> > > > > > > > > > -L/lib/../lib
> > > > > > > > > > -L/usr/lib/i386-linux-gnu
> > > > > > > > > > -L/usr/lib/../lib
> > > > > > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../..
> > > > > > > > > >
> > > > > > > > > > It must be finding libbufr.a in one of those
directories,
> > > > > otherwise
> > > > > > > we
> > > > > > > > > > would get an error about that.  I believe that the
> version
> > of
> > > > > > > libbufr.a
> > > > > > > > > it
> > > > > > > > > > is finding is not the version that you compiled
using the
> > > > > > > > "-DUNDERSCORE"
> > > > > > > > > > option.
> > > > > > > > > >
> > > > > > > > > > I was able to replicate your error by re-compiling
a
> > version
> > > of
> > > > > > > BUFRLIB
> > > > > > > > > > *without* -DUNDERSCORE, and then by building MET
linking
> to
> > > > that
> > > > > > bad
> > > > > > > > > > version.
> > > > > > > > > >
> > > > > > > > > > What you'll need to do is set the MET_BUFRLIB
environment
> > > > > variable
> > > > > > as
> > > > > > > > > > indicated on this page:
> > > > > > > > > > http://www.dtcenter.org/met/
> users/support/online_tutorial/
> > > > > > > > > > METv5.0/compilation/configure.php
> > > > > > > > > >
> > > > > > > > > > Then source your .cshrc or equivalent file, then
run your
> > > > > configure
> > > > > > > > > > command, and then run make install and make test.
> > > > > > > > > >
> > > > > > > > > > Please give that a try.  It should solve the
problem you
> > are
> > > > > > > > > encountering.
> > > > > > > > > >
> > > > > > > > > > Thanks,
> > > > > > > > > > Julie
> > > > > > > > > >
> > > > > > > > > > On Wed, Mar 4, 2015 at 5:36 AM, Zilore Mumba via
RT <
> > > > > > > met_help at ucar.edu
> > > > > > > > >
> > > > > > > > > > wrote:
> > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > > Ticket/Display.html?id=70551
> > > > > >
> > > > > > > > > > >
> > > > > > > > > > > *Julie, I installed with the following commands.
gcc -c
> > > > > > > -DUNDERSCORE
> > > > > > > > > *.c*
> > > > > > > > > > >    *gfortran -c -DUNDERSCORE -fno-second-
underscore *.f
> > > *.F*
> > > > > > > > > > >    *ar crv libbufr.a *.o*
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > *Please find attached the config.log and
> > make_install.log *
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > On Tue, Mar 3, 2015 at 7:10 PM, Julie Prestopnik
via
> RT <
> > > > > > > > > > met_help at ucar.edu
> > > > > > > > > > > >
> > > > > > > > > > > wrote:
> > > > > > > > > > >
> > > > > > > > > > > > I'm sorry to hear that you are still
experiencing
> > > problems
> > > > > > > > installing
> > > > > > > > > > > > METv5.0.
> > > > > > > > > > > >
> > > > > > > > > > > > Specifically regarding BUFRLIB, please compile
it
> using
> > > the
> > > > > > > options
> > > > > > > > > > > listed
> > > > > > > > > > > > on this page:
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > http://www.dtcenter.org/met/
> > users/support/online_tutorial/
> > > > > > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > > >
> > > > > > > > > > > > Failing to use the "-DUNDERSCORE
> > -fno-second-underscore"
> > > > (for
> > > > > > GNU
> > > > > > > > > > > > compilers) options will result in undefined
> references
> > > when
> > > > > > > > building
> > > > > > > > > > the
> > > > > > > > > > > > pb2nc tool.
> > > > > > > > > > > >
> > > > > > > > > > > > If you'd like to send us the output of make
please do
> > the
> > > > > > > > following:
> > > > > > > > > > > >    make clean
> > > > > > > > > > > >    make install >& make_install.log
> > > > > > > > > > > >
> > > > > > > > > > > > And then send us the files "config.log" and
> > > > > "make_install.log".
> > > > > > > > > > > >
> > > > > > > > > > > > I hope you'll find what you have been able to
install
> > > > useful.
> > > > > > > > Please
> > > > > > > > > > let
> > > > > > > > > > > > us know if you have any questions.
> > > > > > > > > > > >
> > > > > > > > > > > > Thanks,
> > > > > > > > > > > > Julie
> > > > > > > > > > > >
> > > > > > > > > > > > On Tue, Mar 3, 2015 at 12:26 AM, Zilore Mumba
via RT
> <
> > > > > > > > > > met_help at ucar.edu>
> > > > > > > > > > > > wrote:
> > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > > > > Ticket/Display.html?id=70551
> > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > > Julie,
> > > > > > > > > > > > > I did not inform you of the conclusion of my
> attempt
> > to
> > > > > > install
> > > > > > > > > > > Met-5.1.
> > > > > > > > > > > > > After making many attempts in
> > > reinstalling/reconfiguring
> > > > > > > BUFRLIB
> > > > > > > > i
> > > > > > > > > > > still
> > > > > > > > > > > > > get errors relating to "undefined reference
to ..."
> > and
> > > > > > > > eventually
> > > > > > > > > I
> > > > > > > > > > > > still
> > > > > > > > > > > > > have 3 executables not installed: pb2nc,
> > modis_regrid,
> > > > > > > > > > plot_mode_field.
> > > > > > > > > > > > > I would like to learn how to use what I have
and
> come
> > > > back
> > > > > > > later
> > > > > > > > to
> > > > > > > > > > > pb2nc
> > > > > > > > > > > > > if necessary. I will inform you if I have
any other
> > > > > problems.
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > > On Tue, Feb 10, 2015 at 7:12 PM, Julie
Prestopnik
> via
> > > RT
> > > > <
> > > > > > > > > > > > > met_help at ucar.edu>
> > > > > > > > > > > > > wrote:
> > > > > > > > > > > > >
> > > > > > > > > > > > > > Thank you for rerunning and sending this
log.
> > > Perhaps
> > > > > MET
> > > > > > > > cannot
> > > > > > > > > > > find
> > > > > > > > > > > > > the
> > > > > > > > > > > > > > BUFR library.
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > On the following page are directions for
setting
> > the
> > > > > > > > environment
> > > > > > > > > > > > > variables
> > > > > > > > > > > > > > before compiling MET:
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > http://www.dtcenter.org/met/
> > users/support/online_tutorial/
> > > > > > > > > > METv5.0/compilation/configure.php
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > The rest of the applications built, so it
looks
> > like
> > > > MET
> > > > > > was
> > > > > > > > able
> > > > > > > > > > to
> > > > > > > > > > > > find
> > > > > > > > > > > > > > the other needed libraries.  The
directions for
> the
> > > > BUFR
> > > > > > > > > > environment
> > > > > > > > > > > > > > variable on the above page are:
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > "Set *$MET_BUFR* to point to the main BUFR
> > directory,
> > > > or
> > > > > > set
> > > > > > > > > > > > > *$MET_BUFRLIB*
> > > > > > > > > > > > > > to point to the directory with the BUFR
library
> > > files.
> > > > > > > Because
> > > > > > > > > MET
> > > > > > > > > > > > > doesn't
> > > > > > > > > > > > > > use any BUFR library include files, you
don't
> need
> > to
> > > > > > specify
> > > > > > > > > > > > > > *$MET_BUFRINC*
> > > > > > > > > > > > > > ."
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > Please try setting either *$MET_BUFR *or
> > > *$MET_BUFRLIB
> > > > > *and
> > > > > > > > then
> > > > > > > > > > > please
> > > > > > > > > > > > > > rerun the configure script and then rerun
make
> > > install.
> > > > > It
> > > > > > > is
> > > > > > > > > > > > important
> > > > > > > > > > > > > to
> > > > > > > > > > > > > > rerun configure before rerunning make
install.
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > Please let me know how it goes.
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > Thanks,
> > > > > > > > > > > > > > Julie
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > On Sat, Feb 7, 2015 at 9:36 PM, Zilore
Mumba via
> > RT <
> > > > > > > > > > > met_help at ucar.edu
> > > > > > > > > > > > >
> > > > > > > > > > > > > > wrote:
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > > > > > > Ticket/Display.html?id=70551
> > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > Julie,
> > > > > > > > > > > > > > > Attached to this mail, please find the
file
> > > > > > > make-install.log.
> > > > > > > > > It
> > > > > > > > > > > does
> > > > > > > > > > > > > > > show 'undefined reference' to some
functions. I
> > > hope
> > > > > this
> > > > > > > > means
> > > > > > > > > > > > > > > something to you and that you can help.
> > > > > > > > > > > > > > > Thanks in advance
> > > > > > > > > > > > > > > Zilore
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > On 2/5/15, Julie Prestopnik via RT <
> > > > met_help at ucar.edu>
> > > > > > > > wrote:
> > > > > > > > > > > > > > > > Thank you for attaching your log
files.  I
> did
> > > not
> > > > > see
> > > > > > > any
> > > > > > > > > > errors
> > > > > > > > > > > > in
> > > > > > > > > > > > > > your
> > > > > > > > > > > > > > > > make-install.log.  Perhaps you ran
make
> install
> > > in
> > > > > the
> > > > > > > > > > following
> > > > > > > > > > > > way:
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > make install > make-install.log
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > This would catch standard out but not
> standard
> > > > error.
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > Could you please try running in the
following
> > way
> > > > > with
> > > > > > > the
> > > > > > > > &,
> > > > > > > > > > > which
> > > > > > > > > > > > > > will
> > > > > > > > > > > > > > > > also capture standard error?
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > make install >& make-install.log
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > And, then please send me the output of
that
> > log.
> > > > > Thank
> > > > > > > > you!
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > Julie
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > On Tue, Feb 3, 2015 at 2:08 PM, Zilore
Mumba
> > via
> > > > RT <
> > > > > > > > > > > > > met_help at ucar.edu
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > wrote:
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > >> <URL: https://rt.rap.ucar.edu/rt/Tic
> > > > > > > > > ket/Display.html?id=70551
> > > > > > > > > > >
> > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > >> Julie,
> > > > > > > > > > > > > > > >> Thank you very much for your
assistance. I
> > > failed
> > > > to
> > > > > > > > install
> > > > > > > > > > > Cairo
> > > > > > > > > > > > > and
> > > > > > > > > > > > > > > >> freetype because of the dependencies.
I will
> > try
> > > > > again
> > > > > > > > with
> > > > > > > > > > the
> > > > > > > > > > > > > links
> > > > > > > > > > > > > > > >> you sent me.
> > > > > > > > > > > > > > > >> Please find attached my config.log
and
> > > > > > make-install.log.
> > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > >> On 2/2/15, Julie Prestopnik via RT <
> > > > > met_help at ucar.edu
> > > > > > >
> > > > > > > > > wrote:
> > > > > > > > > > > > > > > >> > I'm so glad you were able to get
MET
> > installed
> > > > and
> > > > > > > that
> > > > > > > > > you
> > > > > > > > > > > > worked
> > > > > > > > > > > > > > out
> > > > > > > > > > > > > > > >> the
> > > > > > > > > > > > > > > >> > issue with the NetCDF environment
> variables.
> > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > >> > You mentioned that three
executables did
> not
> > > > > > build.  I
> > > > > > > > > would
> > > > > > > > > > > > like
> > > > > > > > > > > > > to
> > > > > > > > > > > > > > > >> > try
> > > > > > > > > > > > > > > >> to
> > > > > > > > > > > > > > > >> > help with those.  The modis_regrid
tool
> has
> > > > > library
> > > > > > > > > > > > dependencies -
> > > > > > > > > > > > > > it
> > > > > > > > > > > > > > > >> > requires the HDF4 and HDF-EOS2
libraries.
> > The
> > > > > > > > > > plot_mode_field
> > > > > > > > > > > > > tool
> > > > > > > > > > > > > > > >> > also
> > > > > > > > > > > > > > > >> > has library dependencies - it
requires the
> > > Cairo
> > > > > and
> > > > > > > > > > FreeType
> > > > > > > > > > > > > > > >> > libraries.
> > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > >> > You can find information on
compiling each
> > of
> > > > > those
> > > > > > > > > library
> > > > > > > > > > > > > > > >> > dependencies
> > > > > > > > > > > > > > > >> > here:
> > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > http://www.dtcenter.org/met/
> > users/support/online_tutorial/
> > > > > > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > >> > You can find information on setting
the up
> > > > > necessary
> > > > > > > > > > > environment
> > > > > > > > > > > > > > > >> variables
> > > > > > > > > > > > > > > >> > for those library locations here:
> > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > http://www.dtcenter.org/met/
> > users/support/online_tutorial/
> > > > > > > > > > METv5.0/compilation/configure.php
> > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > >> > And with pb2nc, I'm not exactly
sure what
> is
> > > > going
> > > > > > on
> > > > > > > > > there.
> > > > > > > > > > > I
> > > > > > > > > > > > > > would
> > > > > > > > > > > > > > > >> > be
> > > > > > > > > > > > > > > >> > happy to take a look at your
configure log
> > and
> > > > > make
> > > > > > > > > install
> > > > > > > > > > > log
> > > > > > > > > > > > > > files
> > > > > > > > > > > > > > > >> > to
> > > > > > > > > > > > > > > >> > see if I can figure out why you
didn't get
> > the
> > > > > > > > executable.
> > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > >> > I hope this helps.
> > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > >> > Thanks,
> > > > > > > > > > > > > > > >> > Julie
> > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > >> > On Sat, Jan 31, 2015 at 5:31 PM,
Zilore
> > Mumba
> > > > via
> > > > > RT
> > > > > > > > > > > > > > > >> > <met_help at ucar.edu>
> > > > > > > > > > > > > > > >> > wrote:
> > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > >> >> <URL:
> > > > > > > > > > > https://rt.rap.ucar.edu/rt/
> Ticket/Display.html?id=70551
> > > > > > > > > > > > >
> > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > >> >> Julg
> > > > > > > > > > > > > > > >> >> Thank you very much for your help.
With
> the
> > > > > advice
> > > > > > > you
> > > > > > > > > gave
> > > > > > > > > > > > me, I
> > > > > > > > > > > > > > was
> > > > > > > > > > > > > > > >> >> able to install MET using gcc and
> > gfortran. I
> > > > > also
> > > > > > > had
> > > > > > > > to
> > > > > > > > > > to
> > > > > > > > > > > > > point
> > > > > > > > > > > > > > > >> >> $MET_NETCDFLIB and, $MET_NETCDFINC
to
> > > > > > > > > > > > /usr/local/netcdf-4.1.3/lib
> > > > > > > > > > > > > > and
> > > > > > > > > > > > > > > >> >> include. Previously I pointed only
to
> > > > > > > > > > > /usr/local/netcdf-4.1.3.
> > > > > > > > > > > > > > > >> >> I have three executables not
included
> > though,
> > > > > these
> > > > > > > are
> > > > > > > > > > > > > > modis_regrid,
> > > > > > > > > > > > > > > >> >> plot_mode_field and pb2nc.
> > > > > > > > > > > > > > > >> >> Thank you very much.
> > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > >> >> On 1/29/15, Julie Prestopnik via
RT <
> > > > > > > met_help at ucar.edu
> > > > > > > > >
> > > > > > > > > > > wrote:
> > > > > > > > > > > > > > > >> >> > I am sorry to hear that you are
having
> > > > problems
> > > > > > > > > > installing
> > > > > > > > > > > > > > METv5.0.
> > > > > > > > > > > > > > > >> >> > I
> > > > > > > > > > > > > > > >> >> > believe this error may have to
do with
> > how
> > > > you
> > > > > > > > compiled
> > > > > > > > > > > > > BUFRLIB.
> > > > > > > > > > > > > > > >> >> > Please
> > > > > > > > > > > > > > > >> >> > take a look at the sample
commands for
> > > > > compiling
> > > > > > > > > BURFLIB
> > > > > > > > > > on
> > > > > > > > > > > > > this
> > > > > > > > > > > > > > > >> >> > page:
> > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > http://www.dtcenter.org/met/
> > users/support/online_tutorial/
> > > > > > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > >> >> > I believe that the
> > *-fno-second-underscore*
> > > > > (GNU
> > > > > > > > > > compilers)
> > > > > > > > > > > > or
> > > > > > > > > > > > > > > >> >> > *-Mnosecond_underscore* (PGI
compilers)
> > > will
> > > > > fix
> > > > > > > the
> > > > > > > > > > error
> > > > > > > > > > > > > you're
> > > > > > > > > > > > > > > >> >> > seeing.
> > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > >> >> > I hope that helps.  If it
doesn't,
> please
> > > > send
> > > > > me
> > > > > > > the
> > > > > > > > > > files
> > > > > > > > > > > > > > > >> >> "make_met.log"
> > > > > > > > > > > > > > > >> >> > and "config.log".
> > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > >> >> > Thanks,
> > > > > > > > > > > > > > > >> >> > Julie
> > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > >> >> > On Thu, Jan 29, 2015 at 3:48 AM,
Zilore
> > > Mumba
> > > > > via
> > > > > > > RT
> > > > > > > > > > > > > > > >> >> > <met_help at ucar.edu>
> > > > > > > > > > > > > > > >> >> > wrote:
> > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > > >> >> >> Thu Jan 29 03:48:08 2015:
Request
> 70551
> > > was
> > > > > > acted
> > > > > > > > > upon.
> > > > > > > > > > > > > > > >> >> >> Transaction: Ticket created by
> > > > > zmumba at gmail.com
> > > > > > > > > > > > > > > >> >> >>        Queue: met_help
> > > > > > > > > > > > > > > >> >> >>      Subject: Problem compiling
Met-V5
> > > > > > > > > > > > > > > >> >> >>        Owner: Nobody
> > > > > > > > > > > > > > > >> >> >>   Requestors: zmumba at gmail.com
> > > > > > > > > > > > > > > >> >> >>       Status: new
> > > > > > > > > > > > > > > >> >> >>  Ticket <URL:
> > > > > > > > > > > > > > > >> https://rt.rap.ucar.edu/rt/
> > > > > > Ticket/Display.html?id=70551
> > > > > > > > > > > > > > > >> >> >> >
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > > >> >> >> I have installed BUFRLIB, GSL
and
> G2CLIB
> > > > > > > > > > > > > > > >> >> >> But then how do I handle the
errors
> > below
> > > in
> > > > > > > > > installing
> > > > > > > > > > > > > MET_V5?
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > tools/other/pb2nc/numpbmsg.f:
> > > > > 23:
> > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > >> >> >> reference to `ufbtab_'
> > > > > > > > > > > > > > > >> >> >> openpb.o: In function
`openpb_':
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > tools/other/pb2nc/openpb.f:21:
> > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > tools/other/pb2nc/openpb.f:22:
> > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > > > > > > > > >> >> >> closepb.o: In function
`closepb_':
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > tools/other/pb2nc/closepb.f:
> > > 19:
> > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > >> >> >> reference to `closbf_'
> > > > > > > > > > > > > > > >> >> >> readpb.o: In function
`readpb_':
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > tools/other/pb2nc/readpb.f:82:
> > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > tools/other/pb2nc/readpb.f:90:
> > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > tools/other/pb2nc/readpb.f:94:
> > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > > > > > >> >> >> dumppb.o: In function
`readpbdump_':
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> tools/other/pb2nc/dumppb.f:
> > > 215:
> > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> tools/other/pb2nc/dumppb.f:
> > > 218:
> > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> tools/other/pb2nc/dumppb.f:
> > > 224:
> > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> tools/other/pb2nc/dumppb.f:
> > > 203:
> > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> tools/other/pb2nc/dumppb.f:
> > > 228:
> > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> tools/other/pb2nc/dumppb.f:
> > > 259:
> > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > > > > > >> >> >> dumppb.o: In function
`dumppb_':
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > tools/other/pb2nc/dumppb.f:56:
> > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > tools/other/pb2nc/dumppb.f:57:
> > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > > > > > > > > >> >> >> collect2: error: ld returned 1
exit
> > status
> > > > > > > > > > > > > > > >> >> >> make[4]: *** [pb2nc] Error 1
> > > > > > > > > > > > > > > >> >> >> make[4]: Leaving directory
> > > > > > > > > > > > > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/
> > > > > > tools/other/pb2nc'
> > > > > > > > > > > > > > > >> >> >> make[3]: *** [install-
recursive]
> Error 1
> > > > > > > > > > > > > > > >> >> >> make[3]: Leaving directory
> > > > > > > > > > > > > > > >> >> >> `/home/zmumba/WRF/met-5.0/src/
> > > tools/other'
> > > > > > > > > > > > > > > >> >> >> make[2]: *** [install-
recursive]
> Error 1
> > > > > > > > > > > > > > > >> >> >> make[2]: Leaving directory
> > > > > > > > > > > > > `/home/zmumba/WRF/met-5.0/src/tools'
> > > > > > > > > > > > > > > >> >> >> make[1]: *** [install-
recursive]
> Error 1
> > > > > > > > > > > > > > > >> >> >> make[1]: Leaving directory
> > > > > > > > > > `/home/zmumba/WRF/met-5.0/src'
> > > > > > > > > > > > > > > >> >> >> make: *** [install-recursive]
Error 1
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > >> >> > --
> > > > > > > > > > > > > > > >> >> > Julie Prestopnik
> > > > > > > > > > > > > > > >> >> > National Center for Atmospheric
> Research
> > > > > > > > > > > > > > > >> >> > Research Applications Laboratory
> > > > > > > > > > > > > > > >> >> > Phone: 303.497.8399
> > <%28303%29%20497-8399>
> > > > > > > > > > > > > > > >> >> > Email: jpresto at ucar.edu
> > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > >> > --
> > > > > > > > > > > > > > > >> > Julie Prestopnik
> > > > > > > > > > > > > > > >> > National Center for Atmospheric
Research
> > > > > > > > > > > > > > > >> > Research Applications Laboratory
> > > > > > > > > > > > > > > >> > Phone: 303.497.8399
> > > > > > > > > > > > > > > >> > Email: jpresto at ucar.edu
> > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > --
> > > > > > > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > > > > > > National Center for Atmospheric
Research
> > > > > > > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > --
> > > > > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > --
> > > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > --
> > > > > > > > > > Julie Prestopnik
> > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> >
> >
>
>

------------------------------------------------
Subject: Problem compiling Met-V5
From: Zilore Mumba
Time: Tue May 02 15:44:11 2017

Julie,
The following is what I have:
1. netcdf in* /usr/local/netcdf-4.4.1.1* and in */usr/local* (i.e.
netcdf-4.4.1.1, netcdf-f and netcdf-cxx)
2.hdf5 in* /usr/local/hdf5* and in * /usr/local*
3. gsl in /usr/local/met6/gsl and in /usr/local
4. BUFRLIB in /usr/local/BUFRLIB (libbufr.a in the directory)
5. g2clib in /usr/local/met6/g2clib
6. cairo in /usr/local/cairo
7. freetype in /usr/local/freetype

The following are environment variables I set:
  export NETCDF=/usr/local/netcdf-4.4.1.1
  export NETCDF_LIB=/usr/local/netcdf-4.4.1.1/lib

  export HDF5_DIR=/usr/local/hdf5
  export PATH=$PATH:$HDF5_DIR/bin

  export MET_LIB_DIR=/usr/local/met6
  export MET_LIBINC=$MET_LIB_DIR/include
  export MET_LIBLIB=$MET_LIB_DIR/lib

  export MET_NETCDF=$NETCDF
  export MET_NETCDFINC=$MET_NETCDF/include
  export MET_NETCDFLIB=$MET_NETCDF/lib
  export PATH=$PATH:$MET_NETCDF/bin

  export MET_BUFRLIB=$MET_LIB_DIR/BUFRLIB
  export MET_GSL=$MET_LIB_DIR/gsl
  export MET_GSLINC=$MET_LIB_DIR/gsl/include/gsl
  export MET_GSLLIB=$MET_LIB_DIR/gsl/lib

  export MET_GRIB2CINC=$MET_LIB_DIR/g2clib
  export MET_GRIB2CLIB=$MET_LIB_DIR/g2clib

  export MET_HDF5=$MET_LIB_DIR/hdf5
  export MET_HDF5LIB=$MET_HDF5/lib
  export MET_HDF5INC=$MET_HDF5/include

  export MET_CAIROINC=/usr/local/cairo/include
  export MET_CAIROLIB=/usr/local/cairo/lib
  export MET_FREETYPEINC=/usr/local/freetype/include
  export MET_FREETYPELIB=/usr/local/freetype/lib

I also have:
  export JASPERLIB=/usr/local/lib
  export JASPERINC=/usr/local/include

  export PNGLIB=/usr/local/lib
  export PNGINC=/usr/local/include
  export JPEGLIB=/usr/local/lib

and my LD_LIBRARY_PATH:
  export
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib:/usr/lib:$MET_LIB_DIR/g2clib:$MET_HDF5/lib:$MET_LIB_DIR/BUFRLIB:$MET_LIB_DIR/gsl/lib:/usr/local/freetype/lib:/usr/local/cairo/lib:$NETCDF/lib:$MET_NETCDF/lib:/lib:/usr/lib/i386-
linux-gnu:/lib/i386-linux-gnu:/usr/lib/ccache

I issued the commands, as root:
./configure --prefix=/usr/local/met6 --enable-grib2 --enable-modis
make install >& make_install.log
The output of the last command is in the attached file.

When I put locate *libgrib2c.a,* it points me to
/usr/local/grib2/g2clib-1.4.0/libgrib2c.a. I installed this with
wgrib2.tgz
(I think).
 There is no bin directory and no executables created.

I hope you can look at this and advise.
Zilore

On Tue, May 2, 2017 at 5:25 PM, Julie Prestopnik via RT
<met_help at ucar.edu>
wrote:

> Hi Zilore.  No need to apologize.  I just wanted to check in, in
case you
> still needed any help getting MET installed.
>
> You should not need to reorganize your installation to put anything
in
> /usr/local/.  We should be able to tell MET where to find anything
it
> needs.
>
> Do you already have successful installations of gsl, cairo,
freetype, and
> bufrlib elsewhere?  If so, I would suggest we go ahead and use those
> installations, telling MET where to find them.  I can help take you
through
> that process.
>
> Please let me know, and we can go from there.
>
> Kind regards,
> Julie
>
> On Tue, May 2, 2017 at 2:27 AM, Zilore Mumba via RT
<met_help at ucar.edu>
> wrote:
>
> >
> > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> >
> > Julie,
> > My apologies, since you sent me mail I had no access to Internet
until
> > today.
> > I have not been able to install met-6.0. My problem seems to have
got
> > worse.
> > I was trying to reorganize my installation by trying to install
> everything
> > in /usr/local so that I do not have any complications of some
libraries
> not
> > being found.
> >
> > I managed to install *gsl-2.3. T*he libraries are installed,
though make
> > check gives one failed test, *Makefile:750: recipe for target
> > 'test-suite.log' failed* (and says See linalg/test-suite.log)
> >
> > *I installed cairo-1.14.8* and *freetype-2.7.1* in their own
directories
> in
> > */usr/loca*l, i.e. */usr/loca*l/cairo and */usr/loca*l/freetype.
Howver
> > trtying to reinstall these in */usr/loca*l I am now getting a lot
of c++
> > style comment problems. I have to work this out.
> >
> > Then I copied BUFRLIB_v10-2-3.tar to /usr/local, untarred it in
that
> > directory.
> > Running:
> > *preproc.sh*,
> > *gcc -c -DUNDERSCORE *.c,*
> > *gfortran -c -DUNDERSCORE -fno-second-underscore *.f *.F*
> > */usr/loca*l
> > *gives the errors in the files attached*
> >
> > *.*
> > *I am not sure if I should just copy **g2clib** into** /usr/local.
> **There
> > are no instructions on how to install, but it has *
> >
> > *libg2c.a*
> >
> > *So currently am still looking at all these issues. Perhaps you
can
> assist
> > me on BUFRLIB. What am I doing wrong? Previously I have not had
any
> > problem.*
> >
> > *Best Regards*
> > *Zilore*
> >
> > On Thu, Apr 27, 2017 at 9:09 PM, Julie Prestopnik via RT <
> > met_help at ucar.edu>
> > wrote:
> >
> > > Hi Zilore.
> > >
> > > I just wanted to touch base and see if you were able to resolve
the
> > > problem.  Please let us know if you need further assistance.
> > >
> > > Thanks,
> > > Julie
> > >
> > > On Tue, Apr 11, 2017 at 4:12 PM, Zilore Mumba via RT <
> met_help at ucar.edu>
> > > wrote:
> > >
> > > >
> > > > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
>
> > > >
> > > > Julie,
> > > > Thanks once again for your time. My apologies, because in the
> > > environmental
> > > > variable I put "/usr/local/MET6" while as the directory I
created was
> > > > "/usr/local/met6", i.e. met capitalized. When I do "ll
> $MET_NETCDFINC"
> > I
> > > > can see the include files, including "netcdf".
> > > > But am getting the same error. Let me work over it. I will get
back
> to
> > > you
> > > > if I fail or succeed.
> > > > Best regards
> > > > Zilore
> > > >
> > > > On Tue, Apr 11, 2017 at 9:52 PM, Julie Prestopnik via RT <
> > > > met_help at ucar.edu>
> > > > wrote:
> > > >
> > > > > Hi Zilore.
> > > > >
> > > > > In your config.log file, it appears that you do not have
your MET
> > > > > environment variables set up.  The MET build process uses
> environment
> > > > > variables to specify the locations of the needed external
> libraries.
> > > > >
> > > > > The following page describes the MET environment variables
that you
> > > will
> > > > > need to set up in your .cshrc or equivalent file:
> > > > >
> > > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > METv6.0/tutorial.php?name=compilation&category=configure
> > > > >
> > > > > The error you are getting:
> > > > >
> > > > > In file included from nc_var_info.cc:24:0:
> > > > > nc_utils.h:22:18: fatal error: netcdf: No such file or
directory
> > > > >
> > > > > seems to imply that MET doesn't know where to find the file
> "netcdf",
> > > > which
> > > > > is included in the NetCDF-CXX installation.  It could be
that
> > > NetCDF-CXX
> > > > is
> > > > > installed and that file does exist, but MET just doesn't
know where
> > to
> > > > find
> > > > > it.  Setting those environment variables will help MET know
where
> > those
> > > > > required libraries and include files are.
> > > > >
> > > > > Here is a quick reference checklist for NetCDF4C++
installation
> that
> > > you
> > > > > can use to see if you have the necessary files:
> > > > >
> > > > > Files for NetCDF4 C:
> > > > >
> > > > >    - $MET_NETCDF/include/netcdf.h
> > > > >    - $MET_NETCDF/lib/libnetcdf.a
> > > > >    - $MET_NETCDF/lib/libnetcdf.so
> > > > >
> > > > > Files for NetCDF4 C++:
> > > > >
> > > > >    - $MET_NETCDF/include/netcdf
> > > > >    - $MET_NETCDF/lib/libnetcdf_c++4.a
> > > > >    - $MET_NETCDF/lib/libnetcdf_c++4.so
> > > > >
> > > > > Files for NetCDF3 C++ (not required, if --disabled-netcdf4
is
> > > activated):
> > > > >
> > > > >    - $MET_NETCDF/include/netcdf.hh
> > > > >    - $MET_NETCDF/lib/libnetcdf_c++.a
> > > > >    - $MET_NETCDF/lib/libnetcdf_c++.so
> > > > >
> > > > > Please follow the instructions on the webpage above to set
up the
> > > > necessary
> > > > > environment variables, then please reconfigure and recompile
MET
> and
> > > let
> > > > us
> > > > > know if you encounter further difficulty.
> > > > >
> > > > > I hope this helps!
> > > > >
> > > > > Thanks!
> > > > >
> > > > > Julie
> > > > >
> > > > > On Tue, Apr 11, 2017 at 1:22 PM, Zilore Mumba via RT <
> > > met_help at ucar.edu>
> > > > > wrote:
> > > > >
> > > > > >
> > > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > > > > >
> > > > > > Julie,
> > > > > > Please find attached to this mail, my config.log and
> > > make-install.log.
> > > > > >
> > > > > > On Tue, Apr 11, 2017 at 4:29 PM, Julie Prestopnik via RT <
> > > > > > met_help at ucar.edu>
> > > > > > wrote:
> > > > > >
> > > > > > > Hi Zilore.  I'm sorry to hear that you are still
experiencing
> > > > problems.
> > > > > > > Could you please send your most recent configure.log and
> > > > > make_install.log
> > > > > > > files?
> > > > > > >
> > > > > > > Thanks!
> > > > > > >
> > > > > > > Julie
> > > > > > >
> > > > > > > On Tue, Apr 11, 2017 at 8:13 AM, Zilore Mumba via RT <
> > > > > met_help at ucar.edu>
> > > > > > > wrote:
> > > > > > >
> > > > > > > >
> > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> Ticket/Display.html?id=70551
> > >
> > > > > > > >
> > > > > > > > Julie,
> > > > > > > > Thanks very much for all the details you provided.
> > > > > > > > However, am still getting the same error, i.e.
> > > > > > > > The file "nc_var_info.cc" (i.e. #include on line 24)
calls
> > > > > > "nc_utils.h".
> > > > > > > > Now the latter file has "#include netcdf" on line 22.
It is
> > this
> > > > > netcdf
> > > > > > > it
> > > > > > > > is saying no such file.
> > > > > > > >
> > > > > > > > I believe my setup is ok.
> > > > > > > > Using the lines you gave me on installing the hdf5 and
netcdf
> > > > > > libraries,
> > > > > > > if
> > > > > > > > I use prefix=${MET_LIB_DIR}, I am not able to find
where the
> > > > > libraries
> > > > > > > are
> > > > > > > > installed, though there are no errors indicated. I
tried to
> set
> > > > > "export
> > > > > > > > MET_LIB_DIR=/usr/local/met6" and alternatively "export
> > > > > > > MET_LIB_DIR=~/met6"
> > > > > > > > after creating the met6 directory in each case.
> > > > > > > > But putting prefix=/usr/local/met6, I get both netcdf-
c and
> > > > > netcdf-cxx
> > > > > > > > libraries in /usr/local/met6/lib, include files in
> > > > > > > /usr/local/met6/include,
> > > > > > > > and some executables in /usr/local/met6/bin as well as
an
> hdf5
> > > > > > directory.
> > > > > > > > So am wondering if the include file nc_utils.h has the
> correct
> > > > entry
> > > > > on
> > > > > > > > line 22.
> > > > > > > > Thanks for your time and effort
> > > > > > > > Zilore
> > > > > > > >
> > > > > > > > On Mon, Apr 10, 2017 at 5:40 PM, Julie Prestopnik via
RT <
> > > > > > > > met_help at ucar.edu>
> > > > > > > > wrote:
> > > > > > > >
> > > > > > > > > Hi Zilore.  In 6.0 we've made a large change from
using
> > NetCDF
> > > 3
> > > > to
> > > > > > 4.
> > > > > > > > > You'll need to have both NetCDF 4 and HDF5, upon
which
> > NetCDF 4
> > > > is
> > > > > > > built,
> > > > > > > > > installed.
> > > > > > > > >
> > > > > > > > > Please feel free to take a look at the MET User's
Guide and
> > the
> > > > > > online
> > > > > > > > > tutorial:
> > > > > > > > >
http://www.dtcenter.org/met/users/docs/users_guide/MET_
> > > > > > > > > Users_Guide_v6.0.pdf
> > > > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > > > >
METv6.0/tutorial.php?name=compilation&category=req_libs
> > > > > > > > >
> > > > > > > > > There is an additional environment variable that
will need
> to
> > > be
> > > > > set,
> > > > > > > > with
> > > > > > > > > the addition of HDF5:
> > > > > > > > > Set *$MET_HDF5* to point to the main HDF5 directory.
> > > > > > > > >
> > > > > > > > > Also, both the NetCDF-C package (netcdf-c-4.4.1.1)
and the
> > > > > NetCDF-CXX
> > > > > > > > > package (netcdf-cxx4-4.3.0) are necessary.
> > > > > > > > >
> > > > > > > > > Here are the commands we've been using to compile
these
> > > packages
> > > > > from
> > > > > > > > > source.  The following assumes that you're using the
GNU
> > > > compilers
> > > > > > and
> > > > > > > > that
> > > > > > > > > you've defined MET_LIB_DIR to point to your desired
> > > installation
> > > > > > > > directory:
> > > > > > > > >
> > > > > > > > > # Compilers
> > > > > > > > >
> > > > > > > > > setenv CC `which gcc`
> > > > > > > > >
> > > > > > > > > setenv CXX `which g++`
> > > > > > > > >
> > > > > > > > > setenv FC `which gfortran`
> > > > > > > > > setenv F77 `which gfortran`
> > > > > > > > >
> > > > > > > > > # HDF5
> > > > > > > > >
> > > > > > > > > wget
> > > > > > > > > https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-
1.10/
> > > > > > > > > hdf5-1.10.0-patch1/src/hdf5-1.10.0-patch1.tar
> > > > > > > > >
> > > > > > > > > tar -xvzf hdf5-1.10.0-patch1.tar
> > > > > > > > >
> > > > > > > > > cd hdf5-1.10.0-patch1
> > > > > > > > >
> > > > > > > > > ./configure --prefix=${MET_LIB_DIR}
> > > > > > > > >
> > > > > > > > > make install
> > > > > > > > >
> > > > > > > > > # NetCDF-C
> > > > > > > > >
> > > > > > > > > wget https://github.com/Unidata/
> > netcdf-c/archive/v4.4.1.1.zip
> > > > > > > > >
> > > > > > > > > unzip v4.4.1.1.zip
> > > > > > > > >
> > > > > > > > > cd netcdf-c-4.4.1.1
> > > > > > > > >
> > > > > > > > > ./configure --prefix=${MET_LIB_DIR}
> > > LDFLAGS=-L${MET_LIB_DIR}/lib
> > > > > > > > > CPPFLAGS=-I${MET_LIB_DIR}/include
> > > > > > > > >
> > > > > > > > > make install
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > # NetCDF-CXX
> > > > > > > > >
> > > > > > > > > wget https://github.com/Unidata/netcdf-
cxx4/archive/v4.3.0
> .
> > > > tar.gz
> > > > > > > > >
> > > > > > > > > tar -xvzf v4.3.0.tar.gz
> > > > > > > > >
> > > > > > > > > cd netcdf-cxx4-4.3.0
> > > > > > > > >
> > > > > > > > > ./configure --prefix=${MET_LIB_DIR}
> > > LDFLAGS=-L${MET_LIB_DIR}/lib
> > > > > > > > > CPPFLAGS=-I${MET_LIB_DIR}/include
> > > > > > > > > make install
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > I hope this helps!  Please let us know if you need
further
> > > > > > assistance.
> > > > > > > > >
> > > > > > > > > Thanks,
> > > > > > > > > Julie
> > > > > > > > >
> > > > > > > > > On Sat, Apr 8, 2017 at 3:53 PM, Zilore Mumba via RT
<
> > > > > > met_help at ucar.edu
> > > > > > > >
> > > > > > > > > wrote:
> > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > Ticket/Display.html?id=70551
> > > > >
> > > > > > > > > >
> > > > > > > > > > Julie, I hope you are fine, and that I can still
reach
> you.
> > > In
> > > > > > March
> > > > > > > > 2015
> > > > > > > > > > you helped me installing met_v5.0. I have now
downloaded
> > v6.0
> > > > > and I
> > > > > > > am
> > > > > > > > > > having a compilation error I do not seem to figure
out.
> > > > > > > > > > I believe I have installed all the libraries (and
set the
> > > > > > environment
> > > > > > > > > > variables correctly: BUFRLIB-v10-2-3, netcdf-
4.4.1.1,
> > > gsl-2.3,
> > > > > > > > > > g2clib-1.6.0, freetype-2.7.1 andcairo-1.14.8.
> > > > > > > > > > I also have zlib, jasper and libpng.
> > > > > > > > > > My configure exits with exit code 0 which I
understand to
> > be
> > > > ok.
> > > > > > > > However
> > > > > > > > > my
> > > > > > > > > > make install gives an error of not finding netcdf
(as you
> > can
> > > > see
> > > > > > > from
> > > > > > > > > > make-install.log). I do not understand which
netcdf it
> > cannot
> > > > > find.
> > > > > > > > > > I hope you can assist.
> > > > > > > > > > Zilore
> > > > > > > > > >
> > > > > > > > > > On Thu, Mar 5, 2015 at 7:59 PM, Julie Prestopnik
via RT <
> > > > > > > > > met_help at ucar.edu
> > > > > > > > > > >
> > > > > > > > > > wrote:
> > > > > > > > > >
> > > > > > > > > > > Hi Zilore.  Thanks for sending your commands and
log
> > files.
> > > > > > > > > > >
> > > > > > > > > > > Looking in "config.log" for the string
"BUFRLIB", it
> > > appears
> > > > > that
> > > > > > > you
> > > > > > > > > did
> > > > > > > > > > > not set the environment variable.
> > > > > > > > > > >
> > > > > > > > > > > The linker error occurs on line 1057 of
> make_install.log.
> > > > > > Looking
> > > > > > > at
> > > > > > > > > > that
> > > > > > > > > > > line, we're telling the linker to look in the
following
> > > > > > directories
> > > > > > > > for
> > > > > > > > > > the
> > > > > > > > > > > file named "libbufr.a":
> > > > > > > > > > >
> > > > > > > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8
> > > > > > > > > > > -L/usr/lib/gcc/i686-linux-gnu/
> > 4.8/../../../i386-linux-gnu
> > > > > > > > > > > -L/usr/lib/gcc/i686-linux-
gnu/4.8/../../../../lib
> > > > > > > > > > > -L/lib/i386-linux-gnu
> > > > > > > > > > > -L/lib/../lib
> > > > > > > > > > > -L/usr/lib/i386-linux-gnu
> > > > > > > > > > > -L/usr/lib/../lib
> > > > > > > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../..
> > > > > > > > > > >
> > > > > > > > > > > It must be finding libbufr.a in one of those
> directories,
> > > > > > otherwise
> > > > > > > > we
> > > > > > > > > > > would get an error about that.  I believe that
the
> > version
> > > of
> > > > > > > > libbufr.a
> > > > > > > > > > it
> > > > > > > > > > > is finding is not the version that you compiled
using
> the
> > > > > > > > > "-DUNDERSCORE"
> > > > > > > > > > > option.
> > > > > > > > > > >
> > > > > > > > > > > I was able to replicate your error by re-
compiling a
> > > version
> > > > of
> > > > > > > > BUFRLIB
> > > > > > > > > > > *without* -DUNDERSCORE, and then by building MET
> linking
> > to
> > > > > that
> > > > > > > bad
> > > > > > > > > > > version.
> > > > > > > > > > >
> > > > > > > > > > > What you'll need to do is set the MET_BUFRLIB
> environment
> > > > > > variable
> > > > > > > as
> > > > > > > > > > > indicated on this page:
> > > > > > > > > > > http://www.dtcenter.org/met/
> > users/support/online_tutorial/
> > > > > > > > > > > METv5.0/compilation/configure.php
> > > > > > > > > > >
> > > > > > > > > > > Then source your .cshrc or equivalent file, then
run
> your
> > > > > > configure
> > > > > > > > > > > command, and then run make install and make
test.
> > > > > > > > > > >
> > > > > > > > > > > Please give that a try.  It should solve the
problem
> you
> > > are
> > > > > > > > > > encountering.
> > > > > > > > > > >
> > > > > > > > > > > Thanks,
> > > > > > > > > > > Julie
> > > > > > > > > > >
> > > > > > > > > > > On Wed, Mar 4, 2015 at 5:36 AM, Zilore Mumba via
RT <
> > > > > > > > met_help at ucar.edu
> > > > > > > > > >
> > > > > > > > > > > wrote:
> > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > > > Ticket/Display.html?id=70551
> > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > *Julie, I installed with the following
commands. gcc
> -c
> > > > > > > > -DUNDERSCORE
> > > > > > > > > > *.c*
> > > > > > > > > > > >    *gfortran -c -DUNDERSCORE -fno-second-
underscore
> *.f
> > > > *.F*
> > > > > > > > > > > >    *ar crv libbufr.a *.o*
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > *Please find attached the config.log and
> > > make_install.log *
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > On Tue, Mar 3, 2015 at 7:10 PM, Julie
Prestopnik via
> > RT <
> > > > > > > > > > > met_help at ucar.edu
> > > > > > > > > > > > >
> > > > > > > > > > > > wrote:
> > > > > > > > > > > >
> > > > > > > > > > > > > I'm sorry to hear that you are still
experiencing
> > > > problems
> > > > > > > > > installing
> > > > > > > > > > > > > METv5.0.
> > > > > > > > > > > > >
> > > > > > > > > > > > > Specifically regarding BUFRLIB, please
compile it
> > using
> > > > the
> > > > > > > > options
> > > > > > > > > > > > listed
> > > > > > > > > > > > > on this page:
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > http://www.dtcenter.org/met/
> > > users/support/online_tutorial/
> > > > > > > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > > > >
> > > > > > > > > > > > > Failing to use the "-DUNDERSCORE
> > > -fno-second-underscore"
> > > > > (for
> > > > > > > GNU
> > > > > > > > > > > > > compilers) options will result in undefined
> > references
> > > > when
> > > > > > > > > building
> > > > > > > > > > > the
> > > > > > > > > > > > > pb2nc tool.
> > > > > > > > > > > > >
> > > > > > > > > > > > > If you'd like to send us the output of make
please
> do
> > > the
> > > > > > > > > following:
> > > > > > > > > > > > >    make clean
> > > > > > > > > > > > >    make install >& make_install.log
> > > > > > > > > > > > >
> > > > > > > > > > > > > And then send us the files "config.log" and
> > > > > > "make_install.log".
> > > > > > > > > > > > >
> > > > > > > > > > > > > I hope you'll find what you have been able
to
> install
> > > > > useful.
> > > > > > > > > Please
> > > > > > > > > > > let
> > > > > > > > > > > > > us know if you have any questions.
> > > > > > > > > > > > >
> > > > > > > > > > > > > Thanks,
> > > > > > > > > > > > > Julie
> > > > > > > > > > > > >
> > > > > > > > > > > > > On Tue, Mar 3, 2015 at 12:26 AM, Zilore
Mumba via
> RT
> > <
> > > > > > > > > > > met_help at ucar.edu>
> > > > > > > > > > > > > wrote:
> > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > > > > > Ticket/Display.html?id=70551
> > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > Julie,
> > > > > > > > > > > > > > I did not inform you of the conclusion of
my
> > attempt
> > > to
> > > > > > > install
> > > > > > > > > > > > Met-5.1.
> > > > > > > > > > > > > > After making many attempts in
> > > > reinstalling/reconfiguring
> > > > > > > > BUFRLIB
> > > > > > > > > i
> > > > > > > > > > > > still
> > > > > > > > > > > > > > get errors relating to "undefined
reference to
> ..."
> > > and
> > > > > > > > > eventually
> > > > > > > > > > I
> > > > > > > > > > > > > still
> > > > > > > > > > > > > > have 3 executables not installed: pb2nc,
> > > modis_regrid,
> > > > > > > > > > > plot_mode_field.
> > > > > > > > > > > > > > I would like to learn how to use what I
have and
> > come
> > > > > back
> > > > > > > > later
> > > > > > > > > to
> > > > > > > > > > > > pb2nc
> > > > > > > > > > > > > > if necessary. I will inform you if I have
any
> other
> > > > > > problems.
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > On Tue, Feb 10, 2015 at 7:12 PM, Julie
Prestopnik
> > via
> > > > RT
> > > > > <
> > > > > > > > > > > > > > met_help at ucar.edu>
> > > > > > > > > > > > > > wrote:
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > > Thank you for rerunning and sending this
log.
> > > > Perhaps
> > > > > > MET
> > > > > > > > > cannot
> > > > > > > > > > > > find
> > > > > > > > > > > > > > the
> > > > > > > > > > > > > > > BUFR library.
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > On the following page are directions for
> setting
> > > the
> > > > > > > > > environment
> > > > > > > > > > > > > > variables
> > > > > > > > > > > > > > > before compiling MET:
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > http://www.dtcenter.org/met/
> > > users/support/online_tutorial/
> > > > > > > > > > > METv5.0/compilation/configure.php
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > The rest of the applications built, so
it looks
> > > like
> > > > > MET
> > > > > > > was
> > > > > > > > > able
> > > > > > > > > > > to
> > > > > > > > > > > > > find
> > > > > > > > > > > > > > > the other needed libraries.  The
directions for
> > the
> > > > > BUFR
> > > > > > > > > > > environment
> > > > > > > > > > > > > > > variable on the above page are:
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > "Set *$MET_BUFR* to point to the main
BUFR
> > > directory,
> > > > > or
> > > > > > > set
> > > > > > > > > > > > > > *$MET_BUFRLIB*
> > > > > > > > > > > > > > > to point to the directory with the BUFR
library
> > > > files.
> > > > > > > > Because
> > > > > > > > > > MET
> > > > > > > > > > > > > > doesn't
> > > > > > > > > > > > > > > use any BUFR library include files, you
don't
> > need
> > > to
> > > > > > > specify
> > > > > > > > > > > > > > > *$MET_BUFRINC*
> > > > > > > > > > > > > > > ."
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > Please try setting either *$MET_BUFR *or
> > > > *$MET_BUFRLIB
> > > > > > *and
> > > > > > > > > then
> > > > > > > > > > > > please
> > > > > > > > > > > > > > > rerun the configure script and then
rerun make
> > > > install.
> > > > > > It
> > > > > > > > is
> > > > > > > > > > > > > important
> > > > > > > > > > > > > > to
> > > > > > > > > > > > > > > rerun configure before rerunning make
install.
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > Please let me know how it goes.
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > Thanks,
> > > > > > > > > > > > > > > Julie
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > On Sat, Feb 7, 2015 at 9:36 PM, Zilore
Mumba
> via
> > > RT <
> > > > > > > > > > > > met_help at ucar.edu
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > > wrote:
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > > > > > > > Ticket/Display.html?id=70551
> > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > Julie,
> > > > > > > > > > > > > > > > Attached to this mail, please find the
file
> > > > > > > > make-install.log.
> > > > > > > > > > It
> > > > > > > > > > > > does
> > > > > > > > > > > > > > > > show 'undefined reference' to some
> functions. I
> > > > hope
> > > > > > this
> > > > > > > > > means
> > > > > > > > > > > > > > > > something to you and that you can
help.
> > > > > > > > > > > > > > > > Thanks in advance
> > > > > > > > > > > > > > > > Zilore
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > On 2/5/15, Julie Prestopnik via RT <
> > > > > met_help at ucar.edu>
> > > > > > > > > wrote:
> > > > > > > > > > > > > > > > > Thank you for attaching your log
files.  I
> > did
> > > > not
> > > > > > see
> > > > > > > > any
> > > > > > > > > > > errors
> > > > > > > > > > > > > in
> > > > > > > > > > > > > > > your
> > > > > > > > > > > > > > > > > make-install.log.  Perhaps you ran
make
> > install
> > > > in
> > > > > > the
> > > > > > > > > > > following
> > > > > > > > > > > > > way:
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > make install > make-install.log
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > This would catch standard out but
not
> > standard
> > > > > error.
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > Could you please try running in the
> following
> > > way
> > > > > > with
> > > > > > > > the
> > > > > > > > > &,
> > > > > > > > > > > > which
> > > > > > > > > > > > > > > will
> > > > > > > > > > > > > > > > > also capture standard error?
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > make install >& make-install.log
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > And, then please send me the output
of that
> > > log.
> > > > > > Thank
> > > > > > > > > you!
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > Julie
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > On Tue, Feb 3, 2015 at 2:08 PM,
Zilore
> Mumba
> > > via
> > > > > RT <
> > > > > > > > > > > > > > met_help at ucar.edu
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > wrote:
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > > >> <URL:
https://rt.rap.ucar.edu/rt/Tic
> > > > > > > > > > ket/Display.html?id=70551
> > > > > > > > > > > >
> > > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > > >> Julie,
> > > > > > > > > > > > > > > > >> Thank you very much for your
assistance. I
> > > > failed
> > > > > to
> > > > > > > > > install
> > > > > > > > > > > > Cairo
> > > > > > > > > > > > > > and
> > > > > > > > > > > > > > > > >> freetype because of the
dependencies. I
> will
> > > try
> > > > > > again
> > > > > > > > > with
> > > > > > > > > > > the
> > > > > > > > > > > > > > links
> > > > > > > > > > > > > > > > >> you sent me.
> > > > > > > > > > > > > > > > >> Please find attached my config.log
and
> > > > > > > make-install.log.
> > > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > > >> On 2/2/15, Julie Prestopnik via RT
<
> > > > > > met_help at ucar.edu
> > > > > > > >
> > > > > > > > > > wrote:
> > > > > > > > > > > > > > > > >> > I'm so glad you were able to get
MET
> > > installed
> > > > > and
> > > > > > > > that
> > > > > > > > > > you
> > > > > > > > > > > > > worked
> > > > > > > > > > > > > > > out
> > > > > > > > > > > > > > > > >> the
> > > > > > > > > > > > > > > > >> > issue with the NetCDF environment
> > variables.
> > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > >> > You mentioned that three
executables did
> > not
> > > > > > > build.  I
> > > > > > > > > > would
> > > > > > > > > > > > > like
> > > > > > > > > > > > > > to
> > > > > > > > > > > > > > > > >> > try
> > > > > > > > > > > > > > > > >> to
> > > > > > > > > > > > > > > > >> > help with those.  The
modis_regrid tool
> > has
> > > > > > library
> > > > > > > > > > > > > dependencies -
> > > > > > > > > > > > > > > it
> > > > > > > > > > > > > > > > >> > requires the HDF4 and HDF-EOS2
> libraries.
> > > The
> > > > > > > > > > > plot_mode_field
> > > > > > > > > > > > > > tool
> > > > > > > > > > > > > > > > >> > also
> > > > > > > > > > > > > > > > >> > has library dependencies - it
requires
> the
> > > > Cairo
> > > > > > and
> > > > > > > > > > > FreeType
> > > > > > > > > > > > > > > > >> > libraries.
> > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > >> > You can find information on
compiling
> each
> > > of
> > > > > > those
> > > > > > > > > > library
> > > > > > > > > > > > > > > > >> > dependencies
> > > > > > > > > > > > > > > > >> > here:
> > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > http://www.dtcenter.org/met/
> > > users/support/online_tutorial/
> > > > > > > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > >> > You can find information on
setting the
> up
> > > > > > necessary
> > > > > > > > > > > > environment
> > > > > > > > > > > > > > > > >> variables
> > > > > > > > > > > > > > > > >> > for those library locations here:
> > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > http://www.dtcenter.org/met/
> > > users/support/online_tutorial/
> > > > > > > > > > > METv5.0/compilation/configure.php
> > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > >> > And with pb2nc, I'm not exactly
sure
> what
> > is
> > > > > going
> > > > > > > on
> > > > > > > > > > there.
> > > > > > > > > > > > I
> > > > > > > > > > > > > > > would
> > > > > > > > > > > > > > > > >> > be
> > > > > > > > > > > > > > > > >> > happy to take a look at your
configure
> log
> > > and
> > > > > > make
> > > > > > > > > > install
> > > > > > > > > > > > log
> > > > > > > > > > > > > > > files
> > > > > > > > > > > > > > > > >> > to
> > > > > > > > > > > > > > > > >> > see if I can figure out why you
didn't
> get
> > > the
> > > > > > > > > executable.
> > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > >> > I hope this helps.
> > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > >> > Thanks,
> > > > > > > > > > > > > > > > >> > Julie
> > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > >> > On Sat, Jan 31, 2015 at 5:31 PM,
Zilore
> > > Mumba
> > > > > via
> > > > > > RT
> > > > > > > > > > > > > > > > >> > <met_help at ucar.edu>
> > > > > > > > > > > > > > > > >> > wrote:
> > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > > >> >> <URL:
> > > > > > > > > > > > https://rt.rap.ucar.edu/rt/
> > Ticket/Display.html?id=70551
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > > >> >> Julg
> > > > > > > > > > > > > > > > >> >> Thank you very much for your
help. With
> > the
> > > > > > advice
> > > > > > > > you
> > > > > > > > > > gave
> > > > > > > > > > > > > me, I
> > > > > > > > > > > > > > > was
> > > > > > > > > > > > > > > > >> >> able to install MET using gcc
and
> > > gfortran. I
> > > > > > also
> > > > > > > > had
> > > > > > > > > to
> > > > > > > > > > > to
> > > > > > > > > > > > > > point
> > > > > > > > > > > > > > > > >> >> $MET_NETCDFLIB and,
$MET_NETCDFINC to
> > > > > > > > > > > > > /usr/local/netcdf-4.1.3/lib
> > > > > > > > > > > > > > > and
> > > > > > > > > > > > > > > > >> >> include. Previously I pointed
only to
> > > > > > > > > > > > /usr/local/netcdf-4.1.3.
> > > > > > > > > > > > > > > > >> >> I have three executables not
included
> > > though,
> > > > > > these
> > > > > > > > are
> > > > > > > > > > > > > > > modis_regrid,
> > > > > > > > > > > > > > > > >> >> plot_mode_field and pb2nc.
> > > > > > > > > > > > > > > > >> >> Thank you very much.
> > > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > > >> >> On 1/29/15, Julie Prestopnik via
RT <
> > > > > > > > met_help at ucar.edu
> > > > > > > > > >
> > > > > > > > > > > > wrote:
> > > > > > > > > > > > > > > > >> >> > I am sorry to hear that you
are
> having
> > > > > problems
> > > > > > > > > > > installing
> > > > > > > > > > > > > > > METv5.0.
> > > > > > > > > > > > > > > > >> >> > I
> > > > > > > > > > > > > > > > >> >> > believe this error may have to
do
> with
> > > how
> > > > > you
> > > > > > > > > compiled
> > > > > > > > > > > > > > BUFRLIB.
> > > > > > > > > > > > > > > > >> >> > Please
> > > > > > > > > > > > > > > > >> >> > take a look at the sample
commands
> for
> > > > > > compiling
> > > > > > > > > > BURFLIB
> > > > > > > > > > > on
> > > > > > > > > > > > > > this
> > > > > > > > > > > > > > > > >> >> > page:
> > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > http://www.dtcenter.org/met/
> > > users/support/online_tutorial/
> > > > > > > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > >> >> > I believe that the
> > > *-fno-second-underscore*
> > > > > > (GNU
> > > > > > > > > > > compilers)
> > > > > > > > > > > > > or
> > > > > > > > > > > > > > > > >> >> > *-Mnosecond_underscore* (PGI
> compilers)
> > > > will
> > > > > > fix
> > > > > > > > the
> > > > > > > > > > > error
> > > > > > > > > > > > > > you're
> > > > > > > > > > > > > > > > >> >> > seeing.
> > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > >> >> > I hope that helps.  If it
doesn't,
> > please
> > > > > send
> > > > > > me
> > > > > > > > the
> > > > > > > > > > > files
> > > > > > > > > > > > > > > > >> >> "make_met.log"
> > > > > > > > > > > > > > > > >> >> > and "config.log".
> > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > >> >> > Thanks,
> > > > > > > > > > > > > > > > >> >> > Julie
> > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > >> >> > On Thu, Jan 29, 2015 at 3:48
AM,
> Zilore
> > > > Mumba
> > > > > > via
> > > > > > > > RT
> > > > > > > > > > > > > > > > >> >> > <met_help at ucar.edu>
> > > > > > > > > > > > > > > > >> >> > wrote:
> > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > > > >> >> >> Thu Jan 29 03:48:08 2015:
Request
> > 70551
> > > > was
> > > > > > > acted
> > > > > > > > > > upon.
> > > > > > > > > > > > > > > > >> >> >> Transaction: Ticket created
by
> > > > > > zmumba at gmail.com
> > > > > > > > > > > > > > > > >> >> >>        Queue: met_help
> > > > > > > > > > > > > > > > >> >> >>      Subject: Problem
compiling
> Met-V5
> > > > > > > > > > > > > > > > >> >> >>        Owner: Nobody
> > > > > > > > > > > > > > > > >> >> >>   Requestors:
zmumba at gmail.com
> > > > > > > > > > > > > > > > >> >> >>       Status: new
> > > > > > > > > > > > > > > > >> >> >>  Ticket <URL:
> > > > > > > > > > > > > > > > >> https://rt.rap.ucar.edu/rt/
> > > > > > > Ticket/Display.html?id=70551
> > > > > > > > > > > > > > > > >> >> >> >
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > > > >> >> >> I have installed BUFRLIB, GSL
and
> > G2CLIB
> > > > > > > > > > > > > > > > >> >> >> But then how do I handle the
errors
> > > below
> > > > in
> > > > > > > > > > installing
> > > > > > > > > > > > > > MET_V5?
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > > tools/other/pb2nc/numpbmsg.f:
> > > > > > 23:
> > > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > > >> >> >> reference to `ufbtab_'
> > > > > > > > > > > > > > > > >> >> >> openpb.o: In function
`openpb_':
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > > tools/other/pb2nc/openpb.f:21:
> > > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > > tools/other/pb2nc/openpb.f:22:
> > > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > > > > > > > > > >> >> >> closepb.o: In function
`closepb_':
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > tools/other/pb2nc/closepb.f:
> > > > 19:
> > > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > > >> >> >> reference to `closbf_'
> > > > > > > > > > > > > > > > >> >> >> readpb.o: In function
`readpb_':
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > > tools/other/pb2nc/readpb.f:82:
> > > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > > tools/other/pb2nc/readpb.f:90:
> > > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > > tools/other/pb2nc/readpb.f:94:
> > > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > > > > > > >> >> >> dumppb.o: In function
`readpbdump_':
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > tools/other/pb2nc/dumppb.f:
> > > > 215:
> > > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > tools/other/pb2nc/dumppb.f:
> > > > 218:
> > > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > tools/other/pb2nc/dumppb.f:
> > > > 224:
> > > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > tools/other/pb2nc/dumppb.f:
> > > > 203:
> > > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > tools/other/pb2nc/dumppb.f:
> > > > 228:
> > > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > tools/other/pb2nc/dumppb.f:
> > > > 259:
> > > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > > > > > > >> >> >> dumppb.o: In function
`dumppb_':
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > > tools/other/pb2nc/dumppb.f:56:
> > > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > > tools/other/pb2nc/dumppb.f:57:
> > > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > > > > > > > > > >> >> >> collect2: error: ld returned
1 exit
> > > status
> > > > > > > > > > > > > > > > >> >> >> make[4]: *** [pb2nc] Error 1
> > > > > > > > > > > > > > > > >> >> >> make[4]: Leaving directory
> > > > > > > > > > > > > > > > >> >> >> `/home/zmumba/WRF/met-
5.0/src/
> > > > > > > tools/other/pb2nc'
> > > > > > > > > > > > > > > > >> >> >> make[3]: *** [install-
recursive]
> > Error 1
> > > > > > > > > > > > > > > > >> >> >> make[3]: Leaving directory
> > > > > > > > > > > > > > > > >> >> >> `/home/zmumba/WRF/met-
5.0/src/
> > > > tools/other'
> > > > > > > > > > > > > > > > >> >> >> make[2]: *** [install-
recursive]
> > Error 1
> > > > > > > > > > > > > > > > >> >> >> make[2]: Leaving directory
> > > > > > > > > > > > > > `/home/zmumba/WRF/met-5.0/src/tools'
> > > > > > > > > > > > > > > > >> >> >> make[1]: *** [install-
recursive]
> > Error 1
> > > > > > > > > > > > > > > > >> >> >> make[1]: Leaving directory
> > > > > > > > > > > `/home/zmumba/WRF/met-5.0/src'
> > > > > > > > > > > > > > > > >> >> >> make: *** [install-recursive]
Error
> 1
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > >> >> > --
> > > > > > > > > > > > > > > > >> >> > Julie Prestopnik
> > > > > > > > > > > > > > > > >> >> > National Center for
Atmospheric
> > Research
> > > > > > > > > > > > > > > > >> >> > Research Applications
Laboratory
> > > > > > > > > > > > > > > > >> >> > Phone: 303.497.8399
> > > <%28303%29%20497-8399>
> > > > > > > > > > > > > > > > >> >> > Email: jpresto at ucar.edu
> > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > >> > --
> > > > > > > > > > > > > > > > >> > Julie Prestopnik
> > > > > > > > > > > > > > > > >> > National Center for Atmospheric
Research
> > > > > > > > > > > > > > > > >> > Research Applications Laboratory
> > > > > > > > > > > > > > > > >> > Phone: 303.497.8399
> > > > > > > > > > > > > > > > >> > Email: jpresto at ucar.edu
> > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > --
> > > > > > > > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > > > > > > > National Center for Atmospheric
Research
> > > > > > > > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > --
> > > > > > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > > --
> > > > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > --
> > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> >
> >
>
>

------------------------------------------------
Subject: Problem compiling Met-V5
From: Julie Prestopnik
Time: Thu May 04 10:15:11 2017

Hi Zilore. I apologize for the delay.  I was out of the office.

Thank you for sending so much information.  First, I'll address a few
things I noticed from the email and then will address the
make_install.log
file that you attached.

I see that for many environment variables you have both the main
variable
set and the INC and LIB variables set.  For example:

  export MET_GSL=$MET_LIB_DIR/gsl
  export MET_GSLINC=$MET_LIB_DIR/gsl/include/gsl
  export MET_GSLLIB=$MET_LIB_DIR/gsl/lib

only MET_GSL *OR *MET_GSLINC *AND *MET_GSLLIB need to be set.  So, for
example, you would either set:

export MET_GSL=$MET_LIB_DIR/gsl

or you would set:

  export MET_GSLINC=$MET_LIB_DIR/gsl/include/gsl
  export MET_GSLLIB=$MET_LIB_DIR/gsl/lib

Additionally, MET does not use MET_HDF5INC and MET_HDF5LIB.  It only
uses
MET_HDF5.

You can take a look at this page of our online tutorial to help figure
out
what should be set and what the value should be:

http://www.dtcenter.org/met/users/support/online_tutorial/METv6.0/tutorial.php?name=compilation&category=configure

Please let us know if you have any questions about that page and what
needs
to be set.

Regarding, NetCDF, MET is expecting all of the library and include
files
from the various NetCDF packages to be in one lib and include
directory.
So, for example, if you have the various NetCDF packages in, for
example,
/usr/local/netcdf-4.4.1.1/lib and /usr/local/netcdf-4.4.1.1/include,
and
/usr/local/netcdf-cxx4-4.3.0/lib and /usr/local/netcdf-cxx4-
4.3.0/include,
perhaps you could create a local directory, like
/d1/zmumba/met_external_libraries/netcdf/lib and
/d1/zmumba/met_external_libraries/netcdf/include, for example, and
copy of
the lib and include files from each package from the /usr/local/ area
and
then set the following:

Either

  export MET_NETCDF=/d1/zmumba/met_external_libraries/netcdf

or
  export
MET_NETCDFINC=/d1/zmumba/met_external_libraries/netcdf/include
  export MET_NETCDFLIB=/d1/zmumba/met_external_libraries/netcdf/lib

In your make_install.log file I see the following error:

/usr/bin/ld: cannot find -lgrib2c

You mentioned that you see libgrib2c.a in /usr/local/grib2/g2clib-
1.4.0/

but you have the following set:

  export MET_GRIB2CINC=$MET_LIB_DIR/g2clib
  export MET_GRIB2CLIB=$MET_LIB_DIR/g2clib

so, MET is looking in /usr/local/met6/g2clib/lib for libgrib2c.a.
Instead
you would want to set the MET_GRIB2CINC and MET_GRIB2CLIB environment
variables in the following way:

  export MET_GRIB2CINC=(Set to wherever the include files are for this
library)
  export MET_GRIB2CLIB=/usr/local/grib2/g2clib-1.4.0/

I hope this helps to clarify things.  I would suggest starting with a
fresh
shell so that you clear our all of the current environment variables
that
are set.

Please let us know if you have further questions and please follow up
to
let us know whether or not you were able to successfully install MET.

Thanks!

Julie

On Tue, May 2, 2017 at 3:44 PM, Zilore Mumba via RT
<met_help at ucar.edu>
wrote:

>
> <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
>
> Julie,
> The following is what I have:
> 1. netcdf in* /usr/local/netcdf-4.4.1.1* and in */usr/local* (i.e.
> netcdf-4.4.1.1, netcdf-f and netcdf-cxx)
> 2.hdf5 in* /usr/local/hdf5* and in * /usr/local*
> 3. gsl in /usr/local/met6/gsl and in /usr/local
> 4. BUFRLIB in /usr/local/BUFRLIB (libbufr.a in the directory)
> 5. g2clib in /usr/local/met6/g2clib
> 6. cairo in /usr/local/cairo
> 7. freetype in /usr/local/freetype
>
> The following are environment variables I set:
>   export NETCDF=/usr/local/netcdf-4.4.1.1
>   export NETCDF_LIB=/usr/local/netcdf-4.4.1.1/lib
>
>   export HDF5_DIR=/usr/local/hdf5
>   export PATH=$PATH:$HDF5_DIR/bin
>
>   export MET_LIB_DIR=/usr/local/met6
>   export MET_LIBINC=$MET_LIB_DIR/include
>   export MET_LIBLIB=$MET_LIB_DIR/lib
>
>   export MET_NETCDF=$NETCDF
>   export MET_NETCDFINC=$MET_NETCDF/include
>   export MET_NETCDFLIB=$MET_NETCDF/lib
>   export PATH=$PATH:$MET_NETCDF/bin
>
>   export MET_BUFRLIB=$MET_LIB_DIR/BUFRLIB
>   export MET_GSL=$MET_LIB_DIR/gsl
>   export MET_GSLINC=$MET_LIB_DIR/gsl/include/gsl
>   export MET_GSLLIB=$MET_LIB_DIR/gsl/lib
>
>   export MET_GRIB2CINC=$MET_LIB_DIR/g2clib
>   export MET_GRIB2CLIB=$MET_LIB_DIR/g2clib
>
>   export MET_HDF5=$MET_LIB_DIR/hdf5
>   export MET_HDF5LIB=$MET_HDF5/lib
>   export MET_HDF5INC=$MET_HDF5/include
>
>   export MET_CAIROINC=/usr/local/cairo/include
>   export MET_CAIROLIB=/usr/local/cairo/lib
>   export MET_FREETYPEINC=/usr/local/freetype/include
>   export MET_FREETYPELIB=/usr/local/freetype/lib
>
> I also have:
>   export JASPERLIB=/usr/local/lib
>   export JASPERINC=/usr/local/include
>
>   export PNGLIB=/usr/local/lib
>   export PNGINC=/usr/local/include
>   export JPEGLIB=/usr/local/lib
>
> and my LD_LIBRARY_PATH:
>   export
> LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib:/usr/lib:$
> MET_LIB_DIR/g2clib:$MET_HDF5/lib:$MET_LIB_DIR/BUFRLIB:$MET_
> LIB_DIR/gsl/lib:/usr/local/freetype/lib:/usr/local/cairo/
> lib:$NETCDF/lib:$MET_NETCDF/lib:/lib:/usr/lib/i386-linux-
> gnu:/lib/i386-linux-gnu:/usr/lib/ccache
>
> I issued the commands, as root:
> ./configure --prefix=/usr/local/met6 --enable-grib2 --enable-modis
> make install >& make_install.log
> The output of the last command is in the attached file.
>
> When I put locate *libgrib2c.a,* it points me to
> /usr/local/grib2/g2clib-1.4.0/libgrib2c.a. I installed this with
> wgrib2.tgz
> (I think).
>  There is no bin directory and no executables created.
>
> I hope you can look at this and advise.
> Zilore
>
> On Tue, May 2, 2017 at 5:25 PM, Julie Prestopnik via RT
<met_help at ucar.edu
> >
> wrote:
>
> > Hi Zilore.  No need to apologize.  I just wanted to check in, in
case you
> > still needed any help getting MET installed.
> >
> > You should not need to reorganize your installation to put
anything in
> > /usr/local/.  We should be able to tell MET where to find anything
it
> > needs.
> >
> > Do you already have successful installations of gsl, cairo,
freetype, and
> > bufrlib elsewhere?  If so, I would suggest we go ahead and use
those
> > installations, telling MET where to find them.  I can help take
you
> through
> > that process.
> >
> > Please let me know, and we can go from there.
> >
> > Kind regards,
> > Julie
> >
> > On Tue, May 2, 2017 at 2:27 AM, Zilore Mumba via RT
<met_help at ucar.edu>
> > wrote:
> >
> > >
> > > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > >
> > > Julie,
> > > My apologies, since you sent me mail I had no access to Internet
until
> > > today.
> > > I have not been able to install met-6.0. My problem seems to
have got
> > > worse.
> > > I was trying to reorganize my installation by trying to install
> > everything
> > > in /usr/local so that I do not have any complications of some
libraries
> > not
> > > being found.
> > >
> > > I managed to install *gsl-2.3. T*he libraries are installed,
though
> make
> > > check gives one failed test, *Makefile:750: recipe for target
> > > 'test-suite.log' failed* (and says See linalg/test-suite.log)
> > >
> > > *I installed cairo-1.14.8* and *freetype-2.7.1* in their own
> directories
> > in
> > > */usr/loca*l, i.e. */usr/loca*l/cairo and */usr/loca*l/freetype.
Howver
> > > trtying to reinstall these in */usr/loca*l I am now getting a
lot of
> c++
> > > style comment problems. I have to work this out.
> > >
> > > Then I copied BUFRLIB_v10-2-3.tar to /usr/local, untarred it in
that
> > > directory.
> > > Running:
> > > *preproc.sh*,
> > > *gcc -c -DUNDERSCORE *.c,*
> > > *gfortran -c -DUNDERSCORE -fno-second-underscore *.f *.F*
> > > */usr/loca*l
> > > *gives the errors in the files attached*
> > >
> > > *.*
> > > *I am not sure if I should just copy **g2clib** into**
/usr/local.
> > **There
> > > are no instructions on how to install, but it has *
> > >
> > > *libg2c.a*
> > >
> > > *So currently am still looking at all these issues. Perhaps you
can
> > assist
> > > me on BUFRLIB. What am I doing wrong? Previously I have not had
any
> > > problem.*
> > >
> > > *Best Regards*
> > > *Zilore*
> > >
> > > On Thu, Apr 27, 2017 at 9:09 PM, Julie Prestopnik via RT <
> > > met_help at ucar.edu>
> > > wrote:
> > >
> > > > Hi Zilore.
> > > >
> > > > I just wanted to touch base and see if you were able to
resolve the
> > > > problem.  Please let us know if you need further assistance.
> > > >
> > > > Thanks,
> > > > Julie
> > > >
> > > > On Tue, Apr 11, 2017 at 4:12 PM, Zilore Mumba via RT <
> > met_help at ucar.edu>
> > > > wrote:
> > > >
> > > > >
> > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > > > >
> > > > > Julie,
> > > > > Thanks once again for your time. My apologies, because in
the
> > > > environmental
> > > > > variable I put "/usr/local/MET6" while as the directory I
created
> was
> > > > > "/usr/local/met6", i.e. met capitalized. When I do "ll
> > $MET_NETCDFINC"
> > > I
> > > > > can see the include files, including "netcdf".
> > > > > But am getting the same error. Let me work over it. I will
get back
> > to
> > > > you
> > > > > if I fail or succeed.
> > > > > Best regards
> > > > > Zilore
> > > > >
> > > > > On Tue, Apr 11, 2017 at 9:52 PM, Julie Prestopnik via RT <
> > > > > met_help at ucar.edu>
> > > > > wrote:
> > > > >
> > > > > > Hi Zilore.
> > > > > >
> > > > > > In your config.log file, it appears that you do not have
your MET
> > > > > > environment variables set up.  The MET build process uses
> > environment
> > > > > > variables to specify the locations of the needed external
> > libraries.
> > > > > >
> > > > > > The following page describes the MET environment variables
that
> you
> > > > will
> > > > > > need to set up in your .cshrc or equivalent file:
> > > > > >
> > > > > > http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > METv6.0/tutorial.php?name=compilation&category=configure
> > > > > >
> > > > > > The error you are getting:
> > > > > >
> > > > > > In file included from nc_var_info.cc:24:0:
> > > > > > nc_utils.h:22:18: fatal error: netcdf: No such file or
directory
> > > > > >
> > > > > > seems to imply that MET doesn't know where to find the
file
> > "netcdf",
> > > > > which
> > > > > > is included in the NetCDF-CXX installation.  It could be
that
> > > > NetCDF-CXX
> > > > > is
> > > > > > installed and that file does exist, but MET just doesn't
know
> where
> > > to
> > > > > find
> > > > > > it.  Setting those environment variables will help MET
know where
> > > those
> > > > > > required libraries and include files are.
> > > > > >
> > > > > > Here is a quick reference checklist for NetCDF4C++
installation
> > that
> > > > you
> > > > > > can use to see if you have the necessary files:
> > > > > >
> > > > > > Files for NetCDF4 C:
> > > > > >
> > > > > >    - $MET_NETCDF/include/netcdf.h
> > > > > >    - $MET_NETCDF/lib/libnetcdf.a
> > > > > >    - $MET_NETCDF/lib/libnetcdf.so
> > > > > >
> > > > > > Files for NetCDF4 C++:
> > > > > >
> > > > > >    - $MET_NETCDF/include/netcdf
> > > > > >    - $MET_NETCDF/lib/libnetcdf_c++4.a
> > > > > >    - $MET_NETCDF/lib/libnetcdf_c++4.so
> > > > > >
> > > > > > Files for NetCDF3 C++ (not required, if --disabled-netcdf4
is
> > > > activated):
> > > > > >
> > > > > >    - $MET_NETCDF/include/netcdf.hh
> > > > > >    - $MET_NETCDF/lib/libnetcdf_c++.a
> > > > > >    - $MET_NETCDF/lib/libnetcdf_c++.so
> > > > > >
> > > > > > Please follow the instructions on the webpage above to set
up the
> > > > > necessary
> > > > > > environment variables, then please reconfigure and
recompile MET
> > and
> > > > let
> > > > > us
> > > > > > know if you encounter further difficulty.
> > > > > >
> > > > > > I hope this helps!
> > > > > >
> > > > > > Thanks!
> > > > > >
> > > > > > Julie
> > > > > >
> > > > > > On Tue, Apr 11, 2017 at 1:22 PM, Zilore Mumba via RT <
> > > > met_help at ucar.edu>
> > > > > > wrote:
> > > > > >
> > > > > > >
> > > > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
> >
> > > > > > >
> > > > > > > Julie,
> > > > > > > Please find attached to this mail, my config.log and
> > > > make-install.log.
> > > > > > >
> > > > > > > On Tue, Apr 11, 2017 at 4:29 PM, Julie Prestopnik via RT
<
> > > > > > > met_help at ucar.edu>
> > > > > > > wrote:
> > > > > > >
> > > > > > > > Hi Zilore.  I'm sorry to hear that you are still
experiencing
> > > > > problems.
> > > > > > > > Could you please send your most recent configure.log
and
> > > > > > make_install.log
> > > > > > > > files?
> > > > > > > >
> > > > > > > > Thanks!
> > > > > > > >
> > > > > > > > Julie
> > > > > > > >
> > > > > > > > On Tue, Apr 11, 2017 at 8:13 AM, Zilore Mumba via RT <
> > > > > > met_help at ucar.edu>
> > > > > > > > wrote:
> > > > > > > >
> > > > > > > > >
> > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > Ticket/Display.html?id=70551
> > > >
> > > > > > > > >
> > > > > > > > > Julie,
> > > > > > > > > Thanks very much for all the details you provided.
> > > > > > > > > However, am still getting the same error, i.e.
> > > > > > > > > The file "nc_var_info.cc" (i.e. #include on line 24)
calls
> > > > > > > "nc_utils.h".
> > > > > > > > > Now the latter file has "#include netcdf" on line
22. It is
> > > this
> > > > > > netcdf
> > > > > > > > it
> > > > > > > > > is saying no such file.
> > > > > > > > >
> > > > > > > > > I believe my setup is ok.
> > > > > > > > > Using the lines you gave me on installing the hdf5
and
> netcdf
> > > > > > > libraries,
> > > > > > > > if
> > > > > > > > > I use prefix=${MET_LIB_DIR}, I am not able to find
where
> the
> > > > > > libraries
> > > > > > > > are
> > > > > > > > > installed, though there are no errors indicated. I
tried to
> > set
> > > > > > "export
> > > > > > > > > MET_LIB_DIR=/usr/local/met6" and alternatively
"export
> > > > > > > > MET_LIB_DIR=~/met6"
> > > > > > > > > after creating the met6 directory in each case.
> > > > > > > > > But putting prefix=/usr/local/met6, I get both
netcdf-c and
> > > > > > netcdf-cxx
> > > > > > > > > libraries in /usr/local/met6/lib, include files in
> > > > > > > > /usr/local/met6/include,
> > > > > > > > > and some executables in /usr/local/met6/bin as well
as an
> > hdf5
> > > > > > > directory.
> > > > > > > > > So am wondering if the include file nc_utils.h has
the
> > correct
> > > > > entry
> > > > > > on
> > > > > > > > > line 22.
> > > > > > > > > Thanks for your time and effort
> > > > > > > > > Zilore
> > > > > > > > >
> > > > > > > > > On Mon, Apr 10, 2017 at 5:40 PM, Julie Prestopnik
via RT <
> > > > > > > > > met_help at ucar.edu>
> > > > > > > > > wrote:
> > > > > > > > >
> > > > > > > > > > Hi Zilore.  In 6.0 we've made a large change from
using
> > > NetCDF
> > > > 3
> > > > > to
> > > > > > > 4.
> > > > > > > > > > You'll need to have both NetCDF 4 and HDF5, upon
which
> > > NetCDF 4
> > > > > is
> > > > > > > > built,
> > > > > > > > > > installed.
> > > > > > > > > >
> > > > > > > > > > Please feel free to take a look at the MET User's
Guide
> and
> > > the
> > > > > > > online
> > > > > > > > > > tutorial:
> > > > > > > > > >
http://www.dtcenter.org/met/users/docs/users_guide/MET_
> > > > > > > > > > Users_Guide_v6.0.pdf
> > > > > > > > > > http://www.dtcenter.org/met/
> users/support/online_tutorial/
> > > > > > > > > >
METv6.0/tutorial.php?name=compilation&category=req_libs
> > > > > > > > > >
> > > > > > > > > > There is an additional environment variable that
will
> need
> > to
> > > > be
> > > > > > set,
> > > > > > > > > with
> > > > > > > > > > the addition of HDF5:
> > > > > > > > > > Set *$MET_HDF5* to point to the main HDF5
directory.
> > > > > > > > > >
> > > > > > > > > > Also, both the NetCDF-C package (netcdf-c-4.4.1.1)
and
> the
> > > > > > NetCDF-CXX
> > > > > > > > > > package (netcdf-cxx4-4.3.0) are necessary.
> > > > > > > > > >
> > > > > > > > > > Here are the commands we've been using to compile
these
> > > > packages
> > > > > > from
> > > > > > > > > > source.  The following assumes that you're using
the GNU
> > > > > compilers
> > > > > > > and
> > > > > > > > > that
> > > > > > > > > > you've defined MET_LIB_DIR to point to your
desired
> > > > installation
> > > > > > > > > directory:
> > > > > > > > > >
> > > > > > > > > > # Compilers
> > > > > > > > > >
> > > > > > > > > > setenv CC `which gcc`
> > > > > > > > > >
> > > > > > > > > > setenv CXX `which g++`
> > > > > > > > > >
> > > > > > > > > > setenv FC `which gfortran`
> > > > > > > > > > setenv F77 `which gfortran`
> > > > > > > > > >
> > > > > > > > > > # HDF5
> > > > > > > > > >
> > > > > > > > > > wget
> > > > > > > > > > https://support.hdfgroup.org/
> ftp/HDF5/releases/hdf5-1.10/
> > > > > > > > > > hdf5-1.10.0-patch1/src/hdf5-1.10.0-patch1.tar
> > > > > > > > > >
> > > > > > > > > > tar -xvzf hdf5-1.10.0-patch1.tar
> > > > > > > > > >
> > > > > > > > > > cd hdf5-1.10.0-patch1
> > > > > > > > > >
> > > > > > > > > > ./configure --prefix=${MET_LIB_DIR}
> > > > > > > > > >
> > > > > > > > > > make install
> > > > > > > > > >
> > > > > > > > > > # NetCDF-C
> > > > > > > > > >
> > > > > > > > > > wget https://github.com/Unidata/
> > > netcdf-c/archive/v4.4.1.1.zip
> > > > > > > > > >
> > > > > > > > > > unzip v4.4.1.1.zip
> > > > > > > > > >
> > > > > > > > > > cd netcdf-c-4.4.1.1
> > > > > > > > > >
> > > > > > > > > > ./configure --prefix=${MET_LIB_DIR}
> > > > LDFLAGS=-L${MET_LIB_DIR}/lib
> > > > > > > > > > CPPFLAGS=-I${MET_LIB_DIR}/include
> > > > > > > > > >
> > > > > > > > > > make install
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > # NetCDF-CXX
> > > > > > > > > >
> > > > > > > > > > wget https://github.com/Unidata/
> netcdf-cxx4/archive/v4.3.0
> > .
> > > > > tar.gz
> > > > > > > > > >
> > > > > > > > > > tar -xvzf v4.3.0.tar.gz
> > > > > > > > > >
> > > > > > > > > > cd netcdf-cxx4-4.3.0
> > > > > > > > > >
> > > > > > > > > > ./configure --prefix=${MET_LIB_DIR}
> > > > LDFLAGS=-L${MET_LIB_DIR}/lib
> > > > > > > > > > CPPFLAGS=-I${MET_LIB_DIR}/include
> > > > > > > > > > make install
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > > I hope this helps!  Please let us know if you need
> further
> > > > > > > assistance.
> > > > > > > > > >
> > > > > > > > > > Thanks,
> > > > > > > > > > Julie
> > > > > > > > > >
> > > > > > > > > > On Sat, Apr 8, 2017 at 3:53 PM, Zilore Mumba via
RT <
> > > > > > > met_help at ucar.edu
> > > > > > > > >
> > > > > > > > > > wrote:
> > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > > Ticket/Display.html?id=70551
> > > > > >
> > > > > > > > > > >
> > > > > > > > > > > Julie, I hope you are fine, and that I can still
reach
> > you.
> > > > In
> > > > > > > March
> > > > > > > > > 2015
> > > > > > > > > > > you helped me installing met_v5.0. I have now
> downloaded
> > > v6.0
> > > > > > and I
> > > > > > > > am
> > > > > > > > > > > having a compilation error I do not seem to
figure out.
> > > > > > > > > > > I believe I have installed all the libraries
(and set
> the
> > > > > > > environment
> > > > > > > > > > > variables correctly: BUFRLIB-v10-2-3, netcdf-
4.4.1.1,
> > > > gsl-2.3,
> > > > > > > > > > > g2clib-1.6.0, freetype-2.7.1 andcairo-1.14.8.
> > > > > > > > > > > I also have zlib, jasper and libpng.
> > > > > > > > > > > My configure exits with exit code 0 which I
understand
> to
> > > be
> > > > > ok.
> > > > > > > > > However
> > > > > > > > > > my
> > > > > > > > > > > make install gives an error of not finding
netcdf (as
> you
> > > can
> > > > > see
> > > > > > > > from
> > > > > > > > > > > make-install.log). I do not understand which
netcdf it
> > > cannot
> > > > > > find.
> > > > > > > > > > > I hope you can assist.
> > > > > > > > > > > Zilore
> > > > > > > > > > >
> > > > > > > > > > > On Thu, Mar 5, 2015 at 7:59 PM, Julie Prestopnik
via
> RT <
> > > > > > > > > > met_help at ucar.edu
> > > > > > > > > > > >
> > > > > > > > > > > wrote:
> > > > > > > > > > >
> > > > > > > > > > > > Hi Zilore.  Thanks for sending your commands
and log
> > > files.
> > > > > > > > > > > >
> > > > > > > > > > > > Looking in "config.log" for the string
"BUFRLIB", it
> > > > appears
> > > > > > that
> > > > > > > > you
> > > > > > > > > > did
> > > > > > > > > > > > not set the environment variable.
> > > > > > > > > > > >
> > > > > > > > > > > > The linker error occurs on line 1057 of
> > make_install.log.
> > > > > > > Looking
> > > > > > > > at
> > > > > > > > > > > that
> > > > > > > > > > > > line, we're telling the linker to look in the
> following
> > > > > > > directories
> > > > > > > > > for
> > > > > > > > > > > the
> > > > > > > > > > > > file named "libbufr.a":
> > > > > > > > > > > >
> > > > > > > > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8
> > > > > > > > > > > > -L/usr/lib/gcc/i686-linux-gnu/
> > > 4.8/../../../i386-linux-gnu
> > > > > > > > > > > > -L/usr/lib/gcc/i686-linux-
gnu/4.8/../../../../lib
> > > > > > > > > > > > -L/lib/i386-linux-gnu
> > > > > > > > > > > > -L/lib/../lib
> > > > > > > > > > > > -L/usr/lib/i386-linux-gnu
> > > > > > > > > > > > -L/usr/lib/../lib
> > > > > > > > > > > > -L/usr/lib/gcc/i686-linux-gnu/4.8/../../..
> > > > > > > > > > > >
> > > > > > > > > > > > It must be finding libbufr.a in one of those
> > directories,
> > > > > > > otherwise
> > > > > > > > > we
> > > > > > > > > > > > would get an error about that.  I believe that
the
> > > version
> > > > of
> > > > > > > > > libbufr.a
> > > > > > > > > > > it
> > > > > > > > > > > > is finding is not the version that you
compiled using
> > the
> > > > > > > > > > "-DUNDERSCORE"
> > > > > > > > > > > > option.
> > > > > > > > > > > >
> > > > > > > > > > > > I was able to replicate your error by re-
compiling a
> > > > version
> > > > > of
> > > > > > > > > BUFRLIB
> > > > > > > > > > > > *without* -DUNDERSCORE, and then by building
MET
> > linking
> > > to
> > > > > > that
> > > > > > > > bad
> > > > > > > > > > > > version.
> > > > > > > > > > > >
> > > > > > > > > > > > What you'll need to do is set the MET_BUFRLIB
> > environment
> > > > > > > variable
> > > > > > > > as
> > > > > > > > > > > > indicated on this page:
> > > > > > > > > > > > http://www.dtcenter.org/met/
> > > users/support/online_tutorial/
> > > > > > > > > > > > METv5.0/compilation/configure.php
> > > > > > > > > > > >
> > > > > > > > > > > > Then source your .cshrc or equivalent file,
then run
> > your
> > > > > > > configure
> > > > > > > > > > > > command, and then run make install and make
test.
> > > > > > > > > > > >
> > > > > > > > > > > > Please give that a try.  It should solve the
problem
> > you
> > > > are
> > > > > > > > > > > encountering.
> > > > > > > > > > > >
> > > > > > > > > > > > Thanks,
> > > > > > > > > > > > Julie
> > > > > > > > > > > >
> > > > > > > > > > > > On Wed, Mar 4, 2015 at 5:36 AM, Zilore Mumba
via RT <
> > > > > > > > > met_help at ucar.edu
> > > > > > > > > > >
> > > > > > > > > > > > wrote:
> > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > > > > Ticket/Display.html?id=70551
> > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > > *Julie, I installed with the following
commands.
> gcc
> > -c
> > > > > > > > > -DUNDERSCORE
> > > > > > > > > > > *.c*
> > > > > > > > > > > > >    *gfortran -c -DUNDERSCORE -fno-second-
underscore
> > *.f
> > > > > *.F*
> > > > > > > > > > > > >    *ar crv libbufr.a *.o*
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > > *Please find attached the config.log and
> > > > make_install.log *
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > > On Tue, Mar 3, 2015 at 7:10 PM, Julie
Prestopnik
> via
> > > RT <
> > > > > > > > > > > > met_help at ucar.edu
> > > > > > > > > > > > > >
> > > > > > > > > > > > > wrote:
> > > > > > > > > > > > >
> > > > > > > > > > > > > > I'm sorry to hear that you are still
experiencing
> > > > > problems
> > > > > > > > > > installing
> > > > > > > > > > > > > > METv5.0.
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > Specifically regarding BUFRLIB, please
compile it
> > > using
> > > > > the
> > > > > > > > > options
> > > > > > > > > > > > > listed
> > > > > > > > > > > > > > on this page:
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > http://www.dtcenter.org/met/
> > > > users/support/online_tutorial/
> > > > > > > > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > Failing to use the "-DUNDERSCORE
> > > > -fno-second-underscore"
> > > > > > (for
> > > > > > > > GNU
> > > > > > > > > > > > > > compilers) options will result in
undefined
> > > references
> > > > > when
> > > > > > > > > > building
> > > > > > > > > > > > the
> > > > > > > > > > > > > > pb2nc tool.
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > If you'd like to send us the output of
make
> please
> > do
> > > > the
> > > > > > > > > > following:
> > > > > > > > > > > > > >    make clean
> > > > > > > > > > > > > >    make install >& make_install.log
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > And then send us the files "config.log"
and
> > > > > > > "make_install.log".
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > I hope you'll find what you have been able
to
> > install
> > > > > > useful.
> > > > > > > > > > Please
> > > > > > > > > > > > let
> > > > > > > > > > > > > > us know if you have any questions.
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > Thanks,
> > > > > > > > > > > > > > Julie
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > On Tue, Mar 3, 2015 at 12:26 AM, Zilore
Mumba via
> > RT
> > > <
> > > > > > > > > > > > met_help at ucar.edu>
> > > > > > > > > > > > > > wrote:
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > > > > > > Ticket/Display.html?id=70551
> > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > Julie,
> > > > > > > > > > > > > > > I did not inform you of the conclusion
of my
> > > attempt
> > > > to
> > > > > > > > install
> > > > > > > > > > > > > Met-5.1.
> > > > > > > > > > > > > > > After making many attempts in
> > > > > reinstalling/reconfiguring
> > > > > > > > > BUFRLIB
> > > > > > > > > > i
> > > > > > > > > > > > > still
> > > > > > > > > > > > > > > get errors relating to "undefined
reference to
> > ..."
> > > > and
> > > > > > > > > > eventually
> > > > > > > > > > > I
> > > > > > > > > > > > > > still
> > > > > > > > > > > > > > > have 3 executables not installed: pb2nc,
> > > > modis_regrid,
> > > > > > > > > > > > plot_mode_field.
> > > > > > > > > > > > > > > I would like to learn how to use what I
have
> and
> > > come
> > > > > > back
> > > > > > > > > later
> > > > > > > > > > to
> > > > > > > > > > > > > pb2nc
> > > > > > > > > > > > > > > if necessary. I will inform you if I
have any
> > other
> > > > > > > problems.
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > On Tue, Feb 10, 2015 at 7:12 PM, Julie
> Prestopnik
> > > via
> > > > > RT
> > > > > > <
> > > > > > > > > > > > > > > met_help at ucar.edu>
> > > > > > > > > > > > > > > wrote:
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > Thank you for rerunning and sending
this log.
> > > > > Perhaps
> > > > > > > MET
> > > > > > > > > > cannot
> > > > > > > > > > > > > find
> > > > > > > > > > > > > > > the
> > > > > > > > > > > > > > > > BUFR library.
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > On the following page are directions
for
> > setting
> > > > the
> > > > > > > > > > environment
> > > > > > > > > > > > > > > variables
> > > > > > > > > > > > > > > > before compiling MET:
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > http://www.dtcenter.org/met/
> > > > users/support/online_tutorial/
> > > > > > > > > > > > METv5.0/compilation/configure.php
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > The rest of the applications built, so
it
> looks
> > > > like
> > > > > > MET
> > > > > > > > was
> > > > > > > > > > able
> > > > > > > > > > > > to
> > > > > > > > > > > > > > find
> > > > > > > > > > > > > > > > the other needed libraries.  The
directions
> for
> > > the
> > > > > > BUFR
> > > > > > > > > > > > environment
> > > > > > > > > > > > > > > > variable on the above page are:
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > "Set *$MET_BUFR* to point to the main
BUFR
> > > > directory,
> > > > > > or
> > > > > > > > set
> > > > > > > > > > > > > > > *$MET_BUFRLIB*
> > > > > > > > > > > > > > > > to point to the directory with the
BUFR
> library
> > > > > files.
> > > > > > > > > Because
> > > > > > > > > > > MET
> > > > > > > > > > > > > > > doesn't
> > > > > > > > > > > > > > > > use any BUFR library include files,
you don't
> > > need
> > > > to
> > > > > > > > specify
> > > > > > > > > > > > > > > > *$MET_BUFRINC*
> > > > > > > > > > > > > > > > ."
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > Please try setting either *$MET_BUFR
*or
> > > > > *$MET_BUFRLIB
> > > > > > > *and
> > > > > > > > > > then
> > > > > > > > > > > > > please
> > > > > > > > > > > > > > > > rerun the configure script and then
rerun
> make
> > > > > install.
> > > > > > > It
> > > > > > > > > is
> > > > > > > > > > > > > > important
> > > > > > > > > > > > > > > to
> > > > > > > > > > > > > > > > rerun configure before rerunning make
> install.
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > Please let me know how it goes.
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > Thanks,
> > > > > > > > > > > > > > > > Julie
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > On Sat, Feb 7, 2015 at 9:36 PM, Zilore
Mumba
> > via
> > > > RT <
> > > > > > > > > > > > > met_help at ucar.edu
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > wrote:
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> > > > > > > > > > Ticket/Display.html?id=70551
> > > > > > > > > > > >
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > Julie,
> > > > > > > > > > > > > > > > > Attached to this mail, please find
the file
> > > > > > > > > make-install.log.
> > > > > > > > > > > It
> > > > > > > > > > > > > does
> > > > > > > > > > > > > > > > > show 'undefined reference' to some
> > functions. I
> > > > > hope
> > > > > > > this
> > > > > > > > > > means
> > > > > > > > > > > > > > > > > something to you and that you can
help.
> > > > > > > > > > > > > > > > > Thanks in advance
> > > > > > > > > > > > > > > > > Zilore
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > On 2/5/15, Julie Prestopnik via RT <
> > > > > > met_help at ucar.edu>
> > > > > > > > > > wrote:
> > > > > > > > > > > > > > > > > > Thank you for attaching your log
files.
> I
> > > did
> > > > > not
> > > > > > > see
> > > > > > > > > any
> > > > > > > > > > > > errors
> > > > > > > > > > > > > > in
> > > > > > > > > > > > > > > > your
> > > > > > > > > > > > > > > > > > make-install.log.  Perhaps you ran
make
> > > install
> > > > > in
> > > > > > > the
> > > > > > > > > > > > following
> > > > > > > > > > > > > > way:
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > make install > make-install.log
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > This would catch standard out but
not
> > > standard
> > > > > > error.
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > Could you please try running in
the
> > following
> > > > way
> > > > > > > with
> > > > > > > > > the
> > > > > > > > > > &,
> > > > > > > > > > > > > which
> > > > > > > > > > > > > > > > will
> > > > > > > > > > > > > > > > > > also capture standard error?
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > make install >& make-install.log
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > And, then please send me the
output of
> that
> > > > log.
> > > > > > > Thank
> > > > > > > > > > you!
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > Julie
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > On Tue, Feb 3, 2015 at 2:08 PM,
Zilore
> > Mumba
> > > > via
> > > > > > RT <
> > > > > > > > > > > > > > > met_help at ucar.edu
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > wrote:
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > > > >> <URL:
https://rt.rap.ucar.edu/rt/Tic
> > > > > > > > > > > ket/Display.html?id=70551
> > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > > > >> Julie,
> > > > > > > > > > > > > > > > > >> Thank you very much for your
> assistance. I
> > > > > failed
> > > > > > to
> > > > > > > > > > install
> > > > > > > > > > > > > Cairo
> > > > > > > > > > > > > > > and
> > > > > > > > > > > > > > > > > >> freetype because of the
dependencies. I
> > will
> > > > try
> > > > > > > again
> > > > > > > > > > with
> > > > > > > > > > > > the
> > > > > > > > > > > > > > > links
> > > > > > > > > > > > > > > > > >> you sent me.
> > > > > > > > > > > > > > > > > >> Please find attached my
config.log and
> > > > > > > > make-install.log.
> > > > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > > > >> On 2/2/15, Julie Prestopnik via
RT <
> > > > > > > met_help at ucar.edu
> > > > > > > > >
> > > > > > > > > > > wrote:
> > > > > > > > > > > > > > > > > >> > I'm so glad you were able to
get MET
> > > > installed
> > > > > > and
> > > > > > > > > that
> > > > > > > > > > > you
> > > > > > > > > > > > > > worked
> > > > > > > > > > > > > > > > out
> > > > > > > > > > > > > > > > > >> the
> > > > > > > > > > > > > > > > > >> > issue with the NetCDF
environment
> > > variables.
> > > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > > >> > You mentioned that three
executables
> did
> > > not
> > > > > > > > build.  I
> > > > > > > > > > > would
> > > > > > > > > > > > > > like
> > > > > > > > > > > > > > > to
> > > > > > > > > > > > > > > > > >> > try
> > > > > > > > > > > > > > > > > >> to
> > > > > > > > > > > > > > > > > >> > help with those.  The
modis_regrid
> tool
> > > has
> > > > > > > library
> > > > > > > > > > > > > > dependencies -
> > > > > > > > > > > > > > > > it
> > > > > > > > > > > > > > > > > >> > requires the HDF4 and HDF-EOS2
> > libraries.
> > > > The
> > > > > > > > > > > > plot_mode_field
> > > > > > > > > > > > > > > tool
> > > > > > > > > > > > > > > > > >> > also
> > > > > > > > > > > > > > > > > >> > has library dependencies - it
requires
> > the
> > > > > Cairo
> > > > > > > and
> > > > > > > > > > > > FreeType
> > > > > > > > > > > > > > > > > >> > libraries.
> > > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > > >> > You can find information on
compiling
> > each
> > > > of
> > > > > > > those
> > > > > > > > > > > library
> > > > > > > > > > > > > > > > > >> > dependencies
> > > > > > > > > > > > > > > > > >> > here:
> > > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > http://www.dtcenter.org/met/
> > > > users/support/online_tutorial/
> > > > > > > > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > > >> > You can find information on
setting
> the
> > up
> > > > > > > necessary
> > > > > > > > > > > > > environment
> > > > > > > > > > > > > > > > > >> variables
> > > > > > > > > > > > > > > > > >> > for those library locations
here:
> > > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > http://www.dtcenter.org/met/
> > > > users/support/online_tutorial/
> > > > > > > > > > > > METv5.0/compilation/configure.php
> > > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > > >> > And with pb2nc, I'm not exactly
sure
> > what
> > > is
> > > > > > going
> > > > > > > > on
> > > > > > > > > > > there.
> > > > > > > > > > > > > I
> > > > > > > > > > > > > > > > would
> > > > > > > > > > > > > > > > > >> > be
> > > > > > > > > > > > > > > > > >> > happy to take a look at your
configure
> > log
> > > > and
> > > > > > > make
> > > > > > > > > > > install
> > > > > > > > > > > > > log
> > > > > > > > > > > > > > > > files
> > > > > > > > > > > > > > > > > >> > to
> > > > > > > > > > > > > > > > > >> > see if I can figure out why you
didn't
> > get
> > > > the
> > > > > > > > > > executable.
> > > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > > >> > I hope this helps.
> > > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > > >> > Thanks,
> > > > > > > > > > > > > > > > > >> > Julie
> > > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > > >> > On Sat, Jan 31, 2015 at 5:31
PM,
> Zilore
> > > > Mumba
> > > > > > via
> > > > > > > RT
> > > > > > > > > > > > > > > > > >> > <met_help at ucar.edu>
> > > > > > > > > > > > > > > > > >> > wrote:
> > > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > > > >> >> <URL:
> > > > > > > > > > > > > https://rt.rap.ucar.edu/rt/
> > > Ticket/Display.html?id=70551
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > > > >> >> Julg
> > > > > > > > > > > > > > > > > >> >> Thank you very much for your
help.
> With
> > > the
> > > > > > > advice
> > > > > > > > > you
> > > > > > > > > > > gave
> > > > > > > > > > > > > > me, I
> > > > > > > > > > > > > > > > was
> > > > > > > > > > > > > > > > > >> >> able to install MET using gcc
and
> > > > gfortran. I
> > > > > > > also
> > > > > > > > > had
> > > > > > > > > > to
> > > > > > > > > > > > to
> > > > > > > > > > > > > > > point
> > > > > > > > > > > > > > > > > >> >> $MET_NETCDFLIB and,
$MET_NETCDFINC to
> > > > > > > > > > > > > > /usr/local/netcdf-4.1.3/lib
> > > > > > > > > > > > > > > > and
> > > > > > > > > > > > > > > > > >> >> include. Previously I pointed
only to
> > > > > > > > > > > > > /usr/local/netcdf-4.1.3.
> > > > > > > > > > > > > > > > > >> >> I have three executables not
included
> > > > though,
> > > > > > > these
> > > > > > > > > are
> > > > > > > > > > > > > > > > modis_regrid,
> > > > > > > > > > > > > > > > > >> >> plot_mode_field and pb2nc.
> > > > > > > > > > > > > > > > > >> >> Thank you very much.
> > > > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > > > >> >> On 1/29/15, Julie Prestopnik
via RT <
> > > > > > > > > met_help at ucar.edu
> > > > > > > > > > >
> > > > > > > > > > > > > wrote:
> > > > > > > > > > > > > > > > > >> >> > I am sorry to hear that you
are
> > having
> > > > > > problems
> > > > > > > > > > > > installing
> > > > > > > > > > > > > > > > METv5.0.
> > > > > > > > > > > > > > > > > >> >> > I
> > > > > > > > > > > > > > > > > >> >> > believe this error may have
to do
> > with
> > > > how
> > > > > > you
> > > > > > > > > > compiled
> > > > > > > > > > > > > > > BUFRLIB.
> > > > > > > > > > > > > > > > > >> >> > Please
> > > > > > > > > > > > > > > > > >> >> > take a look at the sample
commands
> > for
> > > > > > > compiling
> > > > > > > > > > > BURFLIB
> > > > > > > > > > > > on
> > > > > > > > > > > > > > > this
> > > > > > > > > > > > > > > > > >> >> > page:
> > > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > http://www.dtcenter.org/met/
> > > > users/support/online_tutorial/
> > > > > > > > > > > > METv5.0/compilation/req_libs.php
> > > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > > >> >> > I believe that the
> > > > *-fno-second-underscore*
> > > > > > > (GNU
> > > > > > > > > > > > compilers)
> > > > > > > > > > > > > > or
> > > > > > > > > > > > > > > > > >> >> > *-Mnosecond_underscore* (PGI
> > compilers)
> > > > > will
> > > > > > > fix
> > > > > > > > > the
> > > > > > > > > > > > error
> > > > > > > > > > > > > > > you're
> > > > > > > > > > > > > > > > > >> >> > seeing.
> > > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > > >> >> > I hope that helps.  If it
doesn't,
> > > please
> > > > > > send
> > > > > > > me
> > > > > > > > > the
> > > > > > > > > > > > files
> > > > > > > > > > > > > > > > > >> >> "make_met.log"
> > > > > > > > > > > > > > > > > >> >> > and "config.log".
> > > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > > >> >> > Thanks,
> > > > > > > > > > > > > > > > > >> >> > Julie
> > > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > > >> >> > On Thu, Jan 29, 2015 at 3:48
AM,
> > Zilore
> > > > > Mumba
> > > > > > > via
> > > > > > > > > RT
> > > > > > > > > > > > > > > > > >> >> > <met_help at ucar.edu>
> > > > > > > > > > > > > > > > > >> >> > wrote:
> > > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > > > > >> >> >> Thu Jan 29 03:48:08 2015:
Request
> > > 70551
> > > > > was
> > > > > > > > acted
> > > > > > > > > > > upon.
> > > > > > > > > > > > > > > > > >> >> >> Transaction: Ticket created
by
> > > > > > > zmumba at gmail.com
> > > > > > > > > > > > > > > > > >> >> >>        Queue: met_help
> > > > > > > > > > > > > > > > > >> >> >>      Subject: Problem
compiling
> > Met-V5
> > > > > > > > > > > > > > > > > >> >> >>        Owner: Nobody
> > > > > > > > > > > > > > > > > >> >> >>   Requestors:
zmumba at gmail.com
> > > > > > > > > > > > > > > > > >> >> >>       Status: new
> > > > > > > > > > > > > > > > > >> >> >>  Ticket <URL:
> > > > > > > > > > > > > > > > > >> https://rt.rap.ucar.edu/rt/
> > > > > > > > Ticket/Display.html?id=70551
> > > > > > > > > > > > > > > > > >> >> >> >
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > > > > >> >> >> I have installed BUFRLIB,
GSL and
> > > G2CLIB
> > > > > > > > > > > > > > > > > >> >> >> But then how do I handle
the
> errors
> > > > below
> > > > > in
> > > > > > > > > > > installing
> > > > > > > > > > > > > > > MET_V5?
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > > > tools/other/pb2nc/numpbmsg.f:
> > > > > > > 23:
> > > > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > > > >> >> >> reference to `ufbtab_'
> > > > > > > > > > > > > > > > > >> >> >> openpb.o: In function
`openpb_':
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > > > tools/other/pb2nc/openpb.f:21:
> > > > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > > > tools/other/pb2nc/openpb.f:22:
> > > > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > > > > > > > > > > >> >> >> closepb.o: In function
`closepb_':
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > > tools/other/pb2nc/closepb.f:
> > > > > 19:
> > > > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > > > >> >> >> reference to `closbf_'
> > > > > > > > > > > > > > > > > >> >> >> readpb.o: In function
`readpb_':
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > > > tools/other/pb2nc/readpb.f:82:
> > > > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > > > tools/other/pb2nc/readpb.f:90:
> > > > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > > > tools/other/pb2nc/readpb.f:94:
> > > > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > > > > > > > >> >> >> dumppb.o: In function
> `readpbdump_':
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > tools/other/pb2nc/dumppb.f:
> > > > > 215:
> > > > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > tools/other/pb2nc/dumppb.f:
> > > > > 218:
> > > > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > tools/other/pb2nc/dumppb.f:
> > > > > 224:
> > > > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > tools/other/pb2nc/dumppb.f:
> > > > > 203:
> > > > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > > > >> >> >> reference to `ireadns_'
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > tools/other/pb2nc/dumppb.f:
> > > > > 228:
> > > > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > > > >> >> >> reference to `ufbint_'
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > tools/other/pb2nc/dumppb.f:
> > > > > 259:
> > > > > > > > > > > > > > > > > >> undefined
> > > > > > > > > > > > > > > > > >> >> >> reference to `ufbevn_'
> > > > > > > > > > > > > > > > > >> >> >> dumppb.o: In function
`dumppb_':
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > > > tools/other/pb2nc/dumppb.f:56:
> > > > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > > > >> >> >> reference to `openbf_'
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > /home/zmumba/WRF/met-5.0/src/
> > > > > tools/other/pb2nc/dumppb.f:57:
> > > > > > > > > > > > > > > > > >> >> >> undefined
> > > > > > > > > > > > > > > > > >> >> >> reference to `datelen_'
> > > > > > > > > > > > > > > > > >> >> >> collect2: error: ld
returned 1
> exit
> > > > status
> > > > > > > > > > > > > > > > > >> >> >> make[4]: *** [pb2nc] Error
1
> > > > > > > > > > > > > > > > > >> >> >> make[4]: Leaving directory
> > > > > > > > > > > > > > > > > >> >> >> `/home/zmumba/WRF/met-
5.0/src/
> > > > > > > > tools/other/pb2nc'
> > > > > > > > > > > > > > > > > >> >> >> make[3]: *** [install-
recursive]
> > > Error 1
> > > > > > > > > > > > > > > > > >> >> >> make[3]: Leaving directory
> > > > > > > > > > > > > > > > > >> >> >> `/home/zmumba/WRF/met-
5.0/src/
> > > > > tools/other'
> > > > > > > > > > > > > > > > > >> >> >> make[2]: *** [install-
recursive]
> > > Error 1
> > > > > > > > > > > > > > > > > >> >> >> make[2]: Leaving directory
> > > > > > > > > > > > > > > `/home/zmumba/WRF/met-5.0/src/tools'
> > > > > > > > > > > > > > > > > >> >> >> make[1]: *** [install-
recursive]
> > > Error 1
> > > > > > > > > > > > > > > > > >> >> >> make[1]: Leaving directory
> > > > > > > > > > > > `/home/zmumba/WRF/met-5.0/src'
> > > > > > > > > > > > > > > > > >> >> >> make: *** [install-
recursive]
> Error
> > 1
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > > > > >> >> >>
> > > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > > >> >> > --
> > > > > > > > > > > > > > > > > >> >> > Julie Prestopnik
> > > > > > > > > > > > > > > > > >> >> > National Center for
Atmospheric
> > > Research
> > > > > > > > > > > > > > > > > >> >> > Research Applications
Laboratory
> > > > > > > > > > > > > > > > > >> >> > Phone: 303.497.8399
> > > > <%28303%29%20497-8399>
> > > > > > > > > > > > > > > > > >> >> > Email: jpresto at ucar.edu
> > > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > > >> >> >
> > > > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > > > >> >>
> > > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > > >> > --
> > > > > > > > > > > > > > > > > >> > Julie Prestopnik
> > > > > > > > > > > > > > > > > >> > National Center for Atmospheric
> Research
> > > > > > > > > > > > > > > > > >> > Research Applications
Laboratory
> > > > > > > > > > > > > > > > > >> > Phone: 303.497.8399
> > > > > > > > > > > > > > > > > >> > Email: jpresto at ucar.edu
> > > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > > >> >
> > > > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > > > >>
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > --
> > > > > > > > > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > > > > > > > > National Center for Atmospheric
Research
> > > > > > > > > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > --
> > > > > > > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > > > > > > National Center for Atmospheric
Research
> > > > > > > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > --
> > > > > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > --
> > > > > > > > > > > > Julie Prestopnik
> > > > > > > > > > > > National Center for Atmospheric Research
> > > > > > > > > > > > Research Applications Laboratory
> > > > > > > > > > > > Phone: 303.497.8399
> > > > > > > > > > > > Email: jpresto at ucar.edu
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> >
> >
>
>

------------------------------------------------
Subject: Problem compiling Met-V5
From: Zilore Mumba
Time: Fri May 05 03:15:45 2017

Julie,
I want to thank you very much for your time, to go through all that I
sent
you.
Following your advice, I have been able to compile met6 and I have 17
executables. So I have material I can work with.
The problem was that in my g2clib the library compiles to* libg2c.a*
(this
is in g2clib-1.6.0.tar.gz), but in g2clib-1.6.0-patch.tar.gz it
compiles
corectly to

* libgrib2c.a*
The small problem I have is with compiling with MODIS-Regrid. I am
getting
the error (excerpt below)
In file included from modis_file.h:22:0,
                 from modis_regrid.cc:27:
cloudsat_swath_file.h:24:17: fatal error: hdf.h: No such file or
directory
compilation terminated.
When I do "*locate hdf.h*", it is not there, yet*
cloudsat_swath_file.h*
has
*#include "hdf.h"*
In my /usr/local/include I have hdf5.h
Would you say why this is so?

I would also like to thank you on clarifying on setting environment
variables. I did not pay attention to the point where it says
MET_<lib> is
ignored. You could make this a bit clearer by giving an example of
what is
meant by MET_<lib>, like "e.g. in setting MET_<lib> for GSL*,* one
would set*
MET_GSL=/wherver/hsl/is/installed*. It took me some time to understand
what
MET_<lib> was supposed to mean.

Thank you and good day
Zilore

On Thu, May 4, 2017 at 6:15 PM, Julie Prestopnik via RT
<met_help at ucar.edu>
wrote:

> Hi Zilore. I apologize for the delay.  I was out of the office.
>
> Thank you for sending so much information.  First, I'll address a
few
> things I noticed from the email and then will address the
make_install.log
> file that you attached.
>
> I see that for many environment variables you have both the main
variable
> set and the INC and LIB variables set.  For example:
>
>   export MET_GSL=$MET_LIB_DIR/gsl
>   export MET_GSLINC=$MET_LIB_DIR/gsl/include/gsl
>   export MET_GSLLIB=$MET_LIB_DIR/gsl/lib
>
> only MET_GSL *OR *MET_GSLINC *AND *MET_GSLLIB need to be set.  So,
for
> example, you would either set:
>
> export MET_GSL=$MET_LIB_DIR/gsl
>
> or you would set:
>
>   export MET_GSLINC=$MET_LIB_DIR/gsl/include/gsl
>   export MET_GSLLIB=$MET_LIB_DIR/gsl/lib
>
> Additionally, MET does not use MET_HDF5INC and MET_HDF5LIB.  It only
uses
> MET_HDF5.
>
> You can take a look at this page of our online tutorial to help
figure out
> what should be set and what the value should be:
>
> http://www.dtcenter.org/met/users/support/online_tutorial/
> METv6.0/tutorial.php?name=compilation&category=configure
>
> Please let us know if you have any questions about that page and
what needs
> to be set.
>
> Regarding, NetCDF, MET is expecting all of the library and include
files
> from the various NetCDF packages to be in one lib and include
directory.
> So, for example, if you have the various NetCDF packages in, for
example,
> /usr/local/netcdf-4.4.1.1/lib and /usr/local/netcdf-4.4.1.1/include,
and
> /usr/local/netcdf-cxx4-4.3.0/lib and /usr/local/netcdf-cxx4-
4.3.0/include,
> perhaps you could create a local directory, like
> /d1/zmumba/met_external_libraries/netcdf/lib and
> /d1/zmumba/met_external_libraries/netcdf/include, for example, and
copy of
> the lib and include files from each package from the /usr/local/
area and
> then set the following:
>
> Either
>
>   export MET_NETCDF=/d1/zmumba/met_external_libraries/netcdf
>
> or
>   export
MET_NETCDFINC=/d1/zmumba/met_external_libraries/netcdf/include
>   export MET_NETCDFLIB=/d1/zmumba/met_external_libraries/netcdf/lib
>
> In your make_install.log file I see the following error:
>
> /usr/bin/ld: cannot find -lgrib2c
>
> You mentioned that you see libgrib2c.a in /usr/local/grib2/g2clib-
1.4.0/
>
> but you have the following set:
>
>   export MET_GRIB2CINC=$MET_LIB_DIR/g2clib
>   export MET_GRIB2CLIB=$MET_LIB_DIR/g2clib
>
> so, MET is looking in /usr/local/met6/g2clib/lib for libgrib2c.a.
Instead
> you would want to set the MET_GRIB2CINC and MET_GRIB2CLIB
environment
> variables in the following way:
>
>   export MET_GRIB2CINC=(Set to wherever the include files are for
this
> library)
>   export MET_GRIB2CLIB=/usr/local/grib2/g2clib-1.4.0/
>
> I hope this helps to clarify things.  I would suggest starting with
a fresh
> shell so that you clear our all of the current environment variables
that
> are set.
>
> Please let us know if you have further questions and please follow
up to
> let us know whether or not you were able to successfully install
MET.
>
> Thanks!
>
> Julie
>
> On Tue, May 2, 2017 at 3:44 PM, Zilore Mumba via RT
<met_help at ucar.edu>
> wrote:
>
> >
> > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> >
> > Julie,
> > The following is what I have:
> > 1. netcdf in* /usr/local/netcdf-4.4.1.1* and in */usr/local* (i.e.
> > netcdf-4.4.1.1, netcdf-f and netcdf-cxx)
> > 2.hdf5 in* /usr/local/hdf5* and in * /usr/local*
> > 3. gsl in /usr/local/met6/gsl and in /usr/local
> > 4. BUFRLIB in /usr/local/BUFRLIB (libbufr.a in the directory)
> > 5. g2clib in /usr/local/met6/g2clib
> > 6. cairo in /usr/local/cairo
> > 7. freetype in /usr/local/freetype
> >
> > The following are environment variables I set:
> >   export NETCDF=/usr/local/netcdf-4.4.1.1
> >   export NETCDF_LIB=/usr/local/netcdf-4.4.1.1/lib
> >
> >   export HDF5_DIR=/usr/local/hdf5
> >   export PATH=$PATH:$HDF5_DIR/bin
> >
> >   export MET_LIB_DIR=/usr/local/met6
> >   export MET_LIBINC=$MET_LIB_DIR/include
> >   export MET_LIBLIB=$MET_LIB_DIR/lib
> >
> >   export MET_NETCDF=$NETCDF
> >   export MET_NETCDFINC=$MET_NETCDF/include
> >   export MET_NETCDFLIB=$MET_NETCDF/lib
> >   export PATH=$PATH:$MET_NETCDF/bin
> >
> >   export MET_BUFRLIB=$MET_LIB_DIR/BUFRLIB
> >   export MET_GSL=$MET_LIB_DIR/gsl
> >   export MET_GSLINC=$MET_LIB_DIR/gsl/include/gsl
> >   export MET_GSLLIB=$MET_LIB_DIR/gsl/lib
> >
> >   export MET_GRIB2CINC=$MET_LIB_DIR/g2clib
> >   export MET_GRIB2CLIB=$MET_LIB_DIR/g2clib
> >
> >   export MET_HDF5=$MET_LIB_DIR/hdf5
> >   export MET_HDF5LIB=$MET_HDF5/lib
> >   export MET_HDF5INC=$MET_HDF5/include
> >
> >   export MET_CAIROINC=/usr/local/cairo/include
> >   export MET_CAIROLIB=/usr/local/cairo/lib
> >   export MET_FREETYPEINC=/usr/local/freetype/include
> >   export MET_FREETYPELIB=/usr/local/freetype/lib
> >
> > I also have:
> >   export JASPERLIB=/usr/local/lib
> >   export JASPERINC=/usr/local/include
> >
> >   export PNGLIB=/usr/local/lib
> >   export PNGINC=/usr/local/include
> >   export JPEGLIB=/usr/local/lib
> >
> > and my LD_LIBRARY_PATH:
> >   export
> > LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib:/usr/lib:$
> > MET_LIB_DIR/g2clib:$MET_HDF5/lib:$MET_LIB_DIR/BUFRLIB:$MET_
> > LIB_DIR/gsl/lib:/usr/local/freetype/lib:/usr/local/cairo/
> > lib:$NETCDF/lib:$MET_NETCDF/lib:/lib:/usr/lib/i386-linux-
> > gnu:/lib/i386-linux-gnu:/usr/lib/ccache
> >
> > I issued the commands, as root:
> > ./configure --prefix=/usr/local/met6 --enable-grib2 --enable-modis
> > make install >& make_install.log
> > The output of the last command is in the attached file.
> >
> > When I put locate *libgrib2c.a,* it points me to
> > /usr/local/grib2/g2clib-1.4.0/libgrib2c.a. I installed this with
> > wgrib2.tgz
> > (I think).
> >  There is no bin directory and no executables created.
> >
> > I hope you can look at this and advise.
> > Zilore
> >
> > On Tue, May 2, 2017 at 5:25 PM, Julie Prestopnik via RT <
> met_help at ucar.edu
> > >
> > wrote:
> >
> > > Hi Zilore.  No need to apologize.  I just wanted to check in, in
case
> you
> > > still needed any help getting MET installed.
> > >
> > > You should not need to reorganize your installation to put
anything in
> > > /usr/local/.  We should be able to tell MET where to find
anything it
> > > needs.
> > >
> > > Do you already have successful installations of gsl, cairo,
freetype,
> and
> > > bufrlib elsewhere?  If so, I would suggest we go ahead and use
those
> > > installations, telling MET where to find them.  I can help take
you
> > through
> > > that process.
> > >
> > > Please let me know, and we can go from there.
> > >
> > > Kind regards,
> > > Julie
> > >
> > > On Tue, May 2, 2017 at 2:27 AM, Zilore Mumba via RT
<met_help at ucar.edu
> >
> > > wrote:
> > >
> > > >
> > > > <URL: https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551
>
> > > >
> > > > Julie,
> > > > My apologies, since you sent me mail I had no access to
Internet
> until
> > > > today.
> > > > I have not been able to install met-6.0. My problem seems to
have got
> > > > worse.
> > > > I was trying to reorganize my installation by trying to
install
> > > everything
> > > > in /usr/local so that I do not have any complications of some
> libraries
> > > not
> > > > being found.
> > > >
> > > > I managed to install *gsl-2.3. T*he libraries are installed,
though
> > make
> > > > check gives one failed test, *Makefile:750: recipe for target
> > > > 'test-suite.log' failed* (and says See linalg/test-suite.log)
> > > >
> > > > *I installed cairo-1.14.8* and *freetype-2.7.1* in their own
> > directories
> > > in
> > > > */usr/loca*l, i.e. */usr/loca*l/cairo and
*/usr/loca*l/freetype.
> Howver
> > > > trtying to reinstall these in */usr/loca*l I am now getting a
lot of
> > c++
> > > > style comment problems. I have to work this out.
> > > >
> > > > Then I copied BUFRLIB_v10-2-3.tar to /usr/local, untarred it
in that
> > > > directory.
> > > > Running:
> > > > *preproc.sh*,
> > > > *gcc -c -DUNDERSCORE *.c,*
> > > > *gfortran -c -DUNDERSCORE -fno-second-underscore *.f *.F*
> > > > */usr/loca*l
> > > > *gives the errors in the files attached*
> > > >
> > > > *.*
> > > > *I am not sure if I should just copy **g2clib** into**
/usr/local.
> > > **There
> > > > are no instructions on how to install, but it has *
> > > >
> > > > *libg2c.a*
> > > >
> > > > *So currently am still looking at all these issues. Perhaps
you can
> > > assist
> > > > me on BUFRLIB. What am I doing wrong? Previously I have not
had any
> > > > problem.*
> > > >
> > > > *Best Regards*
> > > > *Zilore*
> > > >
> > > > On Thu, Apr 27, 2017 at 9:09 PM, Julie Prestopnik via RT <
> > > > met_help at ucar.edu>
> > > > wrote:
> > > >
> > > > > Hi Zilore.
> > > > >
> > > > > I just wanted to touch base and see if you were able to
resolve the
> > > > > problem.  Please let us know if you need further assistance.
> > > > >
> > > > > Thanks,
> > > > > Julie
> > > > >
> > > > > On Tue, Apr 11, 2017 at 4:12 PM, Zilore Mumba via RT <
> > > met_help at ucar.edu>
> > > > > wrote:
> > > > >
> > > > > >
> > > > > > <URL:
https://rt.rap.ucar.edu/rt/Ticket/Display.html?id=70551 >
> > > > > >
> > > > > > Julie,
> > > > > > Thanks once again for your time. My apologies, because in
the
> > > > > environmental
> > > > > > variable I put "/usr/local/MET6" while as the directory I
created
> > was
> > > > > > "/usr/local/met6", i.e. met capitalized. When I do "ll
> > > $MET_NETCDFINC"
> > > > I
> > > > > > can see the include files, including "netcdf".
> > > > > > But am getting the same error. Let me work over it. I will
get
> back
> > > to
> > > > > you
> > > > > > if I fail or succeed.
> > > > > > Best regards
> > > > > > Zilore
> > > > > >
> > > > > > On Tue, Apr 11, 2017 at 9:52 PM, Julie Prestopnik via RT <
> > > > > > met_help at ucar.edu>
> > > > > > wrote:
> > > > > >
> > > > > > > Hi Zilore.
> > > > > > >
> > > > > > > In your config.log file, it appears that you do not have
your
> MET
> > > > > > > environment variables set up.  The MET build process
uses
> > > environment
> > > > > > > variables to specify the locations of the needed
external
> > > libraries.
> > > > > > >
> > > > > > > The following page describes the MET environment
variables that
> > you
> > > > > will
> > > > > > > need to set up in your .cshrc or equivalent file:
> > > > > > >
> > > > > > >
http://www.dtcenter.org/met/users/support/online_tutorial/
> > > > > > > METv6.0/tutorial.php?name=compilation&category=configure
> > > > > > >
> > > > > > > The error you are getting:
> > > > > > >
> > > > > > > In file included from nc_var_info.cc:24:0:
> > > > > > > nc_utils.h:22:18: fatal error: netcdf: No such file or
> directory
> > > > > > >
> > > > > > > seems to imply that MET doesn't know where to find the
file
> > > "netcdf",
> > > > > > which
> > > > > > > is included in the NetCDF-CXX installation.  It could be
that
> > > > > NetCDF-CXX
> > > > > > is
> > > > > > > installed and that file does exist, but MET just doesn't
know
> > where
> > > > to
> > > > > > find
> > > > > > > it.  Setting those environment variables will help MET
know
> where
> > > > those
> > > > > > > required libraries and include files are.
> > > > > > >
> > > > > > > Here is a quick reference checklist for NetCDF4C++
installation
> > > that
> > > > > you
> > > > > > > can use to see if you have the necessary files:
> > > > > > >
> > > > > > > Files for NetCDF4 C:
> > > > > > >
> > > > > > >    - $MET_NETCDF/include/netcdf.h
> > > > > > >    - $MET_NETCDF/lib/libnetcdf.a
> > > > > > >    - $MET_NETCDF/lib/libnetcdf.so
> > > > > > >
> > > > > > > Files for NetCDF4 C++:
> > > > > > >
> > > > > > >    - $MET_NETCDF/include/netcdf
> > > > > > >    - $MET_NETCDF/lib/libnetcdf_c++4.a
> > > > > > >    - $MET_NETCDF/lib/libnetcdf_c++4.so
> > > > > > >
> > > > > > > Files for NetCDF3 C++ (not required, if --disabled-
netcdf4 is
> > > > > activated):
> > > > > > >
> > > > > > >    - $MET_NETCDF/include/netcdf.hh
> > > > > > >    - $MET_NETCDF/lib/libnetcdf_c++.a
> > > > > > >    - $MET_NETCDF/lib/libnetcdf_c++.so
> > > > > > >
> > > > > > > Please follow the instructions on the webpage above to
set up
> the
> > > > > > necessary
> > > > > > > environment variables, then please reconfigure and
recompile
> MET
> > > and
> > > > > let
> > > > > > us
> > > > > > > know if you encounter further difficulty.
> > > > > > >
> > > > > > > I hope this helps!
> > > > > > >
> > > > > > > Thanks!
> > > > > > >
> > > > > > > Julie
> > > > > > >
> > > > > > > On Tue, Apr 11, 2017 at 1:22 PM, Zilore Mumba via RT <
> > > > > met_help at ucar.edu>
> > > > > > > wrote:
> > > > > > >
> > > > > > > >
> > > > > > > > <URL: https://rt.rap.ucar.edu/rt/
> Ticket/Display.html?id=70551
> > >
> > > > > > > >
> > > > > > > > Julie,
> > > > > > > > Please find attached to this mail, my config.log and
> > > > > make-install.log.
> > > > > > > >
> > > > > > > > On Tue, Apr 11, 2017 at 4:29 PM, Julie Prestopnik via
RT <
> > > > > > > > met_help at ucar.edu>
> > > > > > > > wrote:
> > > > > > > >
> > > > > > > > > Hi Zilore.  I'm sorry to hear that you are still
> experiencing
> > > > > > problems.
> > > > > > > > > Could you please send your most recent configure.log
and
> > > > > > > make_install.log
> > > > > > > > > files?
> > > > > > > > >
> > > > > > > > > Thanks!
> > > > > > > > >
> > > > > > > > > Julie
> > > > > > > > >
>