[Met_help] VSDBAnalysis problem (UNCLASSIFIED)

John Halley Gotway johnhg at rap.ucar.edu
Thu Feb 5 16:38:16 MST 2009


The VSDB-Analysis tool reads files ending in ".vsdb".  It looks in the path or filename you specified with the "-lookin" command line argument for those ".vsdb" files.

I believe that this error message is telling you that it can't determine the line type for one of the lines in the ".vsdb" files it's reading.  That may be because the file was "corrupted" in some
way.  Perhaps data was accidentally added or removed from it... or something like that.

Please try the following, rerun your "VSDB_T.sh" script, but add in the argument "-v 3".  That'll generate more log messages for you.  In particular, it'll tell you which file it was processing when
it ran into this error.  Then look in that VSDB file to see if anything looks funny.

If you can't find anything wrong with it, please me a copy of it, and I'll take a look at it to see why you're getting that error message.

John Halley Gotway

Sauter, Barbara (Civ, ARL/CISD) wrote:
> Classification:  UNCLASSIFIED 
> Caveats: NONE
> PointStat is working well for me, but I'm having a problem with
> VSDBAnalysis.
> At least for now I am ignoring any statistics related to threshold
> values.  Everything I'm concerned with is available in the xxx_cnt.txt
> file, as in the attached example.  What I'd really like is an equivalent
> file over all the .vsdb files in a particular directory, but I guess I
> can only generate separate files for a single parameter at a time.
> This worked for me for temperature, based on a previous version of the
> attached script (VSDB_T.sh) and config file
> (VSDBAnalysisConfig_DUG_TMP).  I copied them to equivalent files for
> relative humidity (VSDB_R.sh and VSDBAnalysisConfig_DUG_RH).  I tried
> something in the temperature files, that did not work.  When I tried to
> change it back to the original, I got the error message shown in the
> attached document named "screentext".  The RH version was still working,
> so I copied it back to temp files, changed the output file name in the
> script and the variable in the config file to TMP.  I still get the same
> error message.
> Do you have any ideas for me?
> Barb Sauter
> (575) 678-2840
> bsauter at arl.army.mil
>  <<point_stat_060000L_20090126_120000V_cnt.txt>> 
>   <<screentext>> 
>   <<VSDBAnalysisConfig_DUG_RH>>  <<VSDB_T.sh>>  <<VSDB_RH.sh>>  
> <<VSDBAnalysisConfig_DUG_TMP>> 
> Classification:  UNCLASSIFIED 
> Caveats: NONE
> ------------------------------------------------------------------------
> _______________________________________________
> Met_help mailing list
> Met_help at mailman.ucar.edu
> http://mailman.ucar.edu/mailman/listinfo/met_help

More information about the Met_help mailing list