[Wrf-users] Converting to LITTLE_R

Tyler Cruickshank tcruickshank at utah.gov
Wed May 12 16:38:56 MDT 2010

Hello all.
We want to implement obs nudging in WRF for a retrospective case, but have not been able to convert DSS bufr data into little_r format.
Here are the steps we followed to get the archived obs data in a WRF ready format.
1) We went to http://dss.ucar.edu/datasets/ds351.0/ and downloaded data and BUFR conversion software.
2) We compiled (tried gfortran and pgf90), created, and ran grabbufr using the grabbufr.sh script.
    - Ran successfully (we think) with pgf90 but gave warnings with gfortran.
3) Compiled (tried gfortran and pgf90), created, and ran bufr_upa2ob.x on the file created in step 2.
    - Exe's created.
    - Exe creates a file but program ends unexpectedly.  Here is the screen output from bufr_upa2ob.x with error:
 idate:    2009010800   NC002005             0
  idate:    2009010723   NC002005             0
  idate:    2009010722   NC004005             0
  idate:    2009010723   NC004005             0
  idate:    2009010800   NC004005             0
  idate:             0                                         -1
 ....all records read, Exit
PGFIO-F-235/formatted write/unit=18/edit descriptor does not match item type.
 File name = Uppertest      .obs    formatted, sequential access   record = 38536
 In source file ../src/bufr_upa2ob.f, at line number 242
4) Went ahead and tried to run Yubao's perl script on the file produced in step 3.
    - Script runs, but the input file format is not what the script expects.
Any thoughts on how I can diagnose the problem?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ucar.edu/pipermail/wrf-users/attachments/20100512/92e9f0ab/attachment.html 

More information about the Wrf-users mailing list