[ncl-talk] Fwd: RIP4 Trajcalc

Lauren Wheeler lauren.bronwyn.wheeler at gmail.com
Thu Jul 31 14:22:14 MDT 2014

I know this isn't quite applicable to NCL but I know that there is a little
documentation on NCL's website about RIP and I wanted to try and see if
anyone in the group could assist me.

I am trying to run RIP4 on Yellowstone and I believe that RIP should be
working, I was able to run ripdp for wrfarw. I have generated hourly files
(from 0 to 12 hours) from an idealized simulation that I would like to use
for a trajectory calculation but when I try to do the calculation I get an
error about a segmentation fault.

I ran ripdp using this line:

ripdp_wrfarw Sierra_Test basic

Everything worked and so I proceeded to run the trajcalc using:

rip Sierra_Test trajcalc.in

Which contains:

 flmin=.09, frmax=.92, fbmin=.10, ftmax=.85,
 xjtraj= 80, 100, 120, 140, 160,
 yitraj= 0, 0, 0, 0, 0,
 zktraj= 565.4935, 565.4935,565.4935 565.4935,565.4935,

>From the documentation I found that when itrajcalc=1 that everything else
in &userin is/should be ignored. When I run rip though I get the following

 Welcome to your friendly RIP (V4.6.6) output file !
 Color Names and Fractions Defined
 Get header info.
forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image              PC                Routine            Line        Source
rip                00000000004C5D60  Unknown               Unknown  Unknown
rip                000000000042528E  Unknown               Unknown  Unknown
rip                00000000004CA9DC  Unknown               Unknown  Unknown
rip                000000000040E4FC  Unknown               Unknown  Unknown
libc.so.6          0000003E9481ECDD  Unknown               Unknown  Unknown
rip                000000000040E3F9  Unknown               Unknown  Unknown

Am I missing any links to pertinent parts of the RIP code? I copied the
precompiled directory into my home dir under bin/RIP4/.

setenv PATH $PATH\:$HOME/bin/RIP4/
setenv RIP_ROOT /glade/u/home/lwheeler/bin/RIP4/
setenv NCARG_ROOT /glade/u/apps/opt/ncl/6.1.0/gnu/4.4.6

Some online documentation that I found suggested that my times were
incorrect but I don't think that's the case and I've tried making
adjustments and I continue to get the same errors. Any help or suggestions
would be appreciated.

Lauren Wheeler
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ucar.edu/pipermail/ncl-talk/attachments/20140731/332aaba2/attachment.html 

More information about the ncl-talk mailing list