[ncl-install] Help on install NCL on my MacBook

Yuanfu Xie yuanfu_xie at yahoo.com
Wed Nov 29 10:05:52 MST 2017

After downloading the gcc/gfortran 6.3 to my /usr/local directory, I reran the nil testing command again. The error messages are different now complaining DISPLAY variable is not set. But it is set. I am not sure what is the problem. Could you give me some advice solving this problem? I attached the new error messages here for your reference. Thanks a lot.
Best regards,
xieyuanfudeMacBook:~ xieyuanfu$ echo $DISPLAY:0.0xieyuanfudeMacBook:~ xieyuanfu$ ng4ex xy01n -clean
NCAR Graphics NCL Example <xy01n>
  Copying xy01n.ncl  Copying xy01.res
Running NCL... Copyright (C) 1995-2017 - All Rights Reserved University Corporation for Atmospheric Research NCAR Command Language Version 6.4.0 The use of this software is governed by a License Agreement. See http://www.ncl.ucar.edu/ for more details. GKS ERROR NUMBER -208 ISSUED FROM SUBROUTINE GOPWK : --X driver error: DISPLAY environment variable not set GKS ERROR NUMBER   25 ISSUED FROM SUBROUTINE GESC  : --SPECIFIED WORKSTATION IS NOT OPENfatal:Workstation with PID#8 is not openfatal:Unable to open Workstation-Can't Createfatal:Unable to access object with id:-4fatal:_NhlCreate:Invalid Parent id #-4fatal:NhlDraw: Invalid Layer Id: -4fatal:Unable to update Workstation with PID#-4fatal:Unable to clear Workstation with PID#-4fatal:["Execute.c":8638]:Execute: Error occurred at or near line 137

Finished running 'ncl < xy01n.ncl'...
xieyuanfudeMacBook:~ xieyuanfu$ 

    On Tuesday, November 28, 2017 8:30 PM, Kevin Hallock <hallock at ucar.edu> wrote:

 Hi Yuanfu,
Did you install gcc/gfortran from the HPC SourceForge website that is linked in the NCL installation documentation? There is a known version incompatibility regarding those gcc/gfortran packages — NCL requires gcc/gfortran 6.3, but their website makes that particular version hard to find. (Unfortunately, gcc/gfortran version 7.1 linked from their homepage will not work with the currently available NCL binaries on our website.)
Could you please run the following commands?which gccgcc --versionls -l /usr/local/lib/libgomp*

On Nov 28, 2017, at 6:11 PM, Yuanfu Xie <yuanfu_xie at yahoo.com> wrote:

Dear colleague,
I tried to install NCL binary files on my MacBook. I followed the steps and ran into an error message when I ran a test. See the attached command and error messages. Would you please let me know how I can fix this? Thank you.
xieyuanfudeMacBook:~ xieyuanfu$ ng4ex xy01n -cleandyld: Library not loaded: /usr/local/lib/libgomp.1.dylib  Referenced from: /Users/xieyuanfu/plotting/ncl_ncarg-6.4.0-MacOS_10.12_64bit_gnu530/bin/ncargpath  Reason: image not foundAbort
Sent from my iPhone_______________________________________________
ncl-install mailing list
List instructions, subscriber options, unsubscribe:

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ucar.edu/pipermail/ncl-install/attachments/20171129/cab722d7/attachment-0001.html>

More information about the ncl-install mailing list