[ncl-install] (no subject)

FO fometeo at gmail.com
Tue Nov 14 05:43:18 MST 2017

Hi :-)

At Ubuntu 16.04 x64 Xenial edition (and others Ubuntu ) I get stuck with

I have made the classic steps of
apt-get install libssl1.0.0 libssl-dev
to have it at
and these to point the right name
cd /lib/x86_64-linux-gnu
ln -s libssl.so.1.0.0 libssl.so.10
ln -s libcrypto.so.1.0.0 libcrypto.so.10

also tried copies to n lib paths to find where NCL expects to have them but
it shows every time:

ng4ex xy01n -clean

NCAR Graphics NCL Example <xy01n>

  Copying xy01n.ncl
  Copying xy01.res

Running NCL...
ncl: /lib/x86_64-linux-gnu/libssl.so.10: version `libssl.so.10' not found
(required by ncl)
ncl: /lib/x86_64-linux-gnu/libcrypto.so.10: version `libcrypto.so.10' not
found (required by ncl)

ncl failed.

I also tried some compat-libssl*.rpm converted by alien to .deb

so please has anyone installed NCL 6.4.0 at a recent Ubuntu?

I was able to install NCL 6.4.0 at an old Ubunt 10.10 using
converted to compat-openssl10_1.0.2j-10_amd64.deb by alien; it required the
libdpkg-perl but at the end
it worked; not with 16.04 - I guess it is not libssl10.so.10 but something
else missing.

I search this forum first and could not found this question, so I wonder
what distros are recommended.

Thank you

Fernando, Portugal
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ucar.edu/pipermail/ncl-install/attachments/20171114/a0b135a3/attachment.html>

More information about the ncl-install mailing list