[ncl-install] Compiling issues 6.4.0, PGI on Cray

brown wrap gramos at yahoo.com
Wed Jun 28 11:08:03 MDT 2017

I guess I am not making myself clear. I was able to produce the Cairo pdf,  but still have the original error:
/lustre/local/ncl_ncarg-6.4.0-pgi/lib/libncarg_gks.a(crodisplay.o): In function `croActivateX11':/lustre/users/ramos/ncl_ncarg-6.4.0-pgi/ncarg2d/src/libncarg_gks/cdrivers/./crodisplay.c:350: undefined reference to `cairo_xlib_surface_get_display'/lustre/users/ramos/ncl_ncarg-6.4.0-pgi/ncarg2d/src/libncarg_gks/cdrivers/./crodisplay.c:350: undefined reference to `cairo_xlib_surface_get_drawable'/lustre/users/ramos/ncl_ncarg-6.4.0-pgi/ncarg2d/src/libncarg_gks/cdrivers/./crodisplay.c:359: undefined reference to `cairo_surface_flush'/lustre/users/ramos/ncl_ncarg-6.4.0-pgi/ncarg2d/src/libncarg_gks/cdrivers/./crodisplay.c:399: undefined reference to `cairo_xlib_surface_set_size'

    On Wednesday, June 28, 2017 9:59 AM, Mary Haley <haley at ucar.edu> wrote:

 Are you able to open the agex01.pdf file?  It should like like the file that is attached.
I don't know what "ieee_inexact is signaling" is.  This is a PGI error. I just googled it, and it seems to come from the STOP statement in agex01.f. You can try this:
ncargex agex01 -W pdf -n
This simply copies the program to your current directory, but doesn't run it.
Then, edit the agex01.f file and remove the STOP line.
Compile and run the agex01.f program with:
ncargf77 -o agex01 agex01.f./agex01
This should produce a cairo1.pdf file (not an agex01.pdf) file.  Have a look at this file and see if it looks like the file I attached.
If you want to see if an X11 window output works, try this:
 ncargex agex01 -W x11 -cleanInstead of a PDF file, you should see a window pop up with a plot that looks like the agex02.pdf file.  To make this "x11" window go away, click on it with your left mouse button.--Mary

On Wed, Jun 28, 2017 at 10:50 AM, brown wrap <gramos at yahoo.com> wrote:

OK, I modified ncargf90  and ncargf77 and I was able to produce cpex08 and  the Cairo pdf, but I still get the original error':
ncargex agex01 -W pdf -clean
NCAR Graphics Fortran  Example <agex01>
  Copying agex01.f
Compiling and linking...pgf90 -tp k8-64 -O -Msignextend -Mreentrant -fPIC -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -mp -O -o agex01 agex01.f -L/lustre/local/ncl_ncarg-6.4. 0-pgi/lib -L/lustre/local/lib -lncarg -lncarg_gks -lncarg_c -lX11 -lcairo -lXrender -lfontconfig -lpixman-1 -lfreetype -lexpat -lpng -lz -liconv -lbz2
Executing <agex01>...Warning: ieee_inexact is signalingFORTRAN STOP
cairo PDF file is named agex01.pdf.
ramos at grace:~>
We don't have an X11 directory. I substituted /lustre/local/lib for the X11 directory and it worked. But as I mentioned, I still have the original error.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ucar.edu/pipermail/ncl-install/attachments/20170628/a273a0f3/attachment-0001.html 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cairo1.pdf
Type: application/pdf
Size: 16709 bytes
Desc: not available
Url : http://mailman.ucar.edu/pipermail/ncl-install/attachments/20170628/a273a0f3/attachment-0001.pdf 

More information about the ncl-install mailing list