[mpas-developers] Integer halo updates

Michael Duda duda at ucar.edu
Fri Jun 11 13:24:17 MDT 2010


Hi, Mark.

I can certainly take a look at these routines. After a quick check
through the code in the topography_mrp branch, though, it looks like
the maxLevelCell, maxLevelEdge, and maxLevelVertex arrays are 1d
arrays, rather than 2d arrays:

var integer maxLevelCell ( nCells ) iro maxLevelCell - -
var integer maxLevelEdge ( nEdges ) ro maxLevelEdge - -
var integer maxLevelVertex ( nVertices ) ro maxLevelVertex - -

In this case, I would expect that the the call to update the halo/ghost
values would look something like

    call dmpar_exch_halo_field1dInteger(domain % dminfo, maxLevelCell, &
            block % mesh % nCells, &
            block % parinfo % cellsToSend, block % parinfo % cellsToRecv)

in the case of maxLevelCell, for example. If you change the calls in
module_test_cases.F to use the 1dInteger versions of these halo exchange
routines, does that correct the segfault issue?

Cheers,
Michael


On Fri, Jun 11, 2010 at 12:01:33PM -0600, Mark Petersen wrote:
> Michael,
> 
> In my ocean_projects/topography_mrp branch, I added the following 
> subroutines to src/framework/module_dmpar.F:
> 
> +   subroutine dmpar_exch_halo_field1dInteger(dminfo, array, dim1, 
> +   subroutine dmpar_exch_halo_field2dInteger(dminfo, array, dim1, dim2, 
> +   subroutine dmpar_exch_halo_field3dInteger(dminfo, array, dim1, dim2,
> 
> I need these to exchange halo information for maxLevel integer arrays for 
> the topography during startup.  I call it with calls like
> 
>     call dmpar_exch_halo_field2dInteger(domain % dminfo, maxLevelCell, &
>             block % mesh % nVertLevels, block % mesh % nCells, &
>             block % parinfo % cellsToSend, block % parinfo % cellsToRecv)
> 
> in src/core_ocean/module_test_cases.F, but get a seg fault.
> 
> Could you please look at my new dmpar subroutines sometime?  The timing is 
> not critical, because my branch works without the halo updates. 
> Eventually we will want these in the trunk framework.
> 
> Thanks,
> Mark
> _______________________________________________
> mpas-developers mailing list
> mpas-developers at mailman.ucar.edu
> http://mailman.ucar.edu/mailman/listinfo/mpas-developers


More information about the mpas-developers mailing list