[pyngl-talk] Issues with running PYNGL function on local computer

Mateus da Silva Teixeira mateusstex at gmail.com
Sat Sep 7 13:25:07 MDT 2019

Hi Austin,

Sometime ago my environment with PyNGL has some inconsistencies, but I
didn't find any trouble with any functions I'm working with, however I
couldn't install any other packages in that environment. I didn't find any
suggestion on Internet to fix that problem. So, I delete entire Anaconda
with all environments and installed it again, solved my problem.

I mentioned Ubuntu only for information, this really shouldn't have any
influence on PyNGL functioning.

Best regards,

Em sex, 6 de set de 2019 às 20:14, Austin Reed <austin.reed at stonybrook.edu>

> One other thing that I tried was I copied someone's (who's code I know
> produces the correct output) environment by package so that they were
> consistent. This did not work though. I do not use Ubuntu, although that
> shouldn't matter. I am using IDLE as a text editor, and running the code
> through terminal in my environment. Do you by any chance have any other
> suggestions? Thanks!
> On Fri, Sep 6, 2019 at 10:26 AM Austin Reed <austin.reed at stonybrook.edu>
> wrote:
>> Thank you for the response Mateus! I just tried to create a new
>> environment to host pyngl...one thing that was interesting is that it was
>> not available at first as a non installed package in anaconda. I had to use
>> "conda install -c conda-forge pyngl" in terminal in order to install it.
>> After that, pyngl would not run until I installed libgfortran and
>> libgfortran-ng. I ran the code again and still recieved "None" as my output
>> :/ . If you have any other ideas/insights let me know! Thanks!
>> On Fri, Sep 6, 2019 at 8:53 AM Mateus da Silva Teixeira <
>> mateusstex at gmail.com> wrote:
>>> Hi Austin,
>>> I ran Ngl.gc_inout examples in Python via Terminal and they work as
>>> expected. I'm using Python 3.7.3 with Anaconda, in Ubuntu 18.04.
>>> Try to create a new environment with PyNGL e run the examples in this
>>> new environment. Maybe your environment has some inconsistency.
>>> Best regards,
>>> Mateus
>>> Em qui, 5 de set de 2019 às 21:07, Austin Reed via pyngl-talk <
>>> pyngl-talk at ucar.edu> escreveu:
>>>> Hi there,
>>>> I am an undergraduate student working with PYNGL to sort through data
>>>> (particularly precip.data) but I have been having issues with running one
>>>> particular function of PyNgl on my local computer. That function is the
>>>> Ngl.gc_inout function. I have tried each example on the Ngl.gc_inout page
>>>> and each example has returned "None.", where it is supposed to return
>>>> something else such as [1]. I have checked with other Ngl functions and
>>>> they all seem to be working, it is just this one that is not producing the
>>>> correct output. The main example is listed below. I currently have python
>>>> 3.7.4 installed on my computer, and am using Anaconda Navigator 1.9.7, with
>>>> PyNgl version 1.6.1. I have also checked with someone who has ran this same
>>>> example on their local computer with PyNgl and she obtained the correct
>>>> result, [1]. I don't have any idea as to why my computer would produce
>>>> "None". If anybody has any insight/ideas about this I would greatly
>>>> appreciate it!
>>>> Best, Austin Reed
>>>> import Ngl
>>>> #---Point at center of diamond.
>>>> inout = *Ngl.gc_inout*(0.0, -2.0, \
>>>>                             [ 0.0,  1.0,  0.0, -1.0,  0.0], \
>>>>                             [-3.0, -2.0, -1.0, -2.0, -3.0] )
>>>> print(inout)
>>>> produces:
>>>> [1]
>>>> _______________________________________________
>>>> pyngl-talk mailing list
>>>> List instructions, subscriber options, unsubscribe:
>>>> http://mailman.ucar.edu/mailman/listinfo/pyngl-talk
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ucar.edu/pipermail/pyngl-talk/attachments/20190907/59ddda53/attachment.html>

More information about the pyngl-talk mailing list