[pyngl-talk] Importing pyngl error

Kevin Hallock hallock at ucar.edu
Thu Sep 28 13:47:56 MDT 2017

Hi Alyssa,

Could you please check the version of XQuartz that’s installed on your machine? (select “About X11” in the “XQuartz” menu while the XQuartz application is open)

For reference, I currently have XQuartz 2.7.11 installed on my Mac. If your version of XQuartz is lower than 2.7.11, you may need to upgrade it in order for PyNIO and PyNGL to work: https://www.xquartz.org/ <https://www.xquartz.org/>

I hope this helps!

> On Sep 28, 2017, at 12:47 PM, Alyssa Stansfield <alyssa.stansfield at stonybrook.edu> wrote:
> Hello,
> I tried installing PyNIO and PyNGL using anaconda in a separate environment, as suggested on the website. When I open Python and import NIO, it works, but when I try to import Ngl, this error message comes up:
>   File "/Users/Alyssa/anaconda/envs/pyn_test/lib/python2.7/site-packages/PyNGL/Ngl.py", line 45, in <module>
>     import fplib
> ImportError: dlopen(/Users/Alyssa/anaconda/envs/pyn_test/lib/python2.7/site-packages/PyNGL/fplib.so, 2): Library not loaded: /opt/X11/lib/libcairo.2.dylib
>   Referenced from: /Users/Alyssa/anaconda/envs/pyn_test/lib/python2.7/site-packages/PyNGL/fplib.so
>   Reason: Incompatible library version: fplib.so requires version 11403.0.0 or later, but libcairo.2.dylib provides version 11203.0.0
> I tried updating all my modules using conda, but still I get this error. Any ideas on how to fix this?
> -Alyssa
> _______________________________________________
> pyngl-talk mailing list
> List instructions, subscriber options, unsubscribe:
> http://mailman.ucar.edu/mailman/listinfo/pyngl-talk

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ucar.edu/pipermail/pyngl-talk/attachments/20170928/dcffcbac/attachment.html>

More information about the pyngl-talk mailing list