[Met_help] known problem but not solution for pb2nc on a 64-bit machine (UNCLASSIFIED)

John Halley Gotway johnhg at rap.ucar.edu
Mon Dec 1 11:33:36 MST 2008

Barbara and Robert,

I checked the MET-Help email history and did find a response to Robert's question on 11/10/2008.  I've copied it below.  Perhaps there was a transmission problem.  Sorry for the confusion.

I'm happy to help you try to get things running.  Robert, please see my response below.

John Halley-Gotway
johnhg at ucar.edu


I don't know immediately what's going on.  I built MET here as 32-bit on Debian Linux system but wasn't able to reproduce the same error message you're seeing.  Looking at your Makefile, I have a
couple of questions...

(1) GSL_BASE is defined to be "/use/local".  I'm wondering if that's a typo.  Do you really intend it to be "/usr/local"?

(2) In NETCDF_LIBS, you're linking to "-L/usr/lib/gcc/x86_64-redhat-linux/3.4.6/32" necessary?  Do you run into problems if you don't link to it?  What happens when you remove that link?

(3) Regarding the undefined reference to "powidf2", I found that function defined on my machine in the following location:

I ran this command: nm /usr/lib/gcc/i486-linux-gnu/4.1.2/libgcc.a | grep powidf2

But I noticed that it's NOT defined in the corresponding version 3.4.6 file: /usr/lib/gcc/i486-linux-gnu/3.4.6/libgcc.a.

So perhaps it has something to do with conflicting versions of the compiler.  What version of the compiler are you running?
When you do "g++ --version", what do you get?  Perhaps you're running version 4.1.2 of the compiler, but trying to link to version 3.4.6 of the libraries.  Just a thought.


Flanigan, Robert (Civ, ARL/CISD) wrote:
> > Hi
> >
> > I am trying to build a 32 bit version of MET on a RedHat 4 64bit system.
> >
> > NetCDF and the other packages compiled in 32 bit mode but I am still have problems with MET.
> > The programs were checked with:
> >
> > carson:rflaniga /opt/NetCDF/v400_32/bin> file ncdump
> > ncdump: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.9, dynamically linked (uses shared libs), for GNU/Linux 2.6.9, not stripped
> >
> > My makefile and the output of the compile are attached.
> >
> >
> > R.Flanigan

Sauter, Barbara (Civ, ARL/CISD) wrote:
> Classification:  UNCLASSIFIED 
> Caveats: NONE
> Hello,
>      Bob Flanigan submitted a help request last month, but has not heard
> anything.  I was trying to run MET1.1 on a linux 64-bit computer, and
> encountered the message indicated in the known problems for MET1.0
> relating to pb2nc on a 64-bit machine.  Bob recompiled the applications
> specified as if running on a 32-bit machine, but pb2nc will not compile.
> Who should he talk to about getting this working?
> Thank you,
> Barb Sauter
> US Army Research Laboratory
> White Sands Missile Range, NM
> Barb:  575-678-2840; bsauter at arl.army.mil
> Bob:  575-678-2717; rflaniga at arl.army.mil
> Classification:  UNCLASSIFIED 
> Caveats: NONE
> _______________________________________________
> Met_help mailing list
> Met_help at mailman.ucar.edu
> http://mailman.ucar.edu/mailman/listinfo/met_help

More information about the Met_help mailing list