[Met_help] help with installation

John Halley Gotway johnhg at rap.ucar.edu
Mon Nov 12 15:38:44 MST 2007


I have a few suggestions.

I noticed a few things in your Makefile.  I see that you're using "icc" and "ifort" for compiling MET.  We have never compiled MET using those compilers.  It was developed and tested using the GNU
compilers "g++" and "g77".  We don't have the icc/ifort compilers available here, so we haven't tested with them yet.  They may or may not work.  If you do continue to use them, I'd be very interested
to learn what, if any, code changes you had to make to use them.

Also, I see that you're using a beta version of NetCDF 4.  MET was developed using NetCDF 3.  It's my understanding that NetCDF 4 is rather different from version 3.  I'd suggest downloading and using
NetCDF 3.6.1 (http://www.unidata.ucar.edu/downloads/netcdf/index.jsp).  Some users have had difficulty using 3.6.2 with MET, and we're still looking into that.  So for the time being, try using 3.6.1

The error you're experiencing is that the compiler isn't able to find the NetCDF include file it's looking for.  And that's because you're using version 4 rather than version 3.

So give NetCDF 3.6.1 a shot and let me know how it goes.  And if you have gcc/g77 available for use, I'd suggest using them instead.

Another thing to check is whether or not you have the "f2c" library on your machine.  When we wrote the documentation, we thought "f2c" was more common than it appears to be.  If it's not on your
machine, it can be downloaded from: http://www.netlib.org/f2c/
And you'll want the file "libf2c.zip".  And follow the directions in the README file.
Then you'll need to update your makefile by adding paths to the f2c library to the "BUFR_INCS" and "BUFR_LIBS" lines as follows:

BUFR_INCS    = -I$(BUFR_BASE) -I/path/to/the/f2c/library/header/files
BUFR_LIBS    = -L$(BUFR_BASE) -I/directory/containing/the/libf2c.a/file

Before you try rebuilding MET, be sure to execute a "make clean".

Please let us know if you run into any more problems.  Hopefully we can get this working well for you.

John Halley Gotway
johnhg at ucar.edu

Erik Noble wrote:
> hi I tried to install this on my MAC. i ran into trouble. I have
> attached the error log file and my makefile for details.
> Do you happen to have any suggestions?
> Sincerely,
> Erik Noble
> ------------------------------------------------------------------------
> _______________________________________________
> Met_help mailing list
> Met_help at mailman.ucar.edu
> http://mailman.ucar.edu/mailman/listinfo/met_help

More information about the Met_help mailing list