[Wrf-users] ARWpost for GrADS application

Young, Jeremy, K jeremy.young868 at topper.wku.edu
Sun Nov 13 10:33:41 MST 2011

Hi Jason,

If I'm understanding your procedure, you have renamed the wrfout files produced by wrf.exe to a different name (your example is t10).  I have not used ARWpost very often, but I'm not sure if ARWpost.exe can understand what it's reading if the wrfout files are renamed.  Looking at the errors you are seeing, I think that this may be your problem.  It's either that the renamed files are not being understood by ARWpost.exe or that there was an error in the compilation of ARWpost.


start_date = '1998-09-01_00:00:00',

end_date   = '1998-09-05_00:00:00',

interval_seconds = 10800,

tacc = 0,

debug_level = 0,



input_root_name = '../WRFV3/run/wrfout_d01_1998-09-01_00:00:00'

output_root_name = './test'

plot = 'all_list'

fields = 'height,pressure,tk,tc'

mercator_defs = .true.


split_output = .true.

frames_per_outfile = 2

plot = 'all'

plot = 'list'

 plot = 'all_list'

! Below is a list of all available diagnostics

fields = 'height,geopt,theta,tc,tk,td,td2,rh,rh2,umet,vmet,pressure,u10m,v10m,wdir,wspd,wd10,ws10,slp,mcape,mcin,lcl,lfc,cape,cin,dbz,max_dbz,clfr'


interp_method = 0,

interp_levels = 1000.,950.,900.,850.,800.,750.,700.,650.,600.,550.,500.,450.,400.,350.,300.,250.,200.,150.,100.,


extrapolate = .true.

interp_method = 0,     ! 0 is model levels, -1 is nice height levels, 1 is user specified pressure/height

interp_levels = 1000.,950.,900.,850.,800.,750.,700.,650.,600.,550.,500.,450.,400.,350.,300.,250.,200.,150.,100.,

interp_levels = 0.25, 0.50, 0.75, 1.00, 2.00, 3.00, 4.00, 5.00, 6.00, 7.00, 8.00, 9.00, 10.0, 11.0, 12.0, 13.0, 14.0, 15.0, 16.0, 17.0, 18.0, 19.0, 20.0,

This is my namelist.ARWpost.  The only lines I changed in this file before running the program were the start date, the end date and the input file name.  I don't see why you couldn't name the output files (the .ctl and the .dat) whatever you wish, but it's possible that renaming the file has corrupted it somehow or that ARWpost cannot accept files with names like this.  My suggestion would be to try and rename the t10 file (and others like it) back to their original names and try again.  To keep the files organized, maybe you could create several directories that would contain each model run and its related wrfout files.

If possible, complete another model run and leave the wrfout files in the ../WRFV3/run directory.  Try and run ARWpost.exe while the wrfout files are still in this location and still have the wrfout_d01____ name.  In doing so, your process would completely match mine and we might be able to see if the problem is related to your file names or if it is related to ARWpost not compiling correctly.

Please respond with any additional questions or problems that you run into.  The attached screenshots show my completion of ARWpost using the namelist above.

Jeremy Young.

From: jasonpadovani at gmail.com [mailto:jasonpadovani at gmail.com] On Behalf Of Jason Padovani Ginies
Sent: Sunday, November 13, 2011 2:17 AM
To: Young, Jeremy, K
Subject: Re: [Wrf-users] ARWpost for GrADS application

Hi Jeremy,

Thank you for your time. I did not get the attachment in the email, could you please send it again?

What I''ve tried so far and the errors I get:

  *   I've made two directories WRFinput [in which I have a wrf output file named t10] and OUTPUT in the ARWpost directory. So in the input and output root name of the namelist i've put (respectively) './WRFinput/t10' and './OUTPUT/test'. I adjusted the dates and the error I get is:
     *    !!!!!!!!!!!!!!!!
  ARWpost v3.1
ls: ./WRFinput/t10: Value too large for defined data type
ls: ./WRFinput/t10: Value too large for defined data type
 Oops, we need at least ONE input file for the program to read.

  *   I've tried to put 'WRFinput/' as the input root name so that ARWpost looks for the files automatically in the directory and the error I get is
  ARWpost v3.1

FOUND the following input files:


   WARNING --- I do not recognize this data.

               Will make an attempt to read it.

 Processing  time --- 2011-01-24_12:00:00
forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image                              PC                Routine            Line        Source
ARWpost.exe        000000000040CC91  Unknown         Unknown  Unknown
ARWpost.exe        0000000000419E58  Unknown         Unknown  Unknown
ARWpost.exe        0000000000419395   Unknown         Unknown  Unknown
ARWpost.exe        0000000000409E78   Unknown         Unknown  Unknown
ARWpost.exe        0000000000408BEC  Unknown         Unknown  Unknown
libc.so.6                00000030D141D994  Unknown         Unknown  Unknown
ARWpost.exe        0000000000408AE9  Unknown         Unknown  Unknown

I can't see where I am going wrong?! perhaps you have come across such errors before?

Thanks again


On Sat, Nov 12, 2011 at 1:28 PM, Young, Jeremy, K <jeremy.young868 at topper.wku.edu<mailto:jeremy.young868 at topper.wku.edu>> wrote:
Hi Jason,

What exactly is your problem?  Maybe the paths to your wrfout files are incorrect?  I've attached the namelist file.  The only things I had to change in the namelist when running ARWpost.exe were the start date, the end date and the name of my wrfout file.

I hope the namelist helps.  If you run into any additional problems I can try and help.

Jeremy Young

From: jasonpadovani at gmail.com<mailto:jasonpadovani at gmail.com> [mailto:jasonpadovani at gmail.com<mailto:jasonpadovani at gmail.com>] On Behalf Of Jason Padovani Ginies
Sent: Friday, November 11, 2011 8:22 PM
To: Young, Jeremy, K
Subject: Re: [Wrf-users] ARWpost for GrADS application

Dear Jeremy,

Thank you for your email. In fact the first modification seems like to have solved the problem already and I now have ARWpost.exe. I still cannot make it work however =( I cannot understand what I am doing wrong to get different error messages. Could I kindly ask you to explain the procedure if you have expertise in the matter? I've tried renaming/relocating and changing the input file and adjusting the namelist accordingly but still I can't seem to get it right.

Could you kindly send me a copy of your namelist.ARWpost and specify the following:

  *   location and name of input(WRF output) files relative to ARWpost.exe

Many thanks,

On Fri, Nov 11, 2011 at 12:42 AM, Young, Jeremy, K <jeremy.young868 at topper.wku.edu<mailto:jeremy.young868 at topper.wku.edu>> wrote:
Hi Jason,

I've seen a similar error message before when attempting to compile ARWpost.  I fixed this problem by adding the following to the configure.arwp file:

--LDFLAGS should now have -L/path/to/netcdf/lib   -lnetcdf -lnetcdff
--CPPFLAGS should now have -I/path/to/netcdf/include  and -R/path/to/netcdf/lib
--Change the "-O" flags to match that of netcdf during compile, probably "-O2".

Changing the optimization flags, LDFLAGS and CPPFLAGS will likely fix your problem.  The-R/path/to/netcdf/lib will eliminate another problem that I ran into when trying to run ARWpost.exe in which an error message saying that there was an "error opening shared libraries ...".  If you see this message, you can use a command like " ln -s /path/to/netcdf/lib/libnetcdf* ." issued from the ARWpost directory to link the necessary libraries and allow them to be referenced.

I hope this helps.

Jeremy Young
System Administrator
Climate Research Lab
Western Kentucky University

From: wrf-users-bounces at ucar.edu<mailto:wrf-users-bounces at ucar.edu> [mailto:wrf-users-bounces at ucar.edu<mailto:wrf-users-bounces at ucar.edu>] On Behalf Of Jason Padovani Ginies
Sent: Thursday, November 10, 2011 1:08 PM
To: wrf-users at ucar.edu<mailto:wrf-users at ucar.edu>
Subject: [Wrf-users] ARWpost for GrADS application

Dear wrf-users,

I am having trouble compiling ARWposts. When I try to compile I get lots of error messages looking like this:

input_module.f:(.text+0x40f): undefined reference to `ncvgt_'

and eventually are confronted with a final error message saying:

make: [ARWpost.exe] Error 1 (ignored)

Some research has led me to believe that the netCDF on the system might causing this problem and that I might have to re-compile that
Is there any way to go around this perhaps another method of converting wrf output in a format readable by GrADS?

Kind regards,

Jason Padovani Ginies
Final Year B.Sc. student
Department of Physics
University of Malta

Wrf-users mailing list
Wrf-users at ucar.edu<mailto:Wrf-users at ucar.edu>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ucar.edu/pipermail/wrf-users/attachments/20111113/a7fcbd21/attachment-0001.html 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: namelist.ARWpost
Type: application/octet-stream
Size: 1200 bytes
Desc: namelist.ARWpost
Url : http://mailman.ucar.edu/pipermail/wrf-users/attachments/20111113/a7fcbd21/attachment-0001.obj 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: screen1.jpg
Type: image/jpeg
Size: 211946 bytes
Desc: screen1.jpg
Url : http://mailman.ucar.edu/pipermail/wrf-users/attachments/20111113/a7fcbd21/attachment-0002.jpg 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: screen2.jpg
Type: image/jpeg
Size: 202910 bytes
Desc: screen2.jpg
Url : http://mailman.ucar.edu/pipermail/wrf-users/attachments/20111113/a7fcbd21/attachment-0003.jpg 

More information about the Wrf-users mailing list