[Wrf-users] problem compiling plotgrids.exe ( Ardie from Malaysia)

Feng Liu fliu at mag.maricopa.gov
Wed May 6 11:04:30 MDT 2009

HI, Wan Ahmad Ardie
For your case,(1) check /usr/lib/ if there is the library named
libgfortran.so.1.0.0. Due to the library's names do not terminate with
.a or .so, in your local lib directory (~/local/lib/) which should add
into $PATH, and then link the library by 
link -s /usr/lib/libgfortran.so.1.0.0 libgfortran.a 
and update your configure.wps by adding  
-lpng -lz -L~/local/lib  -lgfortran
try to compile your WPS again. 
If you fail to fix the problem please let me know and you may check your
configure.wps first if the libraries in this file are consistent (e.g.
library location directory, name and version number) in your system. For
example, check library X11 is located at /usr/lib, or /usr/X11R6/lib
Good luck.


From: wrf-users-bounces at ucar.edu [mailto:wrf-users-bounces at ucar.edu] On
Behalf Of Ahmad Wan
Sent: Saturday, April 25, 2009 11:35 PM
To: wrf-users at ucar.edu
Subject: [Wrf-users] problem compiling plotgrids.exe ( Ardie from

Hi, I am Wan Ahmad Ardie from Malaysia, i have a problem with the
compilation of plotgrids.exe.

My installation of WRF Preprocessing System (WPS) was successful, in
fact, I have been using this for a few months now. But now I needed to
see if I can use the plotgrids.exe, which I have never managed to
successfully compile before. I have tried a few configure options, tried
editing the configure.wps ( just the ncarg libraries changing
-L/usr/X11R6/lib  to  -L/usr/lib)  but none worked. Here is an example
of the Intel option:

5.  PC Linux i486 i586 i686, Intel compiler  serial, NO GRIB2

./compile >& compile.output

(some of the lines in compile.output):

i1mach.f:(.text+0x177): undefined reference to `_gfortran_st_write_done'
i1mach.f:(.text+0x183): undefined reference to `_gfortran_stop_numeric'
i1mach.f:(.text+0x4b4): undefined reference to `_gfortran_st_write'
i1mach.f:(.text+0x4bc): undefined reference to `_gfortran_st_write_done'
i1mach.f:(.text+0x4c8): undefined reference to `_gfortran_stop_numeric'
i1mach.f:(.text+0x640): undefined reference to `_gfortran_st_write'
i1mach.f:(.text+0x65a): undefined reference to
i1mach.f:(.text+0x671): undefined reference to
i1mach.f:(.text+0x68b): undefined reference to
i1mach.f:(.text+0x693): undefined reference to `_gfortran_st_write_done'
i1mach.f:(.text+0x69f): undefined reference to `_gfortran_stop_numeric'
make[1]: [plotgrids.exe] Error 1 (ignored)
make[1]: Leaving directory `/home/ardie/WRF_model/WPS/util/src'
if [ -h plotgrids.exe ] ; then \

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ucar.edu/pipermail/wrf-users/attachments/20090506/e63868e1/attachment.html 

More information about the Wrf-users mailing list