[ncl-install] ncl not seeing NCARG_ROOT?

Dave Allured - NOAA Affiliate dave.allured at noaa.gov
Fri Feb 16 16:38:19 MST 2018

On my institutional system, the sys admins will sometimes put NCL inside a
wrapper script, invisible to casual use.  This is done specifically to be
able to redefine $NCARG_ROOT and make other possible changes, to make a
working NCL.  You might check to see if something like this is active in
your ubuntu install, and not working right.  The "where ncl" command may be

You could try a test script with these tests, without first trying to
"load" anything.

    print (getenv ("NCARG_ROOT"))
    system ("echo $NCARG_ROOT")
    system ("env | grep NCARG")

--Dave A.

On Fri, Feb 16, 2018 at 4:11 PM, Kevin Hallock via ncl-install <
ncl-install at ucar.edu> wrote:

> Hi Dave,
> Are you using the ncl-ncarg package provided via apt on Ubuntu? I just
> tried running the same ‘load "$NCARG_ROOT/lib/ncarg/
> nclscripts/csm/gsn_code.ncl"’ command on an Ubuntu 16.04 system using NCL
> 6.3.0 from the ncl-ncarg apt package and experienced the same error.
> I was, however, able to successfully run the “load” command on the same
> machine using one of our precompiled binaries
> <http://ncl.ucar.edu/Download/> (specifically ncl_
> ncarg-6.4.0-Debian8.6_64bit_gnu492.tar.gz for Ubuntu 16.04).
> I’m not sure why the ncl-ncarg package seems to be broken, but
> unfortunately we are not the maintainers of that package. If you continue
> to experience issues like this, I would strongly recommend using either a precompiled
> NCL binary <http://ncl.ucar.edu/Download/> or installing NCL via conda
> <http://ncl.ucar.edu/Download/conda.shtml>.
> Additionally, the ncl-ncarg package provides NCL v6.3.0, which was
> released in March 2015. Both of the alternative installation methods I
> linked to currently offer NCL v6.4.0 (released February 2017) and will also
> offer NCL v6.5.0 for download when it is released in the near future.
> I hope this helps!
> Kevin
> On Feb 16, 2018, at 3:36 PM, Dave Burns via ncl-install <
> ncl-install at ucar.edu> wrote:
> Hello.
> Executing ncl on a newly installed ubuntu box and an old ncl file that
> used to work generates this error:
> >fatal:Could not open ($NCARG_ROOT/lib/ncarg/nclscripts/csm/gsn_code.ncl)
> >fatal:error at line 2 in file proj1.ncl
> That's odd, because NCARG_ROOT is defined and that file is openable and
> has permissive permissions for all users:
> >user at host:~/Downloads/1200/0214$ echo $NCARG_ROOT
> /usr
> >user at host:~/Downloads/1200/0214$ ls -la $NCARG_ROOT/lib/ncarg/
> nclscripts/csm/gsn_code.ncl
> -rwxr-xr-x 1 root root 490093 Jan 28  2016 /usr/lib/ncarg/nclscripts/csm/
> gsn_code.ncl
> >user at host:~/Downloads/1200/0214$ head  $NCARG_ROOT/lib/ncarg/
> nclscripts/csm/gsn_code.ncl
> ;
> ;      $Id: gsn_code.ncl,v 2010-05-06 17:13:26 haley Exp $
> ;;;;;
> So I am confused. The only way "could not open" would make sense was if
> ncl was opening the file for write access, which still doesn't make sense.
> Here are the first lines from the ncl file:
> load "$NCARG_ROOT/lib/ncarg/nclscripts/csm/gsn_code.ncl"      ; These
> four libraries are automatically
> load "$NCARG_ROOT/lib/ncarg/nclscripts/csm/gsn_csm.ncl"       ; loaded
> from NCL V6.4.0 onward.
> load "$NCARG_ROOT/lib/ncarg/nclscripts/csm/contributed.ncl"   ; No need
> for user to explicitly load.
> How do I fix this?
> thanks,
> Dave
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ucar.edu/pipermail/ncl-install/attachments/20180216/c927af9c/attachment-0001.html>

More information about the ncl-install mailing list