[ncl-install] MacOSx precompile error with later version of gcc

Kevin Hallock hallock at ucar.edu
Mon Nov 20 11:40:13 MST 2017

Hi Joffa,

I’m sorry to hear that the conda installation method isn’t working for you either.

I’d really like to figure out what caused that “libopenblasp” error, so I was wondering if you could please run the command “conda list -n ncl_stable” and reply with the output? (A text file or just the raw terminal output copy-pasted into the email would be preferred so that I can compare your output with my own conda environments more easily).


> On Nov 18, 2017, at 7:24 AM, Joffa Applegate <jmappleg at asu.edu> wrote:
> Hi Kevin, I tried the conda install and here’s where I ended up:
> <Screen Shot 2017-11-18 at 7.21.50 AM.png>
> Here’s what conda installed:
> <Screen Shot 2017-11-18 at 7.21.41 AM.png>
> Thanks,
> Joffa
>> On Nov 17, 2017, at 12:08 PM, Kevin Hallock <hallock at ucar.edu <mailto:hallock at ucar.edu>> wrote:
>> Hi,
>> It seems like there may be a problem with gcc/gfortran on your machine. The precompiled builds of NCL for Mac OS X are built against a particular version of gcc/gfortran, and it looks like you’re using Xcode’s gcc and Homebrew’s gfortran. Please see the following links for more information:
>> http://ncl.ucar.edu/Download/macosx.shtml#InstallCompilers <http://ncl.ucar.edu/Download/macosx.shtml#InstallCompilers>
>> http://ncl.ucar.edu/Download/macosx.shtml#MissingLibs <http://ncl.ucar.edu/Download/macosx.shtml#MissingLibs>
>> http://hpc.sourceforge.net/ <http://hpc.sourceforge.net/>
>> If you already use Homebrew in /usr/local, you may not want to install the HPC gcc/gfortran package into the same directory as your Homebrew packages. Using the conda package manager to install NCL might be preferable in this situation: http://ncl.ucar.edu/Download/conda.shtml <http://ncl.ucar.edu/Download/conda.shtml>
>> I hope this helps,
>> Kevin
>>> On Nov 17, 2017, at 11:32 AM, Joffa Applegate <jmappleg at asu.edu <mailto:jmappleg at asu.edu>> wrote:
>>> Hello, tried installing precompiled ncl code and have library error message. 
>>> ng4ex xy01n -clean
>>> dyld: Library not loaded: /usr/local/lib/libgomp.1.dylib
>>>   Referenced from: /usr/local/ncl-6.4.0/bin/ncargpath
>>>   Reason: image not found
>>> Here’s config info:
>>> molly:~ jma$ sw_vers -productVersion
>>> 10.12.6
>>> molly:~ jma$ uname -m
>>> x86_64
>>> molly:~ jma$ gcc --version
>>> Configured with: --prefix=/Applications/Xcode.app/Contents/Developer/usr --with-gxx-include-dir=/usr/include/c++/4.2.1
>>> Apple LLVM version 9.0.0 (clang-900.0.38)
>>> Target: x86_64-apple-darwin16.7.0
>>> Thread model: posix
>>> InstalledDir: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin
>>> molly:~ jma$ gfortran --version
>>> GNU Fortran (Homebrew GCC 7.2.0) 7.2.0
>>> Thank you!
>>> _______________________________________________
>>> ncl-install mailing list
>>> List instructions, subscriber options, unsubscribe:
>>> http://mailman.ucar.edu/mailman/listinfo/ncl-install <http://mailman.ucar.edu/mailman/listinfo/ncl-install>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ucar.edu/pipermail/ncl-install/attachments/20171120/7a7b131d/attachment-0001.html>

More information about the ncl-install mailing list