[ncl-install] Problem installing ncl 6 in Centos 4

Mary Haley haley at ucar.edu
Fri Jul 29 09:05:40 MDT 2011

Hi Oscar,

I am unable to build a binary with your requirements because I don't have access to a system with glibc 2.3. You will need to build NCL/NCARG from source code.

What versions of gcc and gfortran do you have:

    gcc --version
    gfortran --version

I don't think older versions of gcc will be an issue, but you will definitely want to use gfortran and not g77.

There's information about building NCL/NCARG at:



On Jul 28, 2011, at 10:41 AM, Oscar Chimborazo wrote:

> Hello dear fellows,
>  I got the next error when I try to run ncl from the precompiled file ncl_ncarg-6.0.0.Linux_RedHat_x86_64_nodap_gcc412.tar.gz :
> "error while loading shared libraries: requires glibc 2.5 or later dynamic linker"
> I have glibc-2.3.4-2.54  and yum repositories don't have the next versions of glibc. I wouldn't like install the complete OS by a new one because I have a lot of programs and process running in that old machine.
> Thanks for any help.
> Oscar
> _______________________________________________
> ncl-install mailing list
> List instructions, subscriber options, unsubscribe:
> http://mailman.ucar.edu/mailman/listinfo/ncl-install

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ucar.edu/pipermail/ncl-install/attachments/20110729/3c469d10/attachment.html 

More information about the ncl-install mailing list