[Dart-dev] DART/branches Revision: 13209

dart at ucar.edu dart at ucar.edu
Wed Jul 31 08:50:39 MDT 2019


nancy at ucar.edu
2019-07-31 08:50:39 -0600 (Wed, 31 Jul 2019)
266
commit some additional comments to the 'preprocess' branch
about how we set the anamorphosis limits.  we have a lot of
arguments already to add_domain() - not sure if adding more
is the right way to go, or if we should repurpose the existing
clamp limits for this.




Modified: DART/branches/preprocess/models/cam-fv/model_mod.f90
===================================================================
--- DART/branches/preprocess/models/cam-fv/model_mod.f90	2019-07-31 14:48:41 UTC (rev 13208)
+++ DART/branches/preprocess/models/cam-fv/model_mod.f90	2019-07-31 14:50:39 UTC (rev 13209)
@@ -2239,11 +2239,18 @@
    call error_handler(E_MSG,routine,string1,source,revision,revdate,text2=string2)
 endif
 
-! CAM only has a single domain (only a single grid, no nests or multiple grids)
+! CAM is a single domain (only a single grid, no nests or multiple grids)
 
+! @todo FIXME:
+! break add_domain() into smaller routines?  e.g. add_domain(fname, nfields, varnames, qtynames) only
+! then set routines for limits and limit type, and another routine for update/noupdate.
+! defaults remain same.  but for readability, extensibility, etc - separate these out??
+
 domain_id = add_domain(cam_template_filename, nfields, var_names, kind_list, &
-                       clamp_vals, update_list)
+                       limit_vals, limit_type, update_list)
 
+! @todo FIXME limit_type = "clamp" (backwards compatible), "anamorphosis" (moha's new stuff)
+
 call fill_cam_stagger_info(grid_stagger)
 
 if (debug_level > 100) call state_structure_info(domain_id)


More information about the Dart-dev mailing list