[Dart-dev] DART/branches Revision: 12875

dart at ucar.edu dart at ucar.edu
Tue Oct 2 12:40:30 MDT 2018


thoar at ucar.edu
2018-10-02 12:40:30 -0600 (Tue, 02 Oct 2018)
55
Getting the latest from the git version of wrf_hydro.




Index: DART/branches/rma_wrfHydro
===================================================================
--- DART/branches/rma_wrfHydro	2018-10-02 16:14:38 UTC (rev 12874)
+++ DART/branches/rma_wrfHydro	2018-10-02 18:40:30 UTC (rev 12875)

Property changes on: DART/branches/rma_wrfHydro
___________________________________________________________________
Modified: svn:mergeinfo
## -42,7 +42,7 ##
 /DART/branches/rma_sprint:8095-8166
 /DART/branches/rma_state_structure_test_dir:9472-9676
 /DART/branches/rma_state_structure_unit_test:9691-10268
-/DART/branches/rma_trunk:12581-12859
+/DART/branches/rma_trunk:12581-12874
 /DART/branches/rma_trunk_clamping:8786-8801
 /DART/branches/rma_trunk_filename:8011-8157
 /DART/branches/rma_trunk_get_state_fun:8568-8596
Modified: DART/branches/rma_wrfHydro/assimilation_code/modules/io/io_filenames_mod.f90
===================================================================
--- DART/branches/rma_wrfHydro/assimilation_code/modules/io/io_filenames_mod.f90	2018-10-02 16:14:38 UTC (rev 12874)
+++ DART/branches/rma_wrfHydro/assimilation_code/modules/io/io_filenames_mod.f90	2018-10-02 18:40:30 UTC (rev 12875)
@@ -103,10 +103,10 @@
           COPY_NOT_PRESENT
 
 ! version controlled file description for error handling, do not edit
-character(len=256), parameter :: source   = &
+character(len=*), parameter :: source   = &
    "$URL$"
-character(len=32 ), parameter :: revision = "$Revision$"
-character(len=128), parameter :: revdate  = "$Date$"
+character(len=*), parameter :: revision = "$Revision$"
+character(len=*), parameter :: revdate  = "$Date$"
 
 ! IO Parameters
 integer, parameter :: NO_IO            = -1

Modified: DART/branches/rma_wrfHydro/assimilation_code/programs/closest_member_tool/closest_member_tool.f90
===================================================================
--- DART/branches/rma_wrfHydro/assimilation_code/programs/closest_member_tool/closest_member_tool.f90	2018-10-02 16:14:38 UTC (rev 12874)
+++ DART/branches/rma_wrfHydro/assimilation_code/programs/closest_member_tool/closest_member_tool.f90	2018-10-02 18:40:30 UTC (rev 12875)
@@ -57,10 +57,10 @@
 implicit none
 
 ! version controlled file description for error handling, do not edit
-character(len=256), parameter :: source   = &
+character(len=*), parameter :: source   = &
    "$URL$"
-character(len=32 ), parameter :: revision = "$Revision$"
-character(len=128), parameter :: revdate  = "$Date$"
+character(len=*), parameter :: revision = "$Revision$"
+character(len=*), parameter :: revdate  = "$Date$"
 
 integer               :: iunit, io, ens, i, j, qtyindex
 integer               :: num_qtys, stype

Added: DART/branches/rma_wrfHydro/assimilation_code/programs/obs_diag/threed_sphere/streamflow_obs_diag.f90
===================================================================
--- DART/branches/rma_wrfHydro/assimilation_code/programs/obs_diag/threed_sphere/streamflow_obs_diag.f90	                        (rev 0)
+++ DART/branches/rma_wrfHydro/assimilation_code/programs/obs_diag/threed_sphere/streamflow_obs_diag.f90	2018-10-02 18:40:30 UTC (rev 12875)
@@ -0,0 +1,4368 @@
+! DART software - Copyright UCAR. This open source software is provided
+! by UCAR, "as is", without charge, subject to all terms of use at
+! http://www.image.ucar.edu/DAReS/DART/DART_download
+!
+! $Id$
+
+program obs_diag
+
+!-----------------------------------------------------------------------
+! The programs defines a series of epochs (periods of time) and geographic
+! regions and accumulates statistics for these epochs and regions.
+!
+! All 'possible' obs_kinds are treated separately.
+!-----------------------------------------------------------------------
+
+! In Atmospheric Science, 'spread' has units of standard deviation ...
+! In filter:obs_space_diagnostics() the 'spread' copies are converted to
+! standard deviations.
+!
+! I should rename some of the variables I use as variances to reflect this.
+! 'priorspred' should really be 'priorvar' since you have to accumulate variances
+! the math is correct as it is, but the variable names don't make it easy ...
+
+use        types_mod, only : r4, r8, digits12, MISSING_R8, MISSING_R4, MISSING_I, &
+                             metadatalength
+
+use obs_sequence_mod, only : read_obs_seq, obs_type, obs_sequence_type,      &
+                             get_first_obs, get_obs_from_key, get_obs_def,   &
+                             get_copy_meta_data, get_obs_time_range,         &
+                             get_time_range_keys, get_obs_values, init_obs,  &
+                             assignment(=), get_num_copies, get_qc,          &
+                             static_init_obs_sequence, destroy_obs_sequence, &
+                             read_obs_seq_header, get_last_obs, destroy_obs, &
+                             get_num_qc, get_qc_meta_data
+
+use      obs_def_mod, only : obs_def_type, get_obs_def_error_variance, &
+                             get_obs_def_time, get_obs_def_location, &
+                             get_obs_def_type_of_obs
+
+use     obs_kind_mod, only : max_defined_types_of_obs,     &
+                             get_quantity_for_type_of_obs, &


More information about the Dart-dev mailing list